kynaptic update funzt nicht :(

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
n1ght
Newbie
Newbie
Beiträge: 9
Registriert: 3. Nov 2004, 20:54

kynaptic update funzt nicht :(

Beitrag von n1ght » 10. Nov 2004, 19:17

Also ich hab alles so gemacht wie es in dem Kurz-how-to steht, aber wenn ich kyaptic herunterladen will kommt:

Code: Alles auswählen

linux:/etc/apt # apt install kynaptic
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
E: Konnte Paket kynaptic nicht finden
Das hier hab ich in meiner sources.list stehen:

Code: Alles auswählen

rpm ftp://mirrors.mathematik.uni-bielefeld.de/pub/linux/suse/apt/ SuSE/9.2-i386 update security kde misc packman packman-i686 wine
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/9.2-i386 update security kde misc packman packman-i686 wine
liegt da eventuell der fehler??

Und meine security.list:

Code: Alles auswählen

rpm      ftp://mirrors.mathematik.uni-bielefeld.de/pub/linux/suse/apt SuSE/9.2-i386 security
rpm      ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 security
Wo liegt der Fehler?? ich find ihn verdammt nochmal nicht :/

Werbung:
Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8709
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 10. Nov 2004, 21:58

Moin,

für Suse 9.2 gibt es noch kein kynaptic.
Wenn dann liegt es in der Sektion/Repository suser-rbos
Bisher liegt da aber nur synaptic.

1. Möglichkeit ... warten ;-)
2. Möglichkeit:
die 9.1er src.rpm laden
und mit rpmbuild --rebuild kynaptic.---src.prm umwandeln
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

n1ght
Newbie
Newbie
Beiträge: 9
Registriert: 3. Nov 2004, 20:54

Beitrag von n1ght » 11. Nov 2004, 09:46

Ok admine... Aber wenn ich kynaptic rebuilden will kommt:

Code: Alles auswählen

        XFree86-devel is needed by kynaptic-0.5-58357cl
        apt-devel >= 0.5.4cnc1 is needed by kynaptic-0.5-58357cl
        glib2-devel is needed by kynaptic-0.5-58357cl
        kdelibs3-devel is needed by kynaptic-0.5-58357cl
        qt3-devel is needed by kynaptic-0.5-58357cl
        popt-devel is needed by kynaptic-0.5-58357cl
        rpm-devel >= 4.2.1 is needed by kynaptic-0.5-58357cl
Und da wären wir wieder bei apt-get ^^ .. Wie kann ich mir diese Files jetzt via apt-get/apt holen? Sry falls ich mich dumm anstelle, aber hab linux erst seit ner woche :lol:
Danke

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8709
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 11. Nov 2004, 10:00

n1ght hat geschrieben:Ok admine... Aber wenn ich kynaptic rebuilden will kommt:

Code: Alles auswählen

        XFree86-devel is needed by kynaptic-0.5-58357cl
        apt-devel >= 0.5.4cnc1 is needed by kynaptic-0.5-58357cl
        glib2-devel is needed by kynaptic-0.5-58357cl
        kdelibs3-devel is needed by kynaptic-0.5-58357cl
        qt3-devel is needed by kynaptic-0.5-58357cl
        popt-devel is needed by kynaptic-0.5-58357cl
        rpm-devel >= 4.2.1 is needed by kynaptic-0.5-58357cl
Und da wären wir wieder bei apt-get ^^ .. Wie kann ich mir diese Files jetzt via apt-get/apt holen? Sry falls ich mich dumm anstelle, aber hab linux erst seit ner woche :lol:
Danke
Du solltest mal deine sources.list erweitern.
So gibt es zum Beispiel apt-devel im Repositorie von suser-rbos.
Schau dir mal das Beispiel an:
http://ftp.gwdg.de/pub/linux/suse/apt/S ... /examples/
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 16. Nov 2004, 11:46

n1ght hat geschrieben:Ok admine... Aber wenn ich kynaptic rebuilden will kommt:

Code: Alles auswählen

        XFree86-devel is needed by kynaptic-0.5-58357cl
        apt-devel >= 0.5.4cnc1 is needed by kynaptic-0.5-58357cl
        glib2-devel is needed by kynaptic-0.5-58357cl
        kdelibs3-devel is needed by kynaptic-0.5-58357cl
        qt3-devel is needed by kynaptic-0.5-58357cl
        popt-devel is needed by kynaptic-0.5-58357cl
        rpm-devel >= 4.2.1 is needed by kynaptic-0.5-58357cl
Und da wären wir wieder bei apt-get ^^ .. Wie kann ich mir diese Files jetzt via apt-get/apt holen?
Dann solltest du dir diese -devel Pakete mal installieren. Ohne *-devel Pakete geht kein compile ;)
Wenn diese *-devel RPMs nicht via apt installierbar sind, dann musst du sie von deiner CD/DVD installieren.
Erst wenn das base-Repository (=SuSE 9.2 Basisversion) auf dem FTP-Server verfügbar ist, kann apt "richtig" arbeiten.

Eine zweite Möglichkeit besteht darin deine DVD/CD als lokales apt-Repository in deine Konfiguration einzubinden (Stichwort: aptate). Dann wird die DVD/CD immer benutzt um fehlende Pakete nachzuinstallieren.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast