gewisse Pakte lassen sich mit apt nicht installieren

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Brumgabrasch
Newbie
Newbie
Beiträge: 29
Registriert: 27. Apr 2004, 17:23

gewisse Pakte lassen sich mit apt nicht installieren

Beitrag von Brumgabrasch » 23. Okt 2004, 20:41

Warum kann Synaptic/Kynaptic/Apt nicht alle Pakte installieren? Bei manchen Pakten (u.a. Mplayer und amsn) lädt es die Datei einfach herunter und danach passiert nichts.

Ein Versuch mit apt über die Kommandozeile ergab:

lx-rene:/home/rene # apt-get install amsn
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden Pakete werden upgegradet werden:
amsn
1 upgraded, 0 newly installed, 0 entfernt und 185 nicht upgegradet.
Muss 0B/3260kB an Archiven holen.
Nach dem Auspacken werden 73,2kB zusätzlicher Plattenplatz benutzt werden.
Checking GPG signatures...
Unknown signature /var/cache/apt/archives/amsn_0.93-0.gbv.3_noarch.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#b7afc211)
E: Error(s) while checking package signatures:
0 unsigned package(s)
1 package(s) with unknown signatures
0 package(s) with illegal/corrupted signatures

Es scheint so, dass die Signatur fehlt. Wie kann man apt(besser kynaptic (ich liebe es halt in manchen Dingen lieber grafisch und in kynaptic habe ich keine Option für etwaige Kommandozeilenparamter für apt gefunden)) dazu bringen diese Pakte trotzdem zu installieren?

Werbung:
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 23. Okt 2004, 20:42

Ich denke man kann das abschalten... steht glaub ich in einem der howtos von oc2pus.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Wolfgang
Hacker
Hacker
Beiträge: 271
Registriert: 26. Mai 2004, 22:05
Wohnort: Köln
Kontaktdaten:

Beitrag von Wolfgang » 23. Okt 2004, 20:50

In Ermangelung fähigerer Leute müssen wir halt hier mal ein wenig aushelfen (obwohl ich apt noch nie benutzt habe)

Das hab ich gefunden:
und um ein weiteres Problem zu vermeiden: editiere /etc/apt/apt.conf.d/gpg-checker.conf und setze die Option GPG::Check auf "false".

Brumgabrasch
Newbie
Newbie
Beiträge: 29
Registriert: 27. Apr 2004, 17:23

Beitrag von Brumgabrasch » 23. Okt 2004, 21:00

Danke vielmals... es funktioniert jetzt wunderbar
Ich hatte im Forum und im Netz gesucht und war nicht auf diese Antwort gestossen...

Gruss Brumgabrasch

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast