Probleme beim Downgrade 9.1 ---> 9.0

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Looser
Newbie
Newbie
Beiträge: 6
Registriert: 21. Sep 2004, 12:40

Hardware Problem

Beitrag von Looser » 21. Sep 2004, 13:47

Hallo,

Vielen dank für diese How-to. Es hat wunderbach geklappt. Es gibt einige kleine Schreibfehler, wie z.B. "modules-init-tools" statt "module-init-tools". Es war mir auch nicht klar, ob den myUpdate skript Fehlerfrei funktionnieren sollte vor und nach dem download Teil ( diese letze Problem kam warscheinlich nur, weil ich schon Kde auf 3.3 installiert hatte. Da mußte ich ein bischen spielen mit apt und rpm ).
Ich war blöd genug nicht zu überprüfen, ob das 2.6 Kernel meine Highpoint 370 Raid karte unterstüzen könnte. Das ist leider nicht der Fall, und jetzt muß ich ein 2.4 Kernel (für suse 9.0) benutzen. Das funktionniert, aber es gibt so viele Inkonsistenz, dass ich gerne zurück zu Suse 9.0 migrieren will. Soll ich einfach es so machen wie in dem How-To? Was soll ich in den preference Datei eingeben? Geht das überhaupt?

Danke für ihre Hilfe,
Looser

PS: Tut mir Leid, dass mein Deutsch so schlecht ist, aber ich bin kein Deutscher. :roll:

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: Hardware Problem

Beitrag von oc2pus » 22. Sep 2004, 10:42

Looser hat geschrieben:Es hat wunderbach geklappt. Es gibt einige kleine Schreibfehler, wie z.B. "modules-init-tools" statt "module-init-tools".
danke, der Tippfehler wurde korrigiert.
Looser hat geschrieben:Das funktionniert, aber es gibt so viele Inkonsistenz, dass ich gerne zurück zu Suse 9.0 migrieren will.
Welche Inkonsistenzen?
evtl hilft rpm -e --justdb k_deflt bzw rpm -e --justdb kernel-default, damit wird der kernel nicht mehr in der RPM Datenbank geführt. Oder FakeProvides {}; in der apt.conf eintragen. Dazu bräuchte ich genauere Infos, welche Inkonsistenzen auftreten.
Looser hat geschrieben:Soll ich einfach es so machen wie in dem How-To? Was soll ich in den preference Datei eingeben? Geht das überhaupt?
ja das sollte ebenfalls gehen. In der sources.list alles zurückändern auf 9.0. Danach apt-get update aufrufen.

In der Preferences folgendes eintragen:

Code: Alles auswählen

Package: *
Pin: release v=9.0
Pin-Priority: 1001
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Looser
Newbie
Newbie
Beiträge: 6
Registriert: 21. Sep 2004, 12:40

Beitrag von Looser » 22. Sep 2004, 15:01

Hallo oc2pus,

Vielen Dank für die Antwort. Ich habe mich schon gestern entschieden, zurück zu 9.0 zu migrieren.
Welche Inkonsistenzen?
Ich weiß nicht, ob ich "Inkonsistenzen" als Wort richtig gewählt habe. Ich habe mehrere Probleme, die von den ganzen init skripts (?) kommen könnten, oder modulen konfig (mit den 2.4 kernel):

- Das netzwerk funktionniert nicht richtig, ich muß meine beide Karten selbst manuel konfigurieren (ifconfig) und hoch laufen lassen, mit ifup.
- Der pppoe treiber muß ich auch selbst laden, und die dsl verbindung manuel hoch bringen
- usb funktionniert nicht mehr
- samba auch nicht

Außerdem, Yast2 sieht kein geräte mehr (kein disk adapter, kein netzwerk karte, kein cd lauftwerk, ...).

Ich glaube, dass ich auch ein bißchen krank bin, weil ich versuche immer die letzte version zu installieren.

Danke für fie Hilfe, und ich sage bescheid wenn etwas nicht laüft.

Jetzt gerade habe ich sowas nach dem download von die ganze packete für 9.0:

Code: Alles auswählen

libcrypto.so.0.9.6 is needed by python-2.3.1-0
libssl.so.0.9.6 is needed by python-2.3.1-0
freeglut-devel is needed by (installed) qt3-devel-3.3.3-15
libgcc >= 3.3.3 is needed by (installed) libdv-0.103-0.pm.0
libstdc++ >= 3.3.3 is needed by (installed) libdv-0.103-0.pm.0
libMagick.so.6 is needed by (installed) pixieplus-0.5.4-410
libMagick.so.6 is needed by (installed) transcode-0.6.12-0.pm.2
libjasper-1.701.so.1 is needed by (installed) kdelibs3-3.3.0-24
libdirectfb-0.9.so.20 is needed by (installed) MPlayer
libresmgr.so.0.9.8 is needed by (installed) gnome-pilot
libresmgr.so.0.9.8 is needed by (installed) kdegraphics3-scan
libresmgr.so.0.9.8 is needed by (installed) kdemultimedia3-CD
liblber.so.199 is needed by (installed) libgda
libldap.so.199 is needed by (installed) libgda
libslang-utf8.so.1 is needed by (installed) kdeaddons3-sound
libslang-utf8.so.1 is needed by (installed) libdv-0.103-0.pm.0
<....>
libdb_cxx-4.2.so is needed by (installed) kdeaddons3-sound
libpopt.so.0 is needed by (installed) gnome-vfs2-2.6.1-7
libpopt.so.0 is needed by (installed) at-spi-1.4.2-5
libpopt.so.0 is needed by (installed) gnome-session-2.6.1-5
<....>
libc.so.6(GLIBC_2.3.4) is needed by (installed) gtkhtml2
libc.so.6(GLIBC_2.3.4) is needed by (installed) kdelibs3
<...>
glibc >= 2.3.3 is needed by (installed) libdv-0.103-0.pm.0
libidn.so.11 is needed by (installed) kconfigure-1.2-493
libidn.so.11 is needed by (installed) kdemultimedia3-sound-3.3.0- 
<....>
libwrap.so.0 is needed by (installed) gnome-session-2.6.1-5
Naja, ich suche auch erstmal, aber wenn Sie ein Tipp haben, ich nehme es gern :wink:

Vielen Dank nochmal,
Looser

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Sep 2004, 18:23

@looser
bitte mit diesem Problem einen neuen Thread eröffnen. OK?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 22. Sep 2004, 23:41

das thema wurde der übersichthalber geteilt (vom howto upgrade 9.0 --> 9.1 )

zum prob gabs bereits 2 posts in neuem thema:
looser hat geschrieben:Hallo,

Ich habe mit dem How-To (http://www.linux-club.de/viewtopic.php?t=13107) von oc2pus mein suse 9.0 zu 9.1 upgraded. Nachdem ich probleme mit den kernel 2.6 hatte, habe ich es geschaft zurück zu 9.0 zu migrieren. Ich habe mehr oder weniger den "rückwärts" How-to gefolgt.

Wenn ihr das auch machen wollt, und dieselbe Probleme als ich habt (How-to thread anschauen), einfach in diesen neudn thread fragen.

@oc2pus : nochmal vielen Dank

Looser

oc2pus hat geschrieben:danke für die Mitarbeit ;)

ist deine Rückmigration erfolgreich abgeschlossen? geht wieder alles?
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Looser
Newbie
Newbie
Beiträge: 6
Registriert: 21. Sep 2004, 12:40

Beitrag von Looser » 23. Sep 2004, 15:12

Hallo,

Oc2pus:
ist deine Rückmigration erfolgreich abgeschlossen? geht wieder alles?
Die ist jetzt fast erfolgreich. Die haben mehrere Datei geändert in 9.1 in /etc. Z.b., /etc/sysconfig/hardware ist eine Datei in 9.0, eine Verzeichnis in 9.1.

Ich muß noch nach Unterschiede suchen. Zum glück hatte ich ein Backup mit Mondorescue (http://www.mondorescue.org, http://www.mikenjane.net/~mike/) gemacht.

Es gab auch ein Problem mit meine Internet Verbindung : die letzte libpcap und smppp packages funktionieren nicht zusamen mit dem ppp package. Ich habe einfach die datei von meine Suse 9.0 DVD wieder installiert. Ich hatte schon gelesen, dass das libpcap=>0.8 probleme hat.

Jetzt, habe ich den kernel 2.4.21-243 neu kompiliert und installiert (inklusive initrd), aber der Rechner hat immer noch Probleme am boot/shutdown time. Ein DVD lauftwerk ist nicht erkannt, am boot. Der Rechner versucht auch immer der ide-floppy module zu laden, obwohl das Ding nicht im mondules.conf oder im initrd zu laden ist. Ich weiß noch nicht woher das kommt:

Code: Alles auswählen

<6>ide-floppy driver 0.99.newide
<6>Partition check:
<6> hde: hde1 hde2 hde3 hde4
<6> hdf: unknown partition table
<6> hdg: hdg1
<6> hdh: hdh1 hdh2 hdh3 hdh4
<6>ide-floppy driver 0.99.newide
<...>
<6>ide-floppy driver 0.99.newide
<3>hde1: bad access: block=0, count=4
<4>end_request: I/O error, dev 21:01 (hde), sector 0
<3>hde1: bad access: block=1, count=3
<4>end_request: I/O error, dev 21:01 (hde), sector 1
<...>
<6>ide-floppy driver 0.99.newide
<6>ide-floppy driver 0.99.newide
<6>ide-floppy driver 0.99.newide
<3>hde1: bad access: block=0, count=4
<4>end_request: I/O error, dev 21:01 (hde), sector 0
<3>hde1: bad access: block=1, count=3
<4>end_request: I/O error, dev 21:01 (hde), sector 1
<3>hde1: bad access: block=2, count=2
Außerdem, der hat auch Probleme meine / Partition (reiserfs) zu unmountieren, wenn ich rebooten muß.

Ich glaube aber, dass meine ganze Probleme liegen irgenwo in /etc. Troz alle diese Probleme, meine Rechner scheint wirklich "schneller" zu sein als vorher.

Naja, das hat doch spaß gemacht :D

Tschüss,
Looser

Looser
Newbie
Newbie
Beiträge: 6
Registriert: 21. Sep 2004, 12:40

Beitrag von Looser » 23. Sep 2004, 19:49

Hallo,

Habe raus gefunden, voher die ganze meldungen kommen : lvm2 stat lvm. Das wars.

looser

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 23. Sep 2004, 19:53

und jetzt ist downgrade perfekt ?

das ist super ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Looser
Newbie
Newbie
Beiträge: 6
Registriert: 21. Sep 2004, 12:40

Beitrag von Looser » 23. Sep 2004, 20:30

Ja, der downgrade ist fast perfekt. Die rpm list von vorher und naher (suse 9.0 -> suse 9.1 -> suse 9.0) sehen ähnlich aus. Natürlich sind welche packete jetzt aktueller als vorher, ich habe auch ein Paar weg gelassen (Anwendung die ich nie benutze). Die einzige sache die nicht mehr laüft ist YOU. Ich benutze apt sowieso, aber es bedeutet, das noch etwas nicht richtig ist. Der YOU kann die server liste nicht mehr downloaden, and zeigt eine Errormeldung, mit das folgende als "Details"

Code: Alles auswählen

URL: http://www.suse.de/cgi-bin/suseservers.cgi
arch=i686&lang=en_US&business=0&check=0&distproduct=SuSE-Linux-DVD-i386-9.0-0&yast2-online-update=2.8.8-71&yast2-packagemanager=2.8.36-1&liby2util=2.8.16-2&timezone=Europe/Berlin
wenn ich einfach ein wget zu die Adresse mache, klappt es problemlos. Keine Ahnung was da passiert.

Egal, ich denke meine Erfahrung zeigt das mann auch downgraden kann. Das ist aber viel mehr Arbeit als die Upgrade, da die RPMs specs/install nicht gedacht sind für eine downgrade.

Looser
Newbie
Newbie
Beiträge: 6
Registriert: 21. Sep 2004, 12:40

YOU, apt und curl

Beitrag von Looser » 24. Sep 2004, 13:30

Hallo,

der downgrade läuft jetzt perfekt. Das Problem mit You war einfach, dass die curl paket Version von apt nicht mit Yast2 funktioniert hat. Ich habe dann eine andere version installiert:

curl-7.10.7-0.pm.1
curl-devel-7.10.7-0.pm.1

statt

curl-7.11.2-2suse90
curl-devel-7.11.2-2suse90

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste