APT Problem

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Psych
Newbie
Newbie
Beiträge: 33
Registriert: 31. Aug 2004, 01:55

APT Problem

Beitrag von Psych » 19. Sep 2004, 13:27

Nach einem Downgrade von Kde 3.3 zu 3.2 bekomm ich bei Apt bei praktisch allen Versuchen irgendwas wieder ans rennen zu bekommen (mein Yast is kaputt) Fehlermeldungen wie diese...

Auch Apt-get -f install ergibt nur: "Außerstande Abhängigkeiten zu reparieren"

Fehlermeldungen sind Seiten lang....hier mal ein Auszug:

Code: Alles auswählen

xsane: Hängt ab von: libgdk-x11-2.0.so.0
         Hängt ab von: libgdk_pixbuf-2.0.so.0
         Hängt ab von: libgphoto2.so.2
         Hängt ab von: libgtk-x11-2.0.so.0
  xscreensaver: Hängt ab von: /bin/sh
                Hängt ab von: libgdk-x11-2.0.so.0
                Hängt ab von: libgdk_pixbuf-2.0.so.0
                Hängt ab von: libgdk_pixbuf_xlib-2.0.so.0
                Hängt ab von: libgtk-x11-2.0.so.0
  yast2: Hängt ab von: yast2-core (>= 2.7.1) aber es ist nicht installiert
         Hängt ab von: /bin/bash
  yast2-bootloader: Hängt ab von: yast2-core aber es ist nicht installiert
                    PreDepends: /bin/sh
                    Hängt ab von: /bin/bash
                    Hängt ab von: libscr.so.2
  yast2-inetd: Hängt ab von: yast2-users aber es ist nicht installiert
  yast2-installation: Hängt ab von: yast2-users aber es ist nicht installiert
                      Hängt ab von: /bin/bash
                      Hängt ab von: /bin/sh
  yast2-ldap: Hängt ab von: libscr.so.2
  yast2-ldap-client: Hängt ab von: yast2-pam aber es ist nicht installiert
                     PreDepends: /bin/sh
  yast2-ncurses: Hängt ab von: libyui.so.2
  yast2-nis-client: Hängt ab von: yast2-pam aber es ist nicht installiert
                    Hängt ab von: yast2-core (>= 2.8.0) aber es ist nicht installiert
                    Hängt ab von: libscr.so.2
  yast2-packagemanager: PreDepends: /bin/sh
  yast2-perl-bindings: Hängt ab von: libpy2plugin.so.2
                       Hängt ab von: libpy2program.so.2
                       Hängt ab von: libpy2scr.so.2
                       Hängt ab von: libpy2stdio.so.2
                       Hängt ab von: libpy2wfm.so.2
                       Hängt ab von: libscr.so.2
                       Hängt ab von: liby2.so.2
                       Hängt ab von: libycp.so.2
                       Hängt ab von: libyui.so.2
  yast2-printer: Hängt ab von: /bin/bash
                 Hängt ab von: libscr.so.2
  yast2-profile-manager: Hängt ab von: libscr.so.2
  yast2-qt: Hängt ab von: libyui.so.2
  yast2-restore: Hängt ab von: yast2-core aber es ist nicht installiert
                 Hängt ab von: aaa_base aber es ist nicht installiert
  yast2-samba-client: Hängt ab von: yast2-pam aber es ist nicht installiert
  yast2-samba-server: Hängt ab von: yast2-pam aber es ist nicht installiert
  yast2-slp: Hängt ab von: libscr.so.2
  yast2-sound: Hängt ab von: /bin/bash
               Hängt ab von: libscr.so.2
  yast2-storage: Hängt ab von: libscr.so.2
  yast2-support: Hängt ab von: /bin/bash
                 Hängt ab von: /bin/sh
  yast2-theme-SuSELinux: PreDepends: /bin/sh
  yast2-transfer: Hängt ab von: libscr.so.2
  yast2-update: Hängt ab von: /bin/bash
                Hängt ab von: /bin/sh
  yast2-x11: Hängt ab von: /bin/sh
             Hängt ab von: libscr.so.2
  yast2-xml: Hängt ab von: libscr.so.2
  yelp: PreDepends: /bin/sh
        PreDepends: /bin/sh
        Hängt ab von: libgdk-x11-2.0.so.0
        Hängt ab von: libgdk_pixbuf-2.0.so.0
        Hängt ab von: libgnome-2.so.0
        Hängt ab von: libgtk-x11-2.0.so.0
  yp-tools: Hängt ab von: /bin/sh
  ypbind: PreDepends: /bin/sh
          PreDepends: /bin/sh
          PreDepends: /bin/sh
          Hängt ab von: /bin/sh
  zsh: PreDepends: /bin/sh
       PreDepends: /bin/sh
  zvbi: PreDepends: /bin/sh
        PreDepends: /bin/sh
Kann mir einer helfen???

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Sep 2004, 13:46

sowas lässt sich besser im chat richten ... http://hotspace.de/irc

ansonsten sources.list anpassen, damit apt nur die kde3.2 sieht
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Psych
Newbie
Newbie
Beiträge: 33
Registriert: 31. Aug 2004, 01:55

Beitrag von Psych » 19. Sep 2004, 14:05

Ausgabe von apt-get update :

Code: Alles auswählen

dhcppc0:/daten/downloads # apt-get update
Hole:1 ftp://ftp.gwdg.de SuSE/9.1-i386 release [10,8kB]
Hole:2 ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.1-i386 release [10,8kB]
21,5kB in 0s (33,3kB/s) geholt
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/base pkglist
Treffer ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.1-i386/base pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/base release
Treffer ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.1-i386/base release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/update pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/update release
Treffer ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.1-i386/update pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/gnome pkglist
Treffer ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.1-i386/update release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/gnome release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/kde3-stable pkglist
Treffer ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.1-i386/security pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/kde3-stable release
Treffer ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.1-i386/security release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/mozilla pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/mozilla release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/samba3 pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/samba3 release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/wine pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/wine release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/xfree86 pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/xfree86 release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/ximian pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/ximian release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/packman pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/packman release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/packman-i686 pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/packman-i686 release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/funktronics pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/funktronics release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/xorg pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/xorg release
Hole:1 ftp://ftp.gwdg.de SuSE/9.1-i386/suser-people pkglist
Fehler ftp://ftp.gwdg.de SuSE/9.1-i386/suser-people pkglist
  Unable to fetch file, server said '/pub/linux/suse/apt/SuSE/9.1-i386/base/pkglist.suser-people.bz2: No such file or directory.  '
Hole:2 ftp://ftp.gwdg.de SuSE/9.1-i386/suser-people release
Ignoriere ftp://ftp.gwdg.de SuSE/9.1-i386/suser-people release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-tcousin pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-tcousin release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-scorot pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-scorot release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-gbv pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-gbv release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-sbarnin pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-sbarnin release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-ollakka pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-ollakka release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-rbos pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suser-rbos release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suse-projects pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/suse-projects release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/base pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/base release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/update pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/update release
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/security pkglist
Treffer ftp://ftp.gwdg.de SuSE/9.1-i386/security release
Gescheitert zu holen ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-i386/base/pkglist.suser-people  Unable to fetch file, server said '/pub/linux/suse/apt/SuSE/9.1-i386/base/pkglist.suser-people.bz2: No such file or directory.  '
rpmdb: read: 0x406ff39c, 4096: Eingabe-/Ausgabefehler
error: db4 error(5) from dbcursor->c_get: Eingabe-/Ausgabefehler
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
W: Release file did not contain checksum information for ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-i386/base/pkglist.suser-people
W: Release file did not contain checksum information for ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-i386/base/release.suser-people
W: Sie möchten `apt-get update' ausführen um diese Problem zu beheben
E: Einige Index-Dateien konnten nicht heruntergeladen werden, sie wurden ignoriert oder alte weiterhin benutzt.

Psych
Newbie
Newbie
Beiträge: 33
Registriert: 31. Aug 2004, 01:55

Beitrag von Psych » 19. Sep 2004, 16:43

dhcppc0:~ # apt-get -s upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be upgraded
XFree86
The following packages have been kept back
control-center2 dirmngr gaim gnome-applets gnome-desktop gnome-panel
gnome-terminal gpdf gpgme gstreamer gstreamer-plugins
gstreamer-plugins-default gstreamer-plugins-excess gstreamer-plugins-extra
kdenetwork3-InstantMessenger kernel-default kernel-source libdvdnav
libgcrypt libgnomeui libgtop libksba librsvg mozilla nautilus sax2 xine-lib
1 upgraded, 0 newly installed, 0 removed and 27 not upgraded.
Inst XFree86 [4.3.99.902-40] (4.3.99.902-43.28 SuSE:9.1/stable)
Conf XFree86 (4.3.99.902-43.28 SuSE:9.1/stable)

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 23. Sep 2004, 08:43

Psych hat geschrieben:dhcppc0:~ # apt-get -s upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be upgraded
XFree86
The following packages have been kept back
control-center2 dirmngr gaim gnome-applets gnome-desktop gnome-panel
gnome-terminal gpdf gpgme gstreamer gstreamer-plugins
gstreamer-plugins-default gstreamer-plugins-excess gstreamer-plugins-extra
kdenetwork3-InstantMessenger kernel-default kernel-source libdvdnav
libgcrypt libgnomeui libgtop libksba librsvg mozilla nautilus sax2 xine-lib
1 upgraded, 0 newly installed, 0 removed and 27 not upgraded.
Inst XFree86 [4.3.99.902-40] (4.3.99.902-43.28 SuSE:9.1/stable)
Conf XFree86 (4.3.99.902-43.28 SuSE:9.1/stable)
Bei so einer Fehlermeldung empfiehlt sich (alles in EINER Zeile eingeben)

Code: Alles auswählen

apt --force control-center2 dirmngr gaim gnome-applets  gnome-desktop gnome-panel gnome-terminal gpdf gpgme gstreamer gstreamer-plugins gstreamer-plugins-default gstreamer-plugins-excess gstreamer-plugins-extra kdenetwork3-InstantMessenger kernel-default kernel-source libdvdnav libgcrypt libgnomeui libgtop libksba librsvg mozilla nautilus sax2
dadurch werden zusätzliche Pakete installiert und die Abhängigkeiten gelöst.
Selbstverständlich kann man auch apt --force <ein-Paket-aus der-Liste> aufrufen, solange bis keine Pakete mehr zurückgehalten werden ...

das Paket xine-lib heisst jetzt libxine1 ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste