[Tool] kio-apt - Integration in den Konqueror

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

[Tool] kio-apt - Integration in den Konqueror

Beitrag von oc2pus » 1. Sep 2004, 09:31

hier ein nettes Tool um apt in den Konqueror zu integrieren:
http://lpnotfr.free.fr/

Beim kompilieren darauf achten, das die RPM-Option beim ./configure angegeben wird, der default ist nämlich Debian ;)

./configure --prefix=/opt/kde3 --with-rpm
If you're a Debian user, and you don't like much the graphical tools like aptitude or dselect, then it's likely you use apt-cache a lot. And you know how it can be painful to search for a package through many MANY "apt-cache search foo" and "apt-cache show bar" lines

The apt ioslave gives the ability to use apt-cache functionalities, as well as dpkg -S (searches the package containing a file) and dpkg -L (list the files in a package) - and the related functions in rpm - into Konqueror, and provides hypertext which makes browsing all this stuff easier :

* apt:/search?search expression
* apt:/show?package
* apt:/policy?package
* apt:/list?package
* apt:/fsearch?package

All URLs that don't match the above formats, including apt:/, show a page with a HTML query form. The same query form is showed at the bottom of every page generated by the ioslave. It shows also a form for accessing packages.debian.org (if dpkg is used) or rpmfind.net (for apt-rpm users).
Zuletzt geändert von oc2pus am 22. Okt 2004, 12:28, insgesamt 2-mal geändert.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 27. Sep 2004, 10:38

Für SuSE-9.1 gibt es dieses Tool jetzt auch als RPM ;)

Es ist über die Komponente suser-oc2pus verfügbar.
Das benötigte RPMs heisst: kio-apt

Installation mit apt install kio-apt
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Dez 2004, 10:29

Für SuSE-9.2 gibt es dieses Tool jetzt auch als RPM ;)

Es ist über die Komponente suser-oc2pus verfügbar.
Das benötigte RPMs heisst: kio-apt

Installation mit apt install kio-apt
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 1 Gast