Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Installation DualBoot Win10 - Leap 15.2 [gelöst]

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

schroer
Member
Member
Beiträge: 140
Registriert: 5. Nov 2006, 22:54
Wohnort: Berlin (D) / Changchun (China)

Installation DualBoot Win10 - Leap 15.2 [gelöst]

Beitrag von schroer »

Sehr geehrte Damen und Herren,
ich bin ('mal wieder) dabei, einen gekauften PC mit Win10 zu einem DualBoot-System aufzurüsten, diesmal mit Leap 15.2.

Nachdem ich glaubte alle erforderlichen System Partionen auf der SSD eingerichtet zu haben (d.h. für Linux "/", "/home", swap) und Leap 15.2 installieren wollte, bin ich auf folgendes Problem in der Installationsprozedur gestoßen, an dem ich nicht weiterkomme:
  • Fehlermeldung
    "System kann eventuell nicht booten: Missing device for /boot/EFI with size equal or bigger than 256 MB and filesystem vfat."
  • Was ich statt dessen vermisste (und möglicherweise damit im Zusammenhang steht): Die Entscheidung, dass der MBR nicht angefasst wird, und auf welche Parition GRUB2 gelegt werden soll.
  • Soll ich zusätzlich eine kleine Partition für "/boot/EFI" einrichten?
    Das wäre dann zusätztich zur schon vorhandenen "EFI-System-Partition" von 100 MB am Anfang der SSD, die das Win10 ja schon mitbrachte?
  • Oder soll ich diese vorhandene EFI-System-Partition auf > 256 MB vergrößern?
  • Wichtig ist mir, dass ich notfalls über fstab und unabhängig von allen Bootmanagern eine Partition zum Booten zur "Aktiven" machen kann, damit von dort ein Betriebssystem gebootet werden kann.
Wenn jemand einen Tipp dazu hat, würde ich mich über eine Antwort freuen.
Mit freundlichen Grüßen
K. Schröer
Zuletzt geändert von schroer am 27. Sep 2020, 21:48, insgesamt 1-mal geändert.
Benutzeravatar
spezi
Advanced Hacker
Advanced Hacker
Beiträge: 808
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von spezi »

Guten Morgen,
mit Win 10 hast Du, aller Wahrscheinlichkeit nach, ein efi System. Du solltest in der Installationsroutine von OS 15.2 die vorhandene efi Partition einhängen. So wie die anderen von Dir genannten Partitionen. MBR brauchst Du nicht. Ich hoffe das ich Dein Problem richtig verstanden habe.

mfg
spezi
Dell Optiplex 790 i5-2400, LG-32MP58, Lenovo V320 i5-7200U, BR MFC-J4420DW, FRITZ!Box 7490, Synology DS215j, oS Leap 15.2, Raucher
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2344
Registriert: 24. Okt 2005, 14:04

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von Heinz-Peter »

Hallo @schroer,

wir hier in Forum benutzen Alle die "Du" Form, weil einfach einfacher :)
Jetzt zurück zu deinem Problem.
Ein Backup deiner Windows Dateien sollst unbedingt machen.
Sprechen wir hier von einer Festplatte?
Wie groß ist die?

Die /boot/EFI Partition von Windows ist mit 100 MB sehr knapp bemessen und eine Vergrößerung der Partition wird dein Windows zerschießen.

Ich habe schon gelesen von zwei /boot/EFI Partition auf EINER Festplatte aber selber nicht getestet. Keine Ahnung ob das gut geht. Warte also auf andere Antworten.

Grüße
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
Benutzeravatar
susejunky
Advanced Hacker
Advanced Hacker
Beiträge: 809
Registriert: 19. Sep 2014, 18:22

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von susejunky »

Hallo schroer,
schroer hat geschrieben: 22. Sep 2020, 08:00... Fehlermeldung
"System kann eventuell nicht booten: Missing device for /boot/EFI with size equal or bigger than 256 MB and filesystem vfat."
Diese "Fehlermeldung" ist bekannt und stiftet meist zu Unrecht Verwirrung, denn in aller Regel sind 100MB für eine EFI Systempartition (ESP) ausreichend, um MS Windows und openSUSE zu installieren.

schroer hat geschrieben: 22. Sep 2020, 08:00... Was ich statt dessen vermisste (und möglicherweise damit im Zusammenhang steht): Die Entscheidung, dass der MBR nicht angefasst wird, und auf welche Parition GRUB2 gelegt werden soll.
Wenn der Systemstart im UEFI-Modus erfolgt (und NICHT im MBR-Modus) dann spiel der MBR beim Systemstart keine Rolle und die Bootloader liegen in der/einer ESP.

NACHTRAG
Hinweis!
Es ist empfehlenswert, immer alle Betriebssysteme im selben Bootmodus (UEFI- oder MBR- Bootmodus) zu installieren. Nur so kann GRUB2 (der openUSE Bootloader) auch alle Betriebssysteme in sein Bootmenü aufnehmen und starten.
ENDE NACHTRAG

schroer hat geschrieben: 22. Sep 2020, 08:00... Soll ich zusätzlich eine kleine Partition für "/boot/EFI" einrichten? Das wäre dann zusätztich zur schon vorhandenen "EFI-System-Partition" von 100 MB am Anfang der SSD, die das Win10 ja schon mitbrachte?
Man kann auch eine weitere ESP (>256MB) anlegen und diese für die openSUSE-Installation benutzen (allerdings muss man dann zukünftig immer beachten, dass es zwei ESPs).

schroer hat geschrieben: 22. Sep 2020, 08:00... Wichtig ist mir, dass ich notfalls über fstab und unabhängig von allen Bootmanagern eine Partition zum Booten zur "Aktiven" machen kann, damit von dort ein Betriebssystem gebootet werden kann.
Die Datei fstab kommt erst zum Tragen, wenn das Betriebssystem bereits gestartet ist.

Hier ein paar Links mit Informationen zum Bootvorgang und UEFI:

https://de.wikipedia.org/wiki/Booten
https://de.wikipedia.org/wiki/UEFI
https://www.rodsbooks.com/efi-bootloaders/

Viele Grüße

susejunky
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5506
Registriert: 23. Sep 2008, 17:09

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von josef-wien »

Nach Deiner Beschreibung hast Du ein UEFI-System. Daher mußt Du Dich von allem lösen, was Du Dir an Wissen über den Boot-Vorgang des PC angeeignet hast, der MBR spielt bei einem UEFI-System nicht mehr mit. Jedes Betriebssystem legt auf der EFI-Systempartlition das ab, was es zu seinem Start benötigt, und erzeugt eine Eintragung im UEFI-Bootmenü. Ignoriere die Meldung hinsichtlich der Größe, und installiere einfach.

Theoretisch sind EFI-Systempartitionen in unbegrenzter Zahl möglich, sinnvoll ist mehr als eine in der Regel nicht. Die gängigen Automatismen der Betriebssysteme gehen alle von einer einzigen EFI-Systempartition aus.
schroer
Member
Member
Beiträge: 140
Registriert: 5. Nov 2006, 22:54
Wohnort: Berlin (D) / Changchun (China)

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von schroer »

Soweit vielen Dank an alle.

Ich habe die EFI-Warnung erst 'mal ignoriert und installieren lassen.
Am Ende kam aber die Meldung
  • "Fehler beim Ausführen des Befehls "[["/usr/sbin/shim-install", "--config-file=/boot/grub2/grub.cfg"]]."
    Abbruch-Code: 1
    Fehlerausgabe: No valid EFI partition
und GRUB2 wurde nicht installiert.
(Rechner fährt hoch wie früher und startet Win10.)

Etwas irritiert hat mich auch noch folgender Ablauf, der aber mit dem EFI-GRUB-Bootproblem nichts zu tun hat:
  • Ich musste am Anfang zustimmen, dass ich irgendwo registriert werde.
  • Dann wurde der öffentliche Schlüssel des Zertifikat für root installiert (oder gefunden) auf "/tmp/d20200922-xxxx-xxxxxx.pub" auf /dev/sda1.
  • Ich versuchte das zu ändern, denn "/dev/sda1" ist die vfat-ESP einer alten 1TB-HDD, die jetzt nur noch als Datenplatte verwendet wird, von der ab nicht gebootet wird. Es war aber nicht möglich, das zu ändern.
"Wir schaffen das." Hat 'mal jemand gesagt.
Zweckdienliche Hinweise sind weiterhin willkommen.

Mit freundlichen Grüßen
K. Schröer
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von Sauerland »

Nachdem ich glaubte alle erforderlichen System Partionen auf der SSD eingerichtet zu haben (d.h. für Linux "/", "/home", swap)
Warum lasst ihr das nicht den Installer machen, bzw macht das während der Installation und nicht vorher?
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von Sauerland »

Früher:
Windows gestartet----Auslagerungsdatei gelöscht----defragmentiert----Windows verkleinert.

Heute:
Zwingend in Windows den Schnellstart deaktivieren.
Da Windows 10 meist im UEFI-Modus installiert ist, sollte openSUSE auch im Uefi-Modus installiert werden, erkennbar daran, das im 1. Installationsbildschirm unten keine F-Tastenabfragen erscheinen. Im UEFI-Modus funktioniert z.b. das eintragen für nomodeset nur mit drücken der Taste e für edit.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5506
Registriert: 23. Sep 2008, 17:09

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von josef-wien »

Frage 1: Hast Du während der Installation dafür gesorgt, daß die EFI-Systempartition unter /boot/efi eingehängt wird?

Frage 2: Kannst Du das installierte System über das Installationsmedium starten?
schroer
Member
Member
Beiträge: 140
Registriert: 5. Nov 2006, 22:54
Wohnort: Berlin (D) / Changchun (China)

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von schroer »

Vielen Dank.

Zu Frage 1 von josef-wien:
Leider nein. Das wusste ich nicht.

Zu Frage 2 von josef-wien:
  • Ja, ich kann über Live-USB-Stick (Leap 15.2 Installtionsmedium), oder jeden anderen Live-USB-Stick (z.B. von PartedMagic, mit dem ich meine Partitionen vorbereitet hatte) starten.
  • Mit Leap15.2-USB-Stick:
    • "Boot from Harddisc" geht nicht, denn er findet /boot/efi nicht.
    • Unter "Start Linux" (oder so ähnlich) findet er auch das Leap15.2; allerdings kommt dann eine Frage "You may select an alternative device name for the system partition", und wenn ich es dann bei /dev/sdb4 belasse (und nicht eine der anderen kryptischen Bezeichnungen "/dev/disk/by-...." wähle, passiert gar nicht mehr.
  • Aber ich kann natürlich auch mit Parted-Magic-USB-Stick das Linux auf dem Parted-Magic-USB-Stick starten.
Weiterhin:
Das "Fastboot" habe ich im BIOS sicherheitshalber deaktiviert.

Aufgrund der Problemlage will ich die "Flughöhe" noch etwas erhöhen:
  • Ich bin gerade dabei einen Rechner aufzusetzen, der zu Hause die Funktion eines Familenservers hat.
  • Das wichtigste: Die 1TB (alte) HDD mit den User-Daten (und (noch) der alten Partitionsstruktur eines Win-Linux-DualBoot-Systems).
  • Diese HDD habe ich in einen neuen DeskTop-PC mit 250GB-SSD stecken lassen.
  • Die SSD wollte ich künftig als System-"Platte" für das DualBoot-System nutzen und die HDD als reine UserDaten-Platte.
Im Voraus vielen Dank für weitere Ideen und Vorschläge
K. Schröer
Benutzeravatar
susejunky
Advanced Hacker
Advanced Hacker
Beiträge: 809
Registriert: 19. Sep 2014, 18:22

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von susejunky »

Hallo schroer,
schroer hat geschrieben: 23. Sep 2020, 08:16... Ja, ich kann über Live-USB-Stick (Leap 15.2 Installtionsmedium) ... starten.
das openSUSE Leap 15.2 Installationsmedium (https://download.opensuse.org/distribut ... x86_64.iso) ist kein LIVE- sondern lediglich ein Installations- und Rescue-System.

LIVE-Systeme wären z.B. https://download.opensuse.org/distribut ... -Media.iso oder https://download.opensuse.org/distribut ... -Media.iso (die allerdings auch zur Installation verwendet werden können).

Für das weiter Vorgehen wäre es gut zu wissen
  • welches System (.iso) Du konkret verwendest
  • ob in Deinem UEFI secureboot aktiviert ist und falls ja, ...
  • ob Deine MS Windows Installation secureboot benötigt.
Eine ausführliche Beschreibung, wie Du Dein System reparieren kannst, findet Du hier : https://forums.opensuse.org/showthread. ... t-scenario (gilt auch noch für openSUSE Leap 15.2)

Wenn Du bei einem konkreten Schritt nicht weiter kommst, melde Dich hier.

Viele Grüße

susejunky
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5506
Registriert: 23. Sep 2008, 17:09

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von josef-wien »

Versuche mit der Super Grub2 Disk das installierte System zu starten. Wenn das funktioniert, dann:

Code: Alles auswählen

lsblk -o +UUID,FSTYPE

Code: Alles auswählen

cat /etc/fstab

Code: Alles auswählen

ls /sys/firmware/efi
(Im installierten System ist die Reparatur bequemer.)
schroer
Member
Member
Beiträge: 140
Registriert: 5. Nov 2006, 22:54
Wohnort: Berlin (D) / Changchun (China)

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von schroer »

Vielen Dank.

Sieht so als gäbe es da noch ein Problem:
  • SecureBoot ist enabled, und ich kann es nicht direkt deaktivieren.
  • Wenn ich versuche von "Super Grub2"-Stick (mit "super_grub2_disk_hybrid_2.04s1.iso") zu booten, kommt eine rote Fehlermeldung:
    "Secure Boot Violation".
Ich kann das alles ändern lassen oder selbst ändern (wenn ich weiß, was ich tun soll).
Das ist ein Tarox-DeskTop, den ich beim lokalen "Computerladen meines Vertrauens" gekauft habe.

Grüße
K. Schröer
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von Sauerland »

SecureBoot ist enabled, und ich kann es nicht direkt deaktivieren.
Das ist ein Punkt in den Tiefen des Bios/UEFI und dort zu deaktivieren.

Ins Bios geht es mit irgendeiner Taste / Tastenkombination vor dem Start des Grub.
Wird in der Doku zu deinem Mainboard stehen.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
schroer
Member
Member
Beiträge: 140
Registriert: 5. Nov 2006, 22:54
Wohnort: Berlin (D) / Changchun (China)

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von schroer »

Entschuldigung. Hat etwas gedauert.
Es konnte mir zwar noch keiner "sagen", wie ich das SecureBoot deaktivieren kann, aber der Wechsel bei "OS Type" von "Windows UEFI mode" zu "Other OS" erlaubte das Booten mit GRUB-USB-Stick.
(Ich verwende die aktuelle Version: "super_grub2_disk_hybrid_2.04s1")

Hier jetzt die Ausgaben:

lsblk

Code: Alles auswählen

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT UUID                                 FSTYPE
sda      8:0    0 931,5G  0 disk                                                 
├─sda1   8:1    0  39,2M  0 part            5450-4444                            vfat
├─sda2   8:2    0  13,3G  0 part            B80ACC5B0ACC17F0                     ntfs
├─sda3   8:3    0 146,5G  0 part            D6F6CE70F6CE5103                     ntfs
├─sda4   8:4    0     1K  0 part                                                 
├─sda5   8:5    0     2G  0 part            e4f9d592-7c64-4e5a-8b33-8625bf8ea3a0 swap
├─sda6   8:6    0  29,3G  0 part            81fc7a5a-23a2-44f6-abdc-9a64c07c1fc9 ext4
├─sda7   8:7    0 146,5G  0 part            512d7306-2ab5-49b9-b193-1bc09e82b6a3 ext4
└─sda8   8:8    0 593,9G  0 part            7CB6E25AB6E21504                     ntfs
sdb      8:16   0 232,9G  0 disk                                                 
├─sdb1   8:17   0   100M  0 part            768D-B009                            vfat
├─sdb2   8:18   0   128M  0 part                                                 
├─sdb3   8:19   0   135G  0 part            20428E2D428E082C                     ntfs
├─sdb4   8:20   0  29,3G  0 part /          77bf308c-8e59-4857-be74-399023aa84c2 ext4
├─sdb5   8:21   0  48,4G  0 part /home      123636dc-9935-4b02-8a6d-2dc3f6b5cf5e ext4
└─sdb6   8:22   0    20G  0 part [SWAP]     86e15d18-1aee-499e-9763-aeb0a2ae0246 swap
sdc      8:32   1  28,7G  0 disk            2019-08-26-06-55-07-00               iso9660
├─sdc1   8:33   1   146K  0 part                                                 
├─sdc2   8:34   1   2,8M  0 part            41D2-D807                            vfat
└─sdc3   8:35   1  12,6M  0 part                                                 hfsplus
sdd      8:48   1   996M  0 disk                                                 
└─sdd1   8:49   1   996M  0 part /mnt       3E2A-9111                            vfat
sr0     11:0    1  1024M  0 rom                                                  
fstab

Code: Alles auswählen

UUID=77bf308c-8e59-4857-be74-399023aa84c2  /      ext4  defaults      0  1
UUID=123636dc-9935-4b02-8a6d-2dc3f6b5cf5e  /home  ext4  data=ordered  0  2
/sys/firmware/efi

Code: Alles auswählen

insgesamt 0
-r--r--r--   1 root root 4096 26. Sep 12:49 config_table
drwxr-xr-x   2 root root    0 26. Sep 12:32 efivars
drwxr-xr-x   3 root root    0 26. Sep 12:49 esrt
-r--r--r--   1 root root 4096 26. Sep 12:49 fw_platform_size
-r--r--r--   1 root root 4096 26. Sep 12:49 fw_vendor
-r--r--r--   1 root root 4096 26. Sep 12:49 runtime
drwxr-xr-x  15 root root    0 26. Sep 12:49 runtime-map
drwxr-xr-x   2 root root    0 26. Sep 12:49 secret-key
-r--------   1 root root 4096 26. Sep 12:49 systab
drwxr-xr-x 102 root root    0 26. Sep 12:49 vars
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von Sauerland »

Es konnte mir zwar noch keiner "sagen", wie ich das SecureBoot deaktivieren kann,
Sauerland hat geschrieben: 23. Sep 2020, 21:43
SecureBoot ist enabled, und ich kann es nicht direkt deaktivieren.
Das ist ein Punkt in den Tiefen des Bios/UEFI und dort zu deaktivieren.

Ins Bios geht es mit irgendeiner Taste / Tastenkombination vor dem Start des Grub.
Wird in der Doku zu deinem Mainboard stehen.
Bei jedem Bios-Hersteller anders, sogar bei den einzelnen Hardwareherstellern.
Daher:
Ohne Infos keine Antwort.
Und selbst da wird wohl mehr geraten werden.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5506
Registriert: 23. Sep 2008, 17:09

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von josef-wien »

Im Kernel ist die EFI-Unterstützung aktiviert. Hänge mit YaST die bereits von Windows verwendete EFI-Systempartition (ich vermute, es ist /dev/sdb1) unter /boot/efi ein, und richte dann mit YaST den Boot-Manager ein. Vor dieser Aktion wirst Du auf der EFI-Systempartition ein Verzeichnis für Windows finden, nach dieser Aktion auch eines für openSUSE (und als root mit

Code: Alles auswählen

efibootmgr -v
die entsprechenden Eintragungen im UEFI-Bootmenü).
schroer
Member
Member
Beiträge: 140
Registriert: 5. Nov 2006, 22:54
Wohnort: Berlin (D) / Changchun (China)

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von schroer »

Vielen Dank!
Es gibt Neuigkeiten.

Zum Thema "SecureBoot":
  • Fa. Tarox (der Konfigurator aus Lünen) ruft mich morgen früh an und erklärt mir, wie ich SecureBoot deaktivieren kann.
  • Das ist aber möglicherweise im Moment nicht das (Haupt-)Problem, s.u.
Zum Thema "GRUB2-Installation" (erfolgreich!):
  • Das, was ich gestern ausgelesen habe, habe ich im Single-User-Command-Line-Modus von Leap15.2 ausgelesen.
  • Grund dafür war, dass ich beim normalen Booten von Leap15.2 mit einem schwarzen Bildschirm geendet bin, auf dem ich zwar meinen Mauszeiger beobachten konnte, aber sonst nichts.
  • Da ich mich mit dem Command-Line-Modus von Yast gar nicht auskenne, habe ich mich nicht getraut, damit weiterzuarbeiten.
  • Aber mir ist dann noch eine andere Idee gekommen: Wenn mit dem Wechsel zu "Other OS" im Bios ein Booten mit dem Grub-USB-Stick möglich war, klappt vielleicht auch die Installation mit dem OpenSuse-Stick.
  • Und so war es dann auch: Ich habe bei der Installation angegeben, dass /dev/sdb1 bei /boot/efi eingehängt werden soll, habe neu installiert, auch Grub wurde installiert und ich konnte starten mit GRUB.
  • Aber leider läuft Leap15.2 nicht. Doch dazu gleich; das scheint ein anderes Problem zu sein. Über das Boot-Menu von Grub kann ich ganz normal Win10 starten.
Neues Problem: Möglicherweise nvidia-Grafiktreiber in Leap15.2?
  • Am Ende der Leap15.2 Installation gab es eine merkwürde Abfrage über einen nvidia-Grafiktreiber. Da ich in dem langen Text nichts gefunden habe, was passiert, wenn ich ein "Ablehnen" eingebe (und ich ja einen Grafiktreiber brauche) habe ich "Akzeptieren" (also "installieren") gewählt.
  • Beim ersten Versuch Leap15.2 (ganz normal über Grub-Menu) zu starten, erhielt ich wieder den schwarzen Bildschirm mit meinem Mauszeiger. Nach einer Viertelstunde habe ich dann mit Hard-Reset neu gestartet.
  • Beim zweiten Versuch Leap15.2 zu starten (auch ganz normal über Grub-Menu), erhielt ich auf einmal viereckig-buntgefleckte Bildschirme.
  • Dann wollte ich Leap15.2 zum dritten Mal installieren und dabei das "Ablehnen" beim Grafiktreiber wählen, aber: Nach dem Starten vom Leap15.2-Installationsstick hatte ich dann dort nach Wahl von "Installation", aber vor dem ersten Bildschirm der Installationsprozedur auch einen viereckig-buntgefleckten Bildschirm, aber kein Installationsmenu.
  • Ich habe es dann noch ein viertes Mal mit dem Leap15.2-Installationsstick probiert, und da ging es wieder. Ich habe dann bei der Frage nach dem Grafiktreiber "Ablehnen" gewählt; Installation lief OK durch; Win10 lässt sich aus dem Grub-Menu starten, ... aber das Booten von Leap15.2 endet diesmal mit einem schwarzen Bildschirm und einem underline-character in der linken oberen Ecke.
Also:
  • Ein Stück weiter (d.h. ich boote mit Grub),
  • aber noch nicht am Ziel (d.h. Leap15.2 läuft noch nicht und ich habe im Moment keine Idee, wie ich das ändern kann).
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von Sauerland »

Starte mal mit nomodeset:
Im grub Bildschirm einfach e drücken und dann in der Zeile mit linux beginnt am Ende mit einem Leerzeichen zum bis dato letzten Punkt einfach

Code: Alles auswählen

nomodeset
eingeben und F10 drücken.

Also mit der Taste Cursor runter auf die Zeile linux gehen und mit der Taste Cursor rechts bis zum letzten Zeichen gehen, dort mit einem Leerzeichen getrennt nomodeset.
Kein Enter, nur F10.

Starte dann dein Linux?
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5506
Registriert: 23. Sep 2008, 17:09

Re: Installation DualBoot Win10 - Leap 15.2 / Ich weiß gerade nicht weiter.

Beitrag von josef-wien »

schroer hat geschrieben:Wenn mit dem Wechsel zu "Other OS" im Bios ein Booten mit dem Grub-USB-Stick möglich war, klappt vielleicht auch die Installation mit dem OpenSuse-Stick.
Das hätte auch im ursprünglichen Zustand funktioniert ([Windows UEFI Mode] = mit "secure boot", [Other OS] = ohne "secure boot").

Ist nach dem Hochfahren im Zustand "schwarzer Bildschirm" das Umschalten mit Strg-Alt-F1 auf eine Textkonsole möglich?

Welche Grafikkarte werkt:

Code: Alles auswählen

/sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
Und nachdem bei jedem Start(versuch) der grafischen Oberfläche die Datei /var/log/Xorg.0.log neu erzeugt wird (sofern Du Xorg und nicht Wayland verwendest), könnte auch deren Inhalt helfen.

Nachtrag auf Grund des Beitrags von Sauerland: Wenn nomodeset hilft, reicht die Ausgabe des Befehls zur Erkennung der Grafikkarte, damit wir wissen, welcher Treiber notwendig ist.
Antworten