Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
gazprom
Newbie
Newbie
Beiträge: 7
Registriert: 10. Dez 2017, 11:49

Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Beitrag von gazprom » 22. Dez 2019, 18:37

Hallo,

Ich versuche wine zu auf Linux Mint 18.3 Cinnamon 64-bit (3.6.6.) über die Konsole zu installieren, da ich
notepad++ auf Linux benötige (zumidest sagt der Online-Tutor das :D)

Mit

Code: Alles auswählen

sudo apt install --install-recommends winehq-stable
bekomme ich folgenden Fehlermeldung:

Code: Alles auswählen

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 winehq-stable : Hängt ab von: wine-stable (= 4.0.3~bionic)
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Meine Frage wäre nun, welche "unmögliche Situation" ich "aufgefordert" habe? :D

Lese ich das richtig, dass wine-stable (von dem winehq-stable abhängt) irgendwie defekt ist?

Thanks, gazprom

Werbung:
abgdf
Guru
Guru
Beiträge: 3245
Registriert: 13. Apr 2004, 21:15

Re: Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Beitrag von abgdf » 23. Dez 2019, 00:01

Kenn' mich mit Deiner Distribution nicht aus, aber neulich konnte ich ein aktuelles wine ganz gut aus den Quellen kompilieren, sogar auf einem inzwischen recht alten System.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5362
Registriert: 23. Sep 2008, 17:09

Re: Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Beitrag von josef-wien » 23. Dez 2019, 00:18

Hast Du die richtigen Repos für Mint 18.x definiert? Siehe z. B. https://itsfoss.com/install-latest-wine/.

Benutzeravatar
StevieRayClapton
Newbie
Newbie
Beiträge: 22
Registriert: 29. Aug 2013, 21:26

Re: Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Beitrag von StevieRayClapton » 23. Dez 2019, 11:31

Wenn es "nur" darum geht einen Editor mit Syntax-Highlighting für verschiedene Programmier-, Auszeichnungs- und Abfragesprachen zu benutzen, könntest Du auch einfach Geany installieren: https://en.wikipedia.org/wiki/Geany. Das ist sicherlich in den Repos von Mint enthalten.

gazprom
Newbie
Newbie
Beiträge: 7
Registriert: 10. Dez 2017, 11:49

Re: Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Beitrag von gazprom » 23. Dez 2019, 12:17

josef-wien hat geschrieben:
23. Dez 2019, 00:18
Hast Du die richtigen Repos für Mint 18.x definiert? Siehe z. B. https://itsfoss.com/install-latest-wine/.
Ja thanks, ich habs geschafft winehq-stable zu installieren, aber wie öffne ich das jetzt?

dpkg -s winehq-stable gibt dies aus:

Code: Alles auswählen

Package: winehq-stable
Status: install ok installed
Priority: optional
Section: otherosfs
Installed-Size: 72
Maintainer: Rosanne DiMesio <dimesio@earthlink.net>, Marcus Meissner <meissner@suse.com>
Architecture: amd64
Source: wine
Version: 4.0.3~xenial
Replaces: wine, wine-amd64, wine-i386, wine1.4, wine1.4-amd64, wine1.4-i386, wine1.5, wine1.5-amd64, wine1.5-i386, wine1.6, wine1.6-amd64, wine1.6-i386, wine1.7, wine1.7-amd64, wine1.7-i386, wine32, wine64
Provides: wine, wine-amd64, wine-i386, wine1.4, wine1.4-amd64, wine1.4-i386, wine1.5, wine1.5-amd64, wine1.5-i386, wine1.6, wine1.6-amd64, wine1.6-i386, wine1.7, wine1.7-amd64, wine1.7-i386, wine32, wine64
Depends: wine-stable (= 4.0.3~xenial)
Conflicts: wine, wine-amd64, wine-i386
Description: WINE Is Not An Emulator - runs MS Windows programs
 Wine is a program which allows running Microsoft Windows programs
 (including DOS, Windows 3.x and Win32 executables) on Unix.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5362
Registriert: 23. Sep 2008, 17:09

Re: Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Beitrag von josef-wien » 23. Dez 2019, 16:35

https://wiki.winehq.org/Wine_User's_Gui ... s_programs

P. S. Dein Potential an Eigeninitiative ist verbesserungswürdig.

gazprom
Newbie
Newbie
Beiträge: 7
Registriert: 10. Dez 2017, 11:49

Re: Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Beitrag von gazprom » 23. Dez 2019, 16:52

josef-wien hat geschrieben:
23. Dez 2019, 16:35
P. S. Dein Potential an Eigeninitiative ist verbesserungswürdig.
Ja, ich verwend halt Linux, weil win 7 völlig zerschossen ist und ich den upgrade auf win 10 verpennt habe.
Auf eine Vereinheitlichung bei Linux hofft man jedoch vergebens.

Benutzeravatar
manzek
Member
Member
Beiträge: 228
Registriert: 20. Mär 2005, 14:21
Wohnort: Oldenburger Land

Re: Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Beitrag von manzek » 23. Dez 2019, 16:55

gazprom hat geschrieben:
23. Dez 2019, 16:52
und ich den upgrade auf win 10 verpennt habe.
Windows 7 lässt sich nach wie vor kostenlos auf Windows 10 upgraden!
Das nur mal so am Rande.
So long, Stephan

---
Gigabyte Z77X-D3H * Intel i7-3770K LCS @ 4,2 GHz * 16 GB DDR3 @ 1866 MHz * nVIDIA GeForce RTX 2070 SUPER, 8192 MB * 23,6" - LED @ 1920x1080 * openSUSE Leap 15.1 * KDE 5.12.x

gazprom
Newbie
Newbie
Beiträge: 7
Registriert: 10. Dez 2017, 11:49

Re: Error: Installlation wine /Linux Mint 18.3 Cinnamon 64-bit (3.6.6.)

Beitrag von gazprom » 23. Dez 2019, 17:37

manzek hat geschrieben:
23. Dez 2019, 16:55


Windows 7 lässt sich nach wie vor kostenlos auf Windows 10 upgraden!
Das nur mal so am Rande.
Ja, win 10 ist in erster Linie für Büroangestellte.

notepad++ über wine funzt jetzt. Das "steil gehen" mit der emulierten Version vermisst man aber.

Geany hab ich versucht über snap zu installieren, läuft noch nicht, ich les aber erst den Artikel, bevor ich
eine Frage dazu stellen. ;)
:D

Dankschön!

Antworten