Seite 1 von 1

[gelöst] mysqli-Extention fehlt in LEAP 15.1

Verfasst: 28. Aug 2019, 17:41
von Fex
Nach dem Update von Leap 42 auf 15.1 fehlt die mysqli-Extension in der PHP 7-Installation. Aufgefallen ist mir das, nachdem beim Start von phpMyAdmin die Fehlermeldung
Die Erweiterung mysqli fehlt. Bitte die PHP-Konfiguration überprüfen. Siehe unsere Dokumentation für mehr Informationen.
ausgegeben wurde.
Habe jetzt folgendes geprüft:

phpinfo() führt die mysqli-Extension nicht auf
in der php.ini ist extension=mysqli aktiviert; im Extension-Verzeichnis /usr/lib64/php7/extensions/ ist keine entsprechende Extension enthalten
zypper se *mysqli bringt die folgende Ausgabe
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+------------------------------+--------------------+--------
| php7-pear-MDB2_Driver_mysqli | MySQLi MDB2 driver | package
Bin jetzt etwas ratlos. Gibt es nebenn den Standard-Repos eine alternative Paketquelle für PHP 7?

Gruß Gert

Re: mysqli-Extention fehlt in LEAP 15.1

Verfasst: 28. Aug 2019, 18:37
von spoensche
Das Paket heisst php7-mysql.

Re: mysqli-Extention fehlt in LEAP 15.1

Verfasst: 28. Aug 2019, 18:59
von Fex
spoensche hat geschrieben:
28. Aug 2019, 18:37
Das Paket heisst php7-mysql.
Danke, das war's! War etwas fehl orientiert, da die mysql-Extension ja aus PHP entfernt wurde, habe ich das Paket nicht beachtet und eben nach mysqli gesucht.