Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Leap 15.0: Kein sauberer shutdown

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Hazel
Member
Member
Beiträge: 204
Registriert: 4. Jun 2004, 10:18
Wohnort: Heroldsberg (ERH)

[Gelöst] Leap 15.0: Kein sauberer shutdown

Beitrag von Hazel » 28. Okt 2018, 21:15

Hallo Forumsbesucher

Ich sitze gerade an einer auf einem (BIOS gesteuerten) Desktop-PC frischinstallierten openSUSE Leap 15.0, die keinen shutdown schafft. Es sieht so aus, als ob der shutdown regulär beginnt, dann aber mit einem grauen Monitorbild stehen bleibt. Ca. 30 Minuten abwarten ändert nichts an diesem Zustand. Dann bleibt nur noch die Betätigung des Gehäuseschalters als letztes Hilfsmittel.

Die mir seit Jahren vertrauten Geräusche aus dem PC-Gehäuse weisen ebenfalls darauf hin, dass der shutdown-Vorgang zwar startet, dann aber irgendwie steckenbleibt. U.a. der Lüfter orgelt weiter.

Keinen Unterschied macht es, ob ich

Code: Alles auswählen

shutdown -h now
oder

Code: Alles auswählen

shutdown -r now
eingebe.

Eine auf einem Notebook vor wenigen Tagen installierte Leap 15.0 hat bisher keine derartigen Probleme gezeigt. Ich bilde mir daher ein, dass ich beide Installationen auf dieselbe Art und Weise durchgeführt habe, ohne irgendwelche abweichenden oder besonders trickreichen Konfigurationsoptionen.

Eine seit Monaten auf demselben PC laufende Leap 42.3 hatte beim shutdown noch nie Probleme.

Gibt es eigentlich log-Dateien vom shutdown-Prozess? ('journalctl' scheint nur Meldungen seit dem letzten Hochfahren wiederzugeben.) Oder was kann ich sonst noch tun?

Grüße
Hazel
Zuletzt geändert von Hazel am 1. Nov 2018, 16:57, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4292
Registriert: 14. Jun 2004, 09:12

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von Geier0815 » 29. Okt 2018, 12:29

Code: Alles auswählen

systemctl poweroff
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

rolandb
Hacker
Hacker
Beiträge: 437
Registriert: 31. Jan 2014, 17:11

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von rolandb » 29. Okt 2018, 19:30

Geier0815 hat geschrieben:
29. Okt 2018, 12:29

Code: Alles auswählen

systemctl poweroff

Code: Alles auswählen

$ file /sbin/shutdown 
/sbin/shutdown: symbolic link to /usr/bin/systemctl

Hazel
Member
Member
Beiträge: 204
Registriert: 4. Jun 2004, 10:18
Wohnort: Heroldsberg (ERH)

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von Hazel » 29. Okt 2018, 19:45

Hallo

Danke Ihr beiden, dass Ihr Euch in mein Problem hineingedacht habt.

Wie nach Rolands Beitrag zu erwarten war, führt

Code: Alles auswählen

systemctl poweroff
exakt in denselben System-Schwebezustand wie anfangs beschrieben.

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1857
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von gehrke » 29. Okt 2018, 20:07

Hazel hat geschrieben:
28. Okt 2018, 21:15
Gibt es eigentlich log-Dateien vom shutdown-Prozess? ('journalctl' scheint nur Meldungen seit dem letzten Hochfahren wiederzugeben.)
Wahrscheinlich musst Du das persistente Logging erst konfigurieren.

Code: Alles auswählen

Storage=persistent
https://www.freedesktop.org/software/sy ... .conf.html

rolandb
Hacker
Hacker
Beiträge: 437
Registriert: 31. Jan 2014, 17:11

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von rolandb » 29. Okt 2018, 22:32

Hazel hat geschrieben:
28. Okt 2018, 21:15
Es sieht so aus, als ob der shutdown regulär beginnt, dann aber mit einem grauen Monitorbild stehen bleibt.
Welche System-Meldungen zeigt denn der Monitor vom shutdown-Vorgang, bevor er auf ein graues Bild wechselt?
Könnest du vielleicht ein Foto davon machen?

Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4292
Registriert: 14. Jun 2004, 09:12

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von Geier0815 » 30. Okt 2018, 11:27

rolandb hat geschrieben:
29. Okt 2018, 19:30
Geier0815 hat geschrieben:
29. Okt 2018, 12:29

Code: Alles auswählen

systemctl poweroff

Code: Alles auswählen

$ file /sbin/shutdown 
/sbin/shutdown: symbolic link to /usr/bin/systemctl
Mir ging es in erster Linie darum das ein "systemctl halt" (also das was ein shutdown -h macht) das System runterfährt aber den Rechner nicht ausschaltet. Also letztlich ein ähnliches Verhalten zeigt wie vom TO beschrieben. "systemctl poweroff" schaltet den Rechner auch aus. Aber offensichtlich liegt das Problem wohl noch an anderer Stelle.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Benutzeravatar
muck19
Hacker
Hacker
Beiträge: 524
Registriert: 21. Mär 2010, 12:20
Wohnort: 77830 Bühlertal

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von muck19 » 30. Okt 2018, 11:36

Hänge mich als Mitleser mal mit dran.
Habe seit 3 Wochen genau das Gleiche Problem.
Von 5x runterfahren geht es 4x nicht, auch als root nicht.
Auf ttf1 ist dann auch nur ein blinkender Cursor zu sehen.
vokoscreen -> Screencastprogramm für OpenSuse / Ubuntu / Debian unter
http://www.kohaupt-online.de/hp
Desktopvideos mit Ton

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16606
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von whois » 30. Okt 2018, 11:49

Hi

Ich nutze kein Suse deshalb frage ich jetzt auch mal allgemein und quer rein.
Läuft bei euch Baloo.
Ich hatte letztens damit ähnliche Probleme bei einem System das ein Freund benutzt und erst das abschalten hat den Status wieder in Ordnung gebracht.
Das war allerdings Kubuntu.

Code: Alles auswählen

balooctl status
Vielleicht der total verkehrte Ansatz aber einen Test ist es Wert.

cu

rolandb
Hacker
Hacker
Beiträge: 437
Registriert: 31. Jan 2014, 17:11

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von rolandb » 30. Okt 2018, 12:09

Geier0815 hat geschrieben:
30. Okt 2018, 11:27
Mir ging es in erster Linie darum das ein "systemctl halt" (also das was ein shutdown -h macht) das System runterfährt aber den Rechner nicht ausschaltet.
Das stimmt nicht.
man shutdown hat geschrieben:OPTIONS
      -h      Equivalent to --poweroff, unless --halt is specified.

Code: Alles auswählen

$ shutdown --halt now
ergibt «dauerhaft» als letzte Zeile der Systemmeldungen:
[XXXXX.XXXXXXX]  reboot: System haltet

Hazel
Member
Member
Beiträge: 204
Registriert: 4. Jun 2004, 10:18
Wohnort: Heroldsberg (ERH)

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von Hazel » 30. Okt 2018, 21:55

Hallo

Ich beantworte erst einmal die heute eingegangenen Fragen:
  • whois hat geschrieben:Läuft bei euch Baloo.
    Und das führt auf:

    Code: Alles auswählen

    hazel@localhost:~> balooctl status
    Baloo ist zurzeit deaktiviert. Zum Aktivieren führen Sie bitte „balooctl enable“ aus
    hazel@localhost:~>
    Also offensichtlich keine Aktivität von baloo.
  • rolandb hat geschrieben:Welche System-Meldungen zeigt denn der Monitor vom shutdown-Vorgang, bevor er auf ein graues Bild wechselt?
    Ein Foto ist nicht nötig, denn das letzte was ich nach Absetzen des shutdown-Befehls auf dem Monitor sehe, sind die letzten boot-Meldungen (einsehbar auf der Konsole F1):

    Code: Alles auswählen

    [FAILED] Failed to start Setup Virtual Console.
    See 'systemctl status systemd-vconsole-setup service' for details.
    [  OK  ] Started Apply Kernel Variables.
    
    Und dann kommen noch eine Handvoll Meldungen, die alle mit OK beginnen, bis es am Ende heißt

    Code: Alles auswählen

    [  OK  ] Reached target System Initialization.
    Welcome to openSUSE Leap 15.0 - Kernel 4.12.14-lp150.12.22-default (tty1).
    
    Was ich aus anderen Foren weiß ist, dass die FAILED-Meldung kein Grund zur Beunruhigung ist (oder nach allgemeiner Einschätzung sein sollte...).

    Alle anderen zitierten Zeilen dürften ebenfalls aus dem abgeschlossenen boot-Vorgang stammen. Irgendwelche Meldungen, die offensichtlich aus dem shutdown-Prozess stammen, tauchen nicht auf.
  • gehrke hat geschrieben:Wahrscheinlich musst Du das persistente Logging erst konfigurieren.
    Ja, das werde ich tun. Dank der von dir zitierten URL sollte ich das auch hinkriegen.

    Grüße an alle
    Hazel

Hazel
Member
Member
Beiträge: 204
Registriert: 4. Jun 2004, 10:18
Wohnort: Heroldsberg (ERH)

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von Hazel » 30. Okt 2018, 22:16

Hallo,

ich möchte noch eine Bemerkung anhängen.

Meine Erfahrungen sind zwar ähnlich wie die von muck19
muck19 hat geschrieben:
30. Okt 2018, 11:36
Von 5x runterfahren geht es 4x nicht, auch als root nicht.
Auf ttf1 ist dann auch nur ein blinkender Cursor zu sehen.
aber doch nicht völlig identisch.

Ich komme nicht zu einem blinkenden Cursor sondern nur zu einer homogen-grauen Monitoranzeige. Und von einer Erfolgsquote von 20 % beim Herunterfahren bin ich auch noch weit entfernt. Sogar nach dem ersten Abschnitt des Installationsvorgangs, als ein Neustart vorgesehen war, klappte es nicht und ich musste den Gehäuseschalter betätigen. Damals hatte ich mir deshalb noch keine Sorgen gemacht, denn alles passierte ja noch aus einer unvollständigen Installation heraus.

Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4292
Registriert: 14. Jun 2004, 09:12

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von Geier0815 » 31. Okt 2018, 10:05

Die Meldungen die Du hier gepostet hast, stammen mMn noch vom Hochfahren. Wenn Du das nächste Mal herunter fahren willst, geh mal per <STRG><ALT><F1> auf tty1, log dich als root ein und versuch mal per "systemctl stop sddm" oder "systemctl stop lightdm" (je nach dem was bei dir werkelt, ich verwende Debian und hab deshalb keine Ahnung) deinen Displaymanager zu stoppen und gib dann mal "systemctl poweroff" ein. Sollte der Splashscreen auftauchen drücke <ESC> um wirklich die Meldungen zu sehen und schreibe uns dann mal die letzten Meldungen die Du zu sehen bekommst.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Hazel
Member
Member
Beiträge: 204
Registriert: 4. Jun 2004, 10:18
Wohnort: Heroldsberg (ERH)

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von Hazel » 31. Okt 2018, 21:19

Hallo
Geier0815 hat geschrieben:Die Meldungen die Du hier gepostet hast, stammen mMn noch vom Hochfahren.
Richtig. Das war auch schon meine Einschätzung.

Geier0815 hat geschrieben:...versuch mal per "systemctl stop sddm" oder "systemctl stop lightdm" ... deinen Displaymanager zu stoppen
Das erzeugt nur Meldungen

Code: Alles auswählen

Failed to stop ssdm.service: Unit ssdm.service not loaded.
Und analog im Fall des "lightdm".

Geier0815 hat geschrieben:...gib dann mal "systemctl poweroff" ein. Sollte der Splashscreen auftauchen drücke <ESC> um wirklich die Meldungen zu sehen..
Ja, das hat ein wenig weiter geführt. Nach <ESC> erscheint eine lange Latte von Meldungen, deren Zeileneinträge jeweils mit "[ OK ]" beginnen. Am Ende steht

Code: Alles auswählen

[  OK  ] Stopped Remount Root and Kernel File Systems.
[  OK  ] Stopped Create Static Device Nodes in /dev.
[  OK  ] Reached target Shutdown.
Und damit ist dann der Zustand erreicht, den ich im meinem Eingangsbeitrag beschrieben habe.

Hilft uns das weiter?

Grüße
Hazel

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16606
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von whois » 1. Nov 2018, 06:08

Hi

Rein interessehalber zeigst du uns das mal bitte. :???:

Code: Alles auswählen

systemctl list-units
cu

Sauerland
Guru
Guru
Beiträge: 3252
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von Sauerland » 1. Nov 2018, 08:20

Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4292
Registriert: 14. Jun 2004, 09:12

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von Geier0815 » 1. Nov 2018, 08:48

Hazel hat geschrieben:
31. Okt 2018, 21:19

Code: Alles auswählen

[  OK  ] Stopped Remount Root and Kernel File Systems.
[  OK  ] Stopped Create Static Device Nodes in /dev.
[  OK  ] Reached target Shutdown.
Und damit ist dann der Zustand erreicht, den ich im meinem Eingangsbeitrag beschrieben habe.

Hilft uns das weiter?

Grüße
Hazel
Mir ehrlich gesagt nicht, denn das ist exakt das Verhalten das ich von SLES12 kenne wenn man "shutdown -h" statt "systemctl poweroff" verwendet.
Der Tip mit dem ACPI von Sauerland wäre das Erste was ich testen würde, ansonsten würde ich in den Einstellungen des Motherbords gucken ob da was zu finden ist was mit Ausschalten zu tun hat. WakeOnLan wäre zB so ein Kandidat oder irgendwelche Energie-Einstellungen oder ähnliches.

Mich würde aber jetzt ehrlich mal interessieren welcher DisplayManager bei dir läuft, allzuviele Kandidaten bleiben ja nicht mehr übrig. KDM, GDM oder XDM würden mir so adhoc noch einfallen. "systemctl | grep dm" könnte dir die Auswahl eingrenzen, aber dann mußt Du selber gucken welcher, von den genannten, aufgelistet wird und auch als loaded und active angezeigt wird.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5175
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von tomm.fa » 1. Nov 2018, 09:38

Wenn ihr wissen wollt welcher Displaymanager verwendet wird, dann sollte es mittels

Code: Alles auswählen

/usr/sbin/update-alternatives --display default-displaymanager
herauszufinden sein, oder

Code: Alles auswählen

systemctl status display-manager.service
Beispiel:

Code: Alles auswählen

/usr/sbin/update-alternatives --display default-displaymanager
default-displaymanager - manual mode
  link best version is /usr/lib/X11/displaymanagers/gdm
  link currently points to /usr/lib/X11/displaymanagers/lightdm
  link default-displaymanager is /usr/lib/X11/displaymanagers/default-displaymanager
/usr/lib/X11/displaymanagers/console - priority 5
/usr/lib/X11/displaymanagers/gdm - priority 25
/usr/lib/X11/displaymanagers/lightdm - priority 15
/usr/lib/X11/displaymanagers/sddm - priority 25
/usr/lib/X11/displaymanagers/xdm - priority 10

Code: Alles auswählen

systemctl status display-manager.service 
● display-manager.service - X Display Manager
   Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2018-11-01 09:05:08 CET; 27min ago
  Process: 2103 ExecStart=/usr/lib/X11/display-manager start (code=exited, status=0/SUCCESS)
 Main PID: 2210 (lightdm)
    Tasks: 5 (limit: 4915)
   CGroup: /system.slice/display-manager.service
           ├─2210 /usr/sbin/lightdm
           └─2218 /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
Würde ich jetzt nur nach sddm schauen mittels systemctl:

Code: Alles auswählen

systemctl status sddm.service 
● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/usr/lib/systemd/system/sddm.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:sddm(1)
           man:sddm.conf(5)
Wäre es dann ein Fehler? Nein, da ich ja eine Alternative und nicht SDDM verwende.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

rolandb
Hacker
Hacker
Beiträge: 437
Registriert: 31. Jan 2014, 17:11

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von rolandb » 1. Nov 2018, 10:30

whois hat geschrieben:
1. Nov 2018, 06:08
Rein interessehalber zeigst du uns das mal bitte. :???:

Code: Alles auswählen

systemctl list-units
Kleiner Hinweis: Dieses Kommando lädt die Liste der bekannten Units (ca. 150) in einen Pager.
 
Hazel hat geschrieben:
31. Okt 2018, 21:19
Geier0815 hat geschrieben:...gib dann mal "systemctl poweroff" ein. Sollte der Splashscreen auftauchen drücke <ESC> um wirklich die Meldungen zu sehen..
Ja, das hat ein wenig weiter geführt. Nach <ESC> erscheint eine lange Latte von Meldungen, deren Zeileneinträge jeweils mit "[ OK ]" beginnen. Am Ende steht

Code: Alles auswählen

[  OK  ] Stopped Remount Root and Kernel File Systems.
[  OK  ] Stopped Create Static Device Nodes in /dev.
[  OK  ] Reached target Shutdown.
Und damit ist dann der Zustand erreicht, den ich im meinem Eingangsbeitrag beschrieben habe.
Hilft uns das weiter?
Das hilft leider nicht weiter, da unterhalb und zugehörig zu "Reached target Shutdown" Kernelmeldungen erscheinen müssten. Spaßes Halber könntest du testen, ob es Unterschiede zwischen systemctl halt, poweroff & reboot gibt.

Der Kernel verschluckt sich offenbar an der Hardware. Was steckt in dem (BIOS gesteuerten) Desktop-PC genau drin?

Code: Alles auswählen

sudo dmidecode -t 2,4,10
Mit welchen Parametern wird der Kernel aktuell gebootet?

Code: Alles auswählen

cat /proc/cmdline
Zuletzt geändert von rolandb am 1. Nov 2018, 10:39, insgesamt 1-mal geändert.

admine
Administrator
Administrator
Beiträge: 8785
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Leap 15.0: Kein sauberer shutdown

Beitrag von admine » 1. Nov 2018, 10:34

rolandb hat geschrieben:
1. Nov 2018, 10:30
Das hilft leider nicht weiter, da unterhalb und zugehörig zu "Reached target Shutdown" Kernelmeldungen erscheinen müssten.
Hm, also bei meinem Leap 15.0-Laptop ist genau das die letzte Meldung - danach ist/geht er aus. ;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Antworten