Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst]k3b findet nach Upgrade MP3 DekodierModul nicht

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
ecki4
Member
Member
Beiträge: 119
Registriert: 14. Okt 2007, 15:31

[gelöst]k3b findet nach Upgrade MP3 DekodierModul nicht

Beitrag von ecki4 » 5. Jan 2018, 18:42

Hallo,
ich habe seit kurzem das Upgrade auf Leap 42.3. durchgeführt. Jetzt meldet sich k3b immer wieder mit der Meldung, das Audio-Dekodier-Modul nicht zu finden, obwohl ich Packman aktiviert habe und alles für k3b installiert habe!

Die Meldung lautet:

MP3-Audio-Dekodier-Modul nicht gefunden. K3b kann kein MP3-Dekodier-Modul finden oder laden. Das bedeutet, dass Sie keine Audio-CDs aus MP3-Dateien erstellen können. Es gibt viele Linux-Distributionen, die aus rechtliche Gründen keine Unterstützung für MP3 mitliefern. Lösung: Um die MP3-Unterstützung zu aktivieren, installieren Sie bitte die MAD-MP3-Dekodierer-Bibliothek und das MP3-Dekodierer-Modul von K3b (welches möglicherweise bereits installiert ist, aber wegen der fehlenden libmad-Bibliothek bislang nicht funktioniert). Bei einigen Distributionen können Sie die MP3-Unterstützung über ein Online-Update nachinstallieren

Kann mir jemand helfen?
Zuletzt geändert von ecki4 am 8. Jan 2018, 18:21, insgesamt 1-mal geändert.

Werbung:
Sauerland
Guru
Guru
Beiträge: 3166
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von Sauerland » 5. Jan 2018, 18:56

Was sagt:

Code: Alles auswählen

zypper se -si mp3 mad lame
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

ecki4
Member
Member
Beiträge: 119
Registriert: 14. Okt 2007, 15:31

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von ecki4 » 5. Jan 2018, 19:21

Obwohl "lame" installiert ist, erscheint die Meldung nach wie vor!

Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von SUSEDJAlex » 5. Jan 2018, 19:32

Da du den Upgrade von 42.2 auf 42.3 gemacht hast, würde mich interessieren ob du das auch für die Repository Packman auch vollzogen hast...

Poste bitte neben die Ausgaben von #Post2 noch

Code: Alles auswählen

zypper lr -uP
LG SUSEDJAlex
openSUSE LEAP 42.3 mit Plasma 5.11 / arch linux mit Kernel 4.9.70-1-lts und XFCE4

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5141
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von tomm.fa » 5. Jan 2018, 20:51

ecki4 hat geschrieben:
5. Jan 2018, 19:21
Obwohl "lame" installiert ist, erscheint die Meldung nach wie vor!
Du hast hier doch dieses Thema eröffnet um vernünftige Hilfe zu erhalten oder nicht? Wenn dich dann jemand nach der Ausgabe eines Befehls fragt, dann sollte das genaue Ergebnis hier vorgeführt werden. Ich erweitere noch um das Wort k3b.
Was ergibt also die Ausgabe von:

Code: Alles auswählen

zypper se -si mp3 mad lame k3b
?
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

ecki4
Member
Member
Beiträge: 119
Registriert: 14. Okt 2007, 15:31

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von ecki4 » 6. Jan 2018, 17:25

Upgrade wurde auch für Packman durchgeführt:

Code: Alles auswählen

1 | http-ftp.uni-erlangen.de-d2aa8382 | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   99     | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_Leap_42.3  
 2 | openSUSE-Leap-42.3-0              | openSUSE-Leap-42.3-0                    | No      | ----      | ----    |   99     | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GH22NS50_K399A861229 
 3 | repo-debug                        | openSUSE-Leap-42.3-Debug                | No      | ----      | ----    |   99     | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/     
 4 | repo-debug-non-oss                | openSUSE-Leap-42.3-Debug-Non-Oss        | No      | ----      | ----    |   99     | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/ 
 5 | repo-debug-update                 | openSUSE-Leap-42.3-Update-Debug         | No      | ----      | ----    |   99     | http://download.opensuse.org/debug/update/leap/42.3/oss/                
 6 | repo-debug-update-non-oss         | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | http://download.opensuse.org/debug/update/leap/42.3/non-oss/            
 7 | repo-non-oss                      | openSUSE-Leap-42.3-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/       
 8 | repo-oss                          | openSUSE-Leap-42.3-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/42.3/repo/oss/           
 9 | repo-source                       | openSUSE-Leap-42.3-Source               | No      | ----      | ----    |   99     | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/    
10 | repo-source-non-oss               | openSUSE-Leap-42.3-Source-Non-Oss       | No      | ----      | ----    |   99     | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/
11 | repo-update                       | openSUSE-Leap-42.3-Update               | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/42.3/oss/                      
12 | repo-update-non-oss               | openSUSE-Leap-42.3-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/42.3/non-oss/   


Das Ergebnis bei zypper:

Code: Alles auswählen

S  | Name                  | Type        | Version      | Arch   | Repository                
---+-----------------------+-------------+--------------+--------+---------------------------
i+ | K3b                   | application |              | noarch | (System Packages)         
i+ | gstreamer-fluendo-mp3 | package     | 21-2.9       | x86_64 | openSUSE-Leap-42.3-Non-Oss
i+ | k3b                   | package     | 17.08.3-10.4 | x86_64 | Packman Repository        
i+ | k3b-debuginfo         | package     | 17.08.3-10.4 | x86_64 | Packman Repository        
i+ | k3b-debugsource       | package     | 17.08.3-10.4 | x86_64 | Packman Repository                                                                                             
i+ | k3b-devel             | package     | 17.08.3-10.4 | x86_64 | Packman Repository                                                                                             
i+ | k3b-lang              | package     | 17.08.3-10.4 | noarch | Packman Repository                                                                                             
i+ | lame                  | package     | 3.99.5-2.1   | x86_64 | openSUSE-Leap-42.3-Update 
i+ | libmad0               | package     | 0.15.1b-2.1  | x86_64 | openSUSE-Leap-42.3-Update 
i+ | libmp3lame0           | package     | 3.99.5-2.1   | x86_64 | openSUSE-Leap-42.3-Update 
i+ | libsnmp30             | package     | 5.7.3-6.6    | x86_64 | openSUSE-Leap-42.3-Oss    
i+ | libtwolame0           | package     | 0.3.13-2.1   | x86_64 | openSUSE-Leap-42.3-Update 
linux-mo7e:~ # 
Leider ohne Erfolg
Zuletzt geändert von gehrke am 6. Jan 2018, 17:34, insgesamt 1-mal geändert.
Grund: Bitte zukünftig <code>-Tags verwenden - https://linux-club.de/forum/viewtopic.php?f=92&t=105750

Sauerland
Guru
Guru
Beiträge: 3166
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von Sauerland » 6. Jan 2018, 18:35

Ist denn in den Einstellungen unter Module das Modul aktiviert?

Ansonsten:

Code: Alles auswählen

zypper in -f libmad0
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

ecki4
Member
Member
Beiträge: 119
Registriert: 14. Okt 2007, 15:31

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von ecki4 » 7. Jan 2018, 17:42

Hier das Ergebnis - es hat sich nichts geändert. Ich verstehe das auch nicht - bei allen vorhergehenden Upgrades (schon unter Open Suse 11.0) hat es immer geklappt!

Code: Alles auswählen

linux-mo7e:~ # zypper in -f libmad0 
Loading repository data... 
Reading installed packages... 
Forcing installation of 'libmad0-0.15.1b-2.1.x86_64' from repository 'openSUSE-Leap-42.3-Update'. 
Resolving package dependencies... 

The following package is going to be reinstalled: 
 libmad0 

1 package to reinstall. 
Overall download size: 70.4 KiB. Already cached: 0 B. No additional space will be used or freed after the operation. 
Continue? [y/n/...? shows all options] (y): y 
Retrieving package libmad0-0.15.1b-2.1.x86_64                                                                                                (1/1),  70.4 KiB (171.9 KiB unpacked) 
Retrieving: libmad0-0.15.1b-2.1.x86_64.rpm .................................................................................................................................[done] 
Checking for file conflicts: ...............................................................................................................................................[done] 
(1/1) Installing: libmad0-0.15.1b-2.1.x86_64 ...............................................................................................................................[done]
Zuletzt geändert von tomm.fa am 7. Jan 2018, 18:17, insgesamt 1-mal geändert.
Grund: Code-Tags gesetzt.

goeba
Hacker
Hacker
Beiträge: 253
Registriert: 23. Nov 2015, 13:48

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von goeba » 7. Jan 2018, 17:52

libmad ist aber aus der SuSE-Quelle installiert, nicht aus packman. Vermutlich ist das nur ein Platzhalter ohne Funktionalität.

Schau mal in Yast Software, ob es auch eine Version von Packman gibt (sieht man, wenn man das package sucht, im Karteireiter "Versionen").

(geht sicher auch irgendwie mit zypper, weiß ich aber nicht auswendig).

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5141
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von tomm.fa » 7. Jan 2018, 18:09

libmad(0) gibt es nicht mehr über PackMan, es kann/darf jetzt direkt von den Distributionen bereitgestellt werden. Siehe auch: http://www.pro-linux.de/news/1/24728/di ... izont.html.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Benutzeravatar
soyo
Hacker
Hacker
Beiträge: 587
Registriert: 30. Nov 2009, 18:25

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von soyo » 7. Jan 2018, 19:00

Hi
Nur so .
Unter Ubuntu finde ich dieses :
Extras
Um Audio-CDs aus MP3-Dateien erstellen zu können, muss folgendes Paket installiert werden [1]:
libk3b6-extracodecs
von hier :
https://wiki.ubuntuusers.de/K3b/

suche ich die lib für Suse , lande ich hier :
https://software.opensuse.org/package/o ... -installer

Hab auch gesehen , das es früher mal nen k3b-codec pack bei Packman gab .

MfG soyo

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5141
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: k3b findet nach Upgrade auf 42.3 MP3 DekodierModul nicht

Beitrag von tomm.fa » 7. Jan 2018, 19:11

Alles nicht mehr aktuell und in diesem Fall nicht von Interesse und notwendig. Auch ist das mit dem opensuse-codecs-installer eher kontraproduktiv da das Repo multimedia:libs mit eingebunden wird und dieses mit dem Repo von PackMan zu verwenden kann problematisch sein.

Ich würde ja mal die (versteckte) Konfigurationsdatei von K3B suchen und löschen oder umbenennen. Auch mal in den Einstellungen von K3B schauen ob alle Suchpfade und restlichen Einstellungen passen.

Auch wenn es ecki4 nichts bringt, hier gibt es jedenfalls keine Probleme.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

ecki4
Member
Member
Beiträge: 119
Registriert: 14. Okt 2007, 15:31

[gelöst]k3b findet nach Upgrade MP3 DekodierModul nicht

Beitrag von ecki4 » 8. Jan 2018, 18:19

Es ist kaum, zu glauben - ich habe die Lösung gefunden! Unter "Installationsquellen - Packman", ist am oberen Rand ganz klein folgendes zu sehen:
Wechsel von Systemdateien zu den Versionen in diesem Repository (Packman Repository). Das hatte ich bis jetzt glatt übersehen - lacht mich bitte nicht aus!!
"Wechsel von Systemdateien " (in blauer Schrift und unterstrichen) wurde angeklickt, alle vorgeschlagenen Aktualisierungen durchgeführt, und jetzt klappt es!
Vielen Dank zum Abschluß an alle, die mir geholfen haben, denn nur angeregt durch diese Ratschläge habe ich alles probiert und bin deswegen auf diese Option gestoßen!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast