Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Grub2 Probleme nach Windows 10 Neuinstallation

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
mike321
Member
Member
Beiträge: 114
Registriert: 15. Sep 2007, 14:12

Grub2 Probleme nach Windows 10 Neuinstallation

Beitrag von mike321 » 18. Dez 2017, 18:09

Hallo Gemeinde!
ich musste gestern meine Windows 10 neu aufsetzen auf einer SSD,mein Opensuse 42.3 habe ich auf einer zweiten normalen Festplatte,dort ist auch der Grub2 installiert im MBR.
Sonst habe ich einfach die Linux Platte abgezogen,Windows eben neuinstalliert,danach wieder Win 10 Platte dran,Linux gebootet,dann Grub2 einlesen lassen fertig und ich konnte wieder mein Windows wieder booten.

Gestern habe ich wohl nicht aufgepasst beim formatieren Bios stand auf Uefi hat er die Platte in GPT formatiert und eingerichtet,danach war es mir nicht mehr möglich Windows wieder einzubinden,auch mit der Grub2 Recover CD.

Ich muss im Augenblick immer ins Bios und die Platten umstellen,gibt es irgendwie eine Möglichkeit das Windows System wieder in den Grub einzubinden oder wäre es am besten Opensuse neuzuinstallieren und wenn ja auf was muss ich achten.
Im Bios auf Uefi oder Uefi+Legacy stellen,Windows Platte besser abziehen beim installieren und reicht es Opensuse upzugraden oder volle Neuinstallation.

Und muss ich sonst noch was beachten am liebsten wäre mir ich müsste mein Linux nicht plätten,aber dieses ständige umstellen der Platten beim starten nervt einfach.

Besten Dank

Gruß

mike
Desktop:OpenSuse Leap 42.3 Plasma 5.11.4 Nvidia - GTX560 - MSI Gaming AMD 970 - FX 8350 - 16GB Teamgroup DDR 3 1333Mhz

Werbung:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 421
Registriert: 19. Sep 2014, 18:22

Re: Grub2 Probleme nach Windows 10 Neuinstallation

Beitrag von susejunky » 18. Dez 2017, 21:09

Hallo mike321,
mike321 hat geschrieben:
18. Dez 2017, 18:09
Hallo Gemeinde!
ich musste gestern meine Windows 10 neu aufsetzen auf einer SSD,mein Opensuse 42.3 habe ich auf einer zweiten normalen Festplatte,dort ist auch der Grub2 installiert im MBR.
Sonst habe ich einfach die Linux Platte abgezogen,Windows eben neuinstalliert,danach wieder Win 10 Platte dran,Linux gebootet,dann Grub2 einlesen lassen fertig und ich konnte wieder mein Windows wieder booten.

Gestern habe ich wohl nicht aufgepasst beim formatieren Bios stand auf Uefi hat er die Platte in GPT formatiert und eingerichtet,
Verstehe ich das richtig? Windows ist nun auf einer SSD mit GPT-Partitionsschema installiert und kann nur im "UEFI mode" gestartet werden. Dein openSUSE ist auf einer Festplatte mit MBR-Partitionsschema (?) installiert und nutzt GRUB2 zum starten. GRUB2 ist für MBR-Boot-Modus konfiguriert; d.h. Dein UEFI muss auf "CSM" (aka "Legacy mode" oder "MBR mode") eingestellt sein, damit GRUB2 das System starten kann.
mike321 hat geschrieben:
18. Dez 2017, 18:09
... Ich muss im Augenblick immer ins Bios und die Platten umstellen,
Bei welcher UEFI-Boot-Modus-Einstellung - "UEFI" oder "CSM"?
mike321 hat geschrieben:
18. Dez 2017, 18:09
...gibt es irgendwie eine Möglichkeit das Windows System wieder in den Grub einzubinden
Möglicherweise, aber um das besser beurteilen zu können, wären noch hilfreich das Ergebnisse von

Code: Alles auswählen

# parted -l
zu kennen.

Viele Grüße

susejunky

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5083
Registriert: 23. Sep 2008, 17:09

Re: Grub2 Probleme nach Windows 10 Neuinstallation

Beitrag von josef-wien » 18. Dez 2017, 22:04

Interpretiere ich Deine Zeilen richtig, daß Du zuerst Windows im "BIOS-Modus" installiert hast (und dann aus dem GRUB2-Menü aufrufen konntest) und danach Windows noch einmal, aber jetzt im "UEFI-Modus" installiert hast (und jetzt nicht mehr in das GRUB2-Menü aufnehmen kannst)? Es ist nicht möglich, aus einem im "BIOS-Modus" installierten GRUB2 ein im "UEFI-Modus" installiertes Windows aufzurufen.

Wenn Dein UEFI über eine EFI-Shell verfügt, besteht die Möglichkeit, zuerst im laufenden Linux die zusammenpassenden Dateien vmlinuz-Kernel und initrd-Kernel ins Hauptverzeichnis der EFI-Partition zu kopieren und dort zur Vermeidung von Tipparbeit auf vmlinuz und initrd umzubenennen, das System neu zu starten, in der EFI-Shell mit dem Befehl

Code: Alles auswählen

fs0:\vmlinuz ' initrd=\initrd '
Linux zu starten, GRUB2 durch GRUB2-EFI zu ersetzen und den Bootloader neu einzurichten (der sich dann so wie der von Windows auf der EFI-Systempartition befindet). Ob Du Dir das zutraust, mußt Du entscheiden, per Ferndiagnose kann hier schwer geholfen werden.

Ansonsten mußt Du durch Neuinstallation eines der beiden Betriebssysteme dafür sorgen, daß beide im selben Modus installiert sind, um den Weg über das UEFI-Bootmenü zu vermeiden. Falls Du openSUSE im "UEFI-Modus" neu installieren willst (das Boot-Menü des Installationsmediums zeigt in diesem Modus unten keine Funktionstasten an), muß die Windows-Platte verfügbar sein, da die EFI-Systempartition auf dieser Platte vorhanden ist und unbedingt darauf geschrieben werden muß.

Vorher wollen wir aber sicherstellen, in welchem Modus Linux derzeit läuft:

Code: Alles auswählen

zypper se -si grub
ls /sys/firmware/efi

Benutzeravatar
mike321
Member
Member
Beiträge: 114
Registriert: 15. Sep 2007, 14:12

Re: Grub2 Probleme nach Windows 10 Neuinstallation

Beitrag von mike321 » 18. Dez 2017, 22:49

Hallo Susejunky

Ich denke Du siehst das soweit richtig ich werde mal den gewünschten Ausdruck einstellen,vielleicht kann ich mir die Neuinstallation dann ja sparen

Code: Alles auswählen

parted -l
Model: ATA SAMSUNG SP2504C (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system     Flags
 1      32,3kB  43,6GB  43,6GB  primary   ntfs            type=07
 2      43,6GB  250GB   206GB   extended                  boot, type=05
 5      43,6GB  125GB   81,5GB  logical   ntfs            type=07
 6      125GB   167GB   41,7GB  logical   ntfs            type=07
 7      167GB   169GB   2147MB  logical   linux-swap(v1)  type=82
 8      169GB   190GB   21,5GB  logical   ext4            type=83
 9      190GB   250GB   59,7GB  logical   ext3            type=83


Model: ATA Intenso SSD Sat (scsi)
Disk /dev/sdb: 127GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  524MB  523MB   ntfs         Basic data partition          hidden, diag
 2      524MB   629MB  105MB   fat32        EFI system partition          boot
 3      629MB   646MB  16,8MB               Microsoft reserved partition  msftres
 4      646MB   127GB  126GB   ntfs         Basic data partition
Erstmal besten Dank an Euch beiden

@josef-wien
danke für die Nachricht,was bedeutet,in welchen Modus mein Linux läuft? Grub 2.efi ist installiert,aber in der Sysconfig ist nur Grub2 eingetragen?
Sorry falls Du was anderes meintest

Gruß
Mike
Desktop:OpenSuse Leap 42.3 Plasma 5.11.4 Nvidia - GTX560 - MSI Gaming AMD 970 - FX 8350 - 16GB Teamgroup DDR 3 1333Mhz

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5083
Registriert: 23. Sep 2008, 17:09

Re: Grub2 Probleme nach Windows 10 Neuinstallation

Beitrag von josef-wien » 18. Dez 2017, 23:39

Warum wohl habe ich zwei Befehle in meinem ersten Beitrag geschrieben?

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 421
Registriert: 19. Sep 2014, 18:22

Re: Grub2 Probleme nach Windows 10 Neuinstallation

Beitrag von susejunky » 19. Dez 2017, 00:01

mike321 hat geschrieben:
18. Dez 2017, 22:49
... Ich denke Du siehst das soweit richtig ich werde mal den gewünschten Ausdruck einstellen,vielleicht kann ich mir die Neuinstallation dann ja sparen

Code: Alles auswählen

parted -l
Model: ATA SAMSUNG SP2504C (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system     Flags
 1      32,3kB  43,6GB  43,6GB  primary   ntfs            type=07
 2      43,6GB  250GB   206GB   extended                  boot, type=05
 5      43,6GB  125GB   81,5GB  logical   ntfs            type=07
 6      125GB   167GB   41,7GB  logical   ntfs            type=07
 7      167GB   169GB   2147MB  logical   linux-swap(v1)  type=82
 8      169GB   190GB   21,5GB  logical   ext4            type=83
 9      190GB   250GB   59,7GB  logical   ext3            type=83


Model: ATA Intenso SSD Sat (scsi)
Disk /dev/sdb: 127GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  524MB  523MB   ntfs         Basic data partition          hidden, diag
 2      524MB   629MB  105MB   fat32        EFI system partition          boot
 3      629MB   646MB  16,8MB               Microsoft reserved partition  msftres
 4      646MB   127GB  126GB   ntfs         Basic data partition
Ich vermute, Dein openSUSE steckt in der "extended partition" (sda8 oder sda9) der mit MBR-Partitionsschema versehenen Festplatte (ATA SAMSUNG SP2504C).

Wie josef-wien schon gesagt hat: Es ist nicht möglich, aus einem im "BIOS-Modus" installierten GRUB2 ein im "UEFI-Modus" installiertes Windows aufzurufen.

Willst Du eine Neu-Installation von Windows vermeiden, dann muss GRUB2 so installiert werden, dass es im "UEFI-Modus" Dein openSUSE (und Dein Windows) starten kann.

Dazu kannst Du, wie von josef-wien beschrieben, vorgehen. Sollte Dein UEFI keine Shell aufweisen, hilft ggf. diese Beschreibung weiter: https://forums.opensuse.org/showthread. ... t-scenario

Viele Grüße

susejunky

Benutzeravatar
mike321
Member
Member
Beiträge: 114
Registriert: 15. Sep 2007, 14:12

Re: Grub2 Probleme nach Windows 10 Neuinstallation

Beitrag von mike321 » 19. Dez 2017, 18:25

Hallo Gemeinde!

Bevor ich mich an die Sache wage will ich nochmal kurz auflisten,ob ich auch alles richtig verstanden habe.ich habe eine Uefi Konsole also stelle ich im Bios
Uefi+Legacy ein,boote mein Linux und und stelle von Grub2 auf Grub2.efi um,fahre den Rechner runter und gebe in die Uefi Konsole

" fs0:\vmlinuz ' initrd=\initrd ' " ein.

Code: Alles auswählen

zypper se -si grub
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                       | Typ   | Version    | Arch   | Repository                 
---+----------------------------+-------+------------+--------+----------------------------
i+ | grub2                      | Paket | 2.02-2.6   | x86_64 | openSUSE-Leap-42.3 (OSS)   
i+ | grub2-branding-openSUSE    | Paket | 42.1-10.5  | noarch | openSUSE-Leap-42.3 (OSS)   
i+ | grub2-i386-pc              | Paket | 2.02-2.6   | x86_64 | openSUSE-Leap-42.3 (OSS)   
i+ | grub2-snapper-plugin       | Paket | 2.02-2.6   | noarch | openSUSE-Leap-42.3 (OSS)   
i+ | grub2-systemd-sleep-plugin | Paket | 2.02-2.6   | noarch | openSUSE-Leap-42.3 (OSS)   
i+ | grub2-theme-breeze         | Paket | 5.11.4-1.1 | noarch | openSUSE-Leap-42.3-Plasma 5
i+ | grub2-x86_64-efi           | Paket | 2.02-2.6   | x86_64 | openSUSE-Leap-42.3 (OSS)   
i+ | ruby2.1-rubygem-cfa_grub2  | Paket | 0.6.2-1.4  | x86_64 | openSUSE-Leap-42.3 (OSS)   
i+ | ruby2.2-rubygem-cfa_grub2  | Paket | 0.6.2-1.4  | x86_64 | openSUSE-Leap-42.3 (OSS)   
i+ | ruby2.3-rubygem-cfa_grub2  | Paket | 0.6.2-1.4  | x86_64 | openSUSE-Leap-42.3 (OSS)   
i+ | ruby2.4-rubygem-cfa_grub2  | Paket | 0.6.2-1.4  | x86_64 | openSUSE-Leap-42.3 (OSS)   
Mars:/home/mike # ls /sys/firmware/efi
ls: Zugriff auf '/sys/firmware/efi' nicht möglich: Datei oder Verzeichnis nicht gefunden
dann startet Linux wieder und ich muss unter Linux den grub2.efi wieder einrichten

Wenn ich soweit alles richtig verstanden habe,werde ich es gleich mal versuchen

Besten Dank

Gruß
mike
Desktop:OpenSuse Leap 42.3 Plasma 5.11.4 Nvidia - GTX560 - MSI Gaming AMD 970 - FX 8350 - 16GB Teamgroup DDR 3 1333Mhz

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5083
Registriert: 23. Sep 2008, 17:09

Re: Grub2 Probleme nach Windows 10 Neuinstallation

Beitrag von josef-wien » 19. Dez 2017, 22:04

Linux läuft derzeit im "BIOS-Modus". Es sind sowohl die Pakete für GRUB2 als auch für GRUB2-EFI installiert. In diesem Zustand brauchst Du den Boot-Manager noch nicht umzustellen.

Wenn das System im "UEFI-Modus" läuft, schaut die Ausgabe des 2. Befehls anders aus. Die EFI-Systempartition muß unter /boot/efi/ eingehängt sein, sonst finden sie im laufenden System die üblichen Automatismen nicht. Bei Problemen mit der Einrichtung von GRUB2-EFI müssen Dir andere Helfer beistehen, ich verwende diese Dinger nicht. Im Erfolgsfall findest Du unter /boot/efi/EFI/ nicht nur ein Verzeichnis für Windows, sondern auch eines für openSUSE.

Benutzeravatar
mike321
Member
Member
Beiträge: 114
Registriert: 15. Sep 2007, 14:12

Re: Grub2 Probleme nach Windows 10 Neuinstallation

Beitrag von mike321 » 19. Dez 2017, 22:23

Hallo!

Okay ich werde erstmal alles so lassen,ich habe Angst das ich noch mehr zerstöre und dann garnichts mehr geht,Wenn ich die Einstellung im Bios auf Uefi+Legacy stehen lassen bootet Opensuse über Gruß ja korrekt und Windows nutze ich eh an diesem Rechner nicht so oft,wenn ich es dann halt mal brauche muss ich halt
kurz ins Bios

ich danke Dir trotzdem für Deine Hilfe und wünsche ein Frohes Fest!

Gruß

mike
Desktop:OpenSuse Leap 42.3 Plasma 5.11.4 Nvidia - GTX560 - MSI Gaming AMD 970 - FX 8350 - 16GB Teamgroup DDR 3 1333Mhz

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast