Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
OpenSuse132
Hacker
Hacker
Beiträge: 364
Registriert: 13. Sep 2015, 08:08

Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von OpenSuse132 » 13. Dez 2017, 11:20

Hallo,

seit Jahren installiere ich Multiboot Systeme, mittlerweile nur noch max. 3 OS auf einer Festplatte mittels mbr und Bios( OpenSuse, Debian und Windows ). Immer im Zusammenhang mit dem GRUB 2.02 beta und vorher.

Die Partitionen erstelle ich immer nach dem gleichen Schema vorab mittels Parted Magic ext4 und NTFS 64 Bit und wie in diesem Beispiel genannt.

Beispiel: 1 TB 1000 MB frei Platz für den mbr, dann Windows auf sda1 OpenSuse auf sda2 root, erweitert (extented) debian, home OpenSuse und home debian und zum Schluss swap für Beide. Das nur so zum Grundsätzlichen.
Den GRUB installiere ich immer im MBR von Windows, wenn ich das richtig verstanden habe und damit sollte es problemlos funktionieren oder kann man das evtl. besser einrichten ?


Dazu habe ich auch schon einige Beiträge im Forum geschrieben. Anscheinend muss ich aber irgendetwas immer wieder falsch einrichten oder erstellen. Zuerst installiere ich Windows, dann OpenSuse und zuletzt Debian.

Was mich schon mal grundsätzlich stört ist, wenn ich unter Debian das GRUB Bootmenü eingerichtet und optimiert habe, dann OpenSuse starte, wird hier dann automatisch über OpenSuse das GRUB Bootmenü verändert.

Desweiteren passiert es immer wieder, dass GRUB leider nicht mehr startet und ich OpenSuse bzw. beide Linux Distros neu installieren muss und dann fangen die Probleme erst richtig an.

Anscheinend gibt es dann immer wieder die gleichen Probleme mit der swap Partition fstab und blkid. Sollte ich dann einfach die swap löschen um das Problem zu lösen oder was wäre hilfreich ?

Siehe hier die Installation auf einer 2 TB grossen Festplatte mit Windows 7 und OpenSuse 42.3 / Debian 9.2 Stretch, hier habe ich nach grub Problemen OpenSuse nochmals neu installiert und danach Debian nochmals neu
installiert und danach kam immer beim Start von OpenSuse 42.3 die Info : a start job is running for dev-disk-by\2duuid-47f205f4......
obwohl ich bereits die fstab bezüglich swap Eintrag korregiert habe, wie man sieht. Anscheinend mache trotzdem immer etwas falsch.

Wer kennt sich mit diesen speziellem Multiboot Problemen im Zusammenhang von Windows10/7 Debian und OpenSuse gut aus und kann mir ein paar hilfreiche Installations Tipps geben, damit es in Zukunft nicht mehr
zu diesen ständigen Problemen kommt ?

Code: Alles auswählen

  fdisk -l


Festplatte /dev/sda: 1,8 TiB, 2000398934016 Bytes, 3907029168 Sektoren 
Einheiten: Sektoren von 1 * 512 = 512 Bytes 
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes 
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes 
Festplattenbezeichnungstyp: dos 
Festplattenbezeichner: 0x0000353d 

Gerät      Boot     Anfang       Ende   Sektoren  Größe Kn Typ 
/dev/sda1  *       2048000  616447999  614400000   293G  7 HPFS/NTFS/exFAT 
/dev/sda2        616448000 1230847999  614400000   293G 83 Linux 
/dev/sda3       1230848000 3907028991 2676180992   1,3T  5 Erweiterte 
/dev/sda5       1230850048 2050050047  819200000 390,6G  7 HPFS/NTFS/exFAT 
/dev/sda6       2050052096 2562052095  512000000 244,1G 83 Linux 
/dev/sda7       2562054144 3176454143  614400000   293G 83 Linux 
/dev/sda8       3586058240 3622922239   36864000  17,6G 82 Linux Swap / Solaris 
/dev/sda9       3622924288 3907028991  284104704 135,5G  b W95 FAT32 
/dev/sda10      3176456192 3545096191  368640000 175,8G 83 Linux 

Partitionstabelleneinträge sind nicht in Festplatten-Reihenfolge.





Blkid

/dev/sda1: LABEL="Win7Ult64" UUID="4C97BF6C3CE6D5B3" TYPE="ntfs" PARTUUID="0000353d-01" 
/dev/sda2: LABEL="Debian92Zalman" UUID="415408a5-29da-4d88-a43d-14a9b956b48e" TYPE="ext4" PARTUUID="0000353d-02" 
/dev/sda5: LABEL="Win7UWork" UUID="39858CD463F8310F" TYPE="ntfs" PARTUUID="0000353d-05" 
/dev/sda6: LABEL="Debian92_Home" UUID="76b1adb2-d0a5-4508-b195-2deeb767a354" TYPE="ext4" PARTUUID="0000353d-06" 
/dev/sda7: LABEL="OpenSuse423P64" UUID="019f6f19-10ff-4e53-951b-02e0a4aebb55" TYPE="ext4" PARTUUID="0000353d-07" 
/dev/sda8: UUID="b5062139-b5cf-4b3f-b62e-010fc9f7934b" TYPE="swap" PARTUUID="0000353d-08" 
/dev/sda9: LABEL="LINUXWINDOW" UUID="89D3-EB94" TYPE="vfat" PARTUUID="0000353d-09" 
/dev/sda10: LABEL="OpenSuseHome" UUID="6d83ec29-0b73-46aa-924e-7c239bb3c2cb" TYPE="ext4" PARTUUID="0000353d-0a" 
/dev/sdb1: LABEL="Intenso8GB" UUID="A872F14672F11A30" TYPE="ntfs" PARTUUID="dc73ef40-01"


fstab

UUID=019f6f19-10ff-4e53-951b-02e0a4aebb55 /                    ext4       acl,user_xattr        1 1 
UUID=6d83ec29-0b73-46aa-924e-7c239bb3c2cb /home                ext4       acl,user_xattr        1 2 
UUID="b5062139-b5cf-4b3f-b62e-010fc9f7934b" TYPE="swap" PARTUUID="0000353d-08" 

   


Code: Alles auswählen

  guenter@linux-jy6o:~> systemd-analyze critical-chain 
The time after the unit is active or started is printed after the "@" character. 
The time the unit takes to start is printed after the "+" character. 

graphical.target @32.509s 
└─multi-user.target @32.509s 
 └─cron.service @32.508s 
   └─postfix.service @30.612s +1.861s 
     └─time-sync.target @30.436s 
       └─ntpd.service @30.000s +435ms 
         └─network.target @29.896s 
           └─wicked.service @12.192s +17.703s 
             └─wickedd-nanny.service @12.176s +12ms 
               └─wickedd.service @12.096s +34ms 
                 └─wickedd-dhcp4.service @11.931s +118ms 
                   └─SuSEfirewall2_init.service @10.256s +1.658s 
                     └─basic.target @7.413s 
                       └─sockets.target @7.413s 
                         └─avahi-daemon.socket @7.413s 
                           └─sysinit.target @7.413s 
                             └─apparmor.service @1.764s +5.647s 
                               └─systemd-journald.socket 
                                 └─-.mount 
                                   └─system.slice 
                                     └─-.slice 
guenter@linux-jy6o:~>  
 

Vielen Dank im voraus


tschüss

OpenSuse 132

Werbung:
josef-wien
Guru
Guru
Beiträge: 4961
Registriert: 23. Sep 2008, 17:09

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von josef-wien » 13. Dez 2017, 11:55

Warum lernst Du es nicht? Dir wurde schon oft genug gesagt, daß Du bei mehreren Systemen in die jeweilige Installationsautomatik eingreifen mußt, damit der jeweilige Boot-Manager so reagiert, wie Du es gerne hättest. Dir wurde schon oft genug gesagt, daß beim Formatieren einer Partition eine neue UUID vergeben wird und das auch bei der SWAP-Partition so ist und das ständige Neuerstellen der SWAP-Partition unnötig ist.

OpenSuse132
Hacker
Hacker
Beiträge: 364
Registriert: 13. Sep 2015, 08:08

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von OpenSuse132 » 13. Dez 2017, 13:33

Hallo,

leider weiss ich nicht wie ich dann bei der neuen (Reparatur ) Installation von OpenSuse etc. in die jeweilige Automatik eingreife, damit der Boot-Manager so reagiert wie ich mir das vorstelle.

Desweiteren formatiere bei einer sogenannten Reparatur Installation, die dann im Regelfall NEU erfolgt, die SWAP nie neu, sondern belasse sie so, also müßte das dann noch normalerweise problemlos funktionieren ?

Wo finde dazu im Forum oder unter https://de.opensuse.org/SDB:Installation_Hilfe genauere Anleitungen oder Hilfe ?

Oder gibt es vielleicht grundsätzlich eine Lösung, sprich evtl. nicht mit GRUB / Bootmenü arbeiten, was wäre da vielleicht einfacher und unkomplizierter ?

Tschüss OpenSuse132

Sauerland
Guru
Guru
Beiträge: 2983
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von Sauerland » 13. Dez 2017, 17:43

Windows und 1x Linux kann ich ja noch verstehen.....
Warum das 2. Linux nicht in eine VM unter dem 1. Linux????
Erspart dir viel Ärger......
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

OpenSuse132
Hacker
Hacker
Beiträge: 364
Registriert: 13. Sep 2015, 08:08

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von OpenSuse132 » 13. Dez 2017, 19:26

Hallo,

früher hatte ich noch Multiboot Systeme mit mindestens 6 bis 8 Distros, da habe ich mich doch schon auf nur noch 3 gut runter gearbeitet, also Debian 9.2 benötige ich für meine alte Hardware, unter Windows 10 und OpenSuse 42.3 wird diese leider
nicht mehr erkannt, dass ist ein Grund mit.

Also muss ich jetzt einfach damit leben, dass OpenSuse 42.3 1 Minute 30 zum Starten zusätzlich benötigt, oder habe ich eine Chance das Problem zu lösen ? Wäre es nicht das einfachste, die Swap löschen oder ?

Tschüss

OpenSuse132

Sauerland
Guru
Guru
Beiträge: 2983
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von Sauerland » 13. Dez 2017, 19:28

Auch unter Debian kann man eine VM installieren.......
Erspart auch Ärger........
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

josef-wien
Guru
Guru
Beiträge: 4961
Registriert: 23. Sep 2008, 17:09

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von josef-wien » 13. Dez 2017, 22:13

OpenSuse132 hat geschrieben:
13. Dez 2017, 13:33
leider weiss ich nicht wie ich dann ... in die jeweilige Automatik eingreife
Beim System A GRUB2 in den MBR installieren. Beim System B GRUB2 in die Systempartition installieren und den MBR unangetastet lassen. Nach jedem Kernel-Update im System B immer im System A veranlassen, daß andere Systeme gesucht und in GRUB2 integriert werden. Alternativ oder zusätzlich im System A eine chainloader-Eintragung auf die Systempartition von System B vornehmen, dann kann GRUB2 von System A GRUB2 von System B aufrufen. Das sind Grundlagen bei parallelen Linux-Installationen. Details kann ich nicht beisteuern, da ich weder Debian noch openSUSE noch GRUB2 verwende.


OpenSuse132 hat geschrieben:
13. Dez 2017, 13:33
SWAP nie neu, sondern belasse sie so
Die Realität beweist, das es nicht so ist.


OpenSuse132 hat geschrieben:
13. Dez 2017, 19:26
Debian 9.2 benötige ich für meine alte Hardware, unter ... OpenSuse 42.3 wird diese leider nicht mehr erkannt
Dein Debian benutzt Kernel 4.9, openSUSE dagegen "nur" 4.4 (beide sind Kernel mit Langzeit-Unterstützung), also kann wohl nur neue Hardware bei openSUSE Probleme verursachen.


OpenSuse132 hat geschrieben:
13. Dez 2017, 19:26
OpenSuse 42.3 1 Minute 30 zum Starten zusätzlich benötigt
https://linux-club.de/forum/viewtopic.php?f=89&t=122144

OpenSuse132
Hacker
Hacker
Beiträge: 364
Registriert: 13. Sep 2015, 08:08

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von OpenSuse132 » 14. Dez 2017, 12:41

Danke,

kann ich denn jetzt in diesem System den derzeitigen Fehler beheben oder nicht ?

Zuletzt wurde Debian installiert, beide grub.s wurden in den mbr installiert Fehlermeldung beim Starten von OpenSuse:

Time in rot a start job is running by dev-disk-by\x2uuid-47f205f4\x2d8d97\x2d4454\x2dbc74\2d820964ba195.device. 1 Minute und 30 Sekunden Wartezeit


Code: Alles auswählen

   /dev/sda9: LABEL="LINUXWINDOW" UUID="89D3-EB94" TYPE="vfat" PARTUUID="0000353d-09" 
/dev/sda10: LABEL="OpenSuseHome" UUID="6d83ec29-0b73-46aa-924e-7c239bb3c2cb" TYPE="ext4" PARTUUID="0000353d-0a" 
/dev/sdb1: LABEL="Intenso8GB" UUID="A872F14672F11A30" TYPE="ntfs" PARTUUID="dc73ef40-01"


fstab

UUID=019f6f19-10ff-4e53-951b-02e0a4aebb55 /                    ext4       acl,user_xattr        1 1 
UUID=6d83ec29-0b73-46aa-924e-7c239bb3c2cb /home                ext4       acl,user_xattr        1 2 
UUID="b5062139-b5cf-4b3f-b62e-010fc9f7934b" TYPE="swap" PARTUUID="0000353d-08" 
  
Tschüss OpenSuse132

OpenSuse132
Hacker
Hacker
Beiträge: 364
Registriert: 13. Sep 2015, 08:08

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von OpenSuse132 » 15. Dez 2017, 15:47

Hallo Josef,

wie ich die
die UUID meiner SWAP-Partition ausgelesen und in den Kerneloptionen unter resume korrigiert.
mittels nano /proc/cmdline die obige Korrektor vornehme, dass bekomme ich anscheinend nicht hin:

Code: Alles auswählen

 nano /proc/cmdline alter Eintrag 


BOOT_IMAGE=/boot/vmlinuz-4.4.92-31-default root=UUID=019f6f19-10ff-4e53-951b-02e0a4aebb55 resume=/dev/disk/by-uuid/47f205f4-8d97-4454-bc74-820964ba195e splash=silent quiet showopts

abgeänderter Eintrag:


BOOT_IMAGE=/boot/vmlinuz-4.4.92-31-default root=UUID=019f6f19-10ff-4e53-951b-02e0a4aebb55 resume=/dev/disk/by-UUID="b5062139-b5cf-4b3f-b62e-010fc9f7934b" TYPE="swap" PARTUUID="0000353d-08      
   
Kann das so korrekt sein ?

Muss ich dann noch in /etc/default/grub eine weitere Korrektur vornehmen ?

Tschüss OpenSuse132

Sauerland
Guru
Guru
Beiträge: 2983
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von Sauerland » 15. Dez 2017, 16:46

Yast----Bootloader----Kernel-Parameter-----Optionale Parameter für die Kernel-Befehlszeile
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

josef-wien
Guru
Guru
Beiträge: 4961
Registriert: 23. Sep 2008, 17:09

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von josef-wien » 15. Dez 2017, 17:22

... und Du sollst die UUID durch die richtige ersetzen und diese nicht verfälschen und keine Angaben hinzufügen und keine Angaben weglassen.

P. S. In meiner Antwort an transwarp stand kein Wort davon, daß /proc/cmdline zu ändern ist. Der Kernel stellt unter /dev, /proc und /sys Daten über sich selbst, die Hardware und das laufende System zur Verfügung, und dort hast Du nichts zu ändern (außer ein Wissender sagt Dir das in Form eines expliziten Befehls).

OpenSuse132
Hacker
Hacker
Beiträge: 364
Registriert: 13. Sep 2015, 08:08

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von OpenSuse132 » 15. Dez 2017, 18:42

Hallo, das die Sache so einfach ist, hätte ich jetzt nicht gedacht

Bootloader-Einstellungen Kernelparameter und den optionalen Eintrag für Kernel Parameter geändert auf:

Code: Alles auswählen

 resume=/dev/sda splash=silent quiet showopts  
und das wars schon, Problem gelöst.

Oder habe ich noch etwas vergessen ? Jedenfalls startet OpenSuse 42.3 wieder fehlerfrei, ausser eben wicked: a start job ist running 30 Sekunden, da kann mit leben.

Tschüss

OpenSuse132

josef-wien
Guru
Guru
Beiträge: 4961
Registriert: 23. Sep 2008, 17:09

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von josef-wien » 15. Dez 2017, 18:59

OpenSuse132 hat geschrieben:
15. Dez 2017, 18:42
resume=/dev/sda
Das ist schlicht und einfach falsch, denn das ist nicht Deine SWAP-Partition.

Und wie Du wieder einmal nicht gelesen hast, ist ein Geräte-Name eine suboptimale Lösung. Du wendest Dich an ein Forum und machst nie das, was Dir Fachleute vorschlagen. Bei Dir ist all unsere Mühe vergebens, ich werde meine Zeit nicht mehr vergeuden.

OpenSuse132
Hacker
Hacker
Beiträge: 364
Registriert: 13. Sep 2015, 08:08

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von OpenSuse132 » 17. Dez 2017, 14:15

Gut, aber wieso startet jetzt mein OpenSuse 42.3 Plasma wieder fehlerfrei, beim Hochfahren kommt keine Fehlermeldung, alles ist grün und selbst bei wicked kommt kein start job ist running mehr.

Desweiteren mit der jetzigen Bootloader Einstellung:

( YAST/Bootloader einrichten/Kernel-Parameter/optionaler Parameter für Kernelparameter/resume=/dev/sda splash=silent quiet showopts)

scheint doch jedenfalls im Moment alles richtig zu sein ? Zumindestens kann ich hier keine Probleme erkennen.

Alle OS Win7/Debian9.2/OpenSuse 42.3 starten derzeit fehlerfrei. Was mir eigentlich nur noch fehlt, ist eine genaue Anleitung wie ich diese 3 OS sinnvoll und optimal als Dauerlösung einrichte, insbesondere wenn es dann
irgendwann zu OS-Updates auf aktuellere Systeme wie OpenSuse 42.4 und oder Debian 10 kommt, wo finde dazu hier im Forum etc. genaue Infos ?

Tschüss

OpenSuse132

marce
Advanced Hacker
Advanced Hacker
Beiträge: 941
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von marce » 17. Dez 2017, 14:26

Das etwas "fehlerfrei läuft" sagt nicht aus, daß es richtig ist.

Du hast als Resume-"Part." /dev/sda angegeben - das gibt's natürlich. Nun überleg Dir aber mal, was passiert, sollte da wirklich mal für einen Resume Daten hingeschrieben werden.

Wie Du bel. viele OS parallel einrichten kannst, ohne daß es beim Upgrade / Update / Neuinstallation zu Problemen kommt steht bereits hier im Thread.

Benutzeravatar
LeapFrog42
Newbie
Newbie
Beiträge: 18
Registriert: 1. Nov 2016, 17:28

Re: Multiboot OpenSuse 42.3 / Debian9.2 Stretch / Windows 7 Ultimate und oder Win 10Pro

Beitrag von LeapFrog42 » 10. Jan 2018, 23:03

Hallo OpenSuse 132,

was vielleicht etwas untergegangen ist, ist die wichtige Anmerkung von josef-wien zum Thema Kernel und neue Hardware
josef-wien hat geschrieben: Dein Debian benutzt Kernel 4.9, openSUSE dagegen "nur" 4.4 (beide sind Kernel mit Langzeit-Unterstützung), also kann wohl nur neue Hardware bei openSUSE Probleme verursachen.
Mein Hobel lief erst ab Kernel 4.9 wirklich stabil - vielleicht auch etwas was zusätzlich helfen kann, falls die einfachere VM-Variante wirklich nicht in Frage kommt

VG
LF42
Laptop: Intel i7 - Skylake , Nvidia GTX970M (Optimus im Bios deaktiviert), OpenSUSE Leap 42.2 64 Bit, KDE Plasma 5.8.6 , Kernel 4.14.x, DKMS, Nvidia Treiber 384.111, Linux HD (LVM, ext4), Win HD + Daten HD (NTFS)

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 3 Gäste