Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Nervige "a start job is running ..."-Meldung

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 295
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

[gelöst] Nervige "a start job is running ..."-Meldung

Beitrag von transwarp » 5. Dez 2017, 07:33

Hallo allerseits.

Nach einem Crash auf meiner Partitionstabelle habe ich meine CloneZilla-Datensicherung zurück gespielt. Mein openSUSE-Tumbleweed-System läuft wieder, jedoch bekomme ich seitdem stets zweimal eine nervige Meldung, die da lautet:

Code: Alles auswählen

[ ** ] a start job is running for dev-disk-by\x2duuid-407c731e\x2dc ...\x2d3ab9988704ed.device (24s / 1min 38s)
Das Ganze lässt sich nicht abbrechen und läuft stur diese anderthalb Minuten, bevor der Bootvorgang weitergeht. Schließlich kommt die Meldung ein zweites Mal.
Bedeutet also gute drei Minuten Däumchendrehen und ich weiß nicht, was er da eigentlich macht. Vielleicht ein Filesystemcheck?
Die uuid wird sich wohl auf meine Platte beziehen. Habe in der fstab die uuid-Einträge gegen "/dev/sda1" ersetzt, er hält aber nach wie vor an der Meldung fest.

Hat jemand eine Idee, wo dieser Job eingetragen sein könnte und wie ich den wieder loswerde?
Zuletzt geändert von transwarp am 5. Dez 2017, 19:35, insgesamt 2-mal geändert.
openSUSE Tumbleweed | Kernel 4.14.2-desktop x86_64 | Plasma 5.11 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber

Werbung:
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5019
Registriert: 23. Sep 2008, 17:09

Re: Nervige "a start job is running ..."-Meldung

Beitrag von josef-wien » 5. Dez 2017, 11:20

Jedes Dateisystem hat eine UUID. Bei einer GPT haben zusätzlich sowohl die GPT selbst als auch jede Partition eine UUID. Mit allen anderen Komponenten, die eine UUID haben, wollen wir uns jetzt nicht auch noch befassen. In Deinem Fall handelt es sich wohl um die UUID des Dateisystems.

Was ergibt als root:

Code: Alles auswählen

blkid
cat /proc/cmdline

Außerdem sind die genauen UUID der Meldungen gefragt, die solltest Du gemeinsam mit allenfalls wichtigen Meldungen davor und danach mit journalctl ausfindig machen können.

spoensche
Moderator
Moderator
Beiträge: 7322
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Nervige "a start job is running ..."-Meldung

Beitrag von spoensche » 5. Dez 2017, 11:58

Code: Alles auswählen

systemctl list-unit | grep uuid-487c731e
Den Unit Namen des Ergebnisses nehmen und folgendes ausführen:

Code: Alles auswählen

systemctl disable dev-disk-by\x2duuid-487c731e................

Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 295
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

Re: Nervige "a start job is running ..."-Meldung

Beitrag von transwarp » 5. Dez 2017, 17:41

@josef-wien
linux-olli:~ # blkid
/dev/sda1: UUID="a876abd2-ae33-4ad3-9135-959f2edb8dc2" TYPE="swap" PARTUUID="000eccbd-01"
/dev/sda2: UUID="ce0ce19b-842b-4200-bb3b-0b5819282270" TYPE="ext4" PTTYPE="dos" PARTUUID="000eccbd-02"
/dev/sda3: UUID="90c9fc46-ee1d-4906-9ea7-f304d2f03765" TYPE="ext4" PARTUUID="000eccbd-03"
/dev/sda5: UUID="941298ce-7c8f-4228-9b3c-454339bec03f" TYPE="ext4" PARTUUID="000eccbd-05"
/dev/sda6: UUID="71254d67-f656-40ef-9eeb-e533a4eb59fe" TYPE="ext4" PARTUUID="000eccbd-06"
/dev/sda7: UUID="35b59840-49ff-4bbd-af29-a7791f847592" TYPE="ext4" PARTUUID="000eccbd-07"
/dev/sdb1: LABEL="SSHD" UUID="9CAE34BDAE3491AE" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a9591b39-286c-48a3-ae7d-948d2f573888"
/dev/sdc1: LABEL="System-reserviert" UUID="01D28545E2FD62A0" TYPE="ntfs" PARTUUID="7160dc98-01"
/dev/sdc2: UUID="01D285475AD0C7D0" TYPE="ntfs" PARTUUID="7160dc98-02"
/dev/sdc5: UUID="01D285475D3592D0" TYPE="ntfs" PARTUUID="7160dc98-05"
/dev/sdc6: UUID="01D28547643DA720" TYPE="ntfs" PARTUUID="7160dc98-06"
linux-olli:~ # cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.14.2-1-default root=UUID=90c9fc46-ee1d-4906-9ea7-f304d2f03765 video=1920x1080 resume=/dev/disk/by-uuid/407c731e-c4bb-42b1-a719-3ab9908704ed splash=silent quiet showopts


Leider nur UUIDs, die nicht mit meiner Fehlermeldung übereinstimmen. Der Befehl von spoensche (siehe unten) zeigt auch, dass es zu der UUID kein device gibt.
Nehme aber an, dass es hiermit zu tun hat:

Code: Alles auswählen

resume=/dev/disk/by-uuid/407c731e-c4bb-42b1-a719-3ab9908704ed
das ist nämlich der Übeltäter. Was bedeutet das 'resume' überhaupt und kann ich es ggf. weglassen?
Zuletzt geändert von transwarp am 5. Dez 2017, 17:46, insgesamt 1-mal geändert.
openSUSE Tumbleweed | Kernel 4.14.2-desktop x86_64 | Plasma 5.11 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber

Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 295
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

Re: Nervige "a start job is running ..."-Meldung

Beitrag von transwarp » 5. Dez 2017, 17:44

@spoensche
Der Befehl:

Code: Alles auswählen

systemctl list-units | grep uuid-407c731e
ergibt kein Ergebnis. Ein Device mit der obigen UUID existiert nicht (oder auch nicht in Teilen davon).

Wie kommt mein System bloss auf sowas ...? :irre:
openSUSE Tumbleweed | Kernel 4.14.2-desktop x86_64 | Plasma 5.11 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber

marce
Advanced Hacker
Advanced Hacker
Beiträge: 1005
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: Nervige "a start job is running ..."-Meldung

Beitrag von marce » 5. Dez 2017, 17:49

aus dem Kopf heraus ist sollte das die SWAP-Partition sein, von der aus dann ein Suspend-2-Disc wieder booten würde...

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5019
Registriert: 23. Sep 2008, 17:09

Re: Nervige "a start job is running ..."-Meldung

Beitrag von josef-wien » 5. Dez 2017, 18:14

transwarp hat geschrieben:
5. Dez 2017, 17:44
Wie kommt mein System bloss auf sowas ...?
Dein System macht genau das, was Du dem Kernel anschaffst: Schau auf der Partition mit der UUID 407c731e-c4bb-42b1-a719-3ab9908704ed nach, ob Du dort ein gültiges Speicherabbild von einem suspend to disk findest, und wenn es der Fall ist, dann lade es. Da es diese UUID bei Dir aber nicht gibt, wartet das System freundlicherweise (wenn auch nach meinem Geschmack viel zu lange), ob sich eine Partition mit dieser UUID vielleicht doch noch meldet.

Ändere in der YaST-Bootloader-Installation den Wert auf die richtige UUID deiner SWAP-Partition, und stelle auch sicher, daß die UUID in der fstab paßt.

Wenn Du resume=xxx wegläßt, wird die in der initrd hinterlegte Partition genommen. Falls Du sicher bist, nie suspend to disk zu brauchen, kannst Du noresume verwenden.

P. S.
transwarp hat geschrieben:
5. Dez 2017, 07:33
die uuid-Einträge gegen "/dev/sda1" ersetzt
Bei mehr als einer Festplatte ist die Verwendung des Geräte-Namens die ungünstigste Variante.

Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 295
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

Re: Nervige "a start job is running ..."-Meldung

Beitrag von transwarp » 5. Dez 2017, 19:34

Ich danke Euch vielmals, Problem ist gelöst.

Habe mir mit

Code: Alles auswählen

blkid /dev/sda1
die UUID meiner SWAP-Partition ausgelesen und in den Kerneloptionen unter resume korrigiert.

Jetzt ist wieder alles in Butter. :D ;)
openSUSE Tumbleweed | Kernel 4.14.2-desktop x86_64 | Plasma 5.11 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste