[ gelöst ]Verfügbare Version installieren , aber wie

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
toyotafahrer
Member
Member
Beiträge: 87
Registriert: 17. Apr 2017, 13:05
Kontaktdaten:

[ gelöst ]Verfügbare Version installieren , aber wie

Beitrag von toyotafahrer » 20. Nov 2017, 11:42

Hallo Ihr lieben,

da ich noch nicht so lange Opensuse 42.2 habe . Habe ich mich mal etwas mit " man Zypper " befasst soweit wie es mein englisch zulässt.
Bei Zypper lu -a bekomme ich nun eine aktuelle Vers. und eine Verfügbare Vers. angezeigt da die Verfügbare Vers. die neuere ist würde ich die auch gern installieren , nur Zypper up macht nichts . Wie also installiere ich nun die Verfügbare Vers. des Paketes.
Hier ist mein Problem.

Code: Alles auswählen

S | Repository                             | Name                         | Aktuelle Version          | Verfügbare Version              | Arch  
--+----------------------------------------+------------------------------+---------------------------+---------------------------------+-------
v | home:Herbster0815                      | filezilla                    | 3.12.0.2-1.1              | 3.29.0-1.1                      | x86_64
v | home:Herbster0815                      | filezilla-lang               | 3.12.0.2-1.1              | 3.29.0-1.1                      | noarch
v | home:Herbster0815                      | gimp                         | 2.8.18-2.3.1              | 2.9.6-1.1                       | x86_64
v | home:Herbster0815                      | gimp-help-browser            | 2.8.18-2.3.1              | 2.9.6-1.1                       | x86_64
v | home:Herbster0815                      | gimp-lang                    | 2.8.18-2.3.1              | 2.9.6-1.1                       | noarch
v | home:Herbster0815                      | gimp-plugins-python          | 2.8.18-2.3.1              | 2.9.6-1.1                       | x86_64
v | Packman Repository                     | gstreamer-plugins-bad        | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | gstreamer-plugins-bad-lang   | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | noarch
v | home:Herbster0815                      | javapackages-tools           | 2.0.1-12.3.1              | 4.7.0+git20170331.ef4057e7-53.1 | x86_64
v | Packman Repository                     | k3b                          | 2.0.3-9.1                 | 17.08.3-10.1                    | x86_64
v | Packman Repository                     | k3b-lang                     | 2.0.3-9.1                 | 17.08.3-10.1                    | noarch
v | home:Sauerland                         | lcms2                        | 2.7-3.3                   | 2.8-86.1                        | x86_64
v | Packman Repository                     | libFLAC++6                   | 1.3.0-12.1                | 1.3.2-3.1                       | x86_64
v | Packman Repository                     | libFLAC8                     | 1.3.0-12.1                | 1.3.2-3.1                       | x86_64
v | Packman Repository                     | libavcodec57                 | 3.3.4-6.16.1              | 3.3.4-6.18.1                    | x86_64
v | Packman Repository                     | libavformat57                | 3.3.4-6.16.1              | 3.3.4-6.18.1                    | x86_64
v | Packman Repository                     | libavutil55                  | 3.3.4-6.16.1              | 3.3.4-6.18.1                    | x86_64
v | home:Herbster0815                      | libbabl-0_1-0                | 0.1.18-1.2                | 0.1.30-23.1                     | x86_64
v | Packman Repository                     | libbzrtp0                    | 1.0.3-6.1                 | 1.0.6-3.1                       | x86_64
v | home:Sauerland                         | libdbusmenu-qt5-2            | 0.9.3+15.10.20150604-4.41 | 0.9.3+15.10.20150604-29.1       | x86_64
v | Mozilla                                | libfreebl3                   | 3.28.6-40.10.1            | 3.33-2.1                        | x86_64
v | home:Herbster0815                      | libgimp-2_0-0                | 2.8.18-2.3.1              | 2.9.6-1.1                       | x86_64
v | home:Herbster0815                      | libgimpui-2_0-0              | 2.8.18-2.3.1              | 2.9.6-1.1                       | x86_64
v | home:Sauerland:branches:home:Sauerland | libgpod-lang                 | 0.8.3-5.32                | 0.8.3-8.44                      | noarch
v | home:Sauerland:branches:home:Sauerland | libgpod-tools                | 0.8.3-5.32                | 0.8.3-8.44                      | x86_64
v | home:Sauerland:branches:home:Sauerland | libgpod4                     | 0.8.3-5.32                | 0.8.3-8.44                      | x86_64
v | Packman Repository                     | libgstadaptivedemux-1_0-0    | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgstbadaudio-1_0-0         | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgstbadbase-1_0-0          | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgstbadvideo-1_0-0         | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgstbasecamerabinsrc-1_0-0 | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgstcodecparsers-1_0-0     | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgstgl-1_0-0               | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgstmpegts-1_0-0           | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgstphotography-1_0-0      | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgsturidownloader-1_0-0    | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | Packman Repository                     | libgstwayland-1_0-0          | 1.8.3-5.3.1               | 1.8.3-5.5.9                     | x86_64
v | home:Sauerland                         | liblcms2-2                   | 2.7-3.3                   | 2.8-86.1                        | x86_64
v | home:Sauerland                         | libltdl7                     | 2.4.2-18.3.1              | 2.4.6-6.2                       | x86_64
v | Packman Repository                     | libmjpegutils-2_0-0          | 2.0.0-16.5                | 2.0.0-18.3                      | x86_64
v | home:Sauerland                         | libmp3lame0                  | 3.99.5-2.1                | 3.99.5-3.1                      | x86_64
v | home:Herbster0815                      | libp11-kit0                  | 0.20.3-11.1               | 0.23.2-29.2                     | x86_64
v | home:Herbster0815                      | libpng16-16                  | 1.6.8-9.3.1               | 1.6.31-106.2                    | x86_64
v | home:Herbster0815                      | libpulse-mainloop-glib0      | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | libpulse0                    | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | libpurple                    | 2.12.0-8.6.1              | 2.12.0-15.1                     | x86_64
v | home:Herbster0815                      | libpurple-lang               | 2.12.0-8.6.1              | 2.12.0-15.1                     | noarch
v | home:Herbster0815                      | libpurple-tcl                | 2.12.0-8.6.1              | 2.12.0-15.1                     | x86_64
v | Packman Repository                     | libquicktime0                | 1.2.4cvs20150223-8.6.1    | 1.2.4cvs20150223-8.9.1          | x86_64
v | home:Herbster0815                      | libslang2                    | 2.2.4-12.5                | 2.3.1a-2.1                      | x86_64
v | Mozilla                                | libsoftokn3                  | 3.28.6-40.10.1            | 3.33-2.1                        | x86_64
v | Packman Repository                     | libsox3                      | 14.4.2-2.5                | 14.4.2-4.3                      | x86_64
v | home:Sauerland                         | libsoxr0                     | 0.1.2-2.4                 | 0.1.2-13.1                      | x86_64
v | Packman Repository                     | libswresample2               | 3.3.4-6.16.1              | 3.3.4-6.18.1                    | x86_64
v | Packman Repository                     | libswscale4                  | 3.3.4-6.16.1              | 3.3.4-6.18.1                    | x86_64
v | home:Herbster0815                      | libtasn1                     | 3.7-12.2                  | 4.12-57.2                       | x86_64
v | home:Herbster0815                      | libtasn1-6                   | 3.7-12.2                  | 4.12-57.2                       | x86_64
v | home:Sauerland                         | libwx_baseu-suse1            | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libwx_baseu_net-suse1        | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libwx_baseu_xml-suse1        | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libwx_gtk2u_adv-suse1        | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libwx_gtk2u_aui-suse1        | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libwx_gtk2u_core-suse1       | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libwx_gtk2u_gl-suse1         | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libwx_gtk2u_html-suse1       | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libwx_gtk2u_qa-suse1         | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libwx_gtk2u_xrc-suse1        | 3.0.2-7.18                | 3.0.2-77.3                      | x86_64
v | home:Sauerland                         | libxkbcommon-x11-0           | 0.6.1-1.4                 | 0.7.1-43.1                      | x86_64
v | home:Sauerland                         | libxkbcommon0                | 0.6.1-1.4                 | 0.7.1-43.1                      | x86_64
v | Packman Repository                     | mjpegtools                   | 2.0.0-16.5                | 2.0.0-18.3                      | x86_64
v | Mozilla                                | mozilla-nss-certs            | 3.28.6-40.10.1            | 3.33-2.1                        | x86_64
v | X11:Utilities                          | numlockx                     | 1.2-181.3                 | 1.2-353.4                       | x86_64
v | home:Herbster0815                      | p11-kit                      | 0.20.3-11.1               | 0.23.2-29.2                     | x86_64
v | home:Herbster0815                      | p11-kit-tools                | 0.20.3-11.1               | 0.23.2-29.2                     | x86_64
v | home:Herbster0815                      | pulseaudio                   | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | pulseaudio-bash-completion   | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | pulseaudio-lang              | 9.0-2.3.1                 | 11.1-1.1                        | noarch
v | home:Herbster0815                      | pulseaudio-module-bluetooth  | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | pulseaudio-module-jack       | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | pulseaudio-module-lirc       | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | pulseaudio-module-x11        | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | pulseaudio-module-zeroconf   | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | pulseaudio-utils             | 9.0-2.3.1                 | 11.1-1.1                        | x86_64
v | home:Herbster0815                      | ruby2.1-rubygem-gem2rpm      | 0.10.1-5.3.1              | 0.10.1-37.1                     | x86_64
v | home:Sauerland                         | sane-backends                | 1.0.24-4.40               | 1.0.27.git20170730-2.1          | x86_64
v | home:Sauerland                         | sane-backends-autoconfig     | 1.0.24-4.40               | 1.0.27.git20170730-2.1          | x86_64
v | Packman Repository                     | sox                          | 14.4.2-2.5                | 14.4.2-4.3                      | x86_64
v | home:Sauerland                         | ucode-intel                  | 20170707-7.6.1            | 20170707-19.1                   | x86_64
v | X11:Utilities                          | x11-tools                    | 0.1-204.3                 | 0.1-246.2                       | noarch
Zuletzt geändert von toyotafahrer am 21. Nov 2017, 10:23, insgesamt 1-mal geändert.
Samsung 17" Laptop NP350E7C CPU i7 / 240GB SSD + 500 GB SSD / 8 GB Ram / ATI HD 7600M
OS = Opensuse 42.3 x64

Werbung:
Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8749
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Re: Verfügbare Version installieren , aber wie

Beitrag von admine » 20. Nov 2017, 12:01

Zum Beispiel so:

Code: Alles auswählen

zypper install filezilla-3.29.0-1.1
Das kann dann aber auch mit einem Repository-Wechsel einhergehen und ob das immer gut ist ... eher nicht. Da solltest du genau wissen, was du tust.
Überhaupt solltest du dir überlegen, ob du die aktuellste Version überhaupt benötigst.
Meist kommt eine Aktualisierung auch, wenn auch etwas später, in das von dir verwendeten Repo und dann greift "zypper up"
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

toyotafahrer
Member
Member
Beiträge: 87
Registriert: 17. Apr 2017, 13:05
Kontaktdaten:

Re: Verfügbare Version installieren , aber wie

Beitrag von toyotafahrer » 20. Nov 2017, 14:13

Danke für die super schnelle Antwort.

Aber alle einzeln so zu installieren da fehlt mir die Lust , und ist glaube ich auch nicht notwendig.

Es funktioniert ja alles , und ich bin super zufrieden.
Das ist mir nur aufgefallen das es eine neue Version von Paketen gibt aber Zypper up die nicht installiert .
Und ich bin neugierig geworden warum das so ist.
Deine Antwort war schon ausreichend . Das mit den Repo`s ist mir auch schon aufgefallen , das ich mit unterschiedlichen Repo`s zum gleichen Ziel komme . Ich glaube das war mit Packman der Fall da gibt es unterschiedliche Repo`s aber zum Schluss kommt das gleiche raus , wahrscheinlich mit unterschiedlichen Versionsnummern .

Aber nun bin ich wieder ein kleines Stück schlauer , wer nicht fragt der bleibt dumm.
Samsung 17" Laptop NP350E7C CPU i7 / 240GB SSD + 500 GB SSD / 8 GB Ram / ATI HD 7600M
OS = Opensuse 42.3 x64

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8749
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Re: Verfügbare Version installieren , aber wie

Beitrag von admine » 20. Nov 2017, 14:32

Ein "zypper dup" würde alles mit einem Schlag aktualisieren.
Aber wie schon erwähnt, musst du dabei genau wissen was du tust und wenn du rundum zufrieden bist, alles läuft und nicht dringend evt. neue Funktionen einer Anwendung benötigst, dann lass es ;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

goeba
Member
Member
Beiträge: 140
Registriert: 23. Nov 2015, 13:48

Re: Verfügbare Version installieren , aber wie

Beitrag von goeba » 20. Nov 2017, 16:33

Zypper hat als Standardeinstellung "vendor stickyness".

Das heißt, dass ein Paket immer - wenn nicht ausdrücklich anders gewünscht - beim gleichen Repository bleibt.

Eine Möglichkeit, die nicht so radikal ist wie "zypper dup" wäre yast.

Dort kannst Du unter "Versionen" die neuer Version anwählen. Dann wird Yast Dir verschiedene Möglichkeiten vorschlagen, unter anderem einen Anbieterwechsel für das fragliche Paket sowie ggf. für Abhängigkeiten dieses Paketes.

(das geht auch irgendwie direkt mit zypper direkt)

zypper dup aktualisiert alles auf die neuste Version. zypper dup --from aktualisiert alles aus einem bestimmten Repo - also ggf. mehr als man bräuchte, um nur ein bestimmtes Paket zu aktualisieren.

Eine typische Anwendung von zypper dup ist der Multimediabereich. Zum Abspielen proprietärer Pakete ist es oft hilfreich, das Packman repo einzubinden und dann alles, was mit Multimedia zu tun hat, mit einem beherzten zypper dup --from packman zu aktualisieren.

Sauerland
Guru
Guru
Beiträge: 2913
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Verfügbare Version installieren , aber wie

Beitrag von Sauerland » 20. Nov 2017, 17:29

Nur mal so als Anmerkung:
/home Repos sind nicht unbedingt immer der Brüller, besser ist es, die Finger davon zu lassen......
Denn du weisst nie, wie die Pakete gebaut werden, ob sie vernünftig gebaut werden, ob sie immer gepatched werden usw.........
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

marce
Advanced Hacker
Advanced Hacker
Beiträge: 922
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: Verfügbare Version installieren , aber wie

Beitrag von marce » 20. Nov 2017, 17:45

Erinnert sich noch jemand an dieses furchtbar beliebte Debian-Zusatz-Repo, welches die "halbe Welt" eingebunden hatte und in das der Maintainer dann, als sich die Zugriffe trotz Hinweis auf Abschaltung nicht verringerten, einen kleinen "Virus" eingebaut hatte, um die Leute "dezent" drauf hinzuweisen, daß da was zu tun wäre?

... private Spaß-Repos sind alles mögliche, aber nicht vertrauenswürdig.

toyotafahrer
Member
Member
Beiträge: 87
Registriert: 17. Apr 2017, 13:05
Kontaktdaten:

Re: Verfügbare Version installieren , aber wie

Beitrag von toyotafahrer » 21. Nov 2017, 10:22

Ja , vielen Dank für die sehr aufschlussreichen Info`s .
Ich lasse alles so wie es ist , ich glaube das ist der bessere Weg für mich.
Wenn ich erst einen Fehler habe und weiß nicht genau wo , dann schreiben einige mit mir wieder viele Seiten voll.
Ich denke das tut nicht Not. Irgendwann werde ich auf die 42.3 wechseln , aber das mache ich mit der DVD und sollte kein Problem sein.
Samsung 17" Laptop NP350E7C CPU i7 / 240GB SSD + 500 GB SSD / 8 GB Ram / ATI HD 7600M
OS = Opensuse 42.3 x64

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste