Kernelfrage nach Crash

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

ThomasG.
Newbie
Newbie
Beiträge: 32
Registriert: 27. Mär 2017, 13:09

Kernelfrage nach Crash

Beitrag von ThomasG. » 28. Sep 2017, 09:31

Liebe Gemeinde ich brauch mal bitte Dringend Eure Hilfe.
Nach Stromausfall war die / Partition im Bootloader weg.
Also da "Unbootbar" auf 2ter Platte neue Installation. Konnte aus der erst Installation alle Daten retten.
Meine Frage kann ich als DAU den Kernel (Netzwerkscanner+Druckr etc.) wieder in das Bestehende System reinkopieren? Und falls hoffentlich ja verartetet mir BITTE wie...
Ich bin auf den PC Angewiesen und es geht auch was auf dem Gebiet Suse aber leider bin ich kein Crack und eher als Nutzer Unterwegs...
Ich hoffe ihr könnt mir Helfen
Danke und Lieben Gruß
thomas

Falls der Beitrag hier Falsch ist BITTE verschieben.

Werbung:
josef-wien
Guru
Guru
Beiträge: 4914
Registriert: 23. Sep 2008, 17:09

Re: Kernelfrage nach Crash

Beitrag von josef-wien » 28. Sep 2017, 17:18

ThomasG. hat geschrieben:Nach Stromausfall war die / Partition im Bootloader weg.
Was willst Du uns damit sagen? Es kann zwar vorkommen, daß nach einem Stromausfall Dateien, die gerade in Arbeit waren, nicht mehr brauchbar sind, aber im Verzeichnis /boot ändern sich Kernel, initrd und die Dateien des Boot-Managers nur bei einem Kernel-Update.


ThomasG. hat geschrieben:"Unbootbar"
Hat Dein BIOS bzw. UEFI keine "startfähige" Platte gefunden? Wurde kein Boot-Manager angezeigt? Konnte der Boot-Manager das System nicht starten? War der Systemstart nicht erfolgreich?

Deine persönlichen Einstellungen kannst Du ja vom "alten" auf das "neue" Home-Verzeichnis übernehmen. Von Eingriffen in die Systemeinstellungen im Verzeichnis /etc kann ich Dir nur abraten, da mußt Du genau wissen, was Du machst, und da ist per Ferndiagnose nicht zu helfen.

ThomasG.
Newbie
Newbie
Beiträge: 32
Registriert: 27. Mär 2017, 13:09

Re: Kernelfrage nach Crash

Beitrag von ThomasG. » 28. Sep 2017, 20:43

Grub hat bei booten kein System gefunden und ich hatte keine Chance Suse hoch zu fahren.
Den Kernel habe ich gesperrt da ich tierisch (für mein können) lange gebraucht habe damit der Brother MFC via Netzwerk arbeitet so wie er soll.
Nein der Bootmanager konnte das System nicht Starten da er der Meinung war ich hätte gar kein Betriebssystem.
Nun geht es mir nur darum das ich nicht wieder Stunden probieren muß damit der Scanner/Drucker via Netzwerk wieder zum laufen kommt.. Eventuell aus Unwissenheit habe ich mich auch Unglücklich Ausgedrückt..
Vom Gedanken her möchte ich nur die Datei in das neue System kopieren in dem genau die Daten gespeichert sind die dem System sagen wo Drucker/Scanner sind und wie die dann anzusteuern sind.

marce
Advanced Hacker
Advanced Hacker
Beiträge: 923
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: Kernelfrage nach Crash

Beitrag von marce » 28. Sep 2017, 20:54

Das dürfte nicht so einfach sein - vermutlich hast Du für den Drucker einen Treiber installiert (der besteht ggf. aus div. Dateien), hast den Druck-Server konfiguriert (auch ein paar Dateien), Einstellungen für Deinen Benutzer gemacht bezüglich Drucker, ...

Der Kernel ist so ziemlich die einzige Komponente, die damit nichts zu tun hat...

ThomasG.
Newbie
Newbie
Beiträge: 32
Registriert: 27. Mär 2017, 13:09

Re: Kernelfrage nach Crash

Beitrag von ThomasG. » 28. Sep 2017, 21:02

ich habe nach langem hin und her via Konsole den Treiber für den Brother MFC 9120 geladen und den rest hat Suse dann alleine gemacht.
Die Einstellungen für den Drucker habe ich via Browser IP direkt am Drucker vorgenommen und auch der Scanner hat lediglich ne IP bekommen.
Ansonsten hat das Suse alles super ohne mein (nicht können hin bekommen

josef-wien
Guru
Guru
Beiträge: 4914
Registriert: 23. Sep 2008, 17:09

Re: Kernelfrage nach Crash

Beitrag von josef-wien » 28. Sep 2017, 22:01

ThomasG. hat geschrieben:Grub hat bei booten kein System gefunden
Hier wäre die genaue Fehlermeldung wichtig. Für den Start von Linux sind die beiden zusammengehörenden Dateien vmlinuzirgendetwas und initrdirgendetwas notwendig. Gibt es diese Dateien im Verzeichnis /boot Deiner alten Installation? Weiters ist eine eingehende Überprüfung des Dateisystems der alten Systempartition anzuraten. Du hast jetzt zwar auf einer anderen Platte wieder ein funktionierendes Linux, aber ich halte es auf Dauer für nicht besonders zweckmäßig, als Problemlösung auf einer anderen Platte ein neues System zu installieren.


ThomasG. hat geschrieben:Den Kernel habe ich gesperrt
Das ist nicht Sinn der Sache, damit verhinderst Du jede Sicherheitsaktualisierung und nimmst Dir die Möglichkeit, bei Bedarf einen älteren Kernel zu starten.

ThomasG.
Newbie
Newbie
Beiträge: 32
Registriert: 27. Mär 2017, 13:09

Re: Kernelfrage nach Crash

Beitrag von ThomasG. » 29. Sep 2017, 07:59

die Fehlermeldung sah so aus das der Rechner booten wollte es aber nicht tat und dann der Bildschirm schwarz geblieben ist und das System sich aufgehängt hat.
Ja ich bin auch nicht davon erbaut das Linux auf meiner 2ten Platte läuft und ich würde das auch wieder ändern... Es geht hier im großen auch mehr oder weniger Primär um diesen Mulitikasten den ich so dringen benötige und es war für mich ne Mega Aufgabe diesen so zum laufen zu bekommen das er Scannt wenn ich das möchte und das er druckt was ich möchte.
Ich hatte nur die Hoffnung um genau diesen Schritt herum zu kommen durch retten der "Alten" Einstellungen und das hineinkopieren in das neue bestehende System

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 1927
Registriert: 24. Okt 2005, 14:04

Re: Kernelfrage nach Crash

Beitrag von Heinz-Peter » 29. Sep 2017, 10:41

Hallo @ThomasG.,

falls du Probleme mit der Installation deines Multifunktionsgerätes (Drucker, Scanner, Kopierer) hast dann denke ich; Vielleicht wäre es besser eine Image Datei von deinem laufenden System brennen, dann kannst von der DVD oder USB-Stück den alten Zustand herstellen.
Wie das geht kann dir vielleicht mein Link helfen, siehe hier https://wiki.archlinux.de/title/Image-Erstellung_mit_dd
Ich habe selber noch keine Image Datei erstellt aber; Wer sucht der findet ;) siehe Link: linux image erstellen
Die bessere Lösung (denke ich) wäre auf einem aktuellen Betriebssystem dein Multifunktionsgerät konfigurieren, dazu einfach hier in Forum ein Thread aufmachen.

Grüße Heinz-Peter
Mein Betriebssystem: Suse 13.2/13.1, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.

josef-wien
Guru
Guru
Beiträge: 4914
Registriert: 23. Sep 2008, 17:09

Re: Kernelfrage nach Crash

Beitrag von josef-wien » 29. Sep 2017, 17:40

ThomasG. hat geschrieben:
29. Sep 2017, 07:59
die Fehlermeldung sah so aus das der Rechner booten wollte es aber nicht tat und dann der Bildschirm schwarz geblieben ist
Diese Beschreibung könnte auch darauf hindeuten, daß "nur" das grafische System nicht gestartet werden konnte. Ergänze vor dem Start im Boot-Menü bei den Boot-Optionen nach einem Leerzeichen die Ziffer(siehe z. B. https://linux-club.de/wiki/opensuse/GRUB2#Der_Editor). Wenn der Textmodus funktioniert, sind wir einen Schritt weiter. Andernsfalls würde ich die Boot-Optionen

Code: Alles auswählen

splash=silent quiet
durch

Code: Alles auswählen

splash=verbose
ersetzen.

spoensche
Moderator
Moderator
Beiträge: 7261
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Kernelfrage nach Crash

Beitrag von spoensche » 29. Sep 2017, 18:39

Wenn du nach den Anweisungen von Josef in der Konsole landest, dann melde dich dort an und poste mal die Ausgabe von

Code: Alles auswählen

egrep "EE|WW" /var/log/Xorg.0.log
.

Was für eine Grafikkarte hast du denn bei dir verbaut?
Ist das die einzige, oder hat dein Board evtl. auch eine onBoard Graka?

ThomasG.
Newbie
Newbie
Beiträge: 32
Registriert: 27. Mär 2017, 13:09

Re: Kernelfrage nach Crash

Beitrag von ThomasG. » 1. Okt 2017, 17:55

spoensche hat geschrieben:
29. Sep 2017, 18:39
Wenn du nach den Anweisungen von Josef in der Konsole landest, dann melde dich dort an und poste mal die Ausgabe von

Code: Alles auswählen

egrep "EE|WW" /var/log/Xorg.0.log
.

Was für eine Grafikkarte hast du denn bei dir verbaut?
Ist das die einzige, oder hat dein Board evtl. auch eine onBoard Graka?
es ist eine Radeon XPress 1200 verbaut... Ist ein Dell Laptop

ThomasG.
Newbie
Newbie
Beiträge: 32
Registriert: 27. Mär 2017, 13:09

Re: Kernelfrage nach Crash

Beitrag von ThomasG. » 1. Okt 2017, 18:15

Code: Alles auswählen

linux-48jm:/home/thomas # egrep "EE|WW" /var/log/Xorg.0.log
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    72.831] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
[    73.186] (WW) Warning, couldn't open module fglrx
[    73.186] (EE) Failed to load module "fglrx" (module does not exist, 0)
[    73.359] (WW) Falling back to old probe method for modesetting
[    73.359] (WW) Falling back to old probe method for fbdev
[    73.363] (WW) Falling back to old probe method for vesa
[    73.648] (WW) RADEON(0): Output LVDS: Strange aspect ratio (367/23000), consider adding a quirk
[   101.273] (WW) RADEON(0): Output LVDS: Strange aspect ratio (367/23000), consider adding a quirk
[   102.257] (WW) RADEON(0): Output LVDS: Strange aspect ratio (367/23000), consider adding a quirk
[   102.455] (WW) RADEON(0): Output LVDS: Strange aspect ratio (367/23000), consider adding a quirk
[   104.117] (WW) RADEON(0): Output LVDS: Strange aspect ratio (367/23000), consider adding a quirk
[   104.349] (WW) RADEON(0): Output LVDS: Strange aspect ratio (367/23000), consider adding a quirk
[   104.574] (WW) RADEON(0): Output LVDS: Strange aspect ratio (367/23000), consider adding a quirk
[   106.846] (WW) RADEON(0): Output LVDS: Strange aspect ratio (367/23000), consider adding a quirk
das hat mir die Konsole als root geschmissen... Beim Start reagiert der Bootloader nicht und wenn ich in den Bootvorgang hinein komme dann sagt er mir immer das /var... Fehlerhaft oder nicht vorhanden ist...

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 1927
Registriert: 24. Okt 2005, 14:04

Re: Kernelfrage nach Crash

Beitrag von Heinz-Peter » 1. Okt 2017, 19:17

ThomasG. hat geschrieben:
1. Okt 2017, 17:55
es ist eine Radeon XPress 1200 verbaut... Ist ein Dell Laptop
Das reicht nicht. Poste bitte die Konsoleausgabe:

Code: Alles auswählen

hwinfo --gfxcard
und dazu gleich

Code: Alles auswählen

zypper lr -uPE
Mein Betriebssystem: Suse 13.2/13.1, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.

spoensche
Moderator
Moderator
Beiträge: 7261
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Kernelfrage nach Crash

Beitrag von spoensche » 1. Okt 2017, 19:49

Wenn du die Möglichkeit hast, im Bootmenü den Eintrag "Failsafe" auszuwählen, dann wähle ihn aus und boote damit.

Wenn das nicht funktioniert, dann füge im Feld Bootoptionen mal folgendes ein:

Code: Alles auswählen

nomodeset
Der X-Server versucht das Treibermodul fglrx zu laden, was wohl nicht vorhanden ist und verwendet daraufhin den Nouveau- Treiber.

Hast du vor dem Crash, den Fglrx Treiber oder den Nouveau-Treiber verwendet?

ThomasG.
Newbie
Newbie
Beiträge: 32
Registriert: 27. Mär 2017, 13:09

Re: Kernelfrage nach Crash

Beitrag von ThomasG. » 1. Okt 2017, 20:41

Heinz-Peter hat geschrieben:
1. Okt 2017, 19:17
ThomasG. hat geschrieben:
1. Okt 2017, 17:55
es ist eine Radeon XPress 1200 verbaut... Ist ein Dell Laptop
Das reicht nicht. Poste bitte die Konsoleausgabe:

Code: Alles auswählen

hwinfo --gfxcard
und dazu gleich

Code: Alles auswählen

zypper lr -uPE

Code: Alles auswählen

linux-48jm:/home/thomas # hwinfo --gfxcard
27: PCI 105.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.374]
  Unique ID: ul7N.tmMlB+Mmn60
  Parent ID: vSkL.HhWbXaBL4dD
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
  SysFS BusID: 0000:01:05.0
  Hardware Class: graphics card
  Model: "ATI RS690M [Radeon Xpress 1200/1250/1270]"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x791f "RS690M [Radeon Xpress 1200/1250/1270]"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x01fd 
  Driver: "radeon"
  Driver Modules: "drm"
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  Memory Range: 0xfe9f0000-0xfe9fffff (rw,non-prefetchable)
  I/O Ports: 0xee00-0xeeff (rw)
  Memory Range: 0xfea00000-0xfeafffff (rw,non-prefetchable)
  IRQ: 26 (17227 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d0000791Fsv00001028sd000001FDbc03sc00i00"
  Driver Info #0:
    Driver Status: radeon is active
    Driver Activation Cmd: "modprobe radeon"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #8 (PCI bridge)

Primary display adapter: #27

Code: Alles auswählen

linux-48jm:/home/thomas # zypper lr -uPE
#  | Alias               | Name                              | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | URI                                                              
---+---------------------+-----------------------------------+-----------+-----------------+----------------+-----------+------------------------------------------------------------------
 1 | google-chrome       | google-chrome                     | Ja        | ( p) Ja         | Ja             |   99      | http://dl.google.com/linux/chrome/rpm/stable/x86_64              
 7 | repo-non-oss        | openSUSE-Leap-42.2-Non-Oss        | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/
 8 | repo-oss            | openSUSE-Leap-42.2-Oss            | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/distribution/leap/42.2/repo/oss/    
11 | repo-update         | openSUSE-Leap-42.2-Update         | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/update/leap/42.2/oss/               
12 | repo-update-non-oss | openSUSE-Leap-42.2-Update-Non-Oss | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/update/leap/42.2/non-oss/           

Sauerland
Guru
Guru
Beiträge: 2918
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Kernelfrage nach Crash

Beitrag von Sauerland » 1. Okt 2017, 21:28

spoensche hat geschrieben:
1. Okt 2017, 19:49
Wenn du die Möglichkeit hast, im Bootmenü den Eintrag "Failsafe" auszuwählen, dann wähle ihn aus und boote damit.

Wenn das nicht funktioniert, dann füge im Feld Bootoptionen mal folgendes ein:

Code: Alles auswählen

nomodeset
Der X-Server versucht das Treibermodul fglrx zu laden, was wohl nicht vorhanden ist und verwendet daraufhin den Nouveau- Treiber.

Hast du vor dem Crash, den Fglrx Treiber oder den Nouveau-Treiber verwendet?
Der fglrx baut nur bis Leap 42.1.
Das ist eine Standardabfrage irgendwo im xorg, ob fglrx vorhanden.
Driver Info #0:
Driver Status: radeon is active
Driver Activation Cmd: "modprobe radeon"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #8 (PCI bridge)
Und dieser Treiber benötigt das Kernel-Modesetting, ebenso wie der intel und der nouveau.
Sonst wird ein rudimentärer Treiber fbdev benutzt.
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

ThomasG.
Newbie
Newbie
Beiträge: 32
Registriert: 27. Mär 2017, 13:09

Re: Kernelfrage nach Crash

Beitrag von ThomasG. » 1. Okt 2017, 21:54

Also ich weiß nicht welcher Treiber Installiert war/ist das hat Linux alles selber gemacht..
ABER--- Ich bin in der Konsole und kann mich als root anmelden.. Habe aber keinen X-Server bzw. keine Grafische Oberfläche und komme jetzt nicht mehr weiter stecke in Init 2 und wenn ich Init 5 Aufrufen möchte dann passiert da nichts weiter.

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 1927
Registriert: 24. Okt 2005, 14:04

Re: Kernelfrage nach Crash

Beitrag von Heinz-Peter » 1. Okt 2017, 22:06

ThomasG. hat geschrieben:
1. Okt 2017, 21:54
Also ich weiß nicht welcher Treiber Installiert war/ist das hat Linux alles selber gemacht..
ABER--- Ich bin in der Konsole und kann mich als root anmelden..
Ich habe keine Erfahrung mit der GRAKA. Hier kannst dich aber informieren: https://de.opensuse.org/SDB:AMD/ATI-Grafiktreiber
Und hier kannst den Treiber suchen: https://support.amd.com/de-de/download

EDIT: Den Treiber finden ist gar nicht so einfach :???: Hier habe ich noch was gefunden: https://www.notebookcheck.com/ATI-Radeo ... 736.0.html
Und hier, ein Artikel von 05.09.2009 https://www.heise.de/newsticker/meldung ... 54757.html

Grüße Heinz-Peter
Zuletzt geändert von Heinz-Peter am 1. Okt 2017, 22:45, insgesamt 1-mal geändert.
Mein Betriebssystem: Suse 13.2/13.1, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5019
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Kernelfrage nach Crash

Beitrag von tomm.fa » 1. Okt 2017, 22:44

Heinz-Peter hat geschrieben:
1. Okt 2017, 22:06
Ich habe keine Erfahrung mit der GRAKA. Hier kannst dich aber informieren: https://de.opensuse.org/SDB:AMD/ATI-Grafiktreiber
Und hier kannst den Treiber suchen: https://support.amd.com/de-de/download

EDIT: Den Treiber finden ist gar nicht so einfach :???: Hier habe ich noch was gefunden: https://www.notebookcheck.com/ATI-Radeo ... 736.0.html

Grüße Heinz-Peter
Du brauchst nicht großartig zu suchen, es bleibt nur radeon. Mit fglrx & Co. wird ThomasG, bzw. dessen verwendete Version von openSUSE, nichts anfangen können.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 1927
Registriert: 24. Okt 2005, 14:04

Re: Kernelfrage nach Crash

Beitrag von Heinz-Peter » 1. Okt 2017, 22:47

tomm.fa hat geschrieben:
1. Okt 2017, 22:44
Du brauchst nicht großartig zu suchen, es bleibt nur radeon. Mit fglrx & Co. wird ThomasG, bzw. dessen verwendete Version von openSUSE, nichts anfangen können.
Danke @tomm.fa.

Grüße Heinz-Peter
Mein Betriebssystem: Suse 13.2/13.1, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste