Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] YaST öffnet keine Fester mehr, seit update gestern

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Benutzer 57057 gelöscht

[gelöst] YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Benutzer 57057 gelöscht » 17. Aug 2017, 13:08

Gestern hatte ich unter Tumbleweed 2017-08-15 (x64 Vs.) 286 updates. Alles lief bis Dato gut, auch YaST.
Heute wollte ich eine Einstellung (Sound) ändern und öffnete YaST, Fester ging auch auf, aber: Ich kann keine Optionen unter YaST anwählen oder öffnen, wie z.B. Soundeinstellungen, Repos, Online-Update, Schriftarten etc.
Bei Anklicken dreht sich der Kreis einige Sekunden, das war es dann auch.
Zuvor hatte alles fehlerfrei funktioniert. Habe ein Bild von der System Info als Verweis verlinkt http://paste.opensuse.org/1cec5c9c
Für mehr Info bitte einfach fragen. Danke.
Zuletzt geändert von Benutzer 57057 gelöscht am 19. Aug 2017, 12:05, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2107
Registriert: 24. Okt 2005, 14:04

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Heinz-Peter » 17. Aug 2017, 17:21

Hallo @cerberos,

hast schon versucht yast2 im Textmodus zu öffnen?
Ich meine Strg+Alt+F1 dann root, dann root-Password, dann yast2.

Grüße Heinz-Peter
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

Benutzer 57057 gelöscht

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Benutzer 57057 gelöscht » 17. Aug 2017, 17:51

Hallo Heinz-Peter,
zunächst Danke für den Tipp; habe wie von dir beschrieben YaST2 geöffnet, alle meine Repos aktualisiert. Das hat funktioniert.
Dann nach dem Neustart habe ich es nochmals über die Konsole (Terminal/root) versucht, auch hier alles in Ordnung. Nur via Menü geht es nicht; YaST Hauptfenster öffnet wie gewohnt, aber gleich, was ich dann dort anklicke - es öffnet sich nichts.
Auch nach dem von dir beschriebenen Weg ist es gleich geblieben.
Gruß Rolf

Sauerland
Guru
Guru
Beiträge: 3617
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Sauerland » 17. Aug 2017, 18:25

Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Benutzer 57057 gelöscht

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Benutzer 57057 gelöscht » 17. Aug 2017, 18:38

Hallo Sauerland,
Danke für deinen Verweis, aber nimm es nicht persönlich - ich habe keine Muse dazu, mir dieses Gesabber in englischer Sprache anzutun :(
Hierfür brauche ich kein Forum in deutscher Sprache. aber trotzdem Dankeschön.

Sauerland
Guru
Guru
Beiträge: 3617
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Sauerland » 17. Aug 2017, 18:41

Warum sollte ich etwas schreiben, was dort schon steht?

Und selbst wenn man kein Englisch kann, sollte man es doch einmal überfliegen.
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5371
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von tomm.fa » 17. Aug 2017, 18:54

http://www.babelfish.de/
Aber auch ohne diese Hilfe habe selbst ich verstanden was zu tun ist. Kurzform: Die dort erwähnten Pakete wurden aktualisiert.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Benutzer 57057 gelöscht

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Benutzer 57057 gelöscht » 17. Aug 2017, 19:14

tomm.fa & Sauerland,

Jetzt werde ich mir den FF 55.0.1 wieder neu installieren, habe ja sonst nichts zu tun. Ist nun wieder drauf, und alles funktioniert fehlerfrei.
Schönen Abend noch.
Zuletzt geändert von Benutzer 57057 gelöscht am 18. Aug 2017, 21:10, insgesamt 1-mal geändert.

Sauerland
Guru
Guru
Beiträge: 3617
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Sauerland » 17. Aug 2017, 19:43

1. Was ist dort installiert? Tumbleweed?
2. Ein allgemeines zypper dup sollte man nicht machen, oder man weiss was man tut. Bei Tumbleweed wird sogar zu zypper dup --no-allow-vendor-change geraten.
3. Wenn dort ein Firefox 45 installiert wird, würden mich die Repolisten doch einmal interessieren.....
4. Bei einem zypper dup würde ich dann auch noch einmal lesen, was da alles so umgestellt /installiert wird.

Aber wie so oft:
Die anderen sind schuld.
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Benutzer 57057 gelöscht

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Benutzer 57057 gelöscht » 17. Aug 2017, 21:52

Hallo Sauerland,
ich war nur total überrascht nach dem zypperdup, dass ich dann anstatt meinen vorherigen FF 55.0.1 diesen FF 45.0 drauf hatte.
Dann noch in englischer Sprache; und alle Einstellungen waren weg.
Sage mir, wie ich das mittels code hier anzeigen kann, dann stelle ich es dir ein.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5371
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von tomm.fa » 17. Aug 2017, 21:59

Die Ausgabe von

Code: Alles auswählen

zypper lr -d
hier einstellen.

Ich hätte ja nur die im dortigem Thema erwähnten Pakete aktualisiert.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Benutzer 57057 gelöscht

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Benutzer 57057 gelöscht » 17. Aug 2017, 22:04

Danke erst mal ... (hätte ich das alles vorher gewusst, wäre ich anders vorgegangen).
Alle Repos stehen auf 99.

Code: Alles auswählen

Passwort: 
linux-1dp0:~ # zypper lr -d
Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.

# | Alias                            | Name                            | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                       | Dienst
--+----------------------------------+---------------------------------+-----------+-----------------+----------------+-----------+--------+---------------------------------------------------------------------------+-------
1 | Mozilla                          | Mozilla                         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Tumbleweed/    |       
2 | Packman                          | Packman                         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/                       |                                                                                                                                                                      
3 | download.opensuse.org-non-oss    | Haupt-Repository (NON-OSS)      | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                     |                                                                                                                                                                      
4 | download.opensuse.org-oss        | Haupt-Repository (OSS)          | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                         |                                                                                                                                                                      
5 | download.opensuse.org-tumbleweed | Hauptaktualisierungs-Repository | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/tumbleweed/                           |                                                                                                                                                                      
6 | openSUSE-20170524-0              | openSUSE-20170524-0             | Nein      | ----            | ----           |   99      | yast2  | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GSA-4167B_CAB8789CA8B2 |                                                                                                                                                                      
7 | repo-source                      | openSUSE-Tumbleweed-Source      | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/source/tumbleweed/repo/oss/                  |                                                                                                                                                                      
linux-1dp0:~ #                  

Alero

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Alero » 18. Aug 2017, 20:12

Packman auch auf 99 zu stellen, macht keinerlei Sinn. Da kannst du dir das Packman - Repo sparen. Besser wäre, dem Packman - Repo eine höhere Priorität zuzuweisen, durch eine niedrigere Prioritäten-Zahl, und dann auf Packman komplett umzustellen mit einem

Code: Alles auswählen

zypper dup --from <Packman - URL oder Nummer>

Benutzer 57057 gelöscht

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Benutzer 57057 gelöscht » 18. Aug 2017, 21:08

Guten Abend Alero,
habe die Packman auf 77 gestellt, alles andere auf 99 belassen; soll ich die Repo "Mozilla" dann löschen, oder so belassen?
Das zypper dup für Packman habe ich auch ausgeführt. Derzeit ist alles im Guten :)
Danke erst mal.

Benutzer 57057 gelöscht

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Benutzer 57057 gelöscht » 18. Aug 2017, 21:12

Sauerland hat geschrieben:
17. Aug 2017, 19:43
Aber wie so oft:
Die anderen sind schuld.
Guten Abend Sauerland,
ging nicht gegen dich, oder tomm.fa; ich war einfach nur stinkig, weil ich diesen dOO.... FF 45 drauf hatte :o
Bin mir eben auch noch nicht so sicher mit Tumbleweed, da laufend so viele updates kommen.
Alles wird gut ;)

Sauerland
Guru
Guru
Beiträge: 3617
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Sauerland » 18. Aug 2017, 21:26

Wer sich das Mozilla Repo einbindet und ein allgemeines zypper dup durchführt, darf sich nicht wundern......

Und ich sag immer:
Tumbleweed ist eher was für Fortgeschrittene......
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Alero

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Alero » 18. Aug 2017, 21:31

Ich kann da nur von mir ausgehen. Ich habe mit dem Mozilla-Repo schon schlechte Erfahrungen gemacht und es zu aktivieren brachte mir keinen wirklichen Mehrwert. Von daher habe ich es entfernt. Aktualisierungen kommen so etwa ein paar Tage später. Das halte ich aber für nicht so wichtig, ob ich den neuesten Firefox zwei Tage eher habe oder später. Hoffe, dir deine Frage beantwortet zu haben.

Ein Tipp noch zum Abschluß:
Wenn du auf Packman umgestellt hast, solltest du ohne zwingenden Grund keine zypper dup mehr ausführen, weil du sonst die Repos wieder wechseln könntest. Das wäre dem System nicht zuträglich. Es wird nur noch ein zypper up zur Aktualisierung des Systems verwendet. Man stößt dann auf solche Absonderlichkeiten in der Konsole, das da geschrieben steht, soundso viele Programme / Treiber werden nicht aktualisiert. Dies ist jedoch nicht schlimm und kann vernachlässigt werden. Es handelt sich um Treiber aus anderen Repos. Die genauen Zusammenhänge der Sache sollen jedoch hier jetzt nicht Sinn der Diskussion sein. Wichtig ist, das du nur noch ein zypper up durchführst, falls du aus der Konsole arbeitest.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5371
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von tomm.fa » 18. Aug 2017, 21:41

Alero hat geschrieben:
18. Aug 2017, 21:31
Ein Tipp noch zum Abschluß:
Wenn du auf Packman umgestellt hast, solltest du ohne zwingenden Grund keine zypper dup mehr ausführen, weil du sonst die Repos wieder wechseln könntest. Das wäre dem System nicht zuträglich. Es wird nur noch ein zypper up zur Aktualisierung des Systems verwendet. Man stößt dann auf solche Absonderlichkeiten in der Konsole, das da geschrieben steht, soundso viele Programme / Treiber werden nicht aktualisiert. Dies ist jedoch nicht schlimm und kann vernachlässigt werden. Es handelt sich um Treiber aus anderen Repos. Die genauen Zusammenhänge der Sache sollen jedoch hier jetzt nicht Sinn der Diskussion sein. Wichtig ist, das du nur noch ein zypper up durchführst, falls du aus der Konsole arbeitest.
Da es um openSUSE Tumbleweed geht siehe:
Sauerland hat geschrieben:
17. Aug 2017, 19:43
Bei Tumbleweed wird sogar zu zypper dup --no-allow-vendor-change geraten.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Benutzer 57057 gelöscht

[gelöst] Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Benutzer 57057 gelöscht » 18. Aug 2017, 21:49

Erst noch mal Danke an alle,

ich habe nun die Repo Mozilla entfernt, werde unter Tumbleweed kein zypper dup mehr ausführen, und warten bis mir Aktualisierungen vom System angeboten werden (oder nur zypper up).
Tumbleweed ist eher was für Fortgeschrittene......
Deshalb "spiele" ich ja auch so oft damit herum: damit ich fortschreiten kann ;) Als Primärsystem habe ich noch mein Leap 42.2.
Zuletzt geändert von Benutzer 57057 gelöscht am 19. Aug 2017, 12:06, insgesamt 1-mal geändert.

Alero

Re: YaST öffnet keine Fester mehr, seit update gestern

Beitrag von Alero » 18. Aug 2017, 22:06

Da es um openSUSE Tumbleweed geht siehe:
Sauerland hat geschrieben:
17. Aug 2017, 19:43
Bei Tumbleweed wird sogar zu zypper dup --no-allow-vendor-change geraten.
zypper dup --no-allow-vendor-change ist bei Tumbleweed mittlerweile Standard. Siehe :

https://lists.opensuse.org/opensuse-fac ... 00172.html

Antworten