[Gelöst] Softwareaktualisierungen

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
GKrause
Newbie
Newbie
Beiträge: 3
Registriert: 19. Apr 2017, 08:47

[Gelöst] Softwareaktualisierungen

Beitrag von GKrause » 19. Apr 2017, 10:36

Liebe Entwickler,
ich benutze ausschließlich das - dankenswerter Weise von Euch zur Verfügung gestellte - Miniprogramm in der Kontrollleiste, um Softwareaktualisierungen durchzuführen; dieses Programm macht mich ja auch auf neue, zur Verfügung stehende Aktualisierungen aufmerksam; jedes Mal drücke ich (brav) die Schaltfläche: Aktualisierungen installieren. Seit geraumer Zeit erscheint dann aber ein Fehler-Fenster: Fehler beim Aktualisieren - Auflösung der Abhängigkeit fehlgeschlagen. Inzwischen stehen 16 Aktualisierungen aus! Da ich nichts an den dahinterliegenden Ausführungen geändert habe, sollten Sie dieses Problem a) erkennen und b) beheben können, denn für mich, als Anwender, liegen die Prozesse im Dunkeln ...
Danke im voraus.
Gottfried Krause
Zuletzt geändert von GKrause am 25. Apr 2017, 14:23, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1624
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: Softwareaktualisierungen

Beitrag von gehrke » 19. Apr 2017, 10:45

GKrause hat geschrieben:
19. Apr 2017, 10:36
Liebe Entwickler,
Ich glaube nicht, dass Du hier besonders viele Entwickler erreichen wirst. Hier findest Du eher User, die anderen Usern helfen.

Aber ohne Details zu dem von Dir verwendeten System zu nennen, wird Dir hier kaum einer helfen können.

Sauerland
Guru
Guru
Beiträge: 2706
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Softwareaktualisierungen

Beitrag von Sauerland » 19. Apr 2017, 17:30

Das Applet macht nur zypper patch und verschluckt sich schon ab und an.

Dann einfach mal in der Konsole ein

Code: Alles auswählen

zypper up
machen und danach schauen, ob sich das Problem gelöst hat.
Desktop: OpenSUSE Leap 42.2, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.1, ATI-Grafik (Radeon-Treiber)
Laptop: OpenSUSE Leap 42.2, Intel-Skylake, Kernel 4.x

Benutzeravatar
StevieD
Member
Member
Beiträge: 127
Registriert: 12. Jun 2005, 18:49
Wohnort: Schmelz, Saarland
Kontaktdaten:

Re: Softwareaktualisierungen

Beitrag von StevieD » 20. Apr 2017, 17:27

Hi,
ich glaube, da gibt es ein Problem mit dem Herstellerwechsel. Susi kann z.B. kein Multimedia, und das Applet will auf Standardrepo aktualisieren statt Packman. Deshalb gibts Mecker.
In Yast kann man zwar erlauben, das App weiss das aber scheinbar nicht.
In der Konsole oder über Yast sollte klappen
Kernel 4.4xx leap 42.2, 2x1000GB + 8GB Ram, AMD 6100 Six-Core, nVidia GT250

Benutzeravatar
Alero
Member
Member
Beiträge: 241
Registriert: 28. Nov 2016, 16:20
Wohnort: Gera, Ost-Thüringen

Re: Softwareaktualisierungen

Beitrag von Alero » 21. Apr 2017, 13:28

Wie hast du die Repos priorisiert?
Zuletzt geändert von gehrke am 21. Apr 2017, 13:46, insgesamt 1-mal geändert.
Grund: Unerwünschte Werbung entfernt

Benutzeravatar
StevieD
Member
Member
Beiträge: 127
Registriert: 12. Jun 2005, 18:49
Wohnort: Schmelz, Saarland
Kontaktdaten:

Re: Softwareaktualisierungen

Beitrag von StevieD » 21. Apr 2017, 17:16

Packman steht bei mir ganz oben, bei dem konkreten Fall wars vermutlich nicht so.
Das war mal ein Schuss in Blaue mit dem Herstellerwechsel.
Kernel 4.4xx leap 42.2, 2x1000GB + 8GB Ram, AMD 6100 Six-Core, nVidia GT250

Freddie62
Advanced Hacker
Advanced Hacker
Beiträge: 1495
Registriert: 24. Jan 2006, 14:21
Wohnort: Bielefeld

Re: Softwareaktualisierungen

Beitrag von Freddie62 » 24. Apr 2017, 13:14

Der flashplayer macht ganz gerne mal Ärger beim updaten, da die Signatur irgendwie nicht passt. Da hilft nur, wie von Sauerland geschrieben, in der Konsole als root ein

Code: Alles auswählen

zypper up
durchzuführen und, falls es wirklich flashplayer ist, die Fehler mit "i" für ignorieren zu beseitigen. Danach sollte Alles wieder wie gewohnt laufen.

CU FReddie
Leap 42.2, Kernel: 4.4.49-16-default, LXDE/KDE5. Schleppi: Dell Latitude 5520 mit Win7 Prof./Leap42.2-X64, Kernel: 4.4.49-16-default, LKDE/KDE5

GKrause
Newbie
Newbie
Beiträge: 3
Registriert: 19. Apr 2017, 08:47

Re: Softwareaktualisierungen

Beitrag von GKrause » 24. Apr 2017, 14:17

DANKE liebe Leute, zypper up hat geholfen :p , aber verstehen muss man das ja nicht, oder?
Nochmals danke. Gottfried

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1624
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: Softwareaktualisierungen

Beitrag von gehrke » 24. Apr 2017, 14:20

Dann bitte das Thema als '[Gelöst]' markieren:
https://linux-club.de/forum/viewtopic.php?f=90&t=120398
TNX

Freddie62
Advanced Hacker
Advanced Hacker
Beiträge: 1495
Registriert: 24. Jan 2006, 14:21
Wohnort: Bielefeld

Re: Softwareaktualisierungen

Beitrag von Freddie62 » 25. Apr 2017, 12:53

GKrause hat geschrieben:
24. Apr 2017, 14:17
DANKE liebe Leute, zypper up hat geholfen :p , aber verstehen muss man das ja nicht, oder?
Nochmals danke. Gottfried
Doch! Das Update-Tool kann (und darf!) von sich aus keine Konflikte lösen, für die ein Eingriff des Nutzers (root) erforderlich ist. Das würde unter Anderem das Sicherheitskonzept untergraben.
Schließlich sind wir hier bei Linux, wo der User entscheidet und nicht bei einem "alternativen Betriebssystem". :D

CU Freddie
Leap 42.2, Kernel: 4.4.49-16-default, LXDE/KDE5. Schleppi: Dell Latitude 5520 mit Win7 Prof./Leap42.2-X64, Kernel: 4.4.49-16-default, LKDE/KDE5

BeastXXL
Member
Member
Beiträge: 179
Registriert: 6. Feb 2010, 10:51

Re: Softwareaktualisierungen

Beitrag von BeastXXL » 25. Apr 2017, 13:52

Hallo GKrause,
ich möchte dich auf einen alten Thread von mir aufmerksam machen. Ich hatte nämlich schon mal richtig schlechte Erfahrungen mit Apper (das Minitool in der Kontrollleiste; sah früher wie ein Käfer aus).
Ich hab's seit oS13.2 deaktiviert und aktuell rufe ich für Updates die "Online-Aktualisierung" auf.

Code: Alles auswählen

zypper up
geht natürlich auch.
Dual-Boot: WIN7 (64Bit), openSUSE Leap 42.2 (x86_64 GNU/Linux), Grub2, KDE, ATI/AMD Radeon HD7770, AMD Athlon II X4 630, 8 GB RAM

GKrause
Newbie
Newbie
Beiträge: 3
Registriert: 19. Apr 2017, 08:47

Re: [Gelöst] Softwareaktualisierungen

Beitrag von GKrause » 25. Apr 2017, 14:26

Danke.
Gottfried

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste