Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

OpenSuse 13.2 Upgrade (zypper) gescheitert [gelöst]

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

radiergummi
Newbie
Newbie
Beiträge: 40
Registriert: 14. Feb 2009, 12:34

OpenSuse 13.2 Upgrade (zypper) gescheitert [gelöst]

Beitrag von radiergummi » 25. Feb 2017, 20:52

Hallo Forum,
ich brauche Eure Hilfe.
Durch einen Bedienerfehler (meinen!) habe ich während des Upgrades von OpenSuse13.2 auf Leap 42.1 alles was mit KDE zu tun hat, yast2 und zypper gelöscht.
Nach Ändern der Repositories von 13.2 auf leap 42.1 sollte zypper aktualisiert werden, was aber auf einen Fehler lief. Auf die in der Folge gelisteten Konflikte habe ich falsch reagiert und die Konfliktparteien gelöscht.
Das System bootet, läuft und startet eine X-Window Umgebung.
Nach meiner Vorstellung muss ich doch nur wieder yast2 und zypper installieren, damit ich weiter machen kann.
Wie geht das? Das folgende rpm file habe ich gefunden.
ftp://195.220.108.108/linux/opensuse/up ... 2.i586.rpm

Bin dankbar um jede Hilfe.
Gruß,
Radiergummi
Zuletzt geändert von radiergummi am 28. Feb 2017, 19:28, insgesamt 1-mal geändert.

Werbung:
Sauerland
Guru
Guru
Beiträge: 3210
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von Sauerland » 25. Feb 2017, 21:07

Installiere neu und binde einfach dein altes /home ein.

Nimm aber Leap42.2, die 42.1 läuft in 3 Monaten aus.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5164
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von tomm.fa » 25. Feb 2017, 21:08

radiergummi hat geschrieben:
25. Feb 2017, 20:52
Das folgende rpm file habe ich gefunden.
ftp://195.220.108.108/linux/opensuse/up ... 2.i586.rpm
Deine vorherige Version (13.2) von openSUSE war ein(e) 32-Bit-System/Installation, du möchtest es so beibehalten und 64-Bit würde auf diesem Rechner auch nicht laufen? Dann hättest du mit openSUSE Leap ein Problem.

Abgesehen davon würde ich beim Wechsel von openSUSE 13.2 auf openSUSE Leap * auf eine Neuinstallation setzen und dann gleich auf openSUSE Leap 42.2 gehen.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

awsatnet
Member
Member
Beiträge: 53
Registriert: 14. Aug 2008, 18:33

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von awsatnet » 25. Feb 2017, 21:17

Du bist tatsächlich mit einer Neuinstallation auch nicht länger dran als mit einem Upgrade, aber auf jeden Fall nervenschonender.
Zudem müsstest Du zwei Mal upgraden, weil die 42.2 das eigentliche Ziel ist.
Wie bereits geschrieben: home-Verzeichnis sichern, wenn Du es nicht sowieso auf einer zweiten Partition hast und mit Deinem alten home-Verzeichnis hast Du in Deiner neuen 42.2-Installation alles so, wie Du es vorher hattest. Was Dir an Softwarepaketen fehlt, installierst Du einfach nach und sollte irgend etwas fehlen, dann kannst Du die Installation ja zu jeder Zeit nachholen.
HP Compaq 8000 Elite DC E5800, 2x3,2 ==> Opensuse Leap 42.2 64-bit Xfce, Win7Pro SP1 64-bit (Dualboot)
Lenovo Thinkpad T400, 2x2,4 ==> Xubuntu 16.04.02 LTS 64 bit auf xfs, Kernel 4.8.0-39
HP Compaq D530, P4 2,4 ==> Xubuntu 16.04 LTS

Sauerland
Guru
Guru
Beiträge: 3210
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von Sauerland » 25. Feb 2017, 21:23

Du bist tatsächlich mit einer Neuinstallation auch nicht länger dran als mit einem Upgrade, aber auf jeden Fall nervenschonender.
Zudem müsstest Du zwei Mal upgraden, weil die 42.2 das eigentliche Ziel ist.
Wie bereits geschrieben: home-Verzeichnis sichern, wenn Du es nicht sowieso auf einer zweiten Partition hast und mit Deinem alten home-Verzeichnis hast Du in Deiner neuen 42.2-Installation alles so, wie Du es vorher hattest. Was Dir an Softwarepaketen fehlt, installierst Du einfach nach und sollte irgend etwas fehlen, dann kannst Du die Installation ja zu jeder Zeit nachholen.
Wenn der TE tatsächlich ein 32 Bit Installation hat, ist eine Neuinstallation der bessere Weg, denn Leap gibt es nur in 64 Bit....
Bei einem Upgrade müsste auch alles in 64 Bit installiert werden....
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

radiergummi
Newbie
Newbie
Beiträge: 40
Registriert: 14. Feb 2009, 12:34

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von radiergummi » 25. Feb 2017, 21:47

Danke für Eure Antworten!
Ja es handelt sich um eine 32bit Installation, aber der Rechner kann 64bit.
Habe ich also schon vorher übersehen, daß man auf Leap nur von 13.2 64bit upgraden kann?

Eine Neuinstallation kann ich mir momentan zeitlich wahrscheinlich nicht leisten. Wer weiß, was ich von meinen heutigen Diensten nicht mehr 1:1 ans Laufen bringe (LVM, Raid, fetchmail, postfix, cyrus, rsync, inotifywait, nfs mounts und exports etc pp). Von daher wäre ich hochzufrieden, wenn ich auch nur bloß das 13.2er wieder am Laufen hätte. Dann könnte ich in Ruhe nebenher ein 42.2 aufsetzen und die Daten umziehen.

Gibt es nicht eine Möglichkeit, die gelöschten Pakete wieder zu installieren?

Danke und Gruß

Sauerland
Guru
Guru
Beiträge: 3210
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von Sauerland » 25. Feb 2017, 22:08

Wenn rpm funktioniert ja.
Gelöschte Pakete stehen in der /var/log/zypp/history, herunterladen und mit rpm hineinprügeln.

PS:
Wer sagt dir eigentlich, das deine Server mit den Konfigurationen nach dem Upgrade auch noch funktionieren, siehe die andere Syntax von z.B. apache Version 2.2 zu 2.4?
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

radiergummi
Newbie
Newbie
Beiträge: 40
Registriert: 14. Feb 2009, 12:34

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von radiergummi » 26. Feb 2017, 09:34

Sauerland hat geschrieben:
25. Feb 2017, 22:08
Wer sagt dir eigentlich, das deine Server mit den Konfigurationen nach dem Upgrade auch noch funktionieren, siehe die andere Syntax von z.B. apache Version 2.2 zu 2.4?
Ei, niemand. Aber ich hätte in dem Fall mehr Zeit, die Kiste in Ruhe aufzubauen.

Deine Tipps haben mir erstmal soweit geholfen, dass ich zumindest zypper wieder am Laufen habe. Prima! Danke!

Code: Alles auswählen

rpm -U ftp://195.220.108.108/linux/opensuse/update/13.2/i586/libsolv-tools-0.6.20-23.1.i586.rpm
rpm -U ftp://195.220.108.108/linux/opensuse/update/13.2/i586/libzypp-14.43.0-41.1.i586.rpm
rpm -U ftp://195.220.108.108/linux/opensuse/update/13.2/i586/zypper-1.11.54-40.2.i586.rpm
Im letzten Schritt des gescheiterten Upgrades hatte ich die Repositories von 13.2 auf Leap/42.1 ändern müssen.
Diese habe ich jetzt mit zypper mr -d deaktiviert.
Anschließend habe ich die 13.2er wieder hinzugefügt:

Code: Alles auswählen

zypper ar http://download.opensuse.org/distribution/13.2/repo/oss/ repo-oss-13.2
zypper ar http://download.opensuse.org/update/13.2/ repo-update-oss-13.2
zypper ar http://download.opensuse.org/distribution/13.2/repo/non-oss/ repo-non-oss-13.2
zypper ar http://download.opensuse.org/update/13.2-non-oss/ repo-update-non-oss-13.2
Ein anschließendes zyper ref bringt folgenden Fehler für das OSS repo:

Code: Alles auswählen

fileserver4:~ # zypper ref
Repository 'repo-non-oss-13.2' ist aktuell.                                                                                                                             
Metadaten von Repository 'repo-oss-13.2' werden abgerufen -----------------------------------------------------------------------------------------------------------[\]

Achtung: Digest verification failed for file 'app-icons.tar.gz'
[/var/cache/zypp/raw/repo-oss-13.2agC93n/suse/setup/descr/app-icons.tar.gz]

  expected ff394b13f277a3c1ee8b0e88f001eaa3153d352c3fd04cb276c4ff3b8e672878
  but got  9a15dfce57d6f06a083e2dee731631f0b15d7a812eeb6b906d20c2568f6cd198

Accepting packages with wrong checksums can lead to a corrupted system and in extreme cases even to a system compromise.

However if you made certain that the file with checksum '9a15..' is secure, correct
and should be used within this operation, enter the first 4 characters of the checksum
to unblock using this file on your own risk. Empty input will discard the file.

Unblock or discard? [9a15/? zeigt alle Optionen] (discard): d
Ungültige Antwort 'd'. [9a15/? zeigt alle Optionen] (discard): 
Metadaten von Repository 'repo-oss-13.2' werden abgerufen ......................................................................................................[Fehler]
Repository 'repo-oss-13.2' ist ungültig.
[repo-oss-13.2|http://download.opensuse.org/distribution/13.2/repo/oss/] Valid metadata not found at specified URL
Bitte überprüfen Sie, ob die für dieses Repository bestimmten URIs auf ein gültiges Repository verweisen.
Repository 'repo-oss-13.2' wird aufgrund des obigen Fehlers übersprungen.
Repository 'repo-update-non-oss-13.2' ist aktuell.                                                                                                                      
Repository 'repo-update-oss-13.2' ist aktuell.                                                                                                                          
Einige der Repositories konnten aufgrund eines Fehlers nicht aktualisiert werden.
fileserver4:~ #
Wie kann ich jetzt weitermachen?

Danke und Gruß

Sauerland
Guru
Guru
Beiträge: 3210
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von Sauerland » 26. Feb 2017, 10:01

Poste:

Code: Alles auswählen

zypper lr -d
Ich füge Repos immer mit der Option -f hinzu = autorefresh.

zypper ar -f ............

Daher poste einmal deine Liste.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

radiergummi
Newbie
Newbie
Beiträge: 40
Registriert: 14. Feb 2009, 12:34

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von radiergummi » 26. Feb 2017, 10:23

Bittesehr ....

Code: Alles auswählen

fileserver4:~ # zypper lr -d
#  | Alias                                     | Name                                        | Aktiviert | GPG-Überprüfung | Aktualisieren | Priorität | Typ    | URI                                                                              | Dienst
---+-------------------------------------------+---------------------------------------------+-----------+-----------------+---------------+-----------+--------+----------------------------------------------------------------------------------+-------
 1 | Aktualisierungen-für-openSUSE-13.2-13.2-0 | Leap-42.1-Update                            | Nein      | ----            | Ja            |   99      | rpm-md | http://download.opensuse.org/update/leap/42.1/oss                                |       
 2 | download.opensuse.org-Extra               | openSUSE BuildService - KDE:Extra           | Nein      | ----            | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.2/              |       
 3 | download.opensuse.org-UpdatedApps         | openSUSE BuildService - KDE:UpdatedApps     | Nein      | ----            | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_13.2/        |       
 4 | home:darix                                | home:darix                                  | Nein      | ----            | Nein          |   99      | rpm-md | http://download.opensuse.org/repositories/home:/darix/openSUSE_13.2/             |       
 5 | home:derselbst                            | home:derselbst                              | Nein      | ----            | Nein          |   99      | rpm-md | http://download.opensuse.org/repositories/home:/derselbst/openSUSE_13.2/         |       
 6 | openSUSE-13.2-13.2-0                      | openSUSE-13.2-13.2-0                        | Nein      | ----            | Nein          |   99      | yast2  | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GH22NS70_K3ZB9293247,/dev/sr0 |       
 7 | openSUSE_13.2_Update                      | Online updates for openSUSE 13.2 (standard) | Nein      | ----            | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/openSUSE:/13.2:/Update/standard/       |       
 8 | openSUSE_Security                         | openSUSE Security                           | Nein      | ----            | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/security/openSUSE_13.2/                |       
 9 | packman.inode.at-suse                     | Packman Repository                          | Nein      | ----            | Ja            |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_13.2/                                      |       
10 | repo-debug                                | openSUSE-13.2-Debug                         | Nein      | ----            | Ja            |   99      | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                   |       
11 | repo-debug-update                         | openSUSE-13.2-Update-Debug                  | Nein      | ----            | Ja            |   99      | NONE   | http://download.opensuse.org/debug/update/13.2/                                  |       
12 | repo-non-oss                              | openSUSE-13.2-Non-Oss                       | Nein      | ----            | Ja            |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                     |       
13 | repo-non-oss-13.2                         | repo-non-oss-13.2                           | Ja        | (r ) Ja         | Nein          |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                     |       
14 | repo-oss                                  | Leap-42.1-OSS                               | Nein      | ----            | Ja            |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                    |       
15 | repo-oss-13.2                             | repo-oss-13.2                               | Ja        | ( p) Ja         | Nein          |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                         |       
16 | repo-source                               | openSUSE-13.2-Source                        | Nein      | ----            | Ja            |   99      | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/                  |       
17 | repo-update-non-oss                       | openSUSE-13.2-Update-Non-Oss                | Nein      | ----            | Ja            |   99      | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                                |       
18 | repo-update-non-oss-13.2                  | repo-update-non-oss-13.2                    | Ja        | (r ) Ja         | Nein          |   99      | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                                |       
19 | repo-update-oss-13.2                      | repo-update-oss-13.2                        | Ja        | (r ) Ja         | Nein          |   99      | rpm-md | http://download.opensuse.org/update/13.2/                                        |       
fileserver4:~ # 
Gruß

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5164
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von tomm.fa » 26. Feb 2017, 10:29

Von Vorteil kann es auch sein, wenn man sich zuvor, also vor einer Aufrüstung (Upgrade), die Versionshinweise der verschiedenen Versionen von openSUSE ansieht.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Sauerland
Guru
Guru
Beiträge: 3210
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von Sauerland » 26. Feb 2017, 11:02

Wie ich oben schon sagte:
ich würde aktualisieren anschalten, löst des öfteren Probleme........

zypper mr ist dein Freund.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

radiergummi
Newbie
Newbie
Beiträge: 40
Registriert: 14. Feb 2009, 12:34

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von radiergummi » 26. Feb 2017, 12:10

Ich habe zypper mr -rk für die vier relevanten Repos ausgeführt.
Zypper ref hat dann noch immer nicht funktioniert.
Der Eintrag in Zeile 15 bei GPG-Überprüfung fiel auf.

Code: Alles auswählen

fileserver4:~ # zypper lr
#  | Alias                                     | Name                                        | Aktiviert | GPG-Überprüfung | Aktualisieren
---+-------------------------------------------+---------------------------------------------+-----------+-----------------+--------------
 1 | Aktualisierungen-für-openSUSE-13.2-13.2-0 | Leap-42.1-Update                            | Nein      | ----            | Ja           
 2 | download.opensuse.org-Extra               | openSUSE BuildService - KDE:Extra           | Nein      | ----            | Ja           
 3 | download.opensuse.org-UpdatedApps         | openSUSE BuildService - KDE:UpdatedApps     | Nein      | ----            | Ja           
 4 | home:darix                                | home:darix                                  | Nein      | ----            | Nein         
 5 | home:derselbst                            | home:derselbst                              | Nein      | ----            | Nein         
 6 | openSUSE-13.2-13.2-0                      | openSUSE-13.2-13.2-0                        | Nein      | ----            | Nein         
 7 | openSUSE_13.2_Update                      | Online updates for openSUSE 13.2 (standard) | Nein      | ----            | Ja           
 8 | openSUSE_Security                         | openSUSE Security                           | Nein      | ----            | Ja           
 9 | packman.inode.at-suse                     | Packman Repository                          | Nein      | ----            | Ja           
10 | repo-debug                                | openSUSE-13.2-Debug                         | Nein      | ----            | Ja           
11 | repo-debug-update                         | openSUSE-13.2-Update-Debug                  | Nein      | ----            | Ja           
12 | repo-non-oss                              | openSUSE-13.2-Non-Oss                       | Nein      | ----            | Ja           
13 | repo-non-oss-13.2                         | repo-non-oss-13.2                           | Ja        | (r ) Ja         | Ja           
14 | repo-oss                                  | Leap-42.1-OSS                               | Nein      | ----            | Ja           
15 | repo-oss-13.2                             | repo-oss-13.2                               | Ja        | ( p) Ja         | Ja           
16 | repo-source                               | openSUSE-13.2-Source                        | Nein      | ----            | Ja           
17 | repo-update-non-oss                       | openSUSE-13.2-Update-Non-Oss                | Nein      | ----            | Ja           
18 | repo-update-non-oss-13.2                  | repo-update-non-oss-13.2                    | Ja        | (r ) Ja         | Ja           
19 | repo-update-oss-13.2                      | repo-update-oss-13.2                        | Ja        | (r ) Ja         | Ja           
fileserver4:~ # zypper ref
Repository 'repo-non-oss-13.2' ist aktuell.                                                                                                                             
Metadaten von Repository 'repo-oss-13.2' werden abgerufen -----------------------------------------------------------------------------------------------------------[|]

Achtung: Digest verification failed for file 'packages.gz'
[/var/cache/zypp/raw/repo-oss-13.2mbZTaM/suse/setup/descr/packages.gz]

  expected 60331108cb93ffe198c899b00998fbf80944a82a43045ea694e1bc0b744a0b7d
  but got  6543d1461fe7fe3477ab7825ff9494de51cf6630031f5a643441626da1270c13

Accepting packages with wrong checksums can lead to a corrupted system and in extreme cases even to a system compromise.

However if you made certain that the file with checksum '6543..' is secure, correct
and should be used within this operation, enter the first 4 characters of the checksum
to unblock using this file on your own risk. Empty input will discard the file.

Unblock or discard? [6543/? zeigt alle Optionen] (discard): 
Metadaten von Repository 'repo-oss-13.2' werden abgerufen ......................................................................................................[Fehler]
Repository 'repo-oss-13.2' ist ungültig.
[repo-oss-13.2|http://download.opensuse.org/distribution/13.2/repo/oss/] Valid metadata not found at specified URL
Bitte überprüfen Sie, ob die für dieses Repository bestimmten URIs auf ein gültiges Repository verweisen.
Repository 'repo-oss-13.2' wird aufgrund des obigen Fehlers übersprungen.
Repository 'repo-update-non-oss-13.2' ist aktuell.                                                                                                                      
Repository 'repo-update-oss-13.2' ist aktuell.                                                                                                                          
Einige der Repositories konnten aufgrund eines Fehlers nicht aktualisiert werden.

Ich habe dann kurzerhand die 4 Repos gelöscht und mit

Code: Alles auswählen

zypper ar -f http://download.opensuse.org/distribution/13.2/repo/oss/ repo-oss-13.2
zypper ar -f http://download.opensuse.org/update/13.2/ repo-update-oss-13.2
zypper ar -f http://download.opensuse.org/distribution/13.2/repo/non-oss/ repo-non-oss-13.2
zypper ar -f http://download.opensuse.org/update/13.2-non-oss/ repo-update-non-oss-13.2
wieder hinzugefügt.

zypper lr sah dann gleichmässiger aus aber zypper ref lief noch immer nicht durch.

Code: Alles auswählen

fileserver4:~ # zypper lr
#  | Alias                                     | Name                                        | Aktiviert | GPG-Überprüfung | Aktualisieren
---+-------------------------------------------+---------------------------------------------+-----------+-----------------+--------------
 1 | Aktualisierungen-für-openSUSE-13.2-13.2-0 | Leap-42.1-Update                            | Nein      | ----            | Ja           
 2 | download.opensuse.org-Extra               | openSUSE BuildService - KDE:Extra           | Nein      | ----            | Ja           
 3 | download.opensuse.org-UpdatedApps         | openSUSE BuildService - KDE:UpdatedApps     | Nein      | ----            | Ja           
 4 | home:darix                                | home:darix                                  | Nein      | ----            | Nein         
 5 | home:derselbst                            | home:derselbst                              | Nein      | ----            | Nein         
 6 | openSUSE-13.2-13.2-0                      | openSUSE-13.2-13.2-0                        | Nein      | ----            | Nein         
 7 | openSUSE_13.2_Update                      | Online updates for openSUSE 13.2 (standard) | Nein      | ----            | Ja           
 8 | openSUSE_Security                         | openSUSE Security                           | Nein      | ----            | Ja           
 9 | packman.inode.at-suse                     | Packman Repository                          | Nein      | ----            | Ja           
10 | repo-debug                                | openSUSE-13.2-Debug                         | Nein      | ----            | Ja           
11 | repo-debug-update                         | openSUSE-13.2-Update-Debug                  | Nein      | ----            | Ja           
12 | repo-non-oss                              | openSUSE-13.2-Non-Oss                       | Nein      | ----            | Ja           
13 | repo-non-oss-13.2                         | repo-non-oss-13.2                           | Ja        | ( p) Ja         | Ja           
14 | repo-oss                                  | Leap-42.1-OSS                               | Nein      | ----            | Ja           
15 | repo-oss-13.2                             | repo-oss-13.2                               | Ja        | ( p) Ja         | Ja           
16 | repo-source                               | openSUSE-13.2-Source                        | Nein      | ----            | Ja           
17 | repo-update-non-oss                       | openSUSE-13.2-Update-Non-Oss                | Nein      | ----            | Ja           
18 | repo-update-non-oss-13.2                  | repo-update-non-oss-13.2                    | Ja        | ( p) Ja         | Ja           
19 | repo-update-oss-13.2                      | repo-update-oss-13.2                        | Ja        | ( p) Ja         | Ja           
fileserver4:~ # zypper ref
Metadaten von Repository 'repo-non-oss-13.2' werden abgerufen ..................................................................................................[fertig]
Zwischenspeicher für Repository 'repo-non-oss-13.2' wird erzeugt ...............................................................................................[fertig]
Metadaten von Repository 'repo-oss-13.2' werden abgerufen -----------------------------------------------------------------------------------------------------------[-]

Achtung: Digest verification failed for file 'app-icons.tar.gz'
[/var/cache/zypp/raw/repo-oss-13.2pte9fC/suse/setup/descr/app-icons.tar.gz]

  expected ff394b13f277a3c1ee8b0e88f001eaa3153d352c3fd04cb276c4ff3b8e672878
  but got  9a15dfce57d6f06a083e2dee731631f0b15d7a812eeb6b906d20c2568f6cd198

Accepting packages with wrong checksums can lead to a corrupted system and in extreme cases even to a system compromise.

However if you made certain that the file with checksum '9a15..' is secure, correct
and should be used within this operation, enter the first 4 characters of the checksum
to unblock using this file on your own risk. Empty input will discard the file.

Unblock or discard? [9a15/? zeigt alle Optionen] (discard): 
Metadaten von Repository 'repo-oss-13.2' werden abgerufen ......................................................................................................[Fehler]
Repository 'repo-oss-13.2' ist ungültig.
[repo-oss-13.2|http://download.opensuse.org/distribution/13.2/repo/oss/] Valid metadata not found at specified URL
Bitte überprüfen Sie, ob die für dieses Repository bestimmten URIs auf ein gültiges Repository verweisen.
Repository 'repo-oss-13.2' wird aufgrund des obigen Fehlers übersprungen.
Metadaten von Repository 'repo-update-non-oss-13.2' werden abgerufen ...........................................................................................[fertig]
Zwischenspeicher für Repository 'repo-update-non-oss-13.2' wird erzeugt ........................................................................................[fertig]
Metadaten von Repository 'repo-update-oss-13.2' werden abgerufen ...............................................................................................[fertig]
Zwischenspeicher für Repository 'repo-update-oss-13.2' wird erzeugt ............................................................................................[fertig]
Einige der Repositories konnten aufgrund eines Fehlers nicht aktualisiert werden.
Habe ich überhaupt das gemacht, was Du meintest?

Gruß

Sauerland
Guru
Guru
Beiträge: 3210
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von Sauerland » 26. Feb 2017, 12:20

Mach ein :

Code: Alles auswählen

zypper clean -a && zypper ref && zypper dup
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

radiergummi
Newbie
Newbie
Beiträge: 40
Registriert: 14. Feb 2009, 12:34

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von radiergummi » 26. Feb 2017, 17:52

Prima, das hat anscheinend funktioniert.
Das Zurückstufen von ein paar Paketen kann ich noch nicht einschätzen...

Hier kommen mal die Ausgaben:

Code: Alles auswählen

fileserver4:~ # zypper clean -a
Alle Repositories wurden bereinigt.
fileserver4:~ # zypper ref
Metadaten von Repository 'repo-non-oss-13.2' werden abgerufen ..................................................................................................[fertig]
Zwischenspeicher für Repository 'repo-non-oss-13.2' wird erzeugt ...............................................................................................[fertig]
Metadaten von Repository 'repo-oss-13.2' werden abgerufen ......................................................................................................[fertig]
Zwischenspeicher für Repository 'repo-oss-13.2' wird erzeugt ...................................................................................................[fertig]
Metadaten von Repository 'repo-update-non-oss-13.2' werden abgerufen ...........................................................................................[fertig]
Zwischenspeicher für Repository 'repo-update-non-oss-13.2' wird erzeugt ........................................................................................[fertig]
Metadaten von Repository 'repo-update-oss-13.2' werden abgerufen ...............................................................................................[fertig]
Zwischenspeicher für Repository 'repo-update-oss-13.2' wird erzeugt ............................................................................................[fertig]
Alle Repositories wurden aktualisiert.
fileserver4:~ # zypper dup
Achtung: Sie wollen eine Distributionsaktualisierung mit allen aktivierten Repositories durchführen. Bevor Sie weitermachen, sollten Sie sicherstellen, das diese Repositories kompatibel sind. Siehe 'man zypper' zu weiteren Informationen zu diesem Befehl.
Daten des Repositories laden ...
Installierte Pakete lesen ...
Distributionsaktualisierung berechnen ...

Die folgenden 135 NEUEN Pakete werden installiert:
  amarok autoyast2-installation baloo-file baloo-kioslaves baloo-pim baloo-tools bluedevil bluedevil-lang btrfsmaintenance choqok command-not-found k3b kaffeine
  kcharselect kdeartwork4-screensaver kdebase4-libkonq kdebase4-runtime kdebase4-runtime-branding-openSUSE kdebase4-workspace-libs kdelibs4 kdelibs4-branding-openSUSE
  kdelibs4-core kdepim4-runtime kdepimlibs4 kdialog kdnssd kfilemetadata kget kio_audiocd kmag kmahjongg kmines kmix kmousetool kompare konqueror-plugins konversation
  konversation-lang kopete kpat krdc kreversi krfb kscd ksudoku ktorrent libakonadi4 libbaloofiles4 libkcddb4 libkcompactdisc4 libkde4 libkdegames6 libkdepimlibs4
  libkexiv2-11 libkfbapi1 libkgapi2-2 libkmahjongg libkmahjongglib4 libkolab0 libkomparediff2-4 libkonq5 libkscreen libksuseinstall1 libktorrent5
  libreoffice-branding-upstream libreoffice-kde4 libyui-ncurses-pkg6 libyui-qt-pkg6 mobipocket NetworkManager-openvpn NetworkManager-pptp NetworkManager-vpnc PackageKit
  PackageKit-backend-zypp PackageKit-branding-openSUSE patterns-openSUSE-sw_management patterns-openSUSE-x11_yast patterns-openSUSE-yast2_basis plasma-nm plasma-nm-lang
  plasma-nm-openvpn plasma-nm-pptp plasma-nm-vpnc python-solv scout snapper-zypp-plugin sweeper yast2 yast2-add-on yast2-apparmor yast2-bootloader yast2-control-center
  yast2-control-center-qt yast2-country yast2-firewall yast2-ftp-server yast2-http-server yast2-inetd yast2-installation yast2-instserver yast2-iscsi-client yast2-ldap
  yast2-mail yast2-metapackage-handler yast2-network yast2-nfs-client yast2-nfs-server yast2-nis-client yast2-nis-server yast2-ntp-client yast2-online-update
  yast2-online-update-frontend yast2-packager yast2-pam yast2-pkg-bindings yast2-printer yast2-proxy yast2-samba-client yast2-samba-server yast2-scanner yast2-security
  yast2-services-manager yast2-slp yast2-slp-server yast2-snapper yast2-sound yast2-storage yast2-sudo yast2-sysconfig yast2-tftp-server yast2-tune yast2-update
  yast2-users yast2-vm zypper-aptitude

Die folgenden 3 NEUEN Schemata werden installiert:
  sw_management x11_yast yast2_basis

Die folgenden 122 Pakete werden GELÖSCHT:
  boost-license1_53_0 cryptsetup-mkinitrd fam gtk3-theming-engine-adwaita libao-plugin4-esd libass4 libbluedevil1 libboost_date_time1_53_0 libboost_filesystem1_53_0
  libboost_program_options1_53_0 libboost_regex1_53_0 libboost_signals1_53_0 libboost_system1_53_0 libboost_thread1_53_0 libcamel-1_2-45 libcdr-0_0-0 libcloog0
  libcmis-0_3-3 libdirectfb-1_6-0 libechonest2_1 libexiv2-12 libgcrypt11 libgdata13 libGLEW1_9 libgps20 libHalf10 libicu51_2 libicu51_2-data libIex-2_0-10
  libIlmImf-Imf_2_0-20 libIlmThread-2_0-10 libixion-0_6-0 libjson0 libkolabxml0 liblept3 libMagickCore-6_Q16-1 libMagickWand-6_Q16-1 libmarblewidget16 libmspub-0_0-0
  libmwaw-0_1-1 libnl1 libntfs-3g84 libodfgen-0_0-0 libopenobex1 liborcus-0_6-0 libpackagekit-glib2-16 libpackagekit-qt2-6 libplist1 libpoppler43 libppl9 libppl_c4
  libprocps1 libpyglib-gi-2_0-python2-0 libreoffice-branding-openSUSE libreoffice-converter libSDL_gfx13 libstlport_gcc4 libudev0 libupower-glib1 libvigraimpex4
  libvisio-0_0-0 libwebp4 libwpd-0_9-9 libwpg-0_2-2 libwps-0_2-2 libxatracker1 libxcb-sync0 libxkbcommon0 libyui5 libyui-ncurses5 libyui-qt5 m2300w nagios-plugins
  nagios-plugins-bgpstate nagios-plugins-breeze nagios-plugins-by_ssh nagios-plugins-cluster nagios-plugins-common nagios-plugins-dhcp nagios-plugins-dig
  nagios-plugins-disk nagios-plugins-disk_smb nagios-plugins-dns nagios-plugins-dummy nagios-plugins-file_age nagios-plugins-flexlm nagios-plugins-http
  nagios-plugins-icmp nagios-plugins-ide_smart nagios-plugins-ifoperstatus nagios-plugins-ifstatus nagios-plugins-ircd nagios-plugins-linux_raid nagios-plugins-load
  nagios-plugins-log nagios-plugins-mailq nagios-plugins-mrtg nagios-plugins-mrtgtraf nagios-plugins-netapp nagios-plugins-nt nagios-plugins-ntp_peer
  nagios-plugins-ntp_time nagios-plugins-nwstat nagios-plugins-oracle nagios-plugins-overcr nagios-plugins-ping nagios-plugins-procs nagios-plugins-real
  nagios-plugins-rpc nagios-plugins-sensors nagios-plugins-smtp nagios-plugins-ssh nagios-plugins-swap nagios-plugins-tcp nagios-plugins-time nagios-plugins-ups
  nagios-plugins-users nagios-plugins-wave opensuse-startup_en python-satsolver ruby20 tightvnc

Die folgenden 2 Pakete werden aktualisiert:
  libsolv-tools libzypp

Die folgenden 11 Pakete werden durch eine ältere Version ausgetauscht:
  arpwatch arpwatch-ethercodes clamav fipscheck keyutils libcap-ng0 libfipscheck1 libkeyutils1 liboauth0 libseccomp2 zypper-log

Die folgenden 10 Pakete werden den Anbieter ändern:
  arpwatch             obs://build.opensuse.org/security -> openSUSE
  arpwatch-ethercodes  obs://build.opensuse.org/security -> openSUSE
  clamav               obs://build.opensuse.org/security -> openSUSE
  fipscheck            obs://build.opensuse.org/security -> openSUSE
  keyutils             obs://build.opensuse.org/security -> openSUSE
  libcap-ng0           obs://build.opensuse.org/security -> openSUSE
  libfipscheck1        obs://build.opensuse.org/security -> openSUSE
  libkeyutils1         obs://build.opensuse.org/security -> openSUSE
  liboauth0            obs://build.opensuse.org/security -> openSUSE
  libseccomp2          obs://build.opensuse.org/security -> openSUSE


2 Pakete werden aktualisiert, 11 werden zurückgestuft, 135 neue, 122 zu entfernen, 10  Anbieterwechsel.
Gesamtgröße des Downloads: 84,4 MiB. Bereits zwischengespeichert: 0 B  Nach der Operation werden zusätzlich 130,2 MiB belegt.
Fortfahren? [j/n/? zeigt alle Optionen] (j): 
hier habe ich nur <Return> gedrückt ...

Code: Alles auswählen

...
...
(255/269) Installation von: kio_audiocd-14.12.3-16.1 ...........................................................................................................[fertig]
(256/269) Installation von: konversation-lang-1.5.1-3.4.1 ......................................................................................................[fertig]
(257/269) Installation von: kget-14.12.3-16.1 ..................................................................................................................[fertig]
(258/269) Installation von: kdeartwork4-screensaver-14.12.3-16.11 ..............................................................................................[fertig]
(259/269) Installation von: konqueror-plugins-15.04.1-20.6 .....................................................................................................[fertig]
(260/269) Installation von: bluedevil-lang-2.1.1-2.5.1 .........................................................................................................[fertig]
(261/269) Installation von: choqok-1.4-5.1.5 ...................................................................................................................[fertig]
(262/269) Installation von: NetworkManager-vpnc-0.9.10.0-2.1.4 .................................................................................................[fertig]
(263/269) Installation von: NetworkManager-pptp-0.9.10.0-2.2.2 .................................................................................................[fertig]
(264/269) Installation von: NetworkManager-openvpn-0.9.10.0-2.1.4 ..............................................................................................[fertig]
(265/269) Installation von: k3b-2.0.2-33.1.8 ...................................................................................................................[fertig]
(266/269) Installation von: ktorrent-4.3.1-8.1.9 ...............................................................................................................[fertig]
(267/269) Installation von: plasma-nm-vpnc-0.9.3.5-2.3.1 .......................................................................................................[fertig]
(268/269) Installation von: plasma-nm-pptp-0.9.3.5-2.3.1 .......................................................................................................[fertig]
(269/269) Installation von: plasma-nm-openvpn-0.9.3.5-2.3.1 ....................................................................................................[fertig]

Hier ist er jetzt stehen geblieben und macht gar nichts mehr.

Die Prozesse machen nix...

Code: Alles auswählen

fileserver4:~ # ps -all
F S   UID   PID  PPID  C PRI  NI ADDR SZ WCHAN  TTY          TIME CMD
0 S     0 12093  2060  1  80   0 - 34391 pipe_w pts/1    00:00:31 zypper
0 S     0 12819 12093  0  80   0 -   827 wait   pts/1    00:00:00 lsof
1 D     0 12820 12819  0  80   0 -   827 rpc_wa pts/1    00:00:00 lsof
0 R     0 13126  3055  0  80   0 -  1456 -      pts/2    00:00:00 ps
fileserver4:~ # 

Code: Alles auswählen

top - 17:50:40 up 19:41,  4 users,  load average: 1,00, 1,01, 0,91
Tasks:   3 total,   0 running,   3 sleeping,   0 stopped,   0 zombie
%Cpu(s):  0,0 us,  0,1 sy,  0,0 ni, 99,9 id,  0,0 wa,  0,0 hi,  0,0 si,  0,0 st
KiB Mem:   8261332 total,  7654032 used,   607300 free,   126360 buffers
KiB Swap:  8384496 total,      292 used,  8384204 free.  6708188 cached Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                        
12093 root      20   0  137564  79596  21252 S 0,000 0,963   0:31.06 zypper                                                         
12819 root      20   0    3308   1932   1812 S 0,000 0,023   0:00.00 lsof                                                           
12820 root      20   0    3308    148      0 D 0,000 0,002   0:00.00 lsof                                                           

Kann/soll ich die drei beenden?

Gruß

EDIT:
die letzten Zeilen aus der history:
17:19 ist eine halbe Stunde her.

Code: Alles auswählen

fileserver4:~ # tail /var/log/zypp/history
2017-02-26 17:19:18|install|bluedevil-lang|2.1.1-2.5.1|noarch||repo-update-oss-13.2|c80feea3ed3fcfd04eb4d95cf3d775024951cacc4a342e57cf676f80ae633547|
2017-02-26 17:19:19|install|choqok|1.4-5.1.5|i586||repo-oss-13.2|c1cbc2879bc803098699c6c5861a3f67272c8a0e|
2017-02-26 17:19:20|install|NetworkManager-vpnc|0.9.10.0-2.1.4|i586||repo-oss-13.2|b3c800c816546705cd2fd8ccc5c69103151ca93d|
2017-02-26 17:19:20|install|NetworkManager-pptp|0.9.10.0-2.2.2|i586||repo-oss-13.2|bd9f7aca2de2393cfd936035307ce2303f825546|
2017-02-26 17:19:20|install|NetworkManager-openvpn|0.9.10.0-2.1.4|i586||repo-oss-13.2|031a59dc47e54fb8a64281b7902e7706998e6415|
2017-02-26 17:19:22|install|k3b|2.0.2-33.1.8|i586||repo-oss-13.2|977e85bd2c883122c23529736579d58aa40f9a56|
2017-02-26 17:19:23|install|ktorrent|4.3.1-8.1.9|i586||repo-oss-13.2|205ee1a14b3285c2db630774cbbf479110424570|
2017-02-26 17:19:23|install|plasma-nm-vpnc|0.9.3.5-2.3.1|i586||repo-update-oss-13.2|9805182f6dbd59da72e046b12991556e4620f9595e41dc5cbe30f37310280451|
2017-02-26 17:19:23|install|plasma-nm-pptp|0.9.3.5-2.3.1|i586||repo-update-oss-13.2|2df21b8b8c80eba6d614e22d5c32afcce64b0433ab8ff392a5af030e01b79f91|
2017-02-26 17:19:23|install|plasma-nm-openvpn|0.9.3.5-2.3.1|i586||repo-update-oss-13.2|c569bf7ddb395c3dc16eb20f678bcc081a98433d84bd5557daaf38e0a3d9b772|

Sauerland
Guru
Guru
Beiträge: 3210
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von Sauerland » 26. Feb 2017, 18:12

Keine Ahnung, ich mache immer eine Neuinstallation unter Beibehaltung des /home.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5099
Registriert: 23. Sep 2008, 17:09

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von josef-wien » 26. Feb 2017, 18:25

Es sieht so aus, als ob zypper alle 269 Pakete installiert bzw. aktualisiert und sich danach "aufgehängt" hat. Ich würde zypper "abschiessen", danach noch einmal zypper dup ausführen und anschließend den Rechner neu starten.

Im übrigen solltest Du darüber nachdenken, Dein System regelmäßig zu sichern (oder wenigstens auf btrfs samt snapper umzustellen).

radiergummi
Newbie
Newbie
Beiträge: 40
Registriert: 14. Feb 2009, 12:34

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von radiergummi » 26. Feb 2017, 18:38

Sauerland hat geschrieben:
26. Feb 2017, 18:12
Keine Ahnung, ich mache immer eine Neuinstallation unter Beibehaltung des /home.
Äh, wie meinen?

Sauerland
Guru
Guru
Beiträge: 3210
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von Sauerland » 26. Feb 2017, 18:48

Äh, wie meinen?
Ganz einfach:
Ich benutze

Code: Alles auswählen

zypper dup
nur 1 mal, und das direkt nach einer Installation um auf das Packman Repo umzustellen.

Ich mache nie mit

Code: Alles auswählen

zypper dup
ein Upgrade zu einem neuen openSUSE Release, ich installiere immer neu, formatiere / und binde die /home immer ohne Neuformatierung ein.
So bleiben alle meine Daten auch in dem neuen openSUSE Release vorhanden. Danach muss ich natürlich meine Server wieder einrichten, dafür nehme ich mir dann Zeit. Die configs hab ich natürlich vorher mit einem Backup weggesichert........
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

radiergummi
Newbie
Newbie
Beiträge: 40
Registriert: 14. Feb 2009, 12:34

Re: OpenSuse 13.2 Upgrade (zypper) gescheitert

Beitrag von radiergummi » 26. Feb 2017, 18:49

josef-wien hat geschrieben:
26. Feb 2017, 18:25
Ich würde zypper "abschiessen", danach noch einmal zypper dup ausführen und anschließend den Rechner neu starten.
Ersteres habe ich bereits gemacht. Auf die Idee, zypper dup erneut auszuführen, kam ich noch nicht.

Hier das Ergebnis:

Code: Alles auswählen

fileserver4:~ # zypper dup
Achtung: Sie wollen eine Distributionsaktualisierung mit allen aktivierten Repositories durchführen. Bevor Sie weitermachen, sollten Sie sicherstellen, das diese Repositories kompatibel sind. Siehe 'man zypper' zu weiteren Informationen zu diesem Befehl.
Daten des Repositories laden ...
Installierte Pakete lesen ...
Distributionsaktualisierung berechnen ...

Keine auszuführenden Aktionen.
Das war also okay. Jetzt wird gebootet!
josef-wien hat geschrieben:
26. Feb 2017, 18:25
... Dein System regelmäßig zu sichern (oder wenigstens auf btrfs samt snapper umzustellen).
Eine Daten-Sicherung läuft jede Nacht mit rsync. Eine System-Sicherung mache ich nur insofern, als ich die von mir bearbeiteten Konfigurationsdateien auch täglich separat wegschreibe. Die Idee dahinter ist, dass ich nur das sichere, was ich nicht durch Installation wiederherstellen kann.
Mit btrfs und snapper habe ich mich noch nicht auseinandergesetzt.
Danke und Gruß

Antworten