Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Nach Upgrade 42.1 - 42.2 kein W7 Eintrag mehr im Bootmenu

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
johnny_lux
Newbie
Newbie
Beiträge: 30
Registriert: 20. Sep 2005, 09:51

[gelöst] Nach Upgrade 42.1 - 42.2 kein W7 Eintrag mehr im Bootmenu

Beitrag von johnny_lux » 20. Jan 2017, 09:42

Moin
Ausgangslage war 64bit Dualbootsystem Leap 42.1 und W7, alles ok.
Nach Upgrade auf 42.2 fehlte der W7 Eintrag im Grub.
Nach langem Stöbern sowohl hier, und auch im Netz, bin ich echt ratlos vom ganzen EFI und Legacy.
Eigentlich möchte ich nur den Booteintrag vom Windows wieder im Grub-Menu.
Kann ich die vorhandenen Betriebssysteme nicht neu abfragen und diesen Status neu im Grub abspeichern ?
Im Ordner /boot/efi/EFI wird ja auch der Ordner Windows angezeigt.
Ich habe auch im Yast versucht den Bootloader neu zu schreiben. Windows taucht nicht auf. Dann ein Versuch NICHT mit Grub-EFI, sondern nur Grub - auch nix. Einzige Änderung war ein anderes Erscheinungsbild des Grub: schlichtes schwarz.
Kann es sein, dass der EFi-Eintrag vom W7 nicht erkannt wird, ich also im Legacy mode bin und ich durch das Herumprobieren mir alles "zerschossen" habe ??
Gruß an die Helfenden
Zuletzt geändert von johnny_lux am 20. Jan 2017, 16:36, insgesamt 1-mal geändert.

Werbung:
Sauerland
Guru
Guru
Beiträge: 3113
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Nach Upgrade 42.1 - 42.2 kein W7 Eintrag mehr im Bootmenu

Beitrag von Sauerland » 20. Jan 2017, 10:17

Ist in Yast----System---Bootloader---Bootloader Optionen ein Haken bei "fremde OS testen"?
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1818
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: Nach Upgrade 42.1 - 42.2 kein W7 Eintrag mehr im Bootmenu

Beitrag von gehrke » 20. Jan 2017, 10:19

Bitte poste den Output der folgenden Befehle (inklusive der Befehle) einzeln in Code-Tags formatiert (Anmeldung als root-User):

Code: Alles auswählen

efibootmgr -v
lsblk
fdisk -l
ls -l /boot
ls -l /boot/efi
ls -l /boot/grub2/grub.cfg
cat /boot/grub2/grub.cfg
grub2-mkconfig
cat /etc/default/grub
uname -a
TNX

Wie hast Du das Upgrade durchgeführt?

johnny_lux
Newbie
Newbie
Beiträge: 30
Registriert: 20. Sep 2005, 09:51

Re: [gelöst] Nach Upgrade 42.1 - 42.2 kein W7 Eintrag mehr im Bootmenu

Beitrag von johnny_lux » 20. Jan 2017, 17:01

Hallo nochmals
Problem behoben. Habe zwecks Test mal im Setup die Legacy Bootquellen deaktiviert. Nach Neustart kam die Meldung " bootmgr is missed, please press strg, alt, entf". Also die Legacy Bootquellen wieder aktiviert, aber keine Laufwerke wurden angezeigt !? Gleiches bei den EFI-Quellen. Daraufhin stellte ich die Standardwerkseinstellungen im Setup her, alles gespeichert und Neustart. Nun kam wieder Grub und ich konnte Leap booten. Im Yast habe ich daraufhin den Bootloader neu geschrieben. Unter Bootcode Optionen Secure Boot aktiviert, Grub-Efi gewählt und Flag für geschützten MBR auf nicht ändern.Unter Kernel Parameter noch das Konsolen-Thema "theme.txt"gewählt, weil hier kein Eintrag war.Unter Bootloader-Optionen nach anderen Betriebssystemen suchen aktiviert. Diese Einstellungen habe ich von einem ähnlich installierten Rechner übernommen.
Und nach Neustart wurde alles wie gewünscht im Grub-Menu angezeigt und es ging !

Ach ja : das Upgrade wurde von DVD aus durchgeführt. Wie dieser Eintrag abhanden gekommen ist, kann ich nicht nachvollziehen. Die Einstellungen im Yast waren vor dem Upgrade genauso wie ich sie nun wieder hergestellt habe.
Trotzdem vielen Dank an die Moderatoren, Guru´s ...

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste