Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] update 42.1-64 nvidia Problem

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

[gelöst] update 42.1-64 nvidia Problem

Beitrag von wschmock » 16. Nov 2016, 13:40

es gibt heute 16.11.2016 schon wieder ein Problem mit dem update (zypper up) und nvidia-kernel. es startet keine grafische Oberfläche mehr. der Bildschirm bleibt schwarz. im Textmodus kann ich in Xorg.0.log sehen, dass der nvidia-Treiber gefunden wird aber failed to initialize. mit Yast->Software update wird der nvidia-kernel nicht installiert und einige andere updates auch nicht. warum macht man updates die nicht funktionieren ?

Werbung:
Sauerland
Guru
Guru
Beiträge: 3466
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: update 42.1-64 nvidia Problem

Beitrag von Sauerland » 16. Nov 2016, 17:20

Dann poste doch einfach einmal als root:

Code: Alles auswählen

zypper up
sowie:

Code: Alles auswählen

zypper se -si kernel nvidia
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update 42.1-64 nvidia Problem

Beitrag von wschmock » 17. Nov 2016, 09:00

13.2-64 Yast->Software update: keine updates

Code: Alles auswählen

kxx:~ # zypper up
Daten des Repositories laden ...
Installierte Pakete lesen ...

Die folgenden 30 Paketaktualisierungen werden NICHT installiert:
  amarok fdupes gstreamer gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-plugins-base gstreamer-plugins-good k3b libdvdread4 libgstallocators-1_0-0 libgstapp-0_10-0
  libgstapp-1_0-0 libgstaudio-1_0-0 libgstfft-1_0-0 libgstinterfaces-0_10-0 libgstpbutils-1_0-0 libgstreamer-0_10-0 libgstreamer-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0
  libgstrtsp-1_0-0 libgstsdp-1_0-0 libgsttag-1_0-0 libgstvideo-1_0-0 libmjpegutils-2_0-0 libquicktime0 libxine2 libxine2-pulse mjpegtools sox

Das folgende NEUE Paket wird installiert:
  libfdk-aac1

Die folgenden 35 Pakete werden aktualisiert:
  gambas3-gb-pdf gambas3-runtime libavcodec52 libavcodec56 libavcodec57 libavfilter1 libavfilter6 libavformat52 libavformat56 libavformat57 libavresample3 libavutil50
  libavutil54 libavutil55 libopencv3_1 libpostproc53 libpostproc54 libswresample1 libswresample2 libswscale0 libswscale3 libswscale4 libvlc5 libvlccore8 libXNVCtrl
  nvidia-computeG03 nvidia-gfxG03-kmp-desktop nvidia-glG03 nvidia-uvm-gfxG03-kmp-desktop vlc vlc-codecs vlc-noX vlc-noX-lang vlc-qt x11-video-nvidiaG03

35 Pakete werden aktualisiert, 1 neu.
Gesamtgröße des Downloads: 97,0 MiB. Bereits zwischengespeichert: 0 B  Nach der Operation werden zusätzlich 764,9 KiB belegt.
Fortfahren? [j/n/? zeigt alle Optionen] (j): n

Code: Alles auswählen

kxx:~ # zypper se -si kernel nvidia
Daten des Repositories laden ...
Installierte Pakete lesen ...

S | Name                          | Typ   | Version               | Arch   | Repository                     
--+-------------------------------+-------+-----------------------+--------+--------------------------------
i | kernel-default-devel          | Paket | 3.16.7-48.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-default-devel          | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-desktop                | Paket | 3.16.7-48.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-desktop                | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-desktop-devel          | Paket | 3.16.7-48.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-desktop-devel          | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-devel                  | Paket | 3.16.7-48.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-devel                  | Paket | 3.16.7-42.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-docs                   | Paket | 3.16.7-48.2           | noarch | Hauptaktualisierungs-Repository
i | kernel-macros                 | Paket | 3.16.7-48.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-source                 | Paket | 3.16.7-48.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-source                 | Paket | 3.16.7-42.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-syms                   | Paket | 3.16.7-48.1           | x86_64 | Hauptaktualisierungs-Repository                                                                  
i | kernel-syms                   | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository                                                                  
i | kernel-xen-devel              | Paket | 3.16.7-48.1           | x86_64 | Hauptaktualisierungs-Repository                                                                  
i | kernel-xen-devel              | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository                                                                  
i | nfs-kernel-server             | Paket | 1.3.0-4.4.1           | x86_64 | Hauptaktualisierungs-Repository                                                                  
i | nvidia-computeG03             | Paket | 340.98-44.1           | x86_64 | (Systempakete)                                                                                   
i | nvidia-gfxG03-kmp-desktop     | Paket | 340.98_k3.16.6_2-44.1 | x86_64 | (Systempakete)                                                                                   
i | nvidia-glG03                  | Paket | 340.98-44.1           | x86_64 | (Systempakete)                                                                                   
i | nvidia-uvm-gfxG03-kmp-desktop | Paket | 340.98_k3.16.6_2-44.1 | x86_64 | (Systempakete)                                                                                   
i | x11-video-nvidiaG03           | Paket | 340.98-44.1           | x86_64 | (Systempakete)                                                                                   
kxx:~ #
42.1-64 Textmodus zypper up:

Code: Alles auswählen

Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

The following 51 package updates will NOT be installed:
  amarok amarok-lang fdupes gstreamer gstreamer-0_10 gstreamer-0_10-lang gstreamer-0_10-plugin-esd gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-lang gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang gstreamer-lang gstreamer-plugins-base gstreamer-plugins-base-lang gstreamer-plugins-good gstreamer-plugins-good-lang gstreamer-plugins-libav libavcodec56 libavdevice56 libavfilter5 libavformat56 libavresample2 libavutil54 libbzrtp0 libgstallocators-1_0-0 libgstapp-0_10-0 libgstapp-1_0-0 libgstaudio-1_0-0 libgstfft-1_0-0 libgstinterfaces-0_10-0 libgstmpegts-1_0-0 libgstpbutils-1_0-0 libgstphotography-1_0-0 libgstreamer-0_10-0 libgstreamer-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0 libgsttag-1_0-0 libgstvideo-1_0-0 libmjpegutils-2_0-0 libpostproc53 libquicktime0 libsox3 libswresample1 libswscale3 libxine2 libxine2-pulse mjpegtools sox

Keine auszuführenden Aktionen.
zypper se -si kernel nvidia:

Code: Alles auswählen

Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name                          | Typ     | Version               | Architektur | Repository                     
--+-------------------------------+---------+-----------------------+-------------+--------------------------------
i | kernel-default                | package | 4.1.34-33.1           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-default                | package | 4.1.34-33.1           | x86_64      | openSUSE-Leap-42.1-Update      
i | kernel-default                | package | 4.1.31-30.2           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-default                | package | 4.1.31-30.2           | x86_64      | openSUSE-Leap-42.1-Update      
i | kernel-default-devel          | package | 4.1.34-33.1           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-default-devel          | package | 4.1.34-33.1           | x86_64      | openSUSE-Leap-42.1-Update      
i | kernel-default-devel          | package | 4.1.31-30.2           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-default-devel          | package | 4.1.31-30.2           | x86_64      | openSUSE-Leap-42.1-Update      
i | kernel-devel                  | package | 4.1.34-33.1           | noarch      | Hauptaktualisierungs-Repository
i | kernel-devel                  | package | 4.1.34-33.1           | noarch      | openSUSE-Leap-42.1-Update      
i | kernel-devel                  | package | 4.1.31-30.1           | noarch      | Hauptaktualisierungs-Repository
i | kernel-devel                  | package | 4.1.31-30.1           | noarch      | openSUSE-Leap-42.1-Update      
i | kernel-firmware               | package | 20160503-3.1          | noarch      | Hauptaktualisierungs-Repository
i | kernel-firmware               | package | 20160503-3.1          | noarch      | openSUSE-Leap-42.1-Update      
i | kernel-macros                 | package | 4.1.34-33.1           | noarch      | Hauptaktualisierungs-Repository
i | kernel-macros                 | package | 4.1.34-33.1           | noarch      | openSUSE-Leap-42.1-Update      
i | kernel-pv-devel               | package | 4.1.34-33.1           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-pv-devel               | package | 4.1.34-33.1           | x86_64      | openSUSE-Leap-42.1-Update      
i | kernel-pv-devel               | package | 4.1.31-30.2           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-pv-devel               | package | 4.1.31-30.2           | x86_64      | openSUSE-Leap-42.1-Update      
i | kernel-source                 | package | 4.1.34-33.1           | noarch      | Hauptaktualisierungs-Repository
i | kernel-source                 | package | 4.1.34-33.1           | noarch      | openSUSE-Leap-42.1-Update      
i | kernel-source                 | package | 4.1.31-30.1           | noarch      | Hauptaktualisierungs-Repository
i | kernel-source                 | package | 4.1.31-30.1           | noarch      | openSUSE-Leap-42.1-Update      
i | kernel-syms                   | package | 4.1.34-33.1           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-syms                   | package | 4.1.34-33.1           | x86_64      | openSUSE-Leap-42.1-Update      
i | kernel-syms                   | package | 4.1.31-30.1           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-syms                   | package | 4.1.31-30.1           | x86_64      | openSUSE-Leap-42.1-Update      
i | kernel-xen-devel              | package | 4.1.34-33.1           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-xen-devel              | package | 4.1.34-33.1           | x86_64      | openSUSE-Leap-42.1-Update      
i | kernel-xen-devel              | package | 4.1.31-30.2           | x86_64      | Hauptaktualisierungs-Repository
i | kernel-xen-devel              | package | 4.1.31-30.2           | x86_64      | openSUSE-Leap-42.1-Update      
i | nfs-kernel-server             | package | 1.3.0-26.1            | x86_64      | Hauptaktualisierungs-Repository
i | nfs-kernel-server             | package | 1.3.0-26.1            | x86_64      | openSUSE-Leap-42.1-Update      
i | nvidia-computeG03             | package | 340.98-45.1           | x86_64      | nVidia Graphics Drivers        
i | nvidia-gfxG03-kmp-default     | package | 340.98_k4.1.12_1-45.1 | x86_64      | nVidia Graphics Drivers        
i | nvidia-glG03                  | package | 340.98-45.1           | x86_64      | nVidia Graphics Drivers        
i | nvidia-uvm-gfxG03-kmp-default | package | 340.98_k4.1.12_1-45.1 | x86_64      | nVidia Graphics Drivers        
i | x11-video-nvidiaG03           | package | 340.98-45.1           | x86_64      | nVidia Graphics Drivers        

Sauerland
Guru
Guru
Beiträge: 3466
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: update 42.1-64 nvidia Problem

Beitrag von Sauerland » 17. Nov 2016, 18:58

Äh und das sagt jetzt was?

Funktioniert es mit 13.2 nicht oder mit 42.1 nicht?

Übrigens stehen die Nvidia Pakete in 13.2 auf Systempakete, da würde ich einmal schauen......
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update 42.1-64 nvidia Problem

Beitrag von wschmock » 17. Nov 2016, 20:57

da die nvidia-Pakete bei 13.2 mit zypper up nicht installiert wurden funktioniert es. nach dem update bei 42.1 funktioniert es nicht.

Wizzzard
Member
Member
Beiträge: 208
Registriert: 27. Mai 2006, 16:28
Wohnort: Pulheim

Re: update 42.1-64 nvidia Problem

Beitrag von Wizzzard » 18. Nov 2016, 13:45

Bei mir hat das Update der G03 Treiber von NVidia funktioniert für Leap 42.1. Aber vorher habe ich virtualbox deinstalliert. Es hätte sehr wahrscheinlich auch ausgereicht, nur das Paket

Code: Alles auswählen

virtualbox-guest-kmp-default
zu entfernen. Sollte dieses Paket bei Dir installiert sein, bleibt nur durch deinstallieren der NVidia-Pakete auf den Nouveau-Treiber zu wechseln, dann sicherstellen, dass das oben genannte virtualbox Paket nicht installiert ist, dann kann man die NVidia-Pakete wieder installieren.

Also was gibt

Code: Alles auswählen

rpm -qa | grep virtualbox
aus?
openSUSE Leap 15.1
Asrock 970 Extreme3 R2.0, AMD FX 8320E 3200 MHz, 16 GiB DDR3 1600, NVidia GTX 1050ti

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update 42.1-64 nvidia Problem

Beitrag von wschmock » 18. Nov 2016, 14:35

virtualbox ist nicht installiert. nach entfernen von nvidia.ko wird der Nouveau-Treiber verwendet. auf dem schwarzen Bildschirm steht eine Nachricht: Das Programm Plasma wurde unerwartet beendet. es kann nur noch der Textmodus (Ctrl Alt F1) verwendet werden.

spoensche
Moderator
Moderator
Beiträge: 7454
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: update 42.1-64 nvidia Problem

Beitrag von spoensche » 18. Nov 2016, 19:11

Reboot und im Grub im Feld Bootoptionen den Parameter

Code: Alles auswählen

nomodeset
einfügen. Was für eine Nvidiakarte hast du?

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update 42.1-64 nvidia Problem

Beitrag von wschmock » 19. Nov 2016, 09:37

mit nomodeset ändert sich nichts. Grafikkarte: GeForce GT 630 Rev. 2. ich habe jetzt 42.2 installiert. der neue nouveau-Treiber kann 2 Monitore (twinview) in voller Auflösung. man braucht den nvidia-Treiber nicht mehr. allerdings funktioniert bei 42.2 einiges nicht: NFS-Server, Drucker, TV-Karte.

Sauerland
Guru
Guru
Beiträge: 3466
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: update 42.1-64 nvidia Problem

Beitrag von Sauerland » 19. Nov 2016, 10:53

allerdings funktioniert bei 42.2 einiges nicht: NFS-Server, Drucker, TV-Karte.
Das glaub ich so jetzt nicht....
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5334
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: update 42.1-64 nvidia Problem

Beitrag von tomm.fa » 19. Nov 2016, 11:20

wschmock hat geschrieben:[…] allerdings funktioniert bei 42.2 einiges nicht: NFS-Server, Drucker, TV-Karte.
Interessiert hier nicht, bitte beim Thema bleiben und für andere Probleme eigenständige Themen erstellen.

Sauerland muss ich jedoch noch zustimmen.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Wizzzard
Member
Member
Beiträge: 208
Registriert: 27. Mai 2006, 16:28
Wohnort: Pulheim

Re: update 42.1-64 nvidia Problem

Beitrag von Wizzzard » 19. Nov 2016, 13:54

wschmock hat geschrieben:virtualbox ist nicht installiert. nach entfernen von nvidia.ko wird der Nouveau-Treiber verwendet. auf dem schwarzen Bildschirm steht eine Nachricht: Das Programm Plasma wurde unerwartet beendet. es kann nur noch der Textmodus (Ctrl Alt F1) verwendet werden.
Es reicht nicht aus, nur das Modul für den Treiber zu tauschen. Die Nvidia-Pakete hätten komplett deinstalliert werden müssen, um wieder auf nouveau zu wechseln.

Aber das Problem scheint ja jetzt durch OS Update erstmal erledigt zu sein.
openSUSE Leap 15.1
Asrock 970 Extreme3 R2.0, AMD FX 8320E 3200 MHz, 16 GiB DDR3 1600, NVidia GTX 1050ti

spoensche
Moderator
Moderator
Beiträge: 7454
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: update 42.1-64 nvidia Problem

Beitrag von spoensche » 20. Nov 2016, 02:06

Setze den Thread bitte noch auf gelöst.

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

[gelöst]Re: update 42.1-64 nvidia Problem

Beitrag von wschmock » 20. Nov 2016, 08:43

Setze den Thread bitte noch auf gelöst.

Antworten