Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

update Problem mit nvidia

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

update Problem mit nvidia

Beitrag von wschmock » 28. Sep 2016, 10:58

nach dem update von heute (28.09.2016) mit zypper up startet die grafische Oberfläche nicht mehr. modprobe nvidia -> modul not found. das Modul ist aber vorhanden in weak updates/updates. das Problem ist bei 42..1 und 13.2 vorhanden. aber es gibt ja unter Advanced options noch die Vorgänger-Versionen. nur die starten auch nicht mehr. nvidia Modul nicht gefunden aber vorhanden. was nun ?

Werbung:
Sauerland
Guru
Guru
Beiträge: 3457
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: update Problem mit nvidia

Beitrag von Sauerland » 28. Sep 2016, 13:42

Poste:

Code: Alles auswählen

zypper lr -d

Code: Alles auswählen

zypper se -si kernel nvidia

Code: Alles auswählen

uname -a

Code: Alles auswählen

cat /var/log/Xorg.0.log

Code: Alles auswählen

journalctl -b | grep -i nvidia
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update Problem mit nvidia

Beitrag von wschmock » 28. Sep 2016, 14:26

hier die Ausgaben der Befehle:

Code: Alles auswählen

#  | Alias                              | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisieren | Priorität | Typ    | URI                                                             | Dienst
---+------------------------------------+---------------------------------------------------------+-----------+-----------------+---------------+-----------+--------+-----------------------------------------------------------------+-------
 1 | download.nvidia.com-opensuse       | nVidia Graphics Drivers                                 | Ja        | (r ) Ja         | Ja            |   80      | rpm-md | http://download.nvidia.com/opensuse/13.2/                       |       
 2 | download.opensuse.org-13.2-non-oss | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja            |   99      | rpm-md | http://download.opensuse.org/update/13.2-non-oss/               |       
 3 | download.opensuse.org-non-oss      | Haupt-Repository (NON-OSS)                              | Ja        | ( p) Ja         | Ja            |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/    |       
 4 | download.opensuse.org-oss          | Haupt-Repository (OSS)                                  | Ja        | ( p) Ja         | Ja            |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/        |       
 5 | download.opensuse.org-oss_1        | Haupt-Repository (Quellen)                              | Ja        | ( p) Ja         | Ja            |   99      | yast2  | http://download.opensuse.org/source/distribution/13.2/repo/oss/ |       
 6 | download.opensuse.org-update       | Hauptaktualisierungs-Repository                         | Ja        | (r ) Ja         | Ja            |   99      | rpm-md | http://download.opensuse.org/update/13.2/                       |       
 7 | ftp.gwdg.de-suse                   | Packman Repository                                      | Ja        | (r ) Ja         | Ja            |   70      | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/        |       
 8 | google-earth                       | google-earth                                            | Ja        | ( p) Ja         | Ja            |   99      | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64              |       
 9 | openSUSE-13.2-0                    | openSUSE-13.2-0                                         | Ja        | ( p) Ja         | Ja            |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/        |       
10 | repo-debug                         | openSUSE-13.2-Debug                                     | Nein      | ----            | Nein          |   99      | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/  |       
11 | repo-debug-update                  | openSUSE-13.2-Update-Debug                              | Nein      | ----            | Ja            |   99      | NONE   | http://download.opensuse.org/debug/update/13.2/                 |       
12 | repo-debug-update-non-oss          | openSUSE-13.2-Update-Debug-Non-Oss                      | Nein      | ----            | Nein          |   99      | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/         |       
Metadaten von Repository 'Packman Repository' werden abgerufen [.....fertig]
Zwischenspeicher für Repository 'Packman Repository' wird erzeugt [....fertig]
Daten des Repositories laden ...
Installierte Pakete lesen ...

S | Name                          | Typ   | Version               | Arch   | Repository                     
--+-------------------------------+-------+-----------------------+--------+--------------------------------
i | kernel-default-devel          | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-default-devel          | Paket | 3.16.7-35.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-desktop                | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-desktop                | Paket | 3.16.7-35.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-desktop-devel          | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-desktop-devel          | Paket | 3.16.7-35.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-devel                  | Paket | 3.16.7-42.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-devel                  | Paket | 3.16.7-35.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-docs                   | Paket | 3.16.7-42.2           | noarch | Hauptaktualisierungs-Repository
i | kernel-macros                 | Paket | 3.16.7-42.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-source                 | Paket | 3.16.7-42.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-source                 | Paket | 3.16.7-35.1           | noarch | Hauptaktualisierungs-Repository
i | kernel-syms                   | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-syms                   | Paket | 3.16.7-35.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-xen-devel              | Paket | 3.16.7-42.1           | x86_64 | Hauptaktualisierungs-Repository
i | kernel-xen-devel              | Paket | 3.16.7-35.1           | x86_64 | Hauptaktualisierungs-Repository
i | nfs-kernel-server             | Paket | 1.3.0-4.4.1           | x86_64 | Hauptaktualisierungs-Repository
i | nvidia-computeG03             | Paket | 340.98-39.1           | x86_64 | nVidia Graphics Drivers        
i | nvidia-gfxG03-kmp-desktop     | Paket | 340.98_k3.16.6_2-39.1 | x86_64 | nVidia Graphics Drivers        
i | nvidia-glG03                  | Paket | 340.98-39.1           | x86_64 | nVidia Graphics Drivers        
i | nvidia-uvm-gfxG03-kmp-desktop | Paket | 340.98_k3.16.6_2-39.1 | x86_64 | nVidia Graphics Drivers        
i | x11-video-nvidiaG03           | Paket | 340.98-39.1           | x86_64 | nVidia Graphics Drivers        

Linux k4l 3.16.7-42-desktop #1 SMP PREEMPT Tue Jun 28 12:20:57 UTC 2016 (35ab731) x86_64 x86_64 x86_64 GNU/Linux

[    19.146] 
X.Org X Server 1.16.1
Release Date: 2014-09-21
[    19.146] X Protocol Version 11, Revision 0
[    19.146] Build Operating System: openSUSE SUSE LINUX
[    19.146] Current Operating System: Linux k4l 3.16.7-42-desktop #1 SMP PREEMPT Tue Jun 28 12:20:57 UTC 2016 (35ab731) x86_64
[    19.146] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.7-42-desktop root=UUID=8b01d683-730a-43cf-89bf-b44f30792093 resume=/dev/disk/by-uuid/8ff200cc-3f0b-44f5-9957-ba3ab7a3daaf splash=silent quiet showopts vga=0x315
[    19.146] Build Date: 08 February 2016  10:43:38AM
[    19.146]  
[    19.146] Current version of pixman: 0.32.6
[    19.146] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    19.146] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    19.146] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 28 13:54:43 2016
[    19.146] (==) Using config file: "/etc/X11/xorg.conf"
[    19.146] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    19.146] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    19.146] (==) ServerLayout "Layout0"
[    19.146] (**) |-->Screen "Screen0" (0)
[    19.146] (**) |   |-->Monitor "Monitor0"
[    19.146] (**) |   |-->Device "Device0"
[    19.146] (**) |-->Input Device "Keyboard0"
[    19.146] (**) |-->Input Device "Mouse0"
[    19.146] (==) Automatically adding devices
[    19.146] (==) Automatically enabling devices
[    19.146] (==) Automatically adding GPU devices
[    19.183] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
[    19.183] 	Entry deleted from font path.
[    19.188] (==) FontPath set to:
	/usr/share/fonts/misc:unscaled,
	/usr/share/fonts/Type1/,
	/usr/share/fonts/100dpi:unscaled,
	/usr/share/fonts/75dpi:unscaled,
	/usr/share/fonts/ghostscript/,
	/usr/share/fonts/cyrillic:unscaled,
	/usr/share/fonts/truetype/,
	built-ins
[    19.188] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    19.188] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    19.188] (WW) Disabling Keyboard0
[    19.188] (WW) Disabling Mouse0
[    19.188] (II) Loader magic: 0x80ec80
[    19.188] (II) Module ABI versions:
[    19.188] 	X.Org ANSI C Emulation: 0.4
[    19.188] 	X.Org Video Driver: 18.0
[    19.188] 	X.Org XInput driver : 21.0
[    19.188] 	X.Org Server Extension : 8.0
[    19.189] (--) PCI:*(0:1:0:0) 10de:1284:1043:846a rev 161, Mem @ 0xf6000000/16777216, 0xe8000000/134217728, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    19.189] (II) LoadModule: "glx"
[    19.217] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    19.558] (II) Module glx: vendor="NVIDIA Corporation"
[    19.558] 	compiled for 4.0.2, module version = 1.0.0
[    19.558] 	Module class: X.Org Server Extension
[    19.558] (II) NVIDIA GLX Module  340.98  Mon Sep 19 17:22:44 PDT 2016
[    19.568] (II) LoadModule: "nvidia"
[    19.573] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    19.574] (II) Module nvidia: vendor="NVIDIA Corporation"
[    19.574] 	compiled for 4.0.2, module version = 1.0.0
[    19.574] 	Module class: X.Org Video Driver
[    19.574] (II) NVIDIA dlloader X Driver  340.98  Mon Sep 19 17:02:58 PDT 2016
[    19.574] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    19.574] (++) using VT number 7

[    19.574] (II) Loading sub module "fb"
[    19.574] (II) LoadModule: "fb"
[    19.574] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    19.574] (II) Module fb: vendor="X.Org Foundation"
[    19.574] 	compiled for 1.16.1, module version = 1.0.0
[    19.574] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    19.574] (WW) Unresolved symbol: fbGetGCPrivateKey
[    19.574] (II) Loading sub module "wfb"
[    19.574] (II) LoadModule: "wfb"
[    19.574] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    19.574] (II) Module wfb: vendor="X.Org Foundation"
[    19.574] 	compiled for 1.16.1, module version = 1.0.0
[    19.574] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    19.574] (II) Loading sub module "ramdac"
[    19.574] (II) LoadModule: "ramdac"
[    19.574] (II) Module "ramdac" already built-in
[    19.621] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    19.621] (EE) NVIDIA:     system's kernel log for additional error messages and
[    19.622] (EE) NVIDIA:     consult the NVIDIA README for details.
[    19.622] (EE) No devices detected.
[    19.622] (EE) 
Fatal server error:
[    19.622] (EE) no screens found(EE) 
[    19.622] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    19.622] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    19.622] (EE) 

Sep 28 13:54:33 k4l kernel: input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input13
Sep 28 13:54:33 k4l kernel: input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14

Sauerland
Guru
Guru
Beiträge: 3457
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: update Problem mit nvidia

Beitrag von Sauerland » 28. Sep 2016, 16:29

Using config file: "/etc/X11/xorg.conf"
Hast du dort etwas eingetragen?
Die Datei wird eigentlich nicht mehr benötigt, das wird alles über Dateien in /etc/X11/xorg.conf.d/ bewerkstelligt.
[ 19.621] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[ 19.621] (EE) NVIDIA: system's kernel log for additional error messages and
[ 19.622] (EE) NVIDIA: consult the NVIDIA README for details.
[ 19.622] (EE) No devices detected.
[ 19.622] (EE)
Fatal server error:
[ 19.622] (EE) no screens found(EE)

Code: Alles auswählen

journalctl -k | grep -i nvidia
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Benutzeravatar
willithepimp
Member
Member
Beiträge: 140
Registriert: 10. Jan 2009, 12:59

Re: update Problem mit nvidia

Beitrag von willithepimp » 28. Sep 2016, 16:58

Kann mich Wschmock nur anschließen. Ich hab das gleiche Problem. Kann allerdings auch noch nichts erhellendes beitragen.
Bloß gut, dass es noch OS 13.2 auf dem Rechner gibt. :/
Gruß

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update Problem mit nvidia

Beitrag von wschmock » 28. Sep 2016, 17:30

"/etc/X11/xorg.conf" wurde in einer Vorgängerversion mit "nvidia-xconfig" erzeugt, keine manuellen Änderungen.

Code: Alles auswählen

journalctl -k | grep -i nvidia
ergibt das:

Code: Alles auswählen

Sep 28 17:14:06 k4l kernel: input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input13
Sep 28 17:14:06 k4l kernel: input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
das Problem bleibt: "modprobe nvidia" Modul nicht gefunden obwohl vorhanden.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5285
Registriert: 23. Sep 2008, 17:09

Re: update Problem mit nvidia

Beitrag von josef-wien » 28. Sep 2016, 17:41

Wird das Modul nach einem

Code: Alles auswählen

depmod -a
auch nicht gefunden?

Wizzzard
Member
Member
Beiträge: 208
Registriert: 27. Mai 2006, 16:28
Wohnort: Pulheim

Re: update Problem mit nvidia

Beitrag von Wizzzard » 28. Sep 2016, 19:11

Bei mir hat das Update heute für den 340.98 für Leap 42.1 funktioniert. Vorher habe ich allerdings aus Erfahrung das Modul

Code: Alles auswählen

virtualbox-guest-kmp-default
deinstalliert.

Wenn ich das vergessen hatte, durfte ich erstmal alle NVidia-Treiber-RPMs deinstallieren, damit das System erstmal wieder mit dem Nouveau-Treiber wieder die graphische Oberfläche starten konnte.
openSUSE Leap 15.1
Asrock 970 Extreme3 R2.0, AMD FX 8320E 3200 MHz, 16 GiB DDR3 1600, NVidia GTX 1050ti

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update Problem mit nvidia

Beitrag von wschmock » 28. Sep 2016, 19:26

nach "depmod -a" funktioniert "modeprobe nvidia" und ist mit "lsmod" zu sehen. nach entfernen von "/etc/X11/xorg.conf" und Neustart steht "nvidia" in "lsmod", wird aber nicht benutzt, die grafische Oberfläche erscheint 600 x 800 Auflösung (noveau-Treiber) und es lässt sich nichts einstellen.

Code: Alles auswählen

# nvidia-xconfig

WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
New X configuration file written to '/etc/X11/xorg.conf'

Drücken Sie eine Taste zum Fortfahren...
eine Datei "xorg-server" ist nicht vorhanden und auch nicht in den Dateilisten bei "Yast- Software installieren" zu finden. mit dem neuen "/etc/X11/xorg.conf" startet die Grafik nicht. probiert mit 13.2

Sauerland
Guru
Guru
Beiträge: 3457
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: update Problem mit nvidia

Beitrag von Sauerland » 28. Sep 2016, 19:33

Noch einmal:
die xorg.conf ist über, die bereitet meist nur Probleme.

Daher lasse ich grundsätzlich die Finger von nvidia-xconfig, dann wird diese Datei erzeugt.
Zuletzt geändert von Sauerland am 28. Sep 2016, 19:35, insgesamt 1-mal geändert.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update Problem mit nvidia

Beitrag von wschmock » 28. Sep 2016, 19:34

"virtualbox-guest-kmp-default" exstiert bei 13.2-64 nicht. "virtualbox-kmp-desktop" ist nicht installiert.

Sauerland
Guru
Guru
Beiträge: 3457
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: update Problem mit nvidia

Beitrag von Sauerland » 28. Sep 2016, 19:38

wschmock hat geschrieben:"virtualbox-guest-kmp-default" exstiert bei 13.2-64 nicht. "virtualbox-kmp-desktop" ist nicht installiert.
Das erstere würde ich so nicht sagen, sollte aber für dich auch nicht massgeblich sein, da Du ja:
Linux k4l 3.16.7-42-desktop #1 SMP PREEMPT Tue Jun 28 12:20:57 UTC 2016 (35ab731) x86_64 x86_64 x86_64 GNU/Linux
Daher wäre für dich zutreffend:

Code: Alles auswählen

virtualbox-guest-kmp-desktop
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update Problem mit nvidia

Beitrag von wschmock » 28. Sep 2016, 19:47

auch "virtualbox-guest-kmp-desktop" ist bei 13.2-64 in den Dateilisten und im Rechner nicht vorhanden.

Sauerland
Guru
Guru
Beiträge: 3457
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: update Problem mit nvidia

Beitrag von Sauerland » 28. Sep 2016, 19:51

Code: Alles auswählen

  | virtualbox-guest-kmp-default | Paket | 5.0.26_k3.16.7_42-51.1 | x86_64 | openSUSE-13.2-Update
  | virtualbox-guest-kmp-desktop | Paket | 5.0.26_k3.16.7_42-51.1 | x86_64 | openSUSE-13.2-Update
Das sind nur Ausschnitte davon, es sind jeweils so ca 10 Stck vorhanden.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5285
Registriert: 23. Sep 2008, 17:09

Re: update Problem mit nvidia

Beitrag von josef-wien » 28. Sep 2016, 22:28

wschmock hat geschrieben:"nvidia" in "lsmod", wird aber nicht benutzt
Und was sagt /var/log/Xorg.0.log jetzt?

Zur Sicherheit:

Code: Alles auswählen

rpm -qa nvidia* | while read paketname ; do rpm -V $paketname || echo $paketname ; done

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

Re: update Problem mit nvidia

Beitrag von wschmock » 29. Sep 2016, 07:24

bei 42.1-64 funktioniert nvidia nach entfernen von "/etc/X11/xorg.conf" und "depmod -a". bei 13.2-64 startet der noveau-Treiber.

Code: Alles auswählen

rpm -qa nvidia* | while read paketname ; do rpm -V $paketname || echo $paketname ; done
hat keine Ausgabe. habe mit Yast alle nvidia-Pakete nochmal akgtualisiert, aber keine Änderung.

Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2587
Registriert: 12. Feb 2005, 22:45

Re: update Problem mit nvidia

Beitrag von panamajo » 29. Sep 2016, 12:38

Das Problem ist schlicht dass NVIDIA keine Kernel-Module für die Desktop Varianten des Kernels bereit stellt.
Bei mir wurden einfach die Default Varianten installiert, die dann aber nicht passen. Je nach weiterer Konfiguration wird dann der nouveau oder SVGA Treiber geladen, der weder Multi-Screen noch OpenGL unterstützt. Ich habe jetzt den Default Kernel installiert und die nvidia-*kmp Module neu installiert, läuft.
Bei einem anderen Rechner (den ich zwar als Desktop nutze, aber den Default Kernel verwende weil es dasselbe Problem schon mal gab) lief das Update problemlos.

Mein anderer Lösungsansatz war old-school den Treiber von nvidia runterzuladen und selbst compilieren scheiterte weil der Treiber checkt ob ggf. nvidia*kmp Pakete installiert sind, wenn man "Shut up and compile" auswählt schlägt das fehl.
Will man dann die Module entfernen will die Paketverwaltung gleich weitere 20 Pakete deinstallieren :schockiert:

[Edit] Lese gerade im README auf dem NVIDIA Server dass die Pakete von Novell/openSUSE maintained werden, ist also deren Bock.

[Edit] Obige Fehlerbeschreibung und Workaround gelten nur für openSUSE Lead 42.[12]. Für openSUSE 13.* sind zumindest die Desktop Varianten im nvidia Repro vorhanden.

Benutzeravatar
willithepimp
Member
Member
Beiträge: 140
Registriert: 10. Jan 2009, 12:59

Re: update Problem mit nvidia

Beitrag von willithepimp » 30. Sep 2016, 15:10

Hallo,
hab eben folgende Lösung für das Nvidia-Update Problem gefunden. ABER! Ich habe es noch nicht ausprobiert. Keine Zeit. Erfolg oder Misserfolg kann ich erst Ende nächster Woche berichten. Dennoch will ich es keinem vorenthalten.
https://oyox.de/1241-nvidia-macht-unter ... -probleme/
Gruß

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5285
Registriert: 23. Sep 2008, 17:09

Re: update Problem mit nvidia

Beitrag von josef-wien » 30. Sep 2016, 17:04

panamajo hat geschrieben:Das Problem ist schlicht dass NVIDIA keine Kernel-Module für die Desktop Varianten des Kernels bereit stellt.
Seit 42.1 gibt es einen kernel-desktop nicht mehr, also muß Dein Nvidia-Problem eine andere Ursache haben.
willithepimp hat geschrieben:hab eben folgende Lösung für das Nvidia-Update Problem gefunden
Das war immer schon so, daß bei Verwendung der nvidia*.run-Datei bei jedem Kernel-Update der Treiber (automatisch oder manuell) neu erstellt werden mußte (und ein Deinstallieren und Neuinstallieren des ganzen Pakets deutlich über das Ziel hinausschießt).

wschmock
Member
Member
Beiträge: 219
Registriert: 28. Nov 2009, 18:01

[gelöst] Re: update Problem mit nvidia

Beitrag von wschmock » 14. Okt 2016, 10:29

mit dem update von heute (14.10.2016) funktioniert nvidia mit 13.2-64 wieder korrekt.

Antworten