OpenSuse Leap 42.1: Aufhängen beim Runterfahren - immer !

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

josef-wien
Guru
Guru
Beiträge: 4874
Registriert: 23. Sep 2008, 17:09

Re: OpenSuse Leap 42.1: Aufhängen beim Runterfahren - immer !

Beitrag von josef-wien » 11. Nov 2017, 17:50

wolfi_z hat geschrieben:
11. Nov 2017, 14:54
hat zumindest schon einmalig funktioniert

Code: Alles auswählen

root@linux-iodi:/home/wolfi> init 3
root@linux-iodi:/home/wolfi> shutdown -h now
wolfi_z hat geschrieben:
11. Nov 2017, 17:41
zweimal zweistufig per Kommandozeile (was ja einmal funktioniert hatte) -> hilft alles nix
Was genau ist jetzt passiert bzw. nicht passiert? Wie paßt das zu Deiner ersten Aussage?
wolfi_z hat geschrieben:
11. Nov 2017, 06:38
bleibt der Rechner aber bei einer Welcome-Zeile (quasi wie Login auf Terminal 1) stehen

Hast Du schon einen anderen display manager probiert (z. B. kdm statt sddm oder umgekehrt)?

Werbung:
wolfi_z
Hacker
Hacker
Beiträge: 391
Registriert: 7. Feb 2004, 12:59
Wohnort: Erlangen / Wiernsheim
Kontaktdaten:

Re: OpenSuse Leap 42.1: Aufhängen beim Runterfahren - immer !

Beitrag von wolfi_z » 11. Nov 2017, 17:55

'Funktionieren' bedeutet, dass der Rechner ordnungsgemaess runterfaehrt.
'Nicht funktionieren' bedeutet, dass der Rechner bei der o. g. 'Welcome' Zeile stehenbleibt (anstatt herunterzufahren).

kdm / sddm muss ich halt mal probieren ...

LG ... Wolfi ;)

josef-wien
Guru
Guru
Beiträge: 4874
Registriert: 23. Sep 2008, 17:09

Re: OpenSuse Leap 42.1: Aufhängen beim Runterfahren - immer !

Beitrag von josef-wien » 11. Nov 2017, 18:04

Du gibst den shutdown-Befehl ein, und es passiert absolut nichts?

wolfi_z
Hacker
Hacker
Beiträge: 391
Registriert: 7. Feb 2004, 12:59
Wohnort: Erlangen / Wiernsheim
Kontaktdaten:

Re: OpenSuse Leap 42.1: Aufhängen beim Runterfahren - immer !

Beitrag von wolfi_z » 11. Nov 2017, 18:09

josef-wien hat geschrieben:
11. Nov 2017, 18:04
Du gibst den shutdown-Befehl ein, und es passiert absolut nichts?
Das Herunterfahren bleibt bei der 'Welcome' Zeile stehen, vgl. weiter oben.
Das grafische Display verschwindet, es sollten jetzt die Shutdown-Meldungen kommen, stattdessen nur 'Welcome' und dann hoert der Cursor auf zu blinken.

Siehe auch im allerersten Beitrag auf der allerersten Seite :D

LG ... Wolfi ;)

goeba
Member
Member
Beiträge: 132
Registriert: 23. Nov 2015, 13:48

Re: OpenSuse Leap 42.1: Aufhängen beim Runterfahren - immer !

Beitrag von goeba » 11. Nov 2017, 18:14

Meine Vorschläge:

a) Booten mit einem einfachen Standard-VGA Treiber. Leider weiß ich aktuell nicht mehr, wie das mit Grub2 geht, vielleicht kann das jemand beantworten.

b) Booten direkt in die Befehlszeile, also ohne, dass X überhaupt gestartet wird. Auch hier wüsste ich gerade nicht, wie.

Denn wenn Du erst "normal" hochfährst, werden ja Programme gestartet und Treiber geladen, und wenn das "entladen" irgendwo hängt, dann hängt es auch, wenn Du X beendest.

Ich hatte auch mal ein System, das sich nicht abschaltete, da lag es definitiv am Grafiktreiber.

wolfi_z
Hacker
Hacker
Beiträge: 391
Registriert: 7. Feb 2004, 12:59
Wohnort: Erlangen / Wiernsheim
Kontaktdaten:

Re: OpenSuse Leap 42.1: Aufhängen beim Runterfahren - immer !

Beitrag von wolfi_z » 11. Nov 2017, 18:19

goeba hat geschrieben:
11. Nov 2017, 18:14
(...) b) Booten direkt in die Befehlszeile, also ohne, dass X überhaupt gestartet wird. Auch hier wüsste ich gerade nicht, wie. (...)
Muesste man vermutlich als Default Runlevel die 3 auswaehlen statt der 5

LG ... Wolfi ;)

josef-wien
Guru
Guru
Beiträge: 4874
Registriert: 23. Sep 2008, 17:09

Re: OpenSuse Leap 42.1: Aufhängen beim Runterfahren - immer !

Beitrag von josef-wien » 11. Nov 2017, 18:22

wolfi_z hat geschrieben:
11. Nov 2017, 18:09
vgl. weiter oben
Das ist keine Antwort auf meine Frage.


goeba hat geschrieben:
11. Nov 2017, 18:14
Booten mit einem einfachen Standard-VGA Treiber.
Um welche Grafikkarte handelt es sich:

Code: Alles auswählen

lspci -nnk | grep -EiA3 '3d|display|vga'
Falls nvidia oder amdgpu-pro nicht installiert ist, kann im Boot-Menü als Boot-Option nomodeset eingegeben werden.


goeba hat geschrieben:
11. Nov 2017, 18:14
Booten direkt in die Befehlszeile
Im Boot-Menü als Boot-Option 3 eingeben.

goeba
Member
Member
Beiträge: 132
Registriert: 23. Nov 2015, 13:48

Re: OpenSuse Leap 42.1: Aufhängen beim Runterfahren - immer !

Beitrag von goeba » 11. Nov 2017, 23:57

Ich habe das mal ausprobiert.

Für Unerfahrene:

Booten, bei dem Kernel, den man booten möchte "e" drücken. Dann in der Zeile, die mit "linux" beginnt am Ende die 3 anfügen. (ich hatte zunächst ganz am Ende der ganzen Befehlskette die 3 angefügt, das war natürlich Unsinn, da hätte ich nur mal die Befehle lesen müssen)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast