Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Suse 13.2 - Standard Bootabschnitt nur 0

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Former
Newbie
Newbie
Beiträge: 22
Registriert: 25. Mär 2015, 22:14

[Gelöst] Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von Former » 25. Mär 2015, 22:40

Hallo zusammen,
ich habe schon so manches Suse-System mit MBR zum Laufen bekommen, aber noch nichts mit EFI und Co zu tun gehabt. An einer Stelle komme ich bei der Installation (parallel zu Win 8.1) nicht weiter:
Ich habe die Platte partioniert (/ und swap) und habe sie eingehängt. Die EFI-Partition habe ich unter /boot/efi eingehängt. Wenn ich jetzt im Standard Bootabschnitt ein zu startendes Betriebssystem wählen möchte steht da nur eine "0". Ich kann installieren, aber es bootet nur Windows. Wer hat einen Tip?
Vielen Dank!!

Gruß Former
Zuletzt geändert von Former am 28. Mär 2015, 19:05, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von linux-freund » 26. Mär 2015, 00:15

Konkret kann ich Dir auf Deine Frage nicht antworten, aber ich poste Dir mal die Anleitung wie ich auf meinen 2 Computern openSUSE neben Win8.1 installiert bekommen habe:

1. openSUSE Version in 64bit runterladen (32bit funktioniert nicht!)
(Nachtrag: Evtl. gibts das 32/64bit Problem seit Kernel 3.15 nicht mehr?? Lest selbst: http://www.heise.de/newsticker/meldung/ ... 10500.html)
2. Secure Boot vorab im UEFI-Bios ausschalten
3. Bootreihenfolge im UEFI-Bios ändern (CD/DVD bzw USB zuerst booten)
4. Schnellstart in Windows8 und UEFI-Bios deaktivieren (kann man auch nach der installation noch machen) --> ist nötig bei gemeinsamer Nutzung von Partitionen durch Windows und Linux, da es sonst zu Fehlern kommen wird. Ansonsten egal.
5. openSUSE DVD im UEFI und nicht im Legacy Modus booten!
6. Installationsroutine in openSUSE Punkt für Punkt durchgehen (ist sehr benutzerfreundlich und einfach zu verstehen)
7. Grub2 wird automatisch durch den Boot im UEFI-Modus von openSUSE in die entsprechend korrekte Partition installiert... nichts ändern!
8. Bei der Übersicht der Einstellungen vor der eigentlichen Installation "secure-boot=true" setzen damit eine Secure-Boot-Unterstützung mit installiert wird.
9. Installation starten und beenden.
10. Rechner neu starten.. jetzt sollte Grub2 mit Windows8 und openSUSE als Option erscheinen und beides sollte funktionieren.
11. Wiederholter Neustart: Im UEFI-Bios Secure-Boot wieder aktivieren
12. openSUSE starten... wenn Secure Boot Unterstützung funktioniert= Toll, andernfalls wieder ins UEFI-Bios und Secure-Boot abschalten= auch nicht weiter tragisch
13. In Windows booten und sicherheitshalber die Anleitung http://www.opensuse-forum.de/allgemeine ... erstellen/ --> Post Nr.4! durchlesen und entsprechende Schritte in Windows8 durchführen. --> Verhindert das Windows8 den Bootloaderpfad bei Updates überschreibt und Grub2 verschwindet!

(bereits hier gepostet)

Vielleicht hilft es ja...
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Former
Newbie
Newbie
Beiträge: 22
Registriert: 25. Mär 2015, 22:14

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von Former » 26. Mär 2015, 22:53

Hallo,
es läuft immer noch nicht. Ich habe es genauso gemacht wie in der Anleitung. Vorher hatte ich noch nicht den Schnellstart von Win 8.1 deaktiviert (mein Bios unterstützt keinen Schnellstart: InsyheH20). Leider habe ich noch keine Auswahl der zu startenden Betriebssysteme während der Installation. Ich habe den "C:\Windows\system32>bcdedit /enum all" ausgeführt und sehe, dass ein shim-Bootloader installiert wurde, habe aber Angst ihn als Standard festzulegen. Meine Sorge ist, dass ich mich aus dem Win 8.1 aussperre.
Wäre es sinnvoll das Win 8.1 platt zu machen und über Recovery (USB-Stick Acer) den Originalzustand der Platte wieder herzustellen. Ich hätte dann eine neue EFI-Partition in der der Schnellstart von Win und Linux Installationsversuche noch nichts verändert haben.
Ich habe einen Acer E5 571G-520X. Eine 13.1 Installation hat übrigens die selben Probleme.

Danke und Gruß
Former

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5421
Registriert: 23. Sep 2008, 17:09

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von josef-wien » 27. Mär 2015, 00:02

Former hat geschrieben:sehe, dass ein shim-Bootloader installiert wurde
Das ist der vorgeschaltete bootloader, der für ein UEFI mit aktiviertem secure boot notwendig ist.
Former hat geschrieben:Meine Sorge ist, dass ich mich aus dem Win 8.1 aussperre.
Neben
Former hat geschrieben:über Recovery (USB-Stick Acer) den Originalzustand der Platte wieder herzustellen
hast Du über das rescue system der openSUSE-DVD die Möglichkeit, Änderungen vorzunehmen. Nach der Anmeldung als root (ohne Paßwort) kannst Du mit

Code: Alles auswählen

efibootmgr
die Eintragungen im UEFI-Boot-Menü ansehen (der Parameter -v zeigt Details dazu). Mit

Code: Alles auswählen

efibootmgr -n 3
kannst Du veranlassen, daß nach einem reboot die Eintragung Nummer 3 verwendet wird. Mit

Code: Alles auswählen

efibootmgr -o 3,1,2
kannst Du die Boot-Reihenfolge festlegen. Aber es geht auch einfacher (wenn Du kein Aptio-BIOS oder ein ähnlich kastriertes UEFI hast): Du rufst beim Systemstart das UEFI-Boot-Menü auf und wählst dort die gewünschte Eintragung aus.

Wie sieht übrigens der Inhalt der EFI-Systempartition aus?

Former
Newbie
Newbie
Beiträge: 22
Registriert: 25. Mär 2015, 22:14

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von Former » 27. Mär 2015, 19:21

Hallo,
wenn ich mit "efibootmgr -n XXXX" den Bootladereintrag von Linux wähle, läuft mein GRUB2 hoch und ich kann Linux wählen. Wenn ich über die Option "efibootmgr -o XXXX,YYYY,..." die Bootreihenfolge festlege, zeigt er mir auch die korrekte Folge, speichert aber nicht. Beim nächsten Booten ist wieder alles beim alten. Ich habe kein Kennwort für UEFI festgelegt. Vielen Dank die Hilfe.

Gruß Former

Benutzeravatar
Rainer Juhser
Moderator
Moderator
Beiträge: 3895
Registriert: 14. Aug 2006, 17:03
Wohnort: 04711 Münchhausen

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von Rainer Juhser » 27. Mär 2015, 20:31

Former hat geschrieben:Wenn ich über die Option "efibootmgr -o XXXX,YYYY,..." die Bootreihenfolge festlege, zeigt er mir auch die korrekte Folge, speichert aber nicht. Beim nächsten Booten ist wieder alles beim alten.
Das sieht nach einem vermackten BIOS aus. Ich habe so einen Fall bei meinem aktuellen PC mit Intel-Mainboard gehabt. Konsequenz war - da ich kein Windows 8 brauche - eine "konventionelle" Installation (MBR und CSM).
Inzwischen gibt es für das Intel-Board ein BIOS-Update, in dem der Fehler gefixt ist, so dass ich bei der nächsten Neuinstallation oder Wechsel der Distribution GPT und UEFI nutzen kann. Vielleicht gibt es ja für dein Gerät auch ein Update. Was ist das denn für ein Teil?
Salü vom Rainer Juhser
_________________________
Bist du neu - guckst du hier:
Neu im Linux-Club?...Bitte LESEN! == Bedienungsanleitung Forum == Hilfe zu Antworten aus dem Forum
== WISSEN PUR: Linupedia - das Linux-Club WIKI!

Former
Newbie
Newbie
Beiträge: 22
Registriert: 25. Mär 2015, 22:14

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von Former » 27. Mär 2015, 20:58

Acer E5 571G-520X
InsydeH20 V1.26
Letzte Woche gekauft!!

Gruß Former

Benutzeravatar
Rainer Juhser
Moderator
Moderator
Beiträge: 3895
Registriert: 14. Aug 2006, 17:03
Wohnort: 04711 Münchhausen

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von Rainer Juhser » 27. Mär 2015, 22:49

Na dann - schaun wir mal. Ich habe mir letzte Woche ein Acer V3-371 für unterwegs bestellt. Mal sehen,. was da bei der Installation 'rauskommt...
Salü vom Rainer Juhser
_________________________
Bist du neu - guckst du hier:
Neu im Linux-Club?...Bitte LESEN! == Bedienungsanleitung Forum == Hilfe zu Antworten aus dem Forum
== WISSEN PUR: Linupedia - das Linux-Club WIKI!

Benutzeravatar
robi
Moderator
Moderator
Beiträge: 3174
Registriert: 25. Aug 2004, 02:13

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von robi » 27. Mär 2015, 22:51

Wenn du Bootreihenfolge so gesetzt hast das normalerweise Linux booten sollte, also in der Reihenfolge zu erst Linux und dann Windows steht, und trotzdem automatisch Windows startet, dann boote mal den Rechner ganz normal durch ohne irgend eine Eingabe, so das windows startet.
dann schau (Administratorrechte notwendig) mit bcdedit was Windows sagt.

Code: Alles auswählen

Firmware Boot Manager
---------------------
identifier              {fwbootmgr}
displayorder            {112d7697-46fe-11e3-beb8-806e6f6e6963}                      # 1. shim oder grub2
                        {bootmgr}                                                                           # 2. Windows
                        {112d7693-46fe-11e3-beb8-806e6f6e6963}                            # 3. irgendwas 
                        {63dfd18a-2c85-11e3-b718-adb8de629832}
                        {63dfd18b-2c85-11e3-b718-adb8de629832}
                        {63dfd18c-2c85-11e3-b718-adb8de629832}
timeout                 2

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\Boot\bootx64.efi        # das hier ist die entscheidendet Zeile
description             Windows Boot Manager
locale                  en-GB
inherit                 {globalsettings}
integrityservices       Enable
default                 {current}
resumeobject            {63dfd18d-2c85-11e3-b718-adb8de629832}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30
wenn dort in der "entscheidenden Zeile " steht : \EFI\Boot\bootx64.efi dann ist das ein Fehler im UEFI
Windows sollte mit "\EFI\Microsoft\Boot\bootmgfw.efi" gestartet werden, das ist der richtige Bootmanager von Windows.

der andere Path ist eine Kopie des Windows Bootmagers der auf einen bei UEFI definierten Default UEFI-Bootloader gelegt ist. (macht Windows automatisch), der aber eigentlich nur dann vom UEFI zu Start genommen werden dürfte, wenn du UEFI entweder sagst das es von dieser Platte booten soll (also ohne einen speziellen Bootloaderspezifischen Eintrag der sich auf der Platte befindet), oder die komplette Bootreihenfolge/Einträge zerstört/beschädigt ist. Diese Kopie des Windowsbootmanager sollte dann dafür sorgen, das auch in diesem Fall dann Windows startet und niemand auf die Idee kommt nur desshalb den Service von Microsoft zu bemühen. ;)

Leider haben einige Hardwarehersteller bei der Entwicklung ihrer UEFI-Firmware nur mit Windows experimentiert und nicht mit Multiboot oder anderen Betriebssystemen und haben teilweise einen Bug im UEFI der den Defaulteintrag prinzipiell immer startet, egal ob dort eine Bootreihenfolge vorhanden ist und wie diese aussieht.

Entweder schauen, ob es ein FW-Update gibt, und hoffen das ist damit behoben.
oder machen was linux-freund unter Punkt 13. erklärt hat. Es gibt aber noch weitere Methoden im Netz zu finden, um das zu verhindern.

------------
Ich bin der radikalen Meinung http://www.uefi.org/registry legt fest wem welches Verzeichnis dort gehört und da hat Microsoft in einer Multibootkonfiguration nichts unter \EFI\BOOT zu suchen, also kann die Kopie des Windows-Bootmanagers dort in diesem Verzeichnis auch gelöscht werden. Leider legt diesen Windows spätestens beim nächsten Upgrade wieder an, wenn man es nicht aktiv verhindert. Bevor man die Datei dort unter \EFI\Boot löscht, sollte man aber auch sicher sein, dass der UEFI-Booteintrag von Windows ansonsten wirklich richtig eingetragen ist, und das die Datei dort auch wirklich eine Kopie des Windowsbootmanagers ist (zB. mit md5sum vergleichen).

Dazu bräuchte man wieder Linux und "efibootmgr -v" da sollte dann beim Windwosbootmanager, der Path "\EFI\Microsoft\Boot\bootmgfw.efi" drin stehen. der Eintrag könnte zB so ähnlich aussehen.

Code: Alles auswählen

Boot0009* Windows Boot Manager  HD(2,96800,31800,663a220a-5b4e-474d-832f-a969d8334cb4)File(\EF
I\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.
d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...o................
wie gesagt, ist meine Meinung, ich habe selbst keinen UEFI mit einem solchem Bug und kann es desshalb nicht selbst ausprobieren, ob dann UEFI sauber nach Bootreihenfolge bootet.

robi

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5421
Registriert: 23. Sep 2008, 17:09

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von josef-wien » 27. Mär 2015, 23:06

Und wenn Du die Boot-Reihenfolge im BIOS oder in Windows änderst?

Former
Newbie
Newbie
Beiträge: 22
Registriert: 25. Mär 2015, 22:14

[gelöst] Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von Former » 28. Mär 2015, 00:35

Hallo zusammen,
erst einmal vielen Dank an alle die mir geholfen haben. Ich habe viel über UEFI gelernt. ich habe mein Problem gelöst und antworte unter 13.2, das regulär hochgefahren ist.
Zunächst habe ich das SECURE BOOT deaktiviert und 13.2 regulär installiert (Secure angekreuzt). Dann habe ich die Rescue DVD gestartet und mittels "efibootmgr" nachgesehen, ob der Bootlader vorhanden ist. Als nächstes bin ich ins UEFI-"Bios" gegangen und habe den SECURE BOOT aktiviert, dann habe ich den Bootlader für vertrauenswürdig erklärt. Nach einem erneuten Booten wurde im Bootladermenü auch der neue Eintrag angeboten. An die richtige Stelle gesetzt und sowohl Win als auch Linux hochlaufen lassen.

Vielen Dank und Gruß
Former

Benutzeravatar
Rainer Juhser
Moderator
Moderator
Beiträge: 3895
Registriert: 14. Aug 2006, 17:03
Wohnort: 04711 Münchhausen

Re: Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von Rainer Juhser » 28. Mär 2015, 15:20

Hallo Former,

wenn dein Problem jetzt gelöst ist, dann erledige doch bitte noch die Formalitäten.

Danke!
Salü vom Rainer Juhser
_________________________
Bist du neu - guckst du hier:
Neu im Linux-Club?...Bitte LESEN! == Bedienungsanleitung Forum == Hilfe zu Antworten aus dem Forum
== WISSEN PUR: Linupedia - das Linux-Club WIKI!

Former
Newbie
Newbie
Beiträge: 22
Registriert: 25. Mär 2015, 22:14

Re: [Gelöst] Suse 13.2 - Standard Bootabschnitt nur 0

Beitrag von Former » 28. Mär 2015, 19:07

Alles klar, hatte den letzten Beitrag mit "gelöst" versehen.

Gruß Former

Antworten