Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Neuinstallation 13.2: error occurred during boot loader inst

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
kzeitler
Newbie
Newbie
Beiträge: 42
Registriert: 15. Sep 2011, 23:34

Neuinstallation 13.2: error occurred during boot loader inst

Beitrag von kzeitler » 29. Dez 2014, 22:47

Hallo, ich habe gerade versucht auf meinem Laptop 13.2 zu installieren und leider gibt's am Ende folgende Meldung:
An error occurred during boot loader installation. Retry boot loader configuration?

Werbung:
kzeitler
Newbie
Newbie
Beiträge: 42
Registriert: 15. Sep 2011, 23:34

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von kzeitler » 29. Dez 2014, 22:55

oops, irgendwie bin ich anscheinend auf "Absenden" gekommen.

Meine 1. Frage: Wie/wo sehe ich denn was für ein Fehler aufgetreten ist?

Ich habe den Laptop völlig platt gemacht und überall die vorgegebenen Defaults verwendet.
Allerdings wird da schon ein ziemlich komplexes Partitionierungsszenario erstellt:
BtrFS für "/" und XFS für /home und viele Subvolumes. Das sagt mir alles leider erst mal gar nichts.

Ich könnte natürlich versuchen selbst zu partitionieren (wie meine vorherige 12.3 Version mit ext4), aber vielleicht
kann man das Problem ja leicht lösen.

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2081
Registriert: 24. Okt 2005, 14:04

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von Heinz-Peter » 29. Dez 2014, 23:10

Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1952
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von gehrke » 30. Dez 2014, 08:24

kzeitler hat geschrieben:Ich habe den Laptop völlig platt gemacht und überall die vorgegebenen Defaults verwendet.
Allerdings wird da schon ein ziemlich komplexes Partitionierungsszenario erstellt:
BtrFS für "/" und XFS für /home und viele Subvolumes. Das sagt mir alles leider erst mal gar nichts.

Ich könnte natürlich versuchen selbst zu partitionieren (wie meine vorherige 12.3 Version mit ext4), aber vielleicht
kann man das Problem ja leicht lösen.
Das hört sich IMHO nicht nach einem Problem mit der Partitionierung an. Vielmehr vermute ich, dass Dein Problem im Bereich MBR/GPT, UEFI, SecureBoot und Bootloader (GRUB2) liegt, wozu Du auch hier im Forum in letzter Zeit eine ganze Reihe von Threads nachlesen kannst. IMHO haben wir zu diesem Thema derzeit keine befriedigende Gesamtsituation.

Such mal im Forum zu diesen Patterns in den letzten 2 Monaten.

http://forum.linux-club.de/viewtopic.php?f=115&t=119778

Benutzeravatar
Rainer Juhser
Moderator
Moderator
Beiträge: 3895
Registriert: 14. Aug 2006, 17:03
Wohnort: 04711 Münchhausen

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von Rainer Juhser » 30. Dez 2014, 15:03

kzeitler hat geschrieben:Ich könnte natürlich versuchen selbst zu partitionieren (wie meine vorherige 12.3 Version mit ext4)
Genau das solltest du tun. Für den privaten Bereich ist das IMHO sinnvoller, als sich mit den Eigenheiten von btrfs herumzuschlagen. Es sei denn, man interessiert sich dafür und will sich dort einzuarbeiten. Das nimmt allerdings eine gewisse Zeit in Anspruch, und man sollte es wohl auch nicht an seinem "Produktivsystem" ausprobieren.
Salü vom Rainer Juhser
_________________________
Bist du neu - guckst du hier:
Neu im Linux-Club?...Bitte LESEN! == Bedienungsanleitung Forum == Hilfe zu Antworten aus dem Forum
== WISSEN PUR: Linupedia - das Linux-Club WIKI!

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1952
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von gehrke » 30. Dez 2014, 15:53

Rainer Juhser hat geschrieben:
kzeitler hat geschrieben:Ich könnte natürlich versuchen selbst zu partitionieren (wie meine vorherige 12.3 Version mit ext4)
Genau das solltest du tun. Für den privaten Bereich ist das IMHO sinnvoller, als sich mit den Eigenheiten von btrfs herumzuschlagen.
Hhmm. Ich denke auch, dass man sich durchaus selbst über eine geeignete Partitionierung Gedanken machen sollte. Aber ich sehe keinen Zusammenhang zwischen der Default-Partitionierung des Installers mit BTRFS und dem hier beschriebenen Problem. Dementsprechend habe ich Zweifel, ob ein Wechsel bei der Partitionierung exakt dieses konkrete Problem beheben wird.

Es sei denn, der TE erzeugt in diesem Zuge die UEFI-Partition manuell oder verändert die Settings oder läßt den Bootloader an eine andere Stelle und in einem anderen Format schreiben. Aber das ist dann nur bedingt ein Thema der Partitionierung und schon gar nicht von BTRFS.

Aber ich bin nicht allwissend und BTRFS wäre natürlich auch noch mal so ein Kandidat. Wo siehst Du da konkret einen Zusammenhang?

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5339
Registriert: 23. Sep 2008, 17:09

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von josef-wien » 30. Dez 2014, 17:29

kzeitler sollte einmal grundlegende Informationen liefern: UEFI ja/nein, GPT ja/nein, secure boot ja/nein, wird bei UEFI-Boot auch die UEFI-Installationsroutine (das ist das Boot-Menü mit drei Auswahlmöglichkeiten) gestartet?

P. S.
kzeitler hat geschrieben:auf meinem Laptop
Bei hier üblichen Plattengrößen sehe ich bei xfs noch mehr Nachteile als bei Riesen-Platten. btrfs würde ich nur dann verwenden, wenn die speicherplatzfressende snapshot-Möglichkeit gewünscht ist.

kzeitler
Newbie
Newbie
Beiträge: 42
Registriert: 15. Sep 2011, 23:34

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von kzeitler » 30. Dez 2014, 19:05

josef-wien hat geschrieben:kzeitler sollte einmal grundlegende Informationen liefern: UEFI ja/nein, GPT ja/nein, secure boot ja/nein, wird bei UEFI-Boot auch die UEFI-Installationsroutine (das ist das Boot-Menü mit drei Auswahlmöglichkeiten) gestartet?
Sorry ich bin da leider nicht up-to-date. Ich habe zwar schon von UEFI, GPT und Secure Boot gehört, aber davon noch nichts benutzt. UEFI-Boot sagt mir nichts. ich versuche mich gerade da etwas schlauer zu machen, aber das wird wohl etwas dauern. UEFI war im BIOS disabled und ich denke, damit sollte man die vormals übliche Installationsprozedur durchführen können.
Leider gibt's nur noch GRUB2 (und GRUB-uefi), so daß ich keinen anderen (älteren) Boot Loader ausprobieren kann.
Bei der Boot Loader Config, gibt's ja ein paar Optionen (Boot from MBR, boot from root partition, Boot from ext partition), sowie "Set active flag" und "Write generic boot code to MBR". Da habe ich jetzt so ziemlich alle Varianten
durchporobiert, aber nichts funktioniert, d.h. entweder gibt's die nichtssagende Fehlermeldung "error occurred during boot loader installation" oder aber es gint keine Fehlermeldung, jedoch bootet die Kiste nicht mehr.

Dann habe ich als nächstes UEFI im BIOS enabled und das gleiche Spielchen nochmal durchgeführt, aber das Ergebnis ist das gleiche.

kzeitler
Newbie
Newbie
Beiträge: 42
Registriert: 15. Sep 2011, 23:34

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von kzeitler » 30. Dez 2014, 19:55

als nächstes habe ich das ganze komplizierte Partition Setup rausgeschmissen und wie bisher 3 ext4 Partitions + Swap angelegt (/, /boot, /home und swap) und schon hat's problemlos geklappt.
Das würde mir eigentlich reichen, aber ich bin auch gerne bereit, das ganze mit etwas Unterstützung noch etwas genauer zu untersuchen. Es wäre schon wichtig zu wissen, was da beim Default Setup
schiefgeht. Wichtig wäre ja vor allem auch eine bessere Fehlerbeschreibung, aber da habe ich nichts gefunden (Details oder ewtwas ähnliches).

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von linux-freund » 30. Dez 2014, 21:06

Möchte an dieser Stelle anmerken das ich das jetzt schon mehrmals gehört habe mit dieser "error occurred during boot loader installation"-Meldung bei der Installation von openSUSE13.2!
Auch ich hatte dieses Problem bei der Installation von openSUSE13.2 auf meinem Laptop mehrere Male hintereinander!
Ich habe die Installation dann einfach solange wiederholt bis es endlich geklappt hat!
Könnte das ein bug sein??
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Benutzeravatar
Rainer Juhser
Moderator
Moderator
Beiträge: 3895
Registriert: 14. Aug 2006, 17:03
Wohnort: 04711 Münchhausen

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von Rainer Juhser » 31. Dez 2014, 00:23

gehrke hat geschrieben:Wo siehst Du da konkret einen Zusammenhang?
Einen direkten Zusammenhang sehe ich da (auch aufgrund mangelnder eigener Erfahrung) nicht. Ich habe nur die Rezensionen zur 13.2 (u.a. Kofler) einigermaßen aufmerksam verfolgt und bin außerdem ein Freund von KISS. Inzwischen hat Robi hier etwas sehr passendes dazu geschrieben.
Salü vom Rainer Juhser
_________________________
Bist du neu - guckst du hier:
Neu im Linux-Club?...Bitte LESEN! == Bedienungsanleitung Forum == Hilfe zu Antworten aus dem Forum
== WISSEN PUR: Linupedia - das Linux-Club WIKI!

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1952
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: Neuinstallation 13.2: error occurred during boot loader

Beitrag von gehrke » 31. Dez 2014, 09:24

linux-freund hat geschrieben:Möchte an dieser Stelle anmerken das ich das jetzt schon mehrmals gehört habe mit dieser "error occurred during boot loader installation"-Meldung bei der Installation von openSUSE13.2!
Auch ich hatte dieses Problem bei der Installation von openSUSE13.2 auf meinem Laptop mehrere Male hintereinander!
Ich habe die Installation dann einfach solange wiederholt bis es endlich geklappt hat!
Könnte das ein bug sein??
Ein Bug?

Tja, ich hatte auch so ein Erlebnis, allerdings bekomme ich die genauen Umstände nicht mehr aus meinem altersschwachen Gedächtnis und muss meine nun folgenden Aussagen durchaus in Frage stellen! Das musste damals schnell gehen und passierte auf mir suspekter Hardware. Das ist schon 2 Monate her und ich gehöre auch schon zum Club der alten Säcke, also sorry, dass es so vage ist...

Am 6. Nov 2014, 22:04 schrieb ich zum Thema 'Qualität OpenSUSE 13.2?' (http://forum.linux-club.de/viewtopic.php?f=89&t=119649):
gehrke hat geschrieben:nach 3 Tagen des Testens von OpenSUSE 13.2 frage ich mich, ob das tatsächlich ernst gemeint sein kann. Entweder habe ich mit dem für den Test verwendeten Notebook komplett ins Klo gegriffen oder die Software ist zu unreif.

Es gab Probleme mit dem Installer bei der Partitionierung, [...]
Ich erinnere mich, dass ich beim ersten Versuch auf ein Problem mit dem Bootloader bei einer Partitonierung bestehend aus LVM+LUKS (mein persönlicher Standard seit Jahren) und BTRFS+XFS als neuem Spielzeug gestossen bin. Letztlich startete die Büchse nicht, das weiß ich wenigstens noch. Ich habe dem keine größere Bedeutung beigemessen und bin dem nicht nachgegangen und habe stattdessen die Installation wiederholt. Ob ich in diesem Zuge Änderungen am UEFI bzw. MBR/GPT oder dem Ziel des Bootloaders gemacht habe, weiß ich leider nicht mehr.

Seitdem habe ich exakt damit keine Probleme mehr, bei einer zweiten Installation auf anderer Hardware gab es keinerlei Probleme. Beide Systeme booten problemlos, eins davon auch im DualBoot-Modus zusammen mit Windows, aber ohne UEFI.

Keine Ahnung ob das jetzt eher hilft oder verwirrt...

Antworten