Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Update hängt... soll ein package removen wie ???

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
chris-sneth
Newbie
Newbie
Beiträge: 42
Registriert: 31. Jan 2006, 13:04
Wohnort: wolfsburg

[gelöst] Update hängt... soll ein package removen wie ???

Beitrag von chris-sneth » 18. Jun 2014, 18:11

hallo
wie kann ich package sssd-32bit 1.9.5 3.1.3 entfernen ???
selbst mit Yast habe ich das versucht es ging nicht

Code: Alles auswählen

Package Installation Failed
Error Message: Installation aborted by user.
Packages
Removed Packages: 2
sssd-32bit, sssd-32bit
Statistics
Elapsed Time: 00:17
Details
Installation log
kann ich da noch was retten

Code: Alles auswählen

zypper ve 
gibt folgendes aus ...
Loading repository data...
Reading installed packages...
The following package is going to be REMOVED:
  sssd-32bit 
1 package to remove.
After the operation, 59.5 KiB will be freed.
Some of the dependencies of installed packages are broken. In order to fix these dependencies, the following actions need to be taken:
Continue? [y/n/? shows all options] (y): y
(1/1) Removing sssd-32bit-1.9.5-3.1.3 .........................................................[error]
Removal of (52653)sssd-32bit-1.9.5-3.1.3.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package sssd-32bit-1.9.5-3.1.3.x86_64 is not installed
wie führe ich das Update nun korrekt durch ???
:???:
warum sagt er aber bei Update durchführen: Removing a protect system package is not allowed ???
das sollte ich doch auch nicht tun ???

bitte helfen !!!
Zuletzt geändert von chris-sneth am 19. Jun 2014, 18:46, insgesamt 5-mal geändert.
--------------------------------------------
do aliens have e - patents ?
----~~~~~----zzzzwwwosch
--------------------------------------------

Werbung:
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2101
Registriert: 24. Okt 2005, 14:04

Re: Update hängt... soll ein package removen wie ???

Beitrag von Heinz-Peter » 18. Jun 2014, 18:33

Mehr Info bitte. Was geben denn: => http://forum.linux-club.de/viewtopic.ph ... 28#p756428

Grüße Heinz-Peter
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

Sauerland
Guru
Guru
Beiträge: 3562
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Update hängt... soll ein package removen wie ???

Beitrag von Sauerland » 18. Jun 2014, 18:37

Als root:

Code: Alles auswählen

rpm --rebuilddb

Code: Alles auswählen

zypper clean -a

Code: Alles auswählen

zypper ref

Code: Alles auswählen

zypper rm sssd-32bit
Und danach einmal zeigen, was da installiert ist:

Code: Alles auswählen

zypper se -si sssd
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

chris-sneth
Newbie
Newbie
Beiträge: 42
Registriert: 31. Jan 2006, 13:04
Wohnort: wolfsburg

Re: Update hängt... soll ein package removen wie ???

Beitrag von chris-sneth » 18. Jun 2014, 19:37

also ...

Code: Alles auswählen

cat /etc/*-release gibt aus:
openSUSE 13.1 (x86_64)
VERSION = 13.1
CODENAME = Bottle
# /etc/SuSE-release is deprecated and will be removed in the future, use /etc/os-release instead
NAME=openSUSE
VERSION="13.1 (Bottle)"
VERSION_ID="13.1"
PRETTY_NAME="openSUSE 13.1 (Bottle) (x86_64)"
ID=opensuse
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:opensuse:13.1"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://opensuse.org/"
ID_LIKE="suse"

Code: Alles auswählen

uname -a
sagt:
Linux x1-6-60-a4-4c-31-c0-bd 3.11.10-11-desktop #1 SMP PREEMPT Mon May 12 13:37:06 UTC 2014 (3d22b5f) x86_64 x86_64 x86_64 GNU/Linux 

Code: Alles auswählen

zypper lr -Pu
# | Alias                     | Name                               | Enabled | Refresh | Priority | URI                                                            
--+---------------------------+------------------------------------+---------+---------+----------+----------------------------------------------------------------
1 | ftp.gwdg.de-suse          | Packman Repository                 | Yes     | Yes     |   99     | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/       
2 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes     |   99     | http://download.opensuse.org/debug/distribution/13.1/repo/oss/ 
3 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | http://download.opensuse.org/debug/update/13.1/                
4 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | http://download.opensuse.org/debug/update/13.1-non-oss/        
5 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/13.1/repo/non-oss/   
6 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/13.1/repo/oss/       
7 | repo-source               | openSUSE-13.1-Source               | No      | Yes     |   99     | http://download.opensuse.org/source/distribution/13.1/repo/oss/
8 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.1/                      
9 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.1-non-oss/      
und dann las letztes zypper lu:

Code: Alles auswählen

zypper lu
Loading repository data...
Reading installed packages...
S | Repository                   | Name              | Current Version      | Available Version    | Arch  
--+------------------------------+-------------------+----------------------+----------------------+-------
v | openSUSE-13.1-Update         | dhcp              | 4.2.5.P1-0.6.5.1     | 4.2.5.P1-0.6.9.1     | x86_64
v | openSUSE-13.1-Update         | dhcp-client       | 4.2.5.P1-0.6.5.1     | 4.2.5.P1-0.6.9.1     | x86_64
v | openSUSE-13.1-Update-Non-Oss | flash-player      | 11.2.202.359-50.1    | 11.2.202.378-54.1    | x86_64
v | openSUSE-13.1-Update-Non-Oss | flash-player-kde4 | 11.2.202.359-50.1    | 11.2.202.378-54.1    | x86_64
v | openSUSE-13.1-Update         | libgudev-1_0-0    | 208-19.1             | 208-23.3             | x86_64
v | openSUSE-13.1-Update         | libudev1          | 208-19.1             | 208-23.3             | x86_64
v | openSUSE-13.1-Update         | libudev1-32bit    | 208-19.1             | 208-23.3             | x86_64
v | Packman Repository           | libx264-142       | 0.142svn20140321-2.4 | 0.142svn20140321-2.5 | x86_64
v | openSUSE-13.1-Update         | systemd           | 208-19.1             | 208-23.3             | x86_64
v | openSUSE-13.1-Update         | systemd-32bit     | 208-19.1             | 208-23.3             | x86_64
v | openSUSE-13.1-Update         | systemd-sysvinit  | 208-19.1             | 208-23.3             | x86_64
v | openSUSE-13.1-Update         | udev              | 208-19.1             | 208-23.3             | x86_64
ist das korrekt ???
und als Nächstes habe ich rpm --rebuilddb, zypper clean -a und zypper ref aufgerufen.
aber

Code: Alles auswählen

zypper rm sssd-32bit meldet:
PackageKit is blocking zypper. This happens if you have an updater applet or other software management application using PackageKit running.
Tell PackageKit to quit? [yes/no] (no): no
System management is locked by the application with pid 5477 (/usr/lib/packagekitd).
Close this application before trying again.
also müsste ich diesen Prozess oder Thread stoppen.: ps mit kill ???
wie geht das ??
Zuletzt geändert von chris-sneth am 19. Jun 2014, 18:48, insgesamt 2-mal geändert.
--------------------------------------------
do aliens have e - patents ?
----~~~~~----zzzzwwwosch
--------------------------------------------

chris-sneth
Newbie
Newbie
Beiträge: 42
Registriert: 31. Jan 2006, 13:04
Wohnort: wolfsburg

Re: Update hängt... soll ein package removen wie ???

Beitrag von chris-sneth » 19. Jun 2014, 17:16

hallo
habe die Terminal-Befehle ausgeführt
1.

Code: Alles auswählen

rpm --rebuilddb
das hat er gemacht ...

2.

Code: Alles auswählen

zypper clean -a
All repositories have been cleaned up.
3.

Code: Alles auswählen

zypper ref
liefert ->

Code: Alles auswählen

zypper ref
Retrieving repository 'Packman Repository' metadata .......................................................................................[done]
Building repository 'Packman Repository' cache ............................................................................................[done]
Retrieving repository 'openSUSE-13.1-Non-Oss' metadata ....................................................................................[done]
Building repository 'openSUSE-13.1-Non-Oss' cache .........................................................................................[done]
Retrieving repository 'openSUSE-13.1-Oss' metadata ........................................................................................[done]
Building repository 'openSUSE-13.1-Oss' cache .............................................................................................[done]
Retrieving repository 'openSUSE-13.1-Update' metadata ----------------------------------------------------------------------------------------[/]
Retrieving repository 'openSUSE-13.1-Update' metadata .....................................................................................[done]
Building repository 'openSUSE-13.1-Update' cache ..........................................................................................[done]
Retrieving repository 'openSUSE-13.1-Update-Non-Oss' metadata .............................................................................[done]
Building repository 'openSUSE-13.1-Update-Non-Oss' cache ..................................................................................[done]
All repositories have been refreshed.
4.

Code: Alles auswählen

zypper rm sssd-32bit
Loading repository data...
Reading installed packages...
Resolving package dependencies...
The following 2 packages are going to be REMOVED:
  sssd-32bit sssd-32bit 
2 packages to remove.
After the operation, 118.9 KiB will be freed.
Continue? [y/n/? shows all options] (y): y
(1/2) Removing sssd-32bit-1.9.5-3.1.3 .....................................................................................................[done]
(2/2) Removing sssd-32bit-1.9.6-3.5.3 .....................................................................................................[done]
x1-6-60-a4-4c-31-c0-bd:~ # zypper se -si sssd

Code: Alles auswählen

zypper se -si sssd
Loading repository data...
Reading installed packages...

S | Name | Type    | Version     | Arch   | Repository          
--+------+---------+-------------+--------+---------------------
i | sssd | package | 1.9.6-3.5.3 | x86_64 | openSUSE-13.1-Update
also danke für die Zypper-Tips, denn jetzt hat er das so gemacht !!! :D
falls da noch was nicht stimmt, sagt es mir.

Jetzt brauche ich nur noch 3D Power für meine ATI Radeon Karte, ob es mit dem Linux ATI-Catalyst geht.
Wozu hab ich die sonst !!! :irre:
--------------------------------------------
do aliens have e - patents ?
----~~~~~----zzzzwwwosch
--------------------------------------------

Sauerland
Guru
Guru
Beiträge: 3562
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Update hängt... soll ein package removen wie ???

Beitrag von Sauerland » 19. Jun 2014, 17:53

Jetzt brauche ich nur noch 3D Power für meine ATI Radeon Karte, ob es mit dem Linux ATI-Catalyst geht.
Neues Problem, neuer Beitrag.
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Antworten