Wo issen die Suse 13.1-NET.iso???

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Justaff
Hacker
Hacker
Beiträge: 279
Registriert: 28. Mär 2008, 22:59
Wohnort: BaWü

Wo issen die Suse 13.1-NET.iso???

Beitrag von Justaff » 30. Nov 2013, 06:30

Hi,

ich hab ja in den vergangen Wochen so manches erlebt, was mich an meinem Verstand hat zweifeln lassen. Aber das, was ich grade erlebt habe, schlägt wirklich dem Fass den Boden aus.

Um es kurz zu machen: Ich habe mir von der offiziellen Suse-Quelle die Datei openSUSE-13.1-NET-i586.iso runtergeladen und hab die sha1-Summe geprüft. Alles OK. Dann hab ich die iso mit dd_rescue auf eine CFII-Karte geladen und auch dort wieder die sha1-Summe geprüft. Wieder alles OK.

Als ich dann jedoch den Rechner von der CFII-Karte boote, meldet sich die Installationroutine von Suse 11.4!!!!!!!!!!!!

Soweit alles verstanden?

Ich hab die ISO nochmals runtergeladen und das ganze Prozedere wiederholt - mit dem gleichen Ergebnis.

Ich finds ja nett, daß die gute alte Version 11.4 so nochmal unter die Leute gebracht wird. Aber woher bekomm ich jetzt die richtige openSUSE-13.1-NET-i586.iso?????

Dank im voraus
Gruß Justaff
4x 2.4GHz :D :-) 4GB, IDE 300 GB, SATA II/III 1TB, DVD, Suse 11.4
defekter Fuji AMILO LI 1718,Celeron 1,6GHz,2GB,250GB, RTL-8139/C/C+, AR242x802.11abg WLAN, Suse 11.4, 10.3 & XP Home,
extern: 500GB, FRITZ!Box 6360 Cable,FritzUsb Stick N, 802.11a+n

Werbung:
Justaff
Hacker
Hacker
Beiträge: 279
Registriert: 28. Mär 2008, 22:59
Wohnort: BaWü

Re: Wo issen die Suse 13.1-NET.iso???

Beitrag von Justaff » 30. Nov 2013, 08:24

Das Ganze is noch schlimmer, denn der gleiche Effekt tritt auch bei der Suse13.1-Gnome-LiveCD auf!!! Das frappierende daran: die Prüfsummen stimmen mit denen der angeblichen Suse 13.1-Varianten (NET, LiveCD etc.) überein, aber es ist jedesmal die gleiche Suse 11.4-NET-Vaiante enthalten!!!
4x 2.4GHz :D :-) 4GB, IDE 300 GB, SATA II/III 1TB, DVD, Suse 11.4
defekter Fuji AMILO LI 1718,Celeron 1,6GHz,2GB,250GB, RTL-8139/C/C+, AR242x802.11abg WLAN, Suse 11.4, 10.3 & XP Home,
extern: 500GB, FRITZ!Box 6360 Cable,FritzUsb Stick N, 802.11a+n

josef-wien
Guru
Guru
Beiträge: 4874
Registriert: 23. Sep 2008, 17:09

Re: Wo issen die Suse 13.1-NET.iso???

Beitrag von josef-wien » 30. Nov 2013, 11:46

Mit an Sicherheit grenzender Wahrscheinlichkeit haben die Zellen Deiner Speicherkarte jenen Status erreicht, ab dem sie nicht mehr gelöscht und somit auch nicht mehr beschrieben werden können. Der bisherige Inhalt bleibt also "auf Dauer" erhalten. Da nicht alle Zellen zum gleichen Zeitpunkt unlöschbar werden, hast Du jetzt eine Mischung aus früheren und jetzigen Schreibvorgängen. Übrigens ist
justaff hat geschrieben:die -f Option steht für "force" und is nötig, weil sonst das ziellaufwerk nicht beschrieben werden kann
nicht nur in diesem Zusammenhang keine besonders gute Idee.

Beim Prüfsummenvergleich nach dem "Schreibvorgang" sind die Daten alle noch im Hauptspeicher, somit entfällt der Lesezugriff auf die Speicherkarte. Wenn Du sie "sicher entfernst" und danach neu einsteckst, wird die Prüfsumme anders sein.

Justaff
Hacker
Hacker
Beiträge: 279
Registriert: 28. Mär 2008, 22:59
Wohnort: BaWü

Re: Wo issen die Suse 13.1-NET.iso???

Beitrag von Justaff » 30. Nov 2013, 13:37

Hi Josef:-)

Erstmal danke für die Antwort. Sorry, aber das war ganz schlecht spekuliert. Die CFII-Karte, die ich hier grade verwende, hatte - wenn es hoch kommt - gerade mal 20 Schreibzyklen hinter sich, bevor ich sie als Installationsmedium für Suse umgewidmet habe. Für Fotografie hab ich sie nur wenige Male benutzt, weil sie dafür zu klein ist. Und die SD-Karte, die ich außerdem noch verwendet habe, war fabrikneu. Ich hab sie erst vor wenigen Tagen für diesen Zweck hier aus der verschwei0ten Packung geholt.

Und dann kommen wir zu den Prüfsummen: Da gab/gibt es also je 2 iso-/sha1-Dateien, mit denen ich es zu tun hatte (die KDE-Live-Variante hab ich noch nicht ausprobiert):

Suse13.1-NET.iso <--> Suse13.1-NET.iso.sha1
Suse13.1 Gnome-Live.iso <--> Suse13.1-Gnome-Live.iso.sha1


Alle 4 Dateien hab ich mir vom Suse-Server runtergeladen und auf Festplatte gespeichert. Nach dem download hab ich die sha1sum für beide Abbilder berechnet und KEINE Fehler gegenüber den *.sha1-Dateien festgestellt. Anschließend wurden die iso's - natürlich jede für sich - mit dd_rescue auf die CFII-Karte geschrieben. Sodann wurde die sha1sum für das ganze Ziellaufwerk - hier /sdc: - berechnet und erneut mit der zugehörigen *.sha1-Datei verglichen. Auch das ergab vollständige Übereinstimmung!!

Und trotzdem kam beim Booten aus jeder der beiden iso's die gleiche Installationsroutine von Suse11.4 gekrochen!!!!

Wie willst du diese Fakten mit deiner Theorie von der - angeblich - defekten CFII-Karte in Einklang bringen???

Daß man Prüfsummen für unterschiedliche Inhalte mit wenig Aufwand so manipulieren kann, daß sie übereinstimmen, war erst vor kurzem Gegenstand öffentlicher Diskussionen. Die Prüfsumme hat, wenn es hoch kommt (sehr grob überschlägig) 40 Stellen mit jeweils 8 bit. Das ergibt einen Informationsgehalt von ca. 320 bit. Das kleinste der iso-Abbilder hat dagegen eine Länge von 247 MB, d.h. es hat einen Informationsgehalt von ca. 250 Mio * 8 bit = 2 GigaBit. Schon aus diesem krassen Mißverhältnis kannst du ersehen, wie vollkommen unmöglich es ist, den Informationsgehalt des gesamten iso-Abbildes auf so einen Winzling von Prüfsumme abzubilden. Das heißt, es gibt 2 GigaBit / 320 bit = 6,25 Mio Dateien der gleichen Länge, die die gleiche Prüfsumme haben. Meine nur sehr überschlägige Rechnung bitte ich zu entschuldigen, aber ich glaube, es wird auch so deutlich worum es geht.

Daß ich i.ü. die CFII-Karte MEHRFACH sicher aus dem System entfernt habe, versteht sich von selbst. Ich bin ja nich ganz doof :-D Aber nur dir zuliebe hab ich es grade nochmal getestet: Karte sicher entfernt, dann wieder eingesteckt und Prüfsumme berechnet. Am Ergebnis hat sich NICHTS geändert! Probier ves einfach selbst.

Übrigens: Daß da eine 11.4 unter falscher Flagge segelt, sieht man schon am Inhalt der Datei Contents auf der CFII-Karte. Da steht nämlich auch immer das Gleiche, nämlich Suse 11.4!!

Ich will keine voreiligen Schlüsse ziehen und überlasse deshalb erstmal den cracks aus diesem Forum das Feld. Nur soviel noch: Jeder, der einen USB-stick oder überflüssige Leer-DVD's hat, kann das hier ohne Probleme nachvollziehen. Einfach eine der genannten iso's auf ne bootfähige Platte schmieren und dann schauen, welches System damit installiert wird. Wozu also lange Diskussionen nach dem Motto: es kann nich sein, was nich sein darf?

Zum Vergleich:
Die Prüfsummenberechnung:
# sha1sum sdc:
4c7eed7e4fb57f66d4db07e44be4260cbf7f8307 sdc:

Der Inhalt von Datei openSUSE-13.1-GNOME-Live-i686.iso.sha1:
4c7eed7e4fb57f66d4db07e44be4260cbf7f8307 openSUSE-13.1-GNOME-Live-i686.iso
Um es nochmals ganz klar zu sagen: Die Prüfsummen sind hier nur Beiwerk. Vorrangig geht es darum, daß die iso-Abbilder andre Systeme enthalten, als ihr Name suggeriert. Darauf kommt es an.

Gruß
Justaff

Edit by admine: Schreibweise angepasst.
4x 2.4GHz :D :-) 4GB, IDE 300 GB, SATA II/III 1TB, DVD, Suse 11.4
defekter Fuji AMILO LI 1718,Celeron 1,6GHz,2GB,250GB, RTL-8139/C/C+, AR242x802.11abg WLAN, Suse 11.4, 10.3 & XP Home,
extern: 500GB, FRITZ!Box 6360 Cable,FritzUsb Stick N, 802.11a+n

josef-wien
Guru
Guru
Beiträge: 4874
Registriert: 23. Sep 2008, 17:09

Re: Wo issen die Suse 13.1-NET.iso???

Beitrag von josef-wien » 30. Nov 2013, 18:13

Justaff hat geschrieben:Jeder, der einen USB-stick oder überflüssige Leer-DVD's hat, kann

Code: Alles auswählen

... feststellen, daß openSUSE-13.1-NET-x86_64.iso mit der sha1sum
    9d5fcabfd5f01edfb62f52f3440efb0b701cc2e4 problemlos funktioniert
    (was auch auf einer mit dd bzw. dd_rescue erstellten Speicherkarte der Fall ist).
... feststellen, daß die Datei content die Version 13.1 enthält.
... feststellen, daß Du uns hier Märchen erzählst.
(Die Speicherkarte hat übrigens eine andere sha1sum, und die ist abhängig davon, ob mit dd oder dd_rescue gearbeitet wird.)

Dein Wissen über Prüfsummen ist verbesserungsbedürftig.

Ich bin draußen.
Zuletzt geändert von josef-wien am 30. Nov 2013, 19:13, insgesamt 1-mal geändert.

GastX

Re: Wo issen die Suse 13.1-NET.iso???

Beitrag von GastX » 30. Nov 2013, 19:12

josef-wien darf man nicht widersprechen. ;)

Mache doch einfach mal folgendes Test:
Überschreibe deine Speicherkarte per dd if=/dev/zero of=/dev/SPEICHERKARTE bs=512k.
Zur Kontrolle machst du ein dd if=/dev/SPEICHERKARTE of=~/SPEICHERKARTE und schaust mit einem HEX-Editor nach, ob wirklich Nullen geschrieben wurden.
Dann partitionierst & formatierst du sie neu und kopierst die Daten erneut darauf (bzw. in deinem Fall dd_rescue).
Dann sollte sich doch zeigen, ob die Karte eine Macke weghat.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 4986
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Wo issen die Suse 13.1-NET.iso???

Beitrag von tomm.fa » 30. Nov 2013, 19:53

Also mit dem ISO und damit erstelltem Installationsmedium der Netzwerk-CD für i586/i686 ist alles in Ordnung. ISO heruntergeladen, Prüfsumme überprüft und passt (SHA1SUM: 4afd1bbb17efc95a1555d211bf5efe04abbb7202), per dd auf einen USB-Stock gebracht, dann am Notebook gestartet, Installationsroutine für openSUSE 13.1 startet. GNOME Live folgt noch und über das KDE Live Medium (x86_64) hatte ich schon installiert.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Benutzeravatar
muck19
Hacker
Hacker
Beiträge: 512
Registriert: 21. Mär 2010, 12:20
Wohnort: 77830 Bühlertal

Re: Wo issen die Suse 13.1-NET.iso???

Beitrag von muck19 » 1. Dez 2013, 15:57

Also bei mir bringt die openSUSE-13.1-NET-i586.iso auch eine 13.1 Installation -

Gruss
Michael
vokoscreen -> Screencastprogramm für OpenSuse / Ubuntu / Debian unter
http://www.kohaupt-online.de/hp
Desktopvideos mit Ton

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste