X-Window-System, KDE, Pulse und ALSA neu installieren

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Adam_Sanders
Newbie
Newbie
Beiträge: 9
Registriert: 17. Apr 2011, 11:47

X-Window-System, KDE, Pulse und ALSA neu installieren

Beitrag von Adam_Sanders » 22. Apr 2011, 22:35

Hallo Leute.

Nachdem ich mein openSUSE auf Version 11.4 upgegradet habe, hatte ich das selbe Symtom wie hier beschrieben. In einer der Antworten hieß es, man solle das PULSE-Audio deinstallieren. Also habe ich in YaST nach den Paketen, die die Zeichenkette 'Pulse' enthalten, gesucht und deinstalliert. Damit habe ich auch das KDE und andere Dateien deinstalliert. Nach einem reboot konnte ich mich nur noch im ICE-WM anmelden, dort habe ich nach längerer probiererei YaST ausführen können. Dort habe ich im Paketmanager alles installiert was die Zechenkette 'KDE' enthielt. Jetzt kann ich mich zwar wieder im KDE anmelden, habe aber nur auf tty1 bis tt6 eine Audioausgabe, im KDE kommt nicht mal ein Testsound aus den Lautsprechern. Außerdem ist nach dieser Aktion das KDE sehr langsam; benötigt für das öffnen von Dolphin ca. 5 Minuten (das ist eins von mehreren Problemen)

Als erstes will ich folgende Komponenten restlos deinstallieren (In welcher Reihenfolge?)
- ALSA
- KDE
- PULSE-Audio
- X-Window-System

Als zweites will ich alle Repositorys ausmisten und ggf. unnötige Pakete deinstallieren.

Anschließend will ich folgende Komponenten neu installieren (In welcher Reihenfolge?)
- ALSA
- KDE
- X-Window-System

Das möchte ich alles in der Konsole (tty1) ausführen. Da ich ein Linux-Einsteiger bin, bin ich auf euere Hilfe angewiesen. Die oben aufgeführten Punkte werde ich dann in den passenden Unterforen erörtern. Nach dem erstellen der entsprechenden Postings, werde ich hier die entsprechenden Links reineditieren.

Als erstes möchte ich wissen, welche Reihenfolge Ihr für die de- und anschließende installation bevorzugt, oder ob Ihr Alternativen in der Hinterhand habt.


MfG Andy

------------
Edit: Rohfassung gegen obenstehenden Text ausgetauscht.
Edit2: Hier ist der Post für KDE und X-Window-System

Edit3: Hier ist der Post für das "SoundSetup" <== [erledigt]

Werbung:
gropiuskalle
Guru
Guru
Beiträge: 4603
Registriert: 20. Nov 2007, 15:17
Wohnort: Berlin
Kontaktdaten:

Re: X-Window-System, KDE, Pulse und ALSA neu installieren

Beitrag von gropiuskalle » 23. Apr 2011, 18:19

Also habe ich in YaST nach den Paketen, die die Zeichenkette 'Pulse' enthalten, gesucht und deinstalliert. Damit habe ich auch das KDE und andere Dateien deinstalliert.
Es gibt zwei PulseAudio-Pakete, die (weshalb auch immer) Abhängigkeiten zu verschiedenen KDE-Paketen haben, nämlich 'libpulse0' und 'libpulse-mainloop-glib0'. Diese müssen auf dem System belassen werden. Der Rest kann raus.

Ich verstehe nicht so ganz, weshalb Du erst alles deinstallieren willst - was Dir jetzt fehlt, ist der größte Teil von KDE, wozu also das komplette X-Window-System und ALSA neu installieren?

Installiere Dir doch einfach die entsprechenden KDE4-Pattern, dann musst Du auch nicht recherchieren, welche Pakete denn im einzelnen benötigt werden. Eine Übersicht über alle verfügbaren KDE4-Pattern erhältst Du so:

Code: Alles auswählen

kalle@hoppers:~> zypper se -s patterns-openSUSE-kde4
Daten des Repositorys laden ...
Installierte Pakete lesen ...

S | Name                                 | Typ   | Version    | Arch | Repository
--+--------------------------------------+-------+------------+------+-----------
i | patterns-openSUSE-kde4               | Paket | 11.4-6.9.1 | i586 | Oss       
  | patterns-openSUSE-kde4_admin         | Paket | 11.4-6.9.1 | i586 | Oss       
i | patterns-openSUSE-kde4_basis         | Paket | 11.4-6.9.1 | i586 | Oss       
  | patterns-openSUSE-kde4_edutainment   | Paket | 11.4-6.9.1 | i586 | Oss       
  | patterns-openSUSE-kde4_games         | Paket | 11.4-6.9.1 | i586 | Oss       
  | patterns-openSUSE-kde4_ide           | Paket | 11.4-6.9.1 | i586 | Oss       
i | patterns-openSUSE-kde4_imaging       | Paket | 11.4-6.9.1 | i586 | Oss       
i | patterns-openSUSE-kde4_internet      | Paket | 11.4-6.9.1 | i586 | Oss       
  | patterns-openSUSE-kde4_laptop        | Paket | 11.4-6.9.1 | i586 | Oss       
i | patterns-openSUSE-kde4_multimedia    | Paket | 11.4-6.9.1 | i586 | Oss       
i | patterns-openSUSE-kde4_office        | Paket | 11.4-6.9.1 | i586 | Oss       
i | patterns-openSUSE-kde4_pure          | Paket | 11.4-6.9.1 | i586 | Oss       
i | patterns-openSUSE-kde4_utilities     | Paket | 11.4-6.9.1 | i586 | Oss       
i | patterns-openSUSE-kde4_utilities_opt | Paket | 11.4-6.9.1 | i586 | Oss       
  | patterns-openSUSE-kde4_xgl           | Paket | 11.4-6.9.1 | i586 | Oss       
i | patterns-openSUSE-kde4_yast          | Paket | 11.4-6.9.1 | i586 | Oss
...die mit 'i' gekenntzeichneten Pattern sind bei mir installiert, das kannst Du also durchaus als Vorschlag aufnehmen. Vermeiden solltest Du Holzhammer-Ansätze wie "alles mit 'pulse' raus, alles mit 'KDE' rein".

Edit: Ich finde es übrigens nicht so toll, dass Du dieses Problem in drei verschiedenen threads abzuhandeln versuchst. Ich werde die anderen beiden threads schließen.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast