[gelöst] Nach Upgrade auf 11.2 keine Tastatur und Maus

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
easyping
Newbie
Newbie
Beiträge: 11
Registriert: 13. Nov 2009, 14:19
Wohnort: Messelhausen

[gelöst] Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von easyping » 13. Nov 2009, 14:34

Hallo,

ich habe heute den Upgrade von openSuse 11.1 auf 11.2 per DVD vorgenommen. Der Upgrade funktionierte tatenlos.

Nur nach der Installation funktioniert die Tastatur und Maus nicht mehr, wenn die grafische Oberfläche geladen wird.
Wenn ich beim Starten von openSuse direkt in den init 3 Modus gehe funktioniert die Tastatur und Maus in der Console. Sobald ich aber in den init 5 Modus wechsel funktioniert die beiden Eingabegeräte nicht mehr.

Von einen anderem PC aus kann ich per ssh auf den PC mit openSuse 11.2 zugreifen und wieder in den Modus init 3 umschalten. Danach habe ich wieder eine Tastatur und Maus.

Ich habe auch schon versucht über sax2 die Konfiguration zu ändern, aber leider ohne Erfolg, denn sobald der X-Server gestartet wird, funktionieren Eingabegeräte nicht mehr.
Auch mit einer neu erstellten automatischen Konfiguration von sax2 ändert sich nichts.

Kann mir jemand weiterhelfen?
Zuletzt geändert von easyping am 18. Nov 2009, 16:16, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von lOtz1009 » 13. Nov 2009, 14:43

Benenn die xorg.conf mal um und starte ohne.
http://www.suse.com/relnotes/i386/openS ... en.html#04
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

easyping
Newbie
Newbie
Beiträge: 11
Registriert: 13. Nov 2009, 14:19
Wohnort: Messelhausen

Re: Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von easyping » 13. Nov 2009, 15:44

lOtz1009 hat geschrieben:Benenn die xorg.conf mal um und starte ohne.
http://www.suse.com/relnotes/i386/openS ... en.html#04
Danke für die Information, aber leider will klappt es nicht.

Noch eine Idee?

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von lOtz1009 » 13. Nov 2009, 15:46

Hmm...schau mal nach dem Start von X in die /var/log/Xorg.0.log bzw. die ~/.xsession-errors vielleicht finden sich dort Hinweise auf einen Übeltäter.
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

easyping
Newbie
Newbie
Beiträge: 11
Registriert: 13. Nov 2009, 14:19
Wohnort: Messelhausen

Re: Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von easyping » 13. Nov 2009, 16:18

lOtz1009 hat geschrieben:Hmm...schau mal nach dem Start von X in die /var/log/Xorg.0.log bzw. die ~/.xsession-errors vielleicht finden sich dort Hinweise auf einen Übeltäter.
Danke für die schnelle Antwort.

Nach dem starten von X habe ich in die beiden Dateien reingeschaut und keine Fehlermeldungen gefunden.

In der Xorg.0.log steht kurz vor dem Ende, dass das Modul XKEYBORAD, wie auch noch andere build-in Erweiterung, eingerichtet wird. Wie schon gesagt ohne Fehlermeldung.

Kann ich noch wo anders nachschauen?

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von lOtz1009 » 13. Nov 2009, 16:19

Da bin ich momentan etwas überfragt.
Werd mal den IRC und die Mailinglisten beobachten. Evtl. findet sich da was.
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

easyping
Newbie
Newbie
Beiträge: 11
Registriert: 13. Nov 2009, 14:19
Wohnort: Messelhausen

Re: Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von easyping » 16. Nov 2009, 13:21

lOtz1009 hat geschrieben:Da bin ich momentan etwas überfragt.
Werd mal den IRC und die Mailinglisten beobachten. Evtl. findet sich da was.
Vielen Dank lOtz1009 für die Hilfe.

Vielleicht helfen folgenden Informationen weiter und zwar habe ich eine virtuelle Maschine mit openSuse 11.2 erstellt mit den Default Optionen und mir ein wenig die Oberfläche angeschaut.

Da das ohne Problem lief, wollte ich nun noch eine weitere virtuelle Maschine mit openSuse 11.2 für einen Server erstellen, nur bei dieser VM verwendete ich statt einer NAT-Netzwerkkarte eine Briged-Netzwerkkarte.
Bei der automatischen Konfiguration meckert das Installation Programm herum, dass es nicht auf den Updateserver zugreifen könne, was korrekt ist, da für die neue VM das zugreifen auf das Internet in der Firewall noch nicht erlaubt ist. Deshalb lies ich das Installationsprogramm dies Fehler überspringen, in den vorherigen Version gab es ja damit auch keine Probleme.

Nur nach der Installation habe ich exakt das gleiche Problem, wie mit meinen PC, den ich upgrade habe, nur dieser PC hat Zugriff auf das Internet.

Daraufhin habe ich das durch einen zweiten Test noch einmal ausprobiert (mit Briged-Netzwerkkarte) und nach der Installation war der gleiche Fehler vorhanden.

Jetzt stellt sich mir die Frage, was läuft evtl. bei der automatischen Installation bei diesem Punkt Updateserver zusätzlich ab?
Wie könnte man am besten einen Vergleich der Konfiguration zwischen den beiden VM's durchführen, damit man die evtl. Unterschiede heraus bekommt, um den Fehler zu beseitigen?

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von lOtz1009 » 18. Nov 2009, 15:33

Evtl. hilft auch folgender Lösungsweg: http://lists.opensuse.org/opensuse-de/2 ... 01035.html
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

easyping
Newbie
Newbie
Beiträge: 11
Registriert: 13. Nov 2009, 14:19
Wohnort: Messelhausen

Re: Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von easyping » 18. Nov 2009, 16:14

lOtz1009 hat geschrieben:Evtl. hilft auch folgender Lösungsweg: http://lists.opensuse.org/opensuse-de/2 ... 01035.html
Super mit dem Lösungsweg hat es geklappt. Vielen Dank für die Unterstützung. :D

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: [gelöst] Nach Upgrade auf 11.2 keine Tastatur und Maus

Beitrag von lOtz1009 » 18. Nov 2009, 16:19

Bitte. Das erinnerte mich doch stark an dein Problem und deswegen hatte ich dort nochmal nachgehakt.

Evtl. hilft dieser Weg auch generell weiter.

Ich pinn das mal.
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste