[gelöst] PC hängt beim Herunterfahren

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

[gelöst] PC hängt beim Herunterfahren

Beitrag von Herz-von-Hessen » 12. Aug 2009, 15:15

Hallo,
nach meiner Neu-Installation (drüber über 11.0) habe ich ein Problem und bleibe mit folgender Fehlermeldung hängen und kann nur im Failsave-Modus arbeiten.
ich habe

Code: Alles auswählen

zypper up
laufen lassen. und dann den aktuellen NVIDIA Treiber über eine *run/Datei installiert.
Hier die Fehlermeldung>
root (hd1,1)
Filesystem type is ext2fs, partition type 0x83
Kernel /boot/vmlinuz-2.6.27.25-0.1-default root=/dev/disk/bz-id/ata-Maxtor-6Y
90PO_Y466SLZE-part-2 acpi=off resume=/dev/disk/by-id/ata-Maxtor-6Y160PO_Y466SLZE
-part1 splashcsilent vga=0x37
[Linux/byImage, setup=0x3000, size=0x2689c0]
initrd /boot/initrd-2.6.27.25-0.1-default
[Linux/initrd@0x37a4a000, 0x5a500d bytes]
Probing EDD (edd=off to disable)...
Hier mein aktuelles System>

Code: Alles auswählen

joerg@dhcppc1:/> uname -a
Linux dhcppc1 2.6.27.25-0.1-default #1 SMP 2009-07-01 15:37:09 +0200 x86_64 x86_64 x86_64 GNU/Linux
joerg@dhcppc1:/> kde4-config --version
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3) "release 4.10.4"
kde4-config: 1.0
so schauen die logfiles aus>
/var/log/Xorg.0.log

und so die
/etc/X11/xorg.conf
auf Hilfe hoffend....Jörg
Zuletzt geändert von Herz-von-Hessen am 27. Aug 2009, 22:30, insgesamt 5-mal geändert.
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

Werbung:
Benutzeravatar
Jägerschlürfer
Moderator
Moderator
Beiträge: 4453
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von Jägerschlürfer » 12. Aug 2009, 15:25

welche *run/Datei hast du denn installiert?
>Linux-Club Foren FAQ< >LC-Wiki< >Paketsuche<

Meine Systeme:
Desktop1: Debian 8
Desktop2: Windows 7, Debian, Aptosid, Opensuse
Notebook: Manjaro
Netbook: Windows 10

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von lOtz1009 » 12. Aug 2009, 15:30

Jedenfalls scheint der nVidia-Treiber nicht richtig installiert zu sein. Ich würde den mittels der run wieder deinstallieren, "vesa" als Treiber in der xorg.conf einrichten, dann ordentlich starten und den Treiber über das Repo einrichten.

In Zukunft große Dateiausgaben wie die Xorg.0.log bitte über einen NoPaste-Service posten, das erspart Scrollarbeit ;)
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8746
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von admine » 12. Aug 2009, 15:45

@ Herz-von-Hessen

Mal als Tipp:
Für so lange Configs, wie die xorg.conf oder log-Files ist es besser einen Nopaste-Service zu nutzen.
z.B.: http://nopaste.info/

Das liest sich entschieden besser ;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von Herz-von-Hessen » 12. Aug 2009, 18:16

Hi,
Jägerschlürfer hat geschrieben:welche *run/Datei hast du denn installiert?
Diesen hier:
NVIDIA-Linux-x86_64-185.18.31-pkg2.run
Meine 3-D Grafik arbeitet wunderbar.
lieben Gruß aus Darmstadt
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von Herz-von-Hessen » 12. Aug 2009, 18:22

Hi,
lOtz hat geschrieben:Jedenfalls scheint der nVidia-Treiber nicht richtig installiert zu sein. Ich würde den mittels der run wieder deinstallieren, "vesa" als Treiber in der xorg.conf einrichten, dann ordentlich starten und den Treiber über das Repo einrichten[/url].
Aber ich kann doch ganz normal 3-D Spiele laufen lassen.
Deinstallieren über die Installationsdatei?
lOtz hat geschrieben:In Zukunft große Dateiausgaben wie die Xorg.0.log bitte über einen NoPaste-Service posten, das erspart Scrollarbeit ;)
ja, aber hier ist es wenigstens ein Fenster im Fenster dachte das wäre ok.
Gruß aus Darmstadt
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von Herz-von-Hessen » 12. Aug 2009, 18:22

admine hat geschrieben:@ Herz-von-Hessen

Mal als Tipp:
Für so lange Configs, wie die xorg.conf oder log-Files ist es besser einen Nopaste-Service zu nutzen.
z.B.: http://nopaste.info/

Das liest sich entschieden besser ;)
verstanden ich mache das bin meinen künftigen Beiträgen :D
Wenn ich im Bootmenü (GRUB) die Option edd=off eingebe dann wird mein Linux ganz normal gestartet und das sogar bis zum KDE-Desktop.
Das muss man doch irgendwo fest eintippen können.
Habe es in der /etc/sysconfig/bootloader dazu geschrieben hat aber nichts bewirkt.
Gruß Jörg
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von revealed » 12. Aug 2009, 21:57

|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

josef-wien
Guru
Guru
Beiträge: 4874
Registriert: 23. Sep 2008, 17:09

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von josef-wien » 12. Aug 2009, 22:49

Herz-von-Hessen hat geschrieben:/etc/sysconfig/bootloader
Das ist eine Konfigurationsdatei für die YaST-Bootloader-Einrichtung.

Du mußt die Datei /boot/grub/menu.lst ändern.

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von Herz-von-Hessen » 13. Aug 2009, 15:28

josef-wien hat geschrieben:
Herz-von-Hessen hat geschrieben:/etc/sysconfig/bootloader
Das ist eine Konfigurationsdatei für die YaST-Bootloader-Einrichtung.

Du mußt die Datei /boot/grub/menu.lst ändern.
Da steht bei den Bootoptionen lediglich ACPI=off
Beim booten steht aber da noch etwas wie vga=0x037 oder ähnlich
Komischerweise bootet das System jetzt doch komplett bis zum Desktop durch, statt dessen geht er jetzt beim herunterfahren nicht mehr aus.
Dies sind die letzen Zeilen in /var/log/messages

Code: Alles auswählen

Aug 13 14:23:20 linux-xamn pulseaudio[4127]: module-alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write! Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.
Aug 13 14:23:20 linux-xamn pulseaudio[4127]: module-alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write! Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.
Aug 13 14:23:20 linux-xamn pulseaudio[4127]: module-alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write! Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.
Aug 13 14:24:29 linux-xamn polkit-grant-helper[4328]: granted authorization for org.freedesktop.packagekit.system-update to pid 4129 [uid=1000] [auth=root]
Aug 13 14:26:59 linux-xamn ntpd[3799]: synchronized to 87.139.126.233, stratum 2
Aug 13 14:26:59 linux-xamn ntpd[3799]: time reset +0.184876 s
Aug 13 14:26:59 linux-xamn ntpd[3799]: kernel time sync status change 0001
Aug 13 14:28:18 linux-xamn su: (to root) joerg on /dev/pts/1
Die Zeile mit dem ALS wiederholt sich zuvor noch zig-mal. Da scheint mein Soundproblem zu liegen.

Hier die "bereinigte" /var/log/messages aus der ich die zig-Zeilen

Code: Alles auswählen

Aug 13 14:23:20 linux-xamn pulseaudio[4127]: module-alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write! Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers
entfernt habe.
http://www.nopaste.com/p/aL3ZTTI0U
Mir fällt auf das etwa im 1-Stunden-Intervall immer wieder die gleichen Meldungen kommen. Bedeutet das was schlechtes oder ist das normal mit diesen Meldungen?
lieben Gruß aus Darmstadt
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von lOtz1009 » 13. Aug 2009, 15:34

Dein PC macht aber auch was er will oder? :D
Also kannst du jetzt ohne die edd-Option starten?
revealed hat geschrieben:hast du das hier?
viewtopic.php?f=4&t=94771&start=0
Hattest du vorher irgendwas am USB-Port angeschlossen?
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von Herz-von-Hessen » 13. Aug 2009, 16:52

lOtz hat geschrieben:Dein PC macht aber auch was er will oder? :D
irgendwie ist das schon merkwürdig, da wird man ganz :irre:
lOtz hat geschrieben:lso kannst du jetzt ohne die edd-Option starten?
Ja das geht, habe es mehrmals getan.
lOtz hat geschrieben:Hattest du vorher irgendwas am USB-Port angeschlossen?
Kann sein das der DVB-T Stick dran war, werde ich sofort mal testen......bin gleich wieder da

EDIT:
......so der PC wurde jetzt heruntergefahren und blieb hier hängen:

Code: Alles auswählen

Sending all processes the TERM signal                                      done
Sending all processes the KILL signal                                      done
The system will be halted immediately.
Master Resource Control: runlevel 0 has been                               reached
Failed services in runlevel 0:                                             alsasound
Skipped services in runlevel 0:                                            SuSEfirewall2_setup
Also liegt es dann eher nicht am belegten oder nicht belegten USB-Port. Die Maus und Tastatur ist ja ebenfalls an USB angeschlossen.
lieben Gruß aus Darmstadt

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von revealed » 13. Aug 2009, 19:47

Hallo!

Poste bitte nochmal deine:

Code: Alles auswählen

zypper sl
oder

Code: Alles auswählen

zypper lr
Eine Idee wäre jetzt erstmal nochmal zu checken ob du vielleicht nochmal:

Code: Alles auswählen

zypper dup
...tun solltest.

Falls da keine großen Kuriositäten in deinen Repos sind, dann habe ich zum test mal ein Script für dich:
# This line checks for missing files:

Code: Alles auswählen

rpm -qa | while read paketname ; do rpm --verify $paketname |grep missing; done
Das läuft je nach Rechnergeschwindigkeit so ca 10 Minuten.
Ergebnis - Falls es welche gibt, sind fehlende Dateien... Falls welche vorhanden sein sollten.

Starte YasT wähle den Filter Dateiliste in "Suche" und suche nach der fehlenden Datei. Aktualisiere das jeweilige RPM.

Wenn du das hast, dann starte nochmal YasT Softwaremanagement. Gehe dort zur "Zusammenfassung".
Lasse dir alle installierten Pakete anzeigen. Dann gibt es oben einen Feldbezeichner "Installiert verfügbar". Diesen kannst du soriteren (Aufsteigend Absteigend.) Klicke dort mindestens 2x drauf. Es sollten möglichst keine Rot hervorgehoben sein. Fall doch. Stelle diese Pakete auf verfügbare Anbieter um oder lösche die unnötiger weise vorhandenen.

Ignoriere keine Abhängigkeiten!

Wenn alles sauber ist dann nochmal

Code: Alles auswählen

rpm -qa | while read paketname ; do rpm --verify $paketname |grep missing; done
Keine missings bitte.

Und mach mal einen:

Code: Alles auswählen

touch /forcefsck
Das lässt beim nächsten Boot eine Dateisystemüberprüfung laufen.

Vielleicht hilft das!!

Gruß,

R
Zuletzt geändert von revealed am 13. Aug 2009, 20:06, insgesamt 2-mal geändert.
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von Herz-von-Hessen » 13. Aug 2009, 20:05

revealed hat geschrieben:Poste bitte nochmal deine:
Hier bitte sehr.

Code: Alles auswählen

dhcppc1:/ # zypper sl
# | Alias             | Name                               | Aktiviert | Aktualisieren | Typ
--+-------------------+------------------------------------+-----------+---------------+-------
1 | Nvidia_Repository | Nvidia Repository                  | Ja        | Ja            | rpm-md
2 | Packman           | Packman repository (openSUSE_11.1) | Ja        | Ja            | rpm-md
3 | openSUSE 11.1-0   | openSUSE 11.1-0                    | Ja        | Ja            | yast2
4 | repo-debug        | openSUSE-11.1-Debug                | Nein      | Ja            | NONE
5 | repo-non-oss      | openSUSE-11.1-Non-Oss              | Ja        | Ja            | yast2
6 | repo-source       | openSUSE-11.1-Source               | Ja        | Ja            | yast2
7 | repo-update       | openSUSE-11.1-Update               | Ja        | Ja            | rpm-md
 
revealed hat geschrieben:Eine Idee wäre jetzt erstmal nochmal zu checken ob du vielleicht nochmal zypper dup tun solltest.
Ict denn zypper update etwas anderes als zypper dup?
Gerade läuft es durch und läd einiges herunter.

lieben Gruß aus Arheilgen
Zuletzt geändert von Herz-von-Hessen am 13. Aug 2009, 20:09, insgesamt 1-mal geändert.
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von revealed » 13. Aug 2009, 20:08

OH und das Script benötigt soweit ich weiss exklusiven Zugriff auf das RPM utility also arbeite wärend es läuft besser nicht mit YasT oder zypper.

Kannst du machen!

Mach das was ich zu YasT geschrieben habe bitte auch.

Nächste Idee wäre dann von meiner Seite pulse weitestgehend zu deinstallieren. Auf ALSA zu setzen und dieses in dem Zuge ALSA nochmal neu vom Server laden und alsaconf (Soundkarte neu einrichten);

Gruß,

R

PS.: Ich war am vorigen Post noch am editieren. Lies den bitte nochmal genau ;)
PPS.: Und stecke mal alles unnötige (USB?) Zeug vom Rechner ab. Und probiere Stück für Stück nochmal. Sorry das ist schon ein bisschen Tortur jetzt. Aber du sagst er läd einiges herunter... Ich vermute deine Software könnte ein bisschen durcheinander gewesen sein.

Code: Alles auswählen

man zypper
#
-d, --build-deps-only
Install only build dependencies of specified packages
-u, --uri
Show also base URI of repositories.
-p, --priority
Show also repository priority.

Examples:

Upgrade the system using 'factory' and 'packman' repository:
$ zypper install zypper libzypp
$ zypper dup -r factory -r packman
PPPS.: Bitte berichte dann von hoffentlich schwerwiegender Besserung.
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von Herz-von-Hessen » 13. Aug 2009, 20:23

Hallo,
revealed hat geschrieben:Mach das was ich zu YasT geschrieben habe bitte auch.
ja bin mittendrin ;)
revealed hat geschrieben:Nächste Idee wäre dann von meiner Seite pulse weitestgehend zu deinstallieren.
Mit dem hatte ich irgendwie schonmal Ärger. Soll ich einfach alles was pulseaudio in der Beschreibung hat deinstallieren?
revealed hat geschrieben:PS.: Ich war am vorigen Post noch am editieren. Lies den bitte nochmal genau ;)
Ich habe schon gedacht ich hätte was an den Augen als ich meine Antwort geschrieben hatte. :???:
revealed hat geschrieben:Falls da keine großen Kuriositäten in deinen Repos sind, dann habe ich zum test mal ein Script für dich:
# This line checks for missing files:

Code: Alles auswählen

rpm -qa | while read paketname ; do rpm --verify $paketname |grep missing; done
Das läuft je nach Rechnergeschwindigkeit so ca 10 Minuten.
revealed hat geschrieben:Ergebnis - Falls es welche gibt, sind fehlende Dateien... Falls welche vorhanden sein sollten.
das ist ja ein richtiges Formelmonster. Bei Gelegenheit muss ich mir mal notieren was es genau tut.
revealed hat geschrieben:Starte YasT wähle den Filter Dateiliste in "Suche" und suche nach der fehlenden Datei. Aktualisiere das jeweilige RPM.
Wenn es eine fehlende gibt...
revealed hat geschrieben:Wenn du das hast, dann starte nochmal YasT Softwaremanagement. Gehe dort zur "Zusammenfassung".
Lasse dir alle installierten Pakete anzeigen. Dann gibt es oben einen Feldbezeichner "Installiert verfügbar". Diesen kannst du soriteren (Aufsteigend Absteigend.) Klicke dort mindestens 2x drauf. Es sollten möglichst keine Rot hervorgehoben sein.
Du meinst Versionsnummer in rot, habe mich schon gefragt warum die rot sind und andere nicht.
Ist das ein Hinweis das diese Versionen schlechte Abhängigkeiten habe. (Wenn man das so sagen kann)
revealed hat geschrieben:Ignoriere keine Abhängigkeiten!
Ja das mache ich
revealed hat geschrieben:Wenn alles sauber ist dann nochmal

Code: Alles auswählen

rpm -qa | while read paketname ; do rpm --verify $paketname |grep missing; done
Keine missings bitte.
revealed hat geschrieben:Und mach mal einen:

Code: Alles auswählen

touch /forcefsck
Das lässt beim nächsten Boot eine Dateisystemüberprüfung laufen.
Vielleicht hilft das!!
vor allem das mein PC Arbeit hat :D
bin dann mal kurz weg Abendessen rein schaufeln.
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von revealed » 13. Aug 2009, 20:26

(Wenn man das so sagen kann)
Ich glaube diese sind beispielsweise rot, wenn du...

Stell dir vor du hast so wie jetzt eher eine minimale Repo liste. Angenommen du hättest dir beispielsweise kurz das Xserver Repo eingebunden, dann Xorg aktualisiert, das Repo aber wieder gelöscht.

Dann hätten all diese Pakete die aus diesem Repo kommen keinen verfügbaren anbieter mehr. Würden in YasT dennoch angezeigt werden und zwar rot. Beispielsweise.

Wenn man viele Repos hat dann kann das zwischendrin auch mal passieren bei SVN oder Beta Paketen usw.. wenn diese downgegradet werden. Ich schau da selber öfter mal nach. Oder wenn es in einem Repo eine Bestimmte Version gab die von beispielsweise 1.3 auf 1.4 geändert wurde. Dann kann es sein dass 1.3 nicht mehr verfügbar ist. Dass man aber das 1.4 von Hand hersuchen muss weil zypper dup das nicht findet... :???:

Alles was Pulse ist -- kann man nicht deinstallieren aber man kann Pulse weitestgehend deinstallieren.
Also die libpulse musst du behalten meine ich als Abhängigkeit vieler Programme unter anderem KDE4.

Auch alsa-plugins-pulse brauchst du nicht unbedingt. Aber schau doch erstmal ob durch das dup vielleicht alles gerichtet wurde.

Man kann dann immernoch mit Kanonen auf was kleines schiessen. Also dieses "ich deinstalliere pulse" ist depracted. Ich hatte da einen Bug deswegen musste ich seither hab ich es nimmer installiert. Deswegen kam trotzdem die Idee..

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von Herz-von-Hessen » 13. Aug 2009, 21:34

Hallo,
das Marathonprogramm ist ins rollen gekommen und es sieht nicht so gut aus:

Code: Alles auswählen

dhcppc1:/ # rpm -qa | while read paketname ; do rpm --verify $paketname |grep missing; done
missing     /usr/lib64/libcucul++.so.0
missing     /usr/lib64/libcucul.so.0
missing     /var/run/smolt_do_opensuse_run
missing     /usr/lib64/libGL.so.1.2
missing     /lib/modules/2.6.27.25-0.1-default/kernel/drivers/media/dvb/cinergyT2/cinergyT2.ko
Die Suche in YAST (alles angeklickt) brachte folgende Ergebnisse:
  • libcucul++.so.0 wird nicht gefunden, libcaca0-0.99.beta16-0.pm.3 ist installiert
    libcucul.so.0 wird nicht gefunden, libcaca0-0.99.beta16-0.pm.3 ist installiert
    smolt_do_opensuse_run wird nicht gefunden, "smolt" ist installiert -> smolt-1.1.1.1-56.1 noarch von repo-update
    libGL.so.1.2 libglib-2_0-0-2.18.2-5.2.1, libglib-2_0-0-32bit-2.18.2-5.2.1 sind installiert.
    cinergyT2.ko kernel-default-extra-2.6.27.25-0.1.1 wird geefunden von repo-update
Beim Versuch alles von Pulseaudio zu deinstallieren gibt es massig Konflikte die auch noch ein Downgrade
und auch einen Anbieterwechsel von libxine und yast verlangen - da graust es mich.
werde mal versuchen erst das Hauptprogramm von Pulseaudio zu entfernen.
*schwitz*
EDIT
ich habe nun einige Teile entfernt und auch keine Abhängigkeiten ignoriert, also kaffeine und anderes down-gegradet.
Das ERgebnis dessen ist das mein gerade installiertes DVB-T wieder nicht geht da könnt ich echt am Rad drehen :zensur:
mache jetzt nochmals zypper dup -> 217mb dann starte ich den PC neu und hoffe das nicht alles im A.... ist.
lieben Gruß aus Darmstadt
Zuletzt geändert von Herz-von-Hessen am 13. Aug 2009, 21:53, insgesamt 1-mal geändert.
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von lOtz1009 » 13. Aug 2009, 21:38

libpulse0 nicht deinstallieren!!!
Daher werden deine Abhängigkeiten kommen.

BTW: ist das Problem mit dem Starten von X mittlerweile gelöst? Hier wirds gerade sehr unübersichtlich. :roll:
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: kein X nach Neuinstallation von openSUSE 11.1

Beitrag von revealed » 13. Aug 2009, 21:49

-> Dieses gibts in: "libcaca0"

Code: Alles auswählen

libcucul.so.0 und libcucul++.so.0
-> dieses wird immer wieder auftauchen (ignorieren)

Code: Alles auswählen

/var/run/smolt_do_opensuse_run 
-> Eigentlich das Paket Mesa (Wird aber vom Nvidia Treiber kommen vermutlich) (ggf. ignorieren).

Code: Alles auswählen

/usr/lib64/libGL.so.1.2 
-> Ist teil von kernel-XY-extra Davon solltest du die Finger lassen!! Das verbiegt dir sonst deine Nvidia und Webcam und TV Karten Treiber wieder:

Code: Alles auswählen

cinergyT2.ko
Falls schon geschehen musst du diese neu einbinden. Das kommt übrigens glaube ich daher dass du dir dvb? selbst gebaut hast für deinen USB Dongel.
libpulse0 nicht deinstallieren!!!
Daher werden deine Abhängigkeiten kommen.
Unbedingt! Darauf achten!

Diese kannst du nicht löschen.

Entschuldigung bitte. Wegen der Übersichtlichkeit und Themenabweichung ist wohl meine Schuld. Aber da scheint grundsätzlich was schepps gewesen zu sein.

Wenn du das mal grad fertig hast... zeige bitte noch:

Code: Alles auswählen

rpm -qa | grep kernel
Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste