[gelöst] Opensuse 11.1 hängt beim Booten nach Online-Update

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

T-B-R
Newbie
Newbie
Beiträge: 3
Registriert: 26. Mai 2009, 14:22

[gelöst] Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von T-B-R » 28. Mai 2009, 12:33

Hallo,

ich habe vor kurzem mein opensuse 11.1 komplett neu aufgesetzt (hab vorher einfach zuviel mit KDE4 experimentiert...) und stehe jetzt vor dem Problem, dass, nach Einspielen aller Updates, das System beim Booten hängt. Das ganze passiert, soweit ich erkennen kann, beim Punkt "DHCP starten". Der Bildschirm wird dann schwarz und es passiert gar nichts mehr.

Wenn ich per Live-DVD eine Reparatur anstoßen will, so wird gemeldet, dass keine root-Partition gefunden werden kann!? Ich benutze zur Partitionierung LVM und Neuinstallationen waren bisher keine Probleme und habe auch bei der aktuellen Neuinstallation die Einhängepunkte korrekt importieren können. Root und /boot sind sind formatiert worden und das System lief bis zur Aktualisierung stabil und ohne Probleme.

Da ich bisher ein aktuelles opensuse 11.1 am Laufen hatte, denke ich, dass es mit einem neueren Patch zusammenhängt.

Ist dieses Problem schon jemandem aufgefallen, bzw. welche Angaben kann ich zu einer Lösung beitragen.

Beste Grüße!

Tim
Zuletzt geändert von T-B-R am 2. Jun 2009, 14:32, insgesamt 1-mal geändert.
AMD Phenom 9850 BE
ASUS M3A78-T
Radeon HD 3300 (onboard)
4GB RAM
500GB Festplatte
Windows XP / opensuse 11.1

Werbung:
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von lOtz1009 » 28. Mai 2009, 12:37

::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von revealed » 28. Mai 2009, 17:02

Starte mal ins runlevel 3:

Beim Bootloader ist unten eine Zeile (Options) wähle den zu startenden Eintrag in Grub (SuSE).
Schreibe am ender der Zeile Options eine einfache "3" ohne Anführungszeichen von anderen Werten getrennt durch Leerzeichen.

Melde dich mit su als SU am PC an.

(Ausgehend, dass die ".omsg" die Fehlermeldungen vom vorigen Systemstart in die grafische Oberfläche beinhaltet):

Code: Alles auswählen

grep failed /var/log/boot.omsg
Schau ob da Network dabei ist..

Eine Frage... Hängt er sich wirklich auf, oder ladet er nur ewig? Schonmal 5 Minuten gewartet? Weil im Falle das rcnetwork fehlschlägt und dein rechner keine IP zugewiesen bekommt, dauert der KDE4 Start ewigst, weil der OpenSuSE Updater usw. den KDE Start verzögern (Mit schwarzem Bild) bis ein Timeout erfolgt ist.

Dann startet er normal durch. Gemäß dem Falle, dass keine Internetverbindung besteht. Also ich hab das Problem zumindest...

Falls das so sein sollte, kann ich dich mit einem Workaround versorgen.

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

gdsle
Newbie
Newbie
Beiträge: 14
Registriert: 11. Jan 2007, 18:42

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von gdsle » 1. Jun 2009, 07:13

Hallo, ich habe dieses Problem auch. 11.1 und kde 4.2.3 und
hal-0.5.12-10.13.1

Weiterhin habe ich festgestellt, dass der Bildschirm bei mir schwarz bleibt, auch nach 15 Minuten. Oben links am Bildschirm ist ein _ abgebildet.
Den Lösungsvorschlag mit dem Link von lOtz habe ich ausprobiert, hat bei mir leider nciht geholfen. Wenn ich vom normalen schwarzen Startbildschirm aus ;-) in einen anderen Modus wechsle und mich dort anmelde, dann kann ich kde mit startx starten. Dauert dann zwar ca 1 Minute länger als früher, aber immerhin.

- Weiterhin habe ich festgestellt, dass ich nicht mehr auf externen Festplatten zugreifen kann. Es kommt die Meldung org.freedesktop.hal.device.permission org.freedesktop.hal.storage.mount-removeable no.
Habe in diversen Threads schon nach Lösungen gesucht, bisher hat nichts geholfen. hal-0.5.12-10.12.1 habe ich auch schon probiert.

-Zu guter letzt funktioniert auch meine Soundkarte nicht mehr. Es kommt eine Meldung von irgend einem Phonon, "Das Abspielgerät funktioniert nicht, es wird auf PulseAudio ausgewichen." Das nächste mal wird denn auf "," ausgewichen. Hier habe ich allerdings noch nichts versucht.

Ich weiss nicht, ob die 3 Punkte mit der gleichen Ursache zu begründen sind.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16597
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von whois » 1. Jun 2009, 09:03

Steht da irgendwas in den Messages?

Code: Alles auswählen

tail /var/log/messages

gdsle
Newbie
Newbie
Beiträge: 14
Registriert: 11. Jan 2007, 18:42

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von gdsle » 1. Jun 2009, 10:28

es steht ncihts wegen dem schwarzen Bildschirm, nichts wegen dem USB und den exernen Festplatten, aber

Jun 1 10:24:06 linux-6twi pulseaudio[4284]: sink-input.c: Assertion 'i->thread_info.rewrite_nbytes == 0' failed at pulsecore/sink-input.c:1144, function pa_sink_input_request_rewind(). Aborting.

beim Sound drin

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16597
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von whois » 1. Jun 2009, 10:37

Ich kann mir zwar nicht vorstellen das dies alles an Pulse liegt aber stell doch mal auf Alsa um.

gdsle
Newbie
Newbie
Beiträge: 14
Registriert: 11. Jan 2007, 18:42

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von gdsle » 1. Jun 2009, 11:30

ich habe nun folgendes gemacht, ohne auf alsa umzusteigen:

als root eingestiegen: --> Sound funktionierte

Computer abgestellt und im failsafe modus hochgefahren.
Der Startbildschirm kommt (ganz normal) und ich kann mich einloggen.
Der Sound funktioniert und ich kann sogar externe Festplatten und USB Sticks mounten und darauf schreiben. Welche Option im Failsafe Modus für das ganze verantwortlich ist weiss ich nicht, versuche ich aber noch rauszufinden.
Gefühlsmässig läuft die Sache mit dem failsafe Modus viel runder und schneller

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16597
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von whois » 1. Jun 2009, 11:36

Verstehe ich zwar ehrlich gesagt nicht aber lege dir doch mal einen anderen User an und logge dich damit ein.
Dann kannst du sehen ob es wirklich nur am WM bzw. Pulse liegt.

gdsle
Newbie
Newbie
Beiträge: 14
Registriert: 11. Jan 2007, 18:42

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von gdsle » 1. Jun 2009, 12:15

ehrlich gesagt versteh ich es auch nicht.

wenn ich im normalen Modus hochfahre, kommt der schwarze Bildschirm, ich wechsle mit CTR-ALT-2 und kann mich aber da einloggen und den kde hochfahren, mit der Konsequenz kein Sound und kein externe Festplatte usw..
da hilft auch kein neuer user

im Failsafe Modus fährt alles hoch wie normal, das einzige was nicht funktioniert ist die Tastatur. Es ist im yast zwar schweiz und de eingestellt, aber tippen tuts amerikanisch. Kann ich im yast umstellen, aber nur für diese Sitzung. Beim nächsten mal hochfahren tippts wieder amerikanisch...
Da er im normalen Modus gar nicht bis zum Startbildschirm kommt, vermute ich, dass eine der Failsafe optionen für meine Schüssel wichtig ist.
Habe sowas noch nie gehabt, strange ;-)

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von revealed » 1. Jun 2009, 13:13

Hi!

Wenn du im Zeilenmodus bist und dich angemeldet hast. Nur interessehalber. Was sagt:

Code: Alles auswählen

rcnetwork status
Weil das Problem klingt doch dezent anders muss ich zugeben.

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

gdsle
Newbie
Newbie
Beiträge: 14
Registriert: 11. Jan 2007, 18:42

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von gdsle » 1. Jun 2009, 13:28

es kommt die Meldung:

das Programm rcnetwork ist nicht verfügbar in paket sysconfig
der absolute pfad für rcnetwork ist /sbin/rcnetwork daher wird davon ausgegangen dass es mit root rechten gestartet werden soll.

aha

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von revealed » 1. Jun 2009, 13:32

Hi!

Sorry! Ich meinte:

Code: Alles auswählen

sudo /sbin/rcnetwork status
oder ähnlich. Du benötigst dafür die entsprechende berechtigung.

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

gdsle
Newbie
Newbie
Beiträge: 14
Registriert: 11. Jan 2007, 18:42

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von gdsle » 1. Jun 2009, 13:43

es steht

eth0 device: VIA Technologies, Inc. VT6105M RhineIII rev 96
eth0 DHCP4 Client (dhcpcd) is running
eth0
eth0 IP Address 192.168.0.2/24
etho IP Address 192.168.0.2/24
eth0 running
Checking mandatory interfaces:
lo
lo IP address 127.0.0.1/8 running
secondary lo IP address: 127.0.0.2/8 running
lo
checking service network.........

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von revealed » 1. Jun 2009, 13:45

Bleibt er da hängen? oder steht da:

Code: Alles auswählen

Checking service network .  .  .  .  .  .  .  .  .  .  .                                          running
Wenn da running steht, bin ich raus.

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

gdsle
Newbie
Newbie
Beiträge: 14
Registriert: 11. Jan 2007, 18:42

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von gdsle » 1. Jun 2009, 13:49

sorry,

es steht beim untersten lo running
und bei checking service network running

habe das beim abtippen vorhin vergessen

sowohl im failsafe mode und im normalen mode
Zuletzt geändert von gdsle am 1. Jun 2009, 13:53, insgesamt 1-mal geändert.

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von revealed » 1. Jun 2009, 13:52

Kannst du noch schauen, ob ich sehe du tippst das ab?

Du müsstest das nicht abtippen erstmal. Schau mal nur ob dabei Zeilen ausgegeben werden:

Code: Alles auswählen

grep EE /var/log/Xorg.0.log

Code: Alles auswählen

grep EE /var/log/Xorg.0.log.old
Diese:

Code: Alles auswählen

        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
Kommt dabei immer! Wenn es mehr sein sollten, dann muss man da ein Auge drauf werfen.

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

gdsle
Newbie
Newbie
Beiträge: 14
Registriert: 11. Jan 2007, 18:42

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von gdsle » 1. Jun 2009, 14:06

es kommt:

lo IP address: 127.0.0.1/8
secondary lo IP address: 127.0.0.2/8
lo running
Checking service network . . . . . . . . . . . running

weiterhin:
im failsafe modus kommt

grep EE /var/log/Xorg.0.log und log.old
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER

im normal modus kann ich erst später schaun

ist da dann überhaupt ein unterschied? also normal und failsafe?

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von revealed » 1. Jun 2009, 14:11

Hi

... der Fehler im Failsafe Modus interessiert mich dabei weniger. Die vom normalen Systemstart umso mehr.

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

gdsle
Newbie
Newbie
Beiträge: 14
Registriert: 11. Jan 2007, 18:42

Re: Opensuse 11.1 hängt beim Booten nach Online-Update

Beitrag von gdsle » 1. Jun 2009, 14:15

ich werde später wieder da sein, muss nun meine Arbeit fertig machen und das geht nur in failsafe. Melde mich dann später wieder. Danke für die Hilfe
Gruss
G

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste