Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Probleme mit Libreoffice Base

Alles rund um Büroanwendungen, Bildungsprogramme und Spiele unter Linux

Moderator: Moderatoren

Antworten
edgarkls
Hacker
Hacker
Beiträge: 548
Registriert: 27. Jan 2005, 15:59
Wohnort: manchester
Kontaktdaten:

Probleme mit Libreoffice Base

Beitrag von edgarkls »

Seit Libreoffice 7.0 (und allen folgenden Versionen) weigert sich Base unter Tumbleweed, existierende Datenbanken zu öffnen. Die einzige Ausnahme ist die mitgelieferte Literaturdatenbank. Die Fehlermeldung ist:
Es wurde kein SDBC-Treiber für die URL 'sdbc:embedded:firebird' gefunden. /home/abuild/rpmbuild/BUILD/libreoffice-7.1.1.2/connectivity/source/commontools/dbexception.cxx:399
Neues Profil anlegen hat nichts genutzt. Eine Google-Suche hat nur erbracht, dass auch andere OpenSuse-Nutzer (Leap und Tumbleweed) das Problem haben, aber niemand hat bisher eine Lösung gefunden.

Eine Vanilla-Version von Libreoffice 7.1.1, gerade installiert, hat das Problem nicht.
Sauerland
Guru
Guru
Beiträge: 4031
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Probleme mit Libreoffice Base

Beitrag von Sauerland »

Das sind alles openSUSE Versionen bzw. von openSUSE gebaut?
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Sauerland
Guru
Guru
Beiträge: 4031
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Probleme mit Libreoffice Base

Beitrag von Sauerland »

Was sagt:

Code: Alles auswählen

java --version
sowie:

Code: Alles auswählen

zypper se -si openjdk
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
edgarkls
Hacker
Hacker
Beiträge: 548
Registriert: 27. Jan 2005, 15:59
Wohnort: manchester
Kontaktdaten:

Re: Probleme mit Libreoffice Base

Beitrag von edgarkls »

Code: Alles auswählen

java --version
openjdk 11.0.10 2021-01-19
OpenJDK Runtime Environment (build 11.0.10+9-suse-1.3-x8664)
OpenJDK 64-Bit Server VM (build 11.0.10+9-suse-1.3-x8664, mixed mode)

Code: Alles auswählen

zypper se -si openjdk
S  | Name                     | Type  | Version         | Arch   | Repository
---+--------------------------+-------+-----------------+--------+-----------------------
i+ | java-11-openjdk          | Paket | 11.0.10.0-1.3   | x86_64 | Haupt-Repository (OSS)
i+ | java-11-openjdk          | Paket | 11.0.10.0-1.3   | x86_64 | openSUSE:Tumbleweed
i+ | java-11-openjdk          | Paket | 11.0.10.0-1.3   | x86_64 | openSUSE-20210210-0
i+ | java-11-openjdk-headless | Paket | 11.0.10.0-1.3   | x86_64 | Haupt-Repository (OSS)
i+ | java-11-openjdk-headless | Paket | 11.0.10.0-1.3   | x86_64 | openSUSE:Tumbleweed
i+ | java-11-openjdk-headless | Paket | 11.0.10.0-1.3   | x86_64 | openSUSE-20210210-0
i+ | java-14-openjdk          | Paket | 14.0.2.0-1.4    | x86_64 | Haupt-Repository (OSS)
i+ | java-14-openjdk          | Paket | 14.0.2.0-1.4    | x86_64 | openSUSE:Tumbleweed
i+ | java-14-openjdk          | Paket | 14.0.2.0-1.4    | x86_64 | openSUSE-20210210-0
i  | java-14-openjdk-headless | Paket | 14.0.2.0-1.4    | x86_64 | Haupt-Repository (OSS)
i  | java-14-openjdk-headless | Paket | 14.0.2.0-1.4    | x86_64 | openSUSE:Tumbleweed
i  | java-14-openjdk-headless | Paket | 14.0.2.0-1.4    | x86_64 | openSUSE-20210210-0
i  | java-16-openjdk          | Paket | 16.0.0.0~35-1.2 | x86_64 | Haupt-Repository (OSS)
i  | java-16-openjdk          | Paket | 16.0.0.0~35-1.2 | x86_64 | openSUSE:Tumbleweed
i  | java-16-openjdk          | Paket | 16.0.0.0~35-1.2 | x86_64 | openSUSE-20210210-0
i  | java-16-openjdk-devel    | Paket | 16.0.0.0~35-1.2 | x86_64 | Haupt-Repository (OSS)
i  | java-16-openjdk-devel    | Paket | 16.0.0.0~35-1.2 | x86_64 | openSUSE:Tumbleweed
i  | java-16-openjdk-devel    | Paket | 16.0.0.0~35-1.2 | x86_64 | openSUSE-20210210-0
i  | java-16-openjdk-headless | Paket | 16.0.0.0~35-1.2 | x86_64 | Haupt-Repository (OSS)
i  | java-16-openjdk-headless | Paket | 16.0.0.0~35-1.2 | x86_64 | openSUSE:Tumbleweed
i  | java-16-openjdk-headless | Paket | 16.0.0.0~35-1.2 | x86_64 | openSUSE-20210210-0
Zuletzt geändert von gehrke am 13. Mär 2021, 12:51, insgesamt 1-mal geändert.
Grund: Bitte zukünftig <code>-Tags verwenden - https://linux-club.de/forum/viewtopic.php?f=92&t=105750
Sauerland
Guru
Guru
Beiträge: 4031
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Probleme mit Libreoffice Base

Beitrag von Sauerland »

Stell mal als root auf Java 14 oder 16 um:

Code: Alles auswählen

update-alternatives --config java
Funktioniert es dann mit Base?
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
edgarkls
Hacker
Hacker
Beiträge: 548
Registriert: 27. Jan 2005, 15:59
Wohnort: manchester
Kontaktdaten:

Re: Probleme mit Libreoffice Base

Beitrag von edgarkls »

Leider nicht. Ich glaube auch nicht unbedingt, dass das ein Java-Problem ist, denn die LO-Version, die ich von libreoffice.org heruntergeladen habe, funktioniert anstandslos. Das deckt sich mit den ergoogelten Erfahrungen anderer Nutzer, bei denen der Opensuse-build ebenfalls nicht funktioniert.
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 902
Registriert: 19. Sep 2014, 18:22

Re: Probleme mit Libreoffice Base

Beitrag von susejunky »

Hallo edgarkls,
edgarkls hat geschrieben: 13. Mär 2021, 11:19... Seit Libreoffice 7.0 (und allen folgenden Versionen) weigert sich Base unter Tumbleweed, existierende Datenbanken zu öffnen.
mit welcher Datenbank-Maschine (HSQLDB, Firebird, sqlite3) arbeiten Deine Datenbank-Dateien?

Soweit mir bekannt gab es seit LibreOffice 6.x Bestrebungen HSQLDB durch Firebird abzulösen. Das hat aber meines Wissens nicht so richtig funktioniert und wurde möglicherweise sogar wieder zurückgenommen. Möglicherweise liegt da Dein Problem.

Ist Firebird auf Deinem System installiert?

Code: Alles auswählen

# zypper se -si firebird
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name     | Type  | Version         | Arch   | Repository
--+----------+-------+-----------------+--------+------------------------
i | firebird | Paket | 3.0.7.33374-2.3 | x86_64 | openSUSE-Tumbleweed-Oss
#
Da ich ausschließlich mit mariadb arbeite, bin ich diesbezüglich nicht auf dem aktuellen Stand.

Viele Grüße

susejunky
edgarkls
Hacker
Hacker
Beiträge: 548
Registriert: 27. Jan 2005, 15:59
Wohnort: manchester
Kontaktdaten:

Re: Probleme mit Libreoffice Base

Beitrag von edgarkls »

Firebird ist installiert.

Code: Alles auswählen

S  | Name                  | Type  | Version         | Arch   | Repository
---+-----------------------+-------+-----------------+--------+-----------------------
i+ | firebird              | Paket | 3.0.7.33374-2.3 | x86_64 | Haupt-Repository (OSS)
i+ | firebird              | Paket | 3.0.7.33374-2.3 | x86_64 | openSUSE:Tumbleweed
i+ | firebird              | Paket | 3.0.7.33374-2.3 | x86_64 | openSUSE-20210210-0
i+ | firebird-examples     | Paket | 3.0.7.33374-2.3 | x86_64 | Haupt-Repository (OSS)
i+ | firebird-examples     | Paket | 3.0.7.33374-2.3 | x86_64 | openSUSE:Tumbleweed
i+ | firebird-examples     | Paket | 3.0.7.33374-2.3 | x86_64 | openSUSE-20210210-0
i+ | firebird-server       | Paket | 3.0.7.33374-2.3 | x86_64 | Haupt-Repository (OSS)
i+ | firebird-server       | Paket | 3.0.7.33374-2.3 | x86_64 | openSUSE:Tumbleweed
i+ | firebird-server       | Paket | 3.0.7.33374-2.3 | x86_64 | openSUSE-20210210-0
i  | firebird-utils        | Paket | 3.0.7.33374-2.3 | x86_64 | Haupt-Repository (OSS)
i  | firebird-utils        | Paket | 3.0.7.33374-2.3 | x86_64 | openSUSE:Tumbleweed
i  | firebird-utils        | Paket | 3.0.7.33374-2.3 | x86_64 | openSUSE-20210210-0
i+ | libobasis7.1-firebird | Paket | 7.1.1.2-2       | x86_64 | (Systempakete)
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 902
Registriert: 19. Sep 2014, 18:22

Re: Probleme mit Libreoffice Base

Beitrag von susejunky »

Hallo edgarkls,
edgarkls hat geschrieben: 13. Mär 2021, 18:07... Firebird ist installiert.
susejunky hat geschrieben: 13. Mär 2021, 17:26... mit welcher Datenbank-Maschine (HSQLDB, Firebird, sqlite3) arbeiten Deine Datenbank-Dateien
???

und zeige bitte einmal das Ergebnis von

Code: Alles auswählen

# zypper lr -uEP
Viele Grüße

susejunky
edgarkls
Hacker
Hacker
Beiträge: 548
Registriert: 27. Jan 2005, 15:59
Wohnort: manchester
Kontaktdaten:

Re: Probleme mit Libreoffice Base

Beitrag von edgarkls »

Code: Alles auswählen

#  | Alias                                  | Name                            | Enabled   | GPG Check       | Refresh        | Priority  | URI
---+----------------------------------------+---------------------------------+-----------+-----------------+----------------+-----------+--------------------------------------------------------------------------
18 | packman                                | packman                         | Ja        | (r ) Ja         | Ja             |   90      | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/
 1 | download.opensuse.org-non-oss          | Haupt-Repository (NON-OSS)      | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/tumbleweed/repo/non-oss/
 2 | download.opensuse.org-oss              | Haupt-Repository (Quellen)      | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/source/tumbleweed/repo/oss/
 3 | download.opensuse.org-oss_1            | Haupt-Repository (OSS)          | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/tumbleweed/repo/oss/
 4 | download.opensuse.org-tumbleweed       | Hauptaktualisierungs-Repository | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/update/tumbleweed/
 5 | https-download.opensuse.org-05f768e5   | openSUSE:Tumbleweed             | Ja        | (r ) Ja         | Ja             |   99      | https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/
15 | microsoft-edge-dev                     | microsoft-edge-dev              | Ja        | (r ) Ja         | Ja             |   99      | https://packages.microsoft.com/yumrepos/edge/
16 | openSUSE-20210210-0                    | openSUSE-20210210-0             | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/tumbleweed/repo/oss/
17 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository            | Ja        | (r ) Ja         | Ja             |   99      | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/
20 | teams                                  | teams                           | Ja        | (r ) Ja         | Ja             |   99      | https://packages.microsoft.com/yumrepos/ms-teams
Soweit ich weiß, arbeitet die Datenbank mit Firebird. So war es zumindest bei den vorherigen Versionen von Libreoffice. Das Problem begann mit dem Update auf 7.04 und hat sich auf alle folgenden Updates vererbt. Neuinstallation und Anlegung eines neuen Profils haben daran nichts geändert. Derzeit arbeite ich mit einer Vanilla-Installation von Libreoffice.org, die anstandslos funktioniert.
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 902
Registriert: 19. Sep 2014, 18:22

Re: Probleme mit Libreoffice Base

Beitrag von susejunky »

Hallo edgarkls,
edgarkls hat geschrieben: 13. Mär 2021, 19:46

Code: Alles auswählen

#  | Alias                                  | Name                            | Enabled   | GPG Check       | Refresh        | Priority  | URI
---+----------------------------------------+---------------------------------+-----------+-----------------+----------------+-----------+--------------------------------------------------------------------------
...
 3 | download.opensuse.org-oss_1            | Haupt-Repository (OSS)          | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/tumbleweed/repo/oss/
...
 5 | https-download.opensuse.org-05f768e5   | openSUSE:Tumbleweed             | Ja        | (r ) Ja         | Ja             |   99      | https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/
...
16 | openSUSE-20210210-0                    | openSUSE-20210210-0             | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/tumbleweed/repo/oss/
...
Das hat zwar sehr wahrscheinlich nichts mit Deinem Problem zu tun, aber ich denke Du benötigst nur eines dieser Repositories (Empfehlung: behalte 3).

Wenn Du wirklich nur mit Firebird-Dateien ein Problem hast, kann ich nur vermuten, dass sich openSUSE entschlossen hat, den (experimentellen?) Firebird-Support in den openSUSE-Paketen (ab Version 7.x?) auszubauen.

Du könntest eine Fehlermeldung unter https://bugzilla.opensuse.org/ einstellen, um konkretere Informationen zu erhalten.

Viele Grüße

susejunky
Antworten