Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

R update 3.x auf 4.x

Alles rund um Büroanwendungen, Bildungsprogramme und Spiele unter Linux

Moderator: Moderatoren

Antworten
newbie5
Newbie
Newbie
Beiträge: 1
Registriert: 3. Mär 2021, 17:02

R update 3.x auf 4.x

Beitrag von newbie5 »

Hallo,

ich bin Linux Anfänger und habe auch relativ neu R installiert. Wie ich während der Arbeit damit festgestellt habe, ist die Version 3.4.4 installiert. Darin laufen leider einige Pakete nicht, die ich benötige, weshalb ich auf eine neuere R-Version updaten wollte. Das habe ich nach dieser Anleitung getan. https://medium.com/@hpgomide/how-to-upd ... e2209409c3

Leider bekomme ich daraufhin folgendes:

Code: Alles auswählen

~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys
     
Executing: /tmp/apt-key-gpghome.XHGumYPCHd/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys

Code: Alles auswählen

~$ sudo add-apt-repository 'deb https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/'
Paketquelle ist bereits vorhanden.

Code: Alles auswählen

~$ sudo apt install r-base
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 r-base : Hängt ab von: r-base-core (>= 4.0.4-1.2004.0) aber 3.4.4-1ubuntu1 soll installiert werden
          Hängt ab von: r-recommended (= 4.0.4-1.2004.0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Ich würde mich sehr freuen wenn mir jemensch weiterhelfen kann.
Zuletzt geändert von gehrke am 3. Mär 2021, 18:28, insgesamt 1-mal geändert.
Grund: Bitte zukünftig <code>-Tags verwenden - https://linux-club.de/forum/viewtopic.php?f=92&t=105750
Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 2296
Registriert: 10. Nov 2012, 11:00

Re: R update 3.x auf 4.x

Beitrag von gehrke »

Bitte zukünftig <code>-Tags verwenden - https://linux-club.de/forum/viewtopic.php?f=92&t=105750
Dadurch werden Beiträge deutlich besser lesbar. Danke.
Keinen Bock mehr auf zentralisierte soziale Netzwerke von US-Konzernen?
Join the fediverse: https://fediverse.party/en/fediverse/ (Friendica, Mastodon, Diaspora und vieles mehr)
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4419
Registriert: 14. Jun 2004, 09:12

Re: R update 3.x auf 4.x

Beitrag von Geier0815 »

Code: Alles auswählen

apt policy r-base
bei ubuntu mit voran gestelltem "sudo", damit wir sehen können welche Repo-Priorität die Repos haben die es überhaupt anbieten. Danach mal

Code: Alles auswählen

apt policy r-base-core
um zu sehen ob die Versionen die verfügbar wären überhaupt zusammen passen. Danach sehen wir weiter
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?
Antworten