Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

gscan2pdf unter Opensuse 15.2

Alles rund um Büroanwendungen, Bildungsprogramme und Spiele unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Sendbote
Newbie
Newbie
Beiträge: 42
Registriert: 6. Feb 2014, 09:21
Wohnort: Südkorea

gscan2pdf unter Opensuse 15.2

Beitrag von Sendbote »

Vor einigen Wochen konnte ich ohne Probleme gscan2pdf auf Ubuntu 20.04 installieren. Es waren, soweit ich mich entsinnen kann, dabei kaum weitere Abhängigkeiten zu berücksichtigen. In den vergangenen Jahren hatte ich erfolglos versucht, es unter Opensuse zum Laufen zu bringen.

Im Oktober diesen Jahres nun wieder ein Versuch in Opensuse 15.2. Nach der Einrichtung des Publishing-Repositories (hier Nr. 7) - und ich hatte auch gelesen, dass "perl-modules" (hier Nr. 18) hilfreich sei, scheint nun ein Installationsvorgang möglich zu sein.

Code: Alles auswählen

~> zypper lr

#  | Alias                                   | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | URI
---+-----------------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+--------------------------------------------------------------------------------------
 1 | Bildung                                 | Bildung                                                 | Ja        | (r ) Ja         | Nein           | http://download.opensuse.org/repositories/Education/openSUSE_Leap_15.2/
 2 | GNOME Applications (openSUSE_Leap_15.1) | GNOME Applications (openSUSE_Leap_15.1)                 | Ja        | (r ) Ja         | Nein           | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_Leap_15.2/
 3 | KDE-Extra                               | KDE-Extra                                               | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_15.2/
 4 | KDE_Grafik                              | KDE_Grafik                                              | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/graphics/openSUSE_Leap_15.2/
 5 | Libreoffice                             | Libreoffice                                             | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/LibreOffice:/6.4/openSUSE_Leap_15.2/
 6 | Packman                                 | Packman                                                 | Ja        | (r ) Ja         | Nein           | http://packman.inode.at/suse/openSUSE_Leap_15.2/
 7 | Publishing                              | Publishing                                              | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/Publishing/openSUSE_Leap_15.2/
 8 | Skype                                   | Skype                                                   | Ja        | (r ) Ja         | Nein           | https://repo.skype.com/rpm/stable/
 9 | Spiele                                  | Spiele                                                  | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/games/openSUSE_Leap_15.2/
10 | Virtualisierung                         | Virtualisierung                                         | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.2/
11 | Wine                                    | Wine                                                    | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_Leap_15.2/
12 | editors                                 | editors                                                 | Ja        | (r ) Ja         | Nein           | http://download.opensuse.org/repositories/editors/openSUSE_Leap_15.2/
13 | home_Kieltux_tools                      | Tools (openSUSE_Leap_15.2)                              | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/home:/Kieltux:/tools/openSUSE_Leap_15.2/
14 | home_Lord-Master                        | home:Lord-Master (openSUSE_Leap_15.2)                   | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/home:/Lord-Master/openSUSE_Leap_15.2/
15 | home_Sauerland                          | Sauerland's Home Project (openSUSE_Leap_15.2)           | Nein      | ----            | ----           | https://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.2/
16 | home_bhwachter_emacs                    | home:bhwachter:emacs (openSUSE_Leap_15.2)               | Ja        | (r ) Ja         | Nein           | https://download.opensuse.org/repositories/home:/bhwachter:/emacs/openSUSE_Leap_15.2/
17 | openSUSE_Leap_15.2_Update               | Online updates for openSUSE Leap:15.2 (standard)        | Ja        | (r ) Ja         | Nein           | http://download.opensuse.org/update/leap/15.2/oss/
18 | perl-modules                            | perl-modules                                            | Ja        | (r ) Ja         | Ja             | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_15.2/
19 | repo-debug                              | Debug Repository                                        | Nein      | ----            | ----           | http://download.opensuse.org/debug/distribution/leap/15.2/repo/oss/
20 | repo-debug-non-oss                      | Debug Repository (Non-OSS)                              | Nein      | ----            | ----           | http://download.opensuse.org/debug/distribution/leap/15.2/repo/non-oss/
21 | repo-debug-update                       | Update Repository (Debug)                               | Nein      | ----            | ----           | http://download.opensuse.org/debug/update/leap/15.2/oss/
22 | repo-debug-update-non-oss               | Update Repository (Debug, Non-OSS)                      | Nein      | ----            | ----           | http://download.opensuse.org/debug/update/leap/15.2/non-oss/
23 | repo-non-oss                            | Non-OSS Repository                                      | Ja        | (r ) Ja         | Ja             | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/
24 | repo-oss                                | Haupt-Repository                                        | Ja        | (r ) Ja         | Ja             | http://download.opensuse.org/distribution/leap/15.2/repo/oss/
25 | repo-source                             | Source Repository                                       | Nein      | ----            | ----           | http://download.opensuse.org/source/distribution/leap/15.2/repo/oss/
26 | repo-source-non-oss                     | Source Repository (Non-OSS)                             | Nein      | ----            | ----           | http://download.opensuse.org/source/distribution/leap/15.2/repo/non-oss/
27 | repo-update                             | Hauptaktualisierungs-Repository                         | Ja        | (r ) Ja         | Ja             | http://download.opensuse.org/update/leap/15.2/oss
28 | repo-update-non-oss                     | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja             | http://download.opensuse.org/update/leap/15.2/non-oss/
29 | skype-stable                            | skype (stable)                                          | Ja        | (r ) Ja         | Ja             | https://repo.skype.com/rpm/stable/
Allerdings nur unter der Bedingung, dass eine scheinbar unendlich lange Reihe anderer Programme zusätzlich installiert werden muss.

Den folgenden Konsolenausdruck, der überwiegend aus Perl- und Tex-Programmpaketen besteht, musste ich kürzen, denn eine vollständige Wiedergabe wäre in diesem Post nicht möglich gewesen. Überlänge!

Code: Alles auswählen

install:/home/marc # zypper in gscan2pdf 
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Paketabhängigkeiten werden aufgelöst...
...
...
...
...
...

Die folgenden 2240 NEUEN Pakete werden installiert:

2240 neue Pakete zu installieren.
Gesamtgröße des Downloads: 857,6 MiB. Bereits im Cache gespeichert: 0 B. Nach der Operation werden zusätzlich 1,4 GiB belegt.
Fortfahren? [j/n/v/...? zeigt alle Optionen] (j): 
Ich hätte nun gerne gewusst, ob all diese Programme für eine Installation von gscan2pdf unter Opensuse 15.2 notwendig sind.

Falls dies zutreffen sollte, würde ich die zusätzlichen 1,4 Gigabyte in Kauf nehmen.
Falls nicht, möchte ich wissent: Gibt es eine andere, "schlankere" Methode, gscan2pdf in Opensuse 15.2 zu installieren?

Für Hinweise wäre ich dankbar!
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sauerland »

Schau mal in Yast---Software---Software installieren----Abhängigkeiten ob dort der Haken bei "empfohlene Pakete installieren" vorhanden ist. Den würde ich einmal entfernen.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sauerland »

Übrigens:
Du hast natürlich einige Repositories eingebunden.
Aber wenn ich die schon aktiviere, dann auch bitte aktualisieren, sonst gibt es Chaos.

Wobei wenig Repos oft mehr darstellt.....
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
Sendbote
Newbie
Newbie
Beiträge: 42
Registriert: 6. Feb 2014, 09:21
Wohnort: Südkorea

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sendbote »

Sauerland hat geschrieben:

Schau mal in Yast---Software---Software installieren----Abhängigkeiten ob dort der Haken bei "empfohlene Pakete installieren" vorhanden ist. Den würde ich einmal entfernen.
Dort kann ich keinen Haken "empfohlene Pakete installieren" finden.

Bei "Installationszusammenfassung / Abhängigkeiten" steht:

Code: Alles auswählen

gscan2pdf - Easy scan to PDF


Version:
2.8.1-lp152.9.2
Bietet:
application()
metainfo()
mimehandler(application/pdf)
application(net.sourceforge.gscan2pdf.desktop)
metainfo(net.sourceforge.gscan2pdf.appdata.xml)
gscan2pdf = 2.8.1-lp152.9.2
perl(Gscan2pdf::Bboxtree) = 2.8.1
perl(Gscan2pdf::Canvas) = 2.8.1
perl(Gscan2pdf::Canvas::Bbox) = 2.8.1
perl(Gscan2pdf::ComboBoxText) = 2.8.1
perl(Gscan2pdf::Config) = 2.8.1
perl(Gscan2pdf::Cuneiform) = 2.8.1
perl(Gscan2pdf::Dialog) = 2.8.1
perl(Gscan2pdf::Dialog::MultipleMessage) = 2.8.1
perl(Gscan2pdf::Dialog::Renumber) = 2.8.1
perl(Gscan2pdf::Dialog::Save) = 2.8.1
perl(Gscan2pdf::Dialog::Scan) = 2.8.1
perl(Gscan2pdf::Dialog::Scan::CLI) = 2.8.1
perl(Gscan2pdf::Dialog::Scan::Image_Sane) = 2.8.1
perl(Gscan2pdf::Document) = 2.8.1
perl(Gscan2pdf::EntryCompletion) = 2.8.1
perl(Gscan2pdf::Frontend::CLI) = 2.8.1
perl(Gscan2pdf::Frontend::Image_Sane) = 2.8.1
perl(Gscan2pdf::ImageView) = 2.8.1
perl(Gscan2pdf::NetPBM) = 2.8.1
perl(Gscan2pdf::Ocropus) = 2.8.1
perl(Gscan2pdf::Page) = 2.8.1
perl(Gscan2pdf::PageRange) = 2.8.1
perl(Gscan2pdf::Scanner::Options) = 2.8.1
perl(Gscan2pdf::Scanner::Profile) = 2.8.1
perl(Gscan2pdf::Tesseract) = 2.8.1
perl(Gscan2pdf::Translation) = 2.8.1
perl(Gscan2pdf::Unpaper) = 2.8.1
Benötigt:
/usr/bin/perl
perl(Config::General)
unpaper
perl(:MODULE_COMPAT_5.26.1)
perl(Data::UUID)
perl(Date::Calc)
perl(Exception::Class)
perl(Filesys::Df)
perl(Glib)
perl(GooCanvas2)
perl(Gtk3)
perl(Gtk3::SimpleList)
perl(Image::Magick)
perl(Image::Sane)
perl(List::MoreUtils)
perl(Locale::gettext)
perl(Log::Log4perl)
perl(PDF::API2)
perl(Proc::ProcessTable)
perl(Readonly)
perl(Set::IntSpan)
perl(Try::Tiny)
typelib(GdkPixdata) = 2.0
typelib(GooCanvas) = 2.0
Empfohlen:
tesseract-ocr
djvulibre
gocr
tiff
Doch im Fenster der "Installationszusammenfassung" taucht wieder eine ultralange Paketliste auf.
Benutzeravatar
Sendbote
Newbie
Newbie
Beiträge: 42
Registriert: 6. Feb 2014, 09:21
Wohnort: Südkorea

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sendbote »

Sauerland hat geschrieben

Übrigens:
Du hast natürlich einige Repositories eingebunden.
Aber wenn ich die schon aktiviere, dann auch bitte aktualisieren, sonst gibt es Chaos.

Wobei wenig Repos oft mehr darstellt.....
Daher bin ich vorsichtig mit dem Aktualisieren und Aktivieren. Ich hatte etwa Repo 15 aktiviert und bekam dann Probleme mit dem Aktualisieren ...

Ist dies nun sinnvoller als der Zustand vorher?

Code: Alles auswählen

 # zypper mr -er 1 2 3 4 5 6 7 8 9 10 11 12 13 14 16 17

 # zypper lr
Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.

#  | Alias                                   | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung
---+-----------------------------------------+---------------------------------------------------------+-----------+-----------------+---------------
 1 | Bildung                                 | Bildung                                                 | Ja        | (r ) Ja         | Ja
 2 | GNOME Applications (openSUSE_Leap_15.1) | GNOME Applications (openSUSE_Leap_15.1)                 | Ja        | (r ) Ja         | Ja
 3 | KDE-Extra                               | KDE-Extra                                               | Ja        | (r ) Ja         | Ja
 4 | KDE_Grafik                              | KDE_Grafik                                              | Ja        | (r ) Ja         | Ja
 5 | Libreoffice                             | Libreoffice                                             | Ja        | (r ) Ja         | Ja
 6 | Packman                                 | Packman                                                 | Ja        | (r ) Ja         | Ja
 7 | Publishing                              | Publishing                                              | Ja        | (r ) Ja         | Ja
 8 | Skype                                   | Skype                                                   | Ja        | (r ) Ja         | Ja
 9 | Spiele                                  | Spiele                                                  | Ja        | (r ) Ja         | Ja
10 | Virtualisierung                         | Virtualisierung                                         | Ja        | (r ) Ja         | Ja
11 | Wine                                    | Wine                                                    | Ja        | (r ) Ja         | Ja
12 | editors                                 | editors                                                 | Ja        | (r ) Ja         | Ja
13 | home_Kieltux_tools                      | Tools (openSUSE_Leap_15.2)                              | Ja        | (r ) Ja         | Ja
14 | home_Lord-Master                        | home:Lord-Master (openSUSE_Leap_15.2)                   | Ja        | (r ) Ja         | Ja
15 | home_Sauerland                          | Sauerland's Home Project (openSUSE_Leap_15.2)           | Nein      | ----            | ----
16 | home_bhwachter_emacs                    | home:bhwachter:emacs (openSUSE_Leap_15.2)               | Ja        | (r ) Ja         | Ja
17 | openSUSE_Leap_15.2_Update               | Online updates for openSUSE Leap:15.2 (standard)        | Ja        | (r ) Ja         | Ja
18 | perl-modules                            | perl-modules                                            | Ja        | (r ) Ja         | Ja
19 | repo-debug                              | Debug Repository                                        | Nein      | ----            | ----
20 | repo-debug-non-oss                      | Debug Repository (Non-OSS)                              | Nein      | ----            | ----
21 | repo-debug-update                       | Update Repository (Debug)                               | Nein      | ----            | ----
22 | repo-debug-update-non-oss               | Update Repository (Debug, Non-OSS)                      | Nein      | ----            | ----
23 | repo-non-oss                            | Non-OSS Repository                                      | Ja        | (r ) Ja         | Ja
24 | repo-oss                                | Haupt-Repository                                        | Ja        | (r ) Ja         | Ja
25 | repo-source                             | Source Repository                                       | Nein      | ----            | ----
26 | repo-source-non-oss                     | Source Repository (Non-OSS)                             | Nein      | ----            | ----
27 | repo-update                             | Hauptaktualisierungs-Repository                         | Ja        | (r ) Ja         | Ja
28 | repo-update-non-oss                     | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja
29 | skype-stable                            | skype (stable)                                          | Ja        | (r ) Ja         | Ja
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sauerland »

Bild

Oder in der /etc/zypp/zypper.conf auskommentieren und auf no setzen:

Code: Alles auswählen

grep -i recommend /etc/zypp/zypper.conf 
# installRecommends = yes
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
Sendbote
Newbie
Newbie
Beiträge: 42
Registriert: 6. Feb 2014, 09:21
Wohnort: Südkorea

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sendbote »

Danke für den Hinweis, Sauerland. Ich habe bei Yast / Software installieren im unteren und nicht im oberen Feld bei Abhängigkeiten gesucht, daher habe ich den Haken dort nicht gefunden.

Nun habe ich also gscan2pdf installiert über Yast - ohne (also nicht angekreuzt) "Abhängigkeiten / empfohlene Pakete installieren".

Die Paketauswahl schrumpft nun auf ein normales Maß zusammen:

Code: Alles auswählen

Installation erfolgreich abgeschlossen
Pakete
Installierte Pakete: 32
gscan2pdf, libgoocanvas-2_0-9, perl-Bit-Vector, perl-Cairo, perl-Cairo-GObject, perl-Carp-Clan, perl-Config-General, perl-Data-UUID... (Mehr)
Statistiken
Verbrauchte Zeit: 00:46
Installierte Gesamt-Größe: 27,49 MiB
Größe heruntergeladener Dateien: 4,77 MiB
Details
Installationsprotokoll


perl-PerlMagick wird heruntergeladen (Downloadgröße 187,1 KiB)
perl-Carp-Clan wird heruntergeladen (Downloadgröße 28,2 KiB)
perl-Config-General wird heruntergeladen (Downloadgröße 74,2 KiB)
perl-Data-UUID wird heruntergeladen (Downloadgröße 29,9 KiB)
perl-Exporter-Tiny wird heruntergeladen (Downloadgröße 54,8 KiB)
perl-ExtUtils-Depends wird heruntergeladen (Downloadgröße 28 KiB)
perl-ExtUtils-PkgConfig wird heruntergeladen (Downloadgröße 17,4 KiB)
perl-File-Path wird heruntergeladen (Downloadgröße 39,8 KiB)
perl-Filesys-Df wird heruntergeladen (Downloadgröße 20 KiB)
perl-Font-TTF wird heruntergeladen (Downloadgröße 334,6 KiB)
perl-List-MoreUtils-XS wird heruntergeladen (Downloadgröße 60,7 KiB)
perl-Proc-ProcessTable wird heruntergeladen (Downloadgröße 51,2 KiB)
perl-Readonly wird heruntergeladen (Downloadgröße 35,7 KiB)
perl-Set-IntSpan wird heruntergeladen (Downloadgröße 31,4 KiB)
perl-Bit-Vector wird heruntergeladen (Downloadgröße 160,5 KiB)
perl-Glib wird heruntergeladen (Downloadgröße 411,2 KiB)
perl-Cairo wird heruntergeladen (Downloadgröße 122,2 KiB)
perl-Log-Log4perl wird heruntergeladen (Downloadgröße 385,4 KiB)
perl-PDF-API2 wird heruntergeladen (Downloadgröße 1,54 MiB)
perl-List-MoreUtils wird heruntergeladen (Downloadgröße 66,5 KiB)
perl-Image-Sane wird heruntergeladen (Downloadgröße 55,3 KiB)
perl-Date-Calc wird heruntergeladen (Downloadgröße 186,9 KiB)
perl-Glib-Object-Introspection wird heruntergeladen (Downloadgröße 86,6 KiB)
perl-Cairo-GObject wird heruntergeladen (Downloadgröße 28,1 KiB)
perl-Gtk3 wird heruntergeladen (Downloadgröße 44,9 KiB)
perl-Gtk3-SimpleList wird heruntergeladen (Downloadgröße 31 KiB)
perl-GooCanvas2 wird heruntergeladen (Downloadgröße 14,6 KiB)
libgoocanvas-2_0-9 wird heruntergeladen (Downloadgröße 107 KiB)
typelib-1_0-GdkPixdata-2_0 wird heruntergeladen (Downloadgröße 24,8 KiB)
unpaper wird heruntergeladen (Downloadgröße 326,4 KiB)
typelib-1_0-GooCanvas-2_0 wird heruntergeladen (Downloadgröße 20,5 KiB)
gscan2pdf wird heruntergeladen (Downloadgröße 246 KiB)
perl-PerlMagick-7.0.7.34-lp152.12.3.1.x86_64.rpm wird installiert (installierte Größe: 463,5 KiB)
perl-Carp-Clan-6.08-lp152.87.1.noarch.rpm wird installiert (installierte Größe: 41,4 KiB)
perl-Config-General-2.63-lp152.51.1.x86_64.rpm wird installiert (installierte Größe: 171,9 KiB)
perl-Data-UUID-1.226-lp152.1.3.x86_64.rpm wird installiert (installierte Größe: 42,2 KiB)
perl-Exporter-Tiny-1.002002-lp152.15.1.noarch.rpm wird installiert (installierte Größe: 111,7 KiB)
perl-ExtUtils-Depends-0.8000-lp152.41.1.noarch.rpm wird installiert (installierte Größe: 37,3 KiB)
perl-ExtUtils-PkgConfig-1.160000-lp152.51.1.noarch.rpm wird installiert (installierte Größe: 19,1 KiB)
perl-File-Path-2.170000-lp152.17.1.noarch.rpm wird installiert (installierte Größe: 63,6 KiB)
perl-Filesys-Df-0.92-lp152.25.1.x86_64.rpm wird installiert (installierte Größe: 35,8 KiB)
perl-Font-TTF-1.06-lp152.30.1.noarch.rpm wird installiert (installierte Größe: 920,9 KiB)
perl-List-MoreUtils-XS-0.430-lp152.18.1.x86_64.rpm wird installiert (installierte Größe: 173,7 KiB)
perl-Proc-ProcessTable-0.59-lp152.36.3.x86_64.rpm wird installiert (installierte Größe: 100,3 KiB)
perl-Readonly-2.05-lp152.68.1.noarch.rpm wird installiert (installierte Größe: 74,3 KiB)
perl-Set-IntSpan-1.19-lp152.3.1.noarch.rpm wird installiert (installierte Größe: 63 KiB)
perl-Bit-Vector-7.4-lp152.26.3.x86_64.rpm wird installiert (installierte Größe: 501,9 KiB)
perl-Glib-1.3293-lp152.69.2.x86_64.rpm wird installiert (installierte Größe: 1,11 MiB)
perl-Cairo-1.107-lp152.41.3.x86_64.rpm wird installiert (installierte Größe: 441 KiB)
perl-Log-Log4perl-1.53-lp152.38.1.noarch.rpm wird installiert (installierte Größe: 955,4 KiB)
perl-PDF-API2-2.038-lp152.59.1.noarch.rpm wird installiert (installierte Größe: 18,94 MiB)
perl-List-MoreUtils-0.430-lp152.119.1.noarch.rpm wird installiert (installierte Größe: 163,3 KiB)
perl-Image-Sane-5-lp152.10.1.x86_64.rpm wird installiert (installierte Größe: 185,8 KiB)
perl-Date-Calc-6.4-lp152.46.1.noarch.rpm wird installiert (installierte Größe: 638 KiB)
perl-Glib-Object-Introspection-0.049-lp152.22.1.x86_64.rpm wird installiert (installierte Größe: 244,8 KiB)
perl-Cairo-GObject-1.005-lp152.6.2.x86_64.rpm wird installiert (installierte Größe: 55,9 KiB)
perl-Gtk3-0.037-lp152.10.1.noarch.rpm wird installiert (installierte Größe: 121,7 KiB)
perl-Gtk3-SimpleList-0.18-lp152.4.1.noarch.rpm wird installiert (installierte Größe: 57,3 KiB)
perl-GooCanvas2-0.06-lp152.3.1.noarch.rpm wird installiert (installierte Größe: 11,9 KiB)
libgoocanvas-2_0-9-2.0.4-lp152.4.4.x86_64.rpm wird installiert (installierte Größe: 304,7 KiB)
typelib-1_0-GdkPixdata-2_0-2.40.0-lp152.1.5.x86_64.rpm wird installiert (installierte Größe: 2,3 KiB)
unpaper-6.1-lp152.3.7.x86_64.rpm wird installiert (installierte Größe: 415 KiB)
typelib-1_0-GooCanvas-2_0-2.0.4-lp152.4.4.x86_64.rpm wird installiert (installierte Größe: 54,6 KiB)
gscan2pdf-2.8.1-lp152.9.2.noarch.rpm wird installiert (installierte Größe: 1,11 MiB)
Das Programm lässt sich aufrufen. Eine erste Überprüfung ergibt, dass mir bekannte Funktionen vorhanden sind. Beim Aufrufen von gscan2pdf erscheint allerdings eine Warnung:
Warning: missing packages
Save image requires libtiff
Save as DjVu requires djvulibre-bin
Vielleicht hat dies nichts weiter zu sagen? Oder doch besser alle empfohlenen Abhängigkeiten installieren? Hier ist es nun 22.55 Uhr. Ich komme erst morgen wieder dazu, das Programm weiter zu überprüfen.

Grüße Sendbote
Christina
Member
Member
Beiträge: 91
Registriert: 4. Mär 2019, 13:44

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Christina »

@Sendbote
Also so direkt kann ich nicht weiterhelfen, aber ich habe gscan2pdf gerade eben vom Repo home:Sauerland installiert.
Es gab keine Probleme mit 2240 Paketen und 1.4 GiB, die installiert werden müssen; nur ca. 20 Pakete.
Das Häkchen (der Klotz) bei Abhängigkeiten: "Empfohlene Pakete installieren" ist drin.
Die Repos perl-modules und Publishing brauche ich gar nicht.

Bein Start hat gscan2pdf ein fehlendes Programm pdftk gemeldet. Das habe ich nachinstalliert.

Am WE hatte ich erst das Upgrade Leap 15.1->15.2 gemacht.

@Sauerland
Ist das home-Repo Sauerland von dir?
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sauerland »

Das Repo ist von mir, aber bitte mit Vorsicht zu geniessen.

Danke auch für die Anmerkung zu pdftk, werde das mal melden.

Ich hab das auch mal installiert, waren dann aber nur ein paar (ich glaub 5) perl-Pakete.
Allerdings nehme ich als erstes den Haken bei empfohlene Pakete installieren heraus.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
Sendbote
Newbie
Newbie
Beiträge: 42
Registriert: 6. Feb 2014, 09:21
Wohnort: Südkorea

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sendbote »

Im September 2020 hatte ich versucht, gsacn2pdf unter Opensuse 15.1 zu installieren. Damals hatte ich bereits das Repo
https://download.opensuse.org/repositor ... Leap_15.1/ eingebunden (oben: Repository Nr. 15).
Es kam allerdings folgende Meldung:

Code: Alles auswählen

# zypper in gscan2pdf

...

Problem: perl(:MODULE_COMPAT_5.30.3) benötigt von gscan2pdf-2.8.1-9.3.noarch wird nirgends zur Verfügung gestellt
 Lösung 1: gscan2pdf-2.8.1-9.3.noarch nicht installieren
 Lösung 2: gscan2pdf-2.8.1-9.3.noarch durch Ignorieren einiger Abhängigkeiten brechen

Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie (a)b [1/2/a/d/?] (a): a
Nachdem die gleichen Probleme in Opensuse 15.2 auftraten, habe ich dann die bereits genannten Repos 7 und 18 eingebunden.

Heute habe ich nun - das nur mit den Minimalvoraussetzungen über das Repo "Publishing" installierte - gscscan2pdf mit der Option "bereinigen beim Löschen von Paketen" über Yast deinstalliert.
Danach habe ich versucht, es noch einmal über das Repository 15 zu installieren, es kam aber wieder die gleiche Meldung:

Code: Alles auswählen

# zypper install -r 15 gscan2pdf
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Paketabhängigkeiten werden aufgelöst...

Problem: perl(Glib) benötigt von gscan2pdf-2.8.1-lp152.13.1.noarch wird nirgends zur Verfügung gestellt
 Lösung 1: gscan2pdf-2.8.1-lp152.13.1.noarch nicht installieren
 Lösung 2: gscan2pdf-2.8.1-lp152.13.1.noarch durch Ignorieren einiger Abhängigkeiten brechen

Eine Installation des Programmes aus diesem Repository über Yast (Häkchen bei "Empfohlene Pakete installieren" nicht gesetzt) funktionierte.

Code: Alles auswählen

Installation erfolgreich abgeschlossen
Pakete
Installierte Pakete: 32
gscan2pdf, libgoocanvas-2_0-9, perl-Bit-Vector, perl-Cairo, perl-Cairo-GObject, perl-Carp-Clan, perl-Config-General, perl-Data-UUID... (Mehr)
Statistiken
Verbrauchte Zeit: 00:43
Installierte Gesamt-Größe: 27,49 MiB
Größe heruntergeladener Dateien: 4,77 MiB
Details

perl-Data-UUID wird heruntergeladen (Downloadgröße 30,3 KiB)
perl-Set-IntSpan wird heruntergeladen (Downloadgröße 31,8 KiB)
perl-PerlMagick wird heruntergeladen (Downloadgröße 187,1 KiB)
perl-Carp-Clan wird heruntergeladen (Downloadgröße 28,2 KiB)
perl-Config-General wird heruntergeladen (Downloadgröße 74,2 KiB)
perl-Exporter-Tiny wird heruntergeladen (Downloadgröße 54,8 KiB)
perl-ExtUtils-Depends wird heruntergeladen (Downloadgröße 28 KiB)
perl-ExtUtils-PkgConfig wird heruntergeladen (Downloadgröße 17,4 KiB)
perl-File-Path wird heruntergeladen (Downloadgröße 39,8 KiB)
perl-Filesys-Df wird heruntergeladen (Downloadgröße 20 KiB)
perl-Font-TTF wird heruntergeladen (Downloadgröße 334,6 KiB)
perl-List-MoreUtils-XS wird heruntergeladen (Downloadgröße 60,7 KiB)
perl-Proc-ProcessTable wird heruntergeladen (Downloadgröße 51,2 KiB)
perl-Readonly wird heruntergeladen (Downloadgröße 35,7 KiB)
perl-Bit-Vector wird heruntergeladen (Downloadgröße 160,5 KiB)
perl-Glib wird heruntergeladen (Downloadgröße 411,2 KiB)
perl-Cairo wird heruntergeladen (Downloadgröße 122,2 KiB)
perl-Log-Log4perl wird heruntergeladen (Downloadgröße 385,4 KiB)
perl-PDF-API2 wird heruntergeladen (Downloadgröße 1,54 MiB)
perl-List-MoreUtils wird heruntergeladen (Downloadgröße 66,5 KiB)
perl-Image-Sane wird heruntergeladen (Downloadgröße 55,3 KiB)
perl-Date-Calc wird heruntergeladen (Downloadgröße 186,9 KiB)
libgoocanvas-2_0-9 wird heruntergeladen (Downloadgröße 107 KiB)
typelib-1_0-GdkPixdata-2_0 wird heruntergeladen (Downloadgröße 24,8 KiB)
unpaper wird heruntergeladen (Downloadgröße 326,4 KiB)
typelib-1_0-GooCanvas-2_0 wird heruntergeladen (Downloadgröße 20,5 KiB)
perl-Glib-Object-Introspection wird heruntergeladen (Downloadgröße 87 KiB)
perl-Cairo-GObject wird heruntergeladen (Downloadgröße 28,5 KiB)
perl-Gtk3 wird heruntergeladen (Downloadgröße 45,3 KiB)
perl-Gtk3-SimpleList wird heruntergeladen (Downloadgröße 31,7 KiB)
perl-GooCanvas2 wird heruntergeladen (Downloadgröße 15 KiB)
gscan2pdf wird heruntergeladen (Downloadgröße 246,5 KiB)
perl-Data-UUID-1.226-lp152.2.7.x86_64.rpm wird installiert (installierte Größe: 42,2 KiB)
perl-Set-IntSpan-1.19-lp152.4.5.noarch.rpm wird installiert (installierte Größe: 63 KiB)
perl-PerlMagick-7.0.7.34-lp152.12.3.1.x86_64.rpm wird installiert (installierte Größe: 463,5 KiB)
perl-Carp-Clan-6.08-lp152.87.1.noarch.rpm wird installiert (installierte Größe: 41,4 KiB)
perl-Config-General-2.63-lp152.51.1.x86_64.rpm wird installiert (installierte Größe: 171,9 KiB)
perl-Exporter-Tiny-1.002002-lp152.15.1.noarch.rpm wird installiert (installierte Größe: 111,7 KiB)
perl-ExtUtils-Depends-0.8000-lp152.41.1.noarch.rpm wird installiert (installierte Größe: 37,3 KiB)
perl-ExtUtils-PkgConfig-1.160000-lp152.51.1.noarch.rpm wird installiert (installierte Größe: 19,1 KiB)
perl-File-Path-2.170000-lp152.17.1.noarch.rpm wird installiert (installierte Größe: 63,6 KiB)
perl-Filesys-Df-0.92-lp152.25.1.x86_64.rpm wird installiert (installierte Größe: 35,8 KiB)
perl-Font-TTF-1.06-lp152.30.1.noarch.rpm wird installiert (installierte Größe: 920,9 KiB)
perl-List-MoreUtils-XS-0.430-lp152.18.1.x86_64.rpm wird installiert (installierte Größe: 173,7 KiB)
perl-Proc-ProcessTable-0.59-lp152.36.3.x86_64.rpm wird installiert (installierte Größe: 100,3 KiB)
perl-Readonly-2.05-lp152.68.1.noarch.rpm wird installiert (installierte Größe: 74,3 KiB)
perl-Bit-Vector-7.4-lp152.26.3.x86_64.rpm wird installiert (installierte Größe: 501,9 KiB)
perl-Glib-1.3293-lp152.69.2.x86_64.rpm wird installiert (installierte Größe: 1,11 MiB)
perl-Cairo-1.107-lp152.41.3.x86_64.rpm wird installiert (installierte Größe: 441 KiB)
perl-Log-Log4perl-1.53-lp152.38.1.noarch.rpm wird installiert (installierte Größe: 955,4 KiB)
perl-PDF-API2-2.038-lp152.59.1.noarch.rpm wird installiert (installierte Größe: 18,94 MiB)
perl-List-MoreUtils-0.430-lp152.119.1.noarch.rpm wird installiert (installierte Größe: 163,3 KiB)
perl-Image-Sane-5-lp152.10.1.x86_64.rpm wird installiert (installierte Größe: 185,8 KiB)
perl-Date-Calc-6.4-lp152.46.1.noarch.rpm wird installiert (installierte Größe: 638 KiB)
libgoocanvas-2_0-9-2.0.4-lp152.4.4.x86_64.rpm wird installiert (installierte Größe: 304,7 KiB)
typelib-1_0-GdkPixdata-2_0-2.40.0-lp152.1.5.x86_64.rpm wird installiert (installierte Größe: 2,3 KiB)
unpaper-6.1-lp152.3.7.x86_64.rpm wird installiert (installierte Größe: 415 KiB)
typelib-1_0-GooCanvas-2_0-2.0.4-lp152.4.4.x86_64.rpm wird installiert (installierte Größe: 54,6 KiB)
perl-Glib-Object-Introspection-0.049-lp152.24.1.x86_64.rpm wird installiert (installierte Größe: 244,8 KiB)
perl-Cairo-GObject-1.005-lp152.7.2.x86_64.rpm wird installiert (installierte Größe: 55,9 KiB)
perl-Gtk3-0.037-lp152.11.1.noarch.rpm wird installiert (installierte Größe: 121,7 KiB)
perl-Gtk3-SimpleList-0.21-lp152.8.2.noarch.rpm wird installiert (installierte Größe: 57,7 KiB)
perl-GooCanvas2-0.06-lp152.4.2.noarch.rpm wird installiert (installierte Größe: 11,9 KiB)
gscan2pdf-2.8.1-lp152.13.1.noarch.rpm wird installiert (installierte Größe: 1,11 MiB)

Doch beim Starten kam auch hier - wie zuvor nach der Installation über das Publishing Repository - die Meldung:
Warning: missing packages
Save image requires libtiff
Save as DjVu requires djvulibre-bin
Die Meldung erscheint, doch das Programm lässt sich danach nicht starten, es stürzt ab.
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sauerland »

Diese warnings sind auch nur Warnungen, wollte gestern mein Paket in Publishing veröffenlichen aber:
Hi
Can you change it to a recommends or suggests (move to after requires), it's only needed if users want to encrypt the pdf.
Also von Requires pdftk auf Recommends pdftk geändert:
Recommends: djvulibre
Recommends: gocr
Recommends: tesseract-ocr
Recommends: tiff
Recommends: pdftk
Und es ist veröffentlicht worden.
Dort siehst du auch dein tiff.
Wenn du die Meldung weg bekommen möchtest, einfach:

Code: Alles auswählen

zypper in tiff
Zum Thema perl(Glib):
auch dies nachinstallieren.

Code: Alles auswählen

zypper in perl-Glib
Nur als Info:
Da ich ja Pakete selber baue, hab ich auch viele Abhängigkeiten schon installiert und kann einiges gar nicht nachverfolgen.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sauerland »

Zum Thema Repos:
Ich habe auch ein paar mehr eingebunden, aber anders als bei dir sind diese Repos aktiv und auch mit Prioritäten versehen.
Und ich lasse meine Finger von irgendwelchen Repos für Programmiersprachen, da gibts dann irgendwann Probleme.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
Sendbote
Newbie
Newbie
Beiträge: 42
Registriert: 6. Feb 2014, 09:21
Wohnort: Südkorea

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sendbote »

Ok, nun habe ich tiff, djvulibre und perl-Glib mit "zypper in" installiert.
Die Warnhinweise verschwinden, doch das Programm lässt sich nicht starten. Im Ordner /tmp versucht es offenbar, die letzte abgestürzte Sitzung wiederherzustellen. Die gscan2pdf Ordner unter /tmp und auch die Konfiguration unter /.config habe ich gelöscht. Nun lässt sich das Programm starten.

Gerade habe ich Dokumente eingescannt und mit Tesseract die Texterkennung eingestellt. Nach zwei Seiten blieben die Dokumente im Scanner hängen. Ich dachte, vielleicht liegt es am Papier, habe es dann noch einmal neu mit anderem Papier versucht. Doch auch nun bleibt das Papier wieder hängen und dieselbe Fehlermeldung:
DS] Profile read from file (tesseract_opencl_profile_devices.dat).
[DS] Device[1] 0:(null) score is 0.517484
[DS] Selected Device[1]: "(null)" (Native)
Error opening data file /usr/share/tessdata/Warning: Parameter not found: enable_new_segsearch.traineddata
Please make sure the TESSDATA_PREFIX environment variable is set to your "tessdata" directory.
Failed loading language 'Warning: Parameter not found: enable_new_segsearch'
Tesseract couldn't load any languages!
Could not initialize tesseract.
Sauerland
Guru
Guru
Beiträge: 3903
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: gscan2pdf unter Opensuse 15.2

Beitrag von Sauerland »

Gerade habe ich Dokumente eingescannt und mit Tesseract die Texterkennung eingestellt. Nach zwei Seiten blieben die Dokumente im Scanner hängen. Ich dachte, vielleicht liegt es am Papier, habe es dann noch einmal neu mit anderem Papier versucht. Doch auch nun bleibt das Papier wieder hängen und dieselbe Fehlermeldung:
Funktioniert anscheinend nicht.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Antworten