Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Leap 15.0 // 15.1: Acroread startet nicht mehr

Alles rund um Büroanwendungen, Bildungsprogramme und Spiele unter Linux

Moderator: Moderatoren

kzeitler
Newbie
Newbie
Beiträge: 42
Registriert: 15. Sep 2011, 23:34

Re: Leap 15.0 Acroread startet nicht mehr

Beitrag von kzeitler » 24. Dez 2018, 14:57

Hallo,
ist das jetzt die libxcb von 15.0 oder die von 42.3? Wie von Joerg Kuehne beschrieben, war bei ihm libxcb eine von den 3 Libraries, die er von 42.3
kopiert hat. Bei mir tut's allerdings die in 15.0, was mich etwas verwundert, denn in /opt/Adobe/Reader9/Reader/intellinux/lib hab ich keine libxcb.
In /usr/lib habe ich:

Code: Alles auswählen

lrwxrwxrwx 1 root root     15 Oct 18 16:14 libxcb.so.1 -> libxcb.so.1.1.0
-rwxr-xr-x 1 root root 182100 Oct 18 16:14 libxcb.so.1.1.0
mit folgender checksum:

Code: Alles auswählen

$ cksum libxcb.so.1.1.0
2636191102 182100 libxcb.so.1.1.0
Gruß
Klaus

Werbung:
thio
Hacker
Hacker
Beiträge: 455
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 Acroread startet nicht mehr

Beitrag von thio » 27. Dez 2018, 14:24

Mit welchem Befehl bekomme ich die Info
lrwxrwxrwx 1 root root 15 Oct 18 16:14 libxcb.so.1 -> libxcb.so.1.1.0

kzeitler
Newbie
Newbie
Beiträge: 42
Registriert: 15. Sep 2011, 23:34

Re: Leap 15.0 Acroread startet nicht mehr

Beitrag von kzeitler » 27. Dez 2018, 23:49

ls -l /opt/Adobe/Reader9/Reader/intellinux/lib/libxcb.*

thio
Hacker
Hacker
Beiträge: 455
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 Acroread startet nicht mehr

Beitrag von thio » 28. Dez 2018, 17:03

Okay, da spuckt er bei mir folgendes aus:

Code: Alles auswählen

@linux-ttgi:~> ls -l /opt/Adobe/Reader9/Reader/intellinux/lib/libxcb.*
lrwxrwxrwx 1 root root     15 15. Dez 13:02 /opt/Adobe/Reader9/Reader/intellinux/lib/libxcb.so.1 -> libxcb.so.1.1.0
-rwxr-xr-x 1 root root 222932 11. Sep 16:06 /opt/Adobe/Reader9/Reader/intellinux/lib/libxcb.so.1.1.0

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2080
Registriert: 24. Okt 2005, 14:04

Re: Leap 15.0 Acroread startet nicht mehr

Beitrag von Heinz-Peter » 28. Dez 2018, 20:08

kzeitler hat geschrieben:
24. Dez 2018, 14:57

Code: Alles auswählen

lrwxrwxrwx 1 root root     15 Oct 18 16:14 libxcb.so.1 -> libxcb.so.1.1.0
-rwxr-xr-x 1 root root 182100 Oct 18 16:14 libxcb.so.1.1.0
mit folgender checksum:

Code: Alles auswählen

$ cksum libxcb.so.1.1.0
2636191102 182100 libxcb.so.1.1.0
Gruß
Klaus
Hallo thio,

ist deine

Code: Alles auswählen

$ cksum libxcb.so.1.1.0
die gleiche?

Gruß Heinz-Peter
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

thio
Hacker
Hacker
Beiträge: 455
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 Acroread startet nicht mehr

Beitrag von thio » 9. Jun 2019, 16:22

Hallo,

hat jemand den Acroread unter Leap 15.1 in der Zwischenzeit zum laufen gebracht?

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5355
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Leap 15.0 Acroread startet nicht mehr

Beitrag von tomm.fa » 9. Jun 2019, 20:36

thio hat geschrieben:
9. Jun 2019, 16:22
Hallo,

hat jemand den Acroread unter Leap 15.1 in der Zwischenzeit zum laufen gebracht?
Nö, kein Bedarf.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

thio
Hacker
Hacker
Beiträge: 455
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 Acroread startet nicht mehr

Beitrag von thio » 10. Jun 2019, 20:10

kzeitler hat geschrieben:
12. Dez 2018, 20:52
Hallo,
normalerweise versuche ich auch acroread zu vermeiden, aber ab und zu ist bzw. war es das einzige Tool welches korrekt funktioniert
(z.B. bei manchen Formularen). Ich nutze inzwischen normalerweise okular für PDFs (evince nervt mich seit der Einführung von CSD).
Bei Problemen versuche ich als nächstes doch evince (mit gtk3-nocsd) und wenn das auch nicht funzt, dann eben doch acroread.

Zurück zu acroread. Es gibt da einen sehr langen und interessanten Thread zum Thema acroread auf 15.0:

https://marc.info/?l=opensuse&m=152822808227841&w=2

Joerg Kuehne beschreibt da sehr schön wie's geht. Ich habe mit folgenden Schritten acroread auf 15.0 installiert:

1. Get AdbeRdr9.5.5-1_i486linux_enu.rpm from ftp://ftp.adobe.com/pub/adobe/reader/un ... 9.5.5/enu/
2. sudo rpm -i AdbeRdr9.5.5-1_i486linux_enu.rpm (Installiert nach /opt/Adobe, das ist mir eh lieber als nach /usr/...)
evtl. muß man noch ein paar Libraries installieren (hab's leider vergessen zu notieren, aber das sieht man an den rpm Fehlermeldungen)
3. Ersetze wie von Joerg beschrieben in /opt/Adobe/Reader9/bin/acroread in Zeile 22 exec mit gdb und starte acroread.
4. Ich mußte nur eine einzige Library (libpcre.so.1) von meinem 42.3 Desktop nach /opt/Adobe/Reader9/Reader/intellinux/lib
kopieren (evtl. muß man diesen Schritt für weitere Libs wiederholen) und schon ging's.

Gruß
Klaus
Ich habe das ganze nun nochmal versucht erneut druchzuführen...

Weiß jetzt aber nicht mehr weiter...

Code: Alles auswählen

@linux:~> acroread
GNU gdb (GDB; openSUSE Leap 15.0) 8.2
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-suse-linux".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://bugs.opensuse.org/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /opt/Adobe/Reader9/Reader/intellinux/bin/acroread...Missing separate debuginfo for /opt/Adobe/Reader9/Reader/intellinux/bin/acroread
(no debugging symbols found)...done.
(gdb) run
Starting program: /opt/Adobe/Reader9/Reader/intellinux/bin/acroread 
Missing separate debuginfo for /lib/ld-linux.so.2
Try: zypper install -C "debuginfo(build-id)=8bfa90774c1d353bac66e92c95e7a19be8ba70ed"
Missing separate debuginfo for /lib/libpthread.so.0
Try: zypper install -C "debuginfo(build-id)=ac7efccb39d37013ad32fe917633cb96315a8c9c"
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Missing separate debuginfo for /usr/lib/libxml2.so.2
Try: zypper install -C "debuginfo(build-id)=555338ed9bedcff0dcb26a8adfbd1b1b76dcd5c4"
Missing separate debuginfo for /lib/libm.so.6
Try: zypper install -C "debuginfo(build-id)=d51aa68d8577eb50a659de35a84786178b3e1e98"
Missing separate debuginfo for /lib/libdl.so.2
Try: zypper install -C "debuginfo(build-id)=1a173244b9540d082093c04d3a1217476a248716"
Missing separate debuginfo for /usr/lib/libgdk_pixbuf_xlib-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=b05a05f873be5a162d94bfd81eaeb4b66cbe09be"
Missing separate debuginfo for /usr/lib/libgtk-x11-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=eca402f04bbdaf6f046001ad978e8a51eda5b1d9"
Missing separate debuginfo for /usr/lib/libgdk-x11-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=f16e1bab46807c5b64b97205ede0a4fcfb4ab6c9"
Missing separate debuginfo for /usr/lib/libatk-1.0.so.0
Try: zypper install -C "debuginfo(build-id)=c95c79a9309765460e13bc2b81b878ed1e393120"
Missing separate debuginfo for /usr/lib/libgdk_pixbuf-2.0.so.0                                                                                               
Try: zypper install -C "debuginfo(build-id)=05b6e7f272b8d54adfbeb081a8bc41a4649a871b"
Missing separate debuginfo for /usr/lib/libpango-1.0.so.0
Try: zypper install -C "debuginfo(build-id)=eaa6592357041186e226b777b991f6ba102f3215"
Missing separate debuginfo for /usr/lib/libgobject-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=4f92ddd5574d58287d8de349955852c830829c95"
Missing separate debuginfo for /usr/lib/libglib-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=71c28f537eb79df2aac2f29f45d1340afc39e0c5"
Missing separate debuginfo for /lib/libc.so.6
Try: zypper install -C "debuginfo(build-id)=4efa626c9331b6ca5155e45dc808699104c71ffe"
Missing separate debuginfo for /usr/lib/libstdc++.so.6
Try: zypper install -C "debuginfo(build-id)=145270fa854c7ffd81f46f87de7b4ce1b4d6ce6e"
Missing separate debuginfo for /opt/Adobe/Reader9/Reader/intellinux/lib/libResAccess.so
Missing separate debuginfo for /lib/libgcc_s.so.1
Try: zypper install -C "debuginfo(build-id)=e6da1be8e584e9b47b7efbac77a17c74160d5552"
Missing separate debuginfo for /lib/libz.so.1
Try: zypper install -C "debuginfo(build-id)=ff2f5d2f5bc60b4cab83b268c5d1623fb6b601ad"
Missing separate debuginfo for /usr/lib/liblzma.so.5
Try: zypper install -C "debuginfo(build-id)=7a6a847f7ecfc70b6066d3f3484f978269d05ad9"
Missing separate debuginfo for /usr/lib/libgmodule-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=d1abd315de0ae40875684d75c034c70c19459e85"
Missing separate debuginfo for /usr/lib/libpangocairo-1.0.so.0
Try: zypper install -C "debuginfo(build-id)=6edeeb5ef007d402b0e097b5a3b661d0a982f0b1"
Missing separate debuginfo for /usr/lib/libcairo.so.2
Try: zypper install -C "debuginfo(build-id)=c30cb779540dac544bda52b90d1b6c466dad0b00"
Missing separate debuginfo for /usr/lib/libgio-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=0d6a44382d28f93b1dfa6baeb5f39cc6dd69e7d5"
Missing separate debuginfo for /usr/lib/libpangoft2-1.0.so.0
Try: zypper install -C "debuginfo(build-id)=f6bca7073528597cbbac8613d213d0ac0d356e6f"
Missing separate debuginfo for /usr/lib/libfontconfig.so.1
Try: zypper install -C "debuginfo(build-id)=833c1660caa6d0ee27c7dd27563f9d2eb40a7488"
Missing separate debuginfo for /usr/lib/libthai.so.0
Try: zypper install -C "debuginfo(build-id)=fb8190d55511230efd1ae9d924cbb08b4be625cc"
Missing separate debuginfo for /usr/lib/libffi.so.7
Try: zypper install -C "debuginfo(build-id)=d955ccbe0e1c30bc1acc3d04ef42c4112ac88cc3"
Missing separate debuginfo for /usr/lib/libpcre.so.1
Try: zypper install -C "debuginfo(build-id)=2e3934206a73089be8849f1f2981515dde536eba"
Missing separate debuginfo for /usr/lib/libfreetype.so.6
Try: zypper install -C "debuginfo(build-id)=c05bb0387c065612d6873350eba6ac22638b3de0"
Missing separate debuginfo for /usr/lib/libEGL.so.1
Try: zypper install -C "debuginfo(build-id)=b98a142a9d89e8adec26554c4be67762041898b0"
Missing separate debuginfo for /usr/lib/libpng16.so.16
Try: zypper install -C "debuginfo(build-id)=9fdcc03172523c472e0bebea8f6ce93ba3f1e943"
Missing separate debuginfo for /usr/lib/libGL.so.1
Try: zypper install -C "debuginfo(build-id)=f3d545036754de442808a68f1abb1ca70089d93a"
Missing separate debuginfo for /lib/librt.so.1
Try: zypper install -C "debuginfo(build-id)=b8dbec18ded60cf55c769cd6f2e9a4c035ee8aed"
Missing separate debuginfo for /lib/libselinux.so.1
Try: zypper install -C "debuginfo(build-id)=bc2b10d2dbd9fa3d54c62441dde957a528ba66e5"
Missing separate debuginfo for /lib/libresolv.so.2
Try: zypper install -C "debuginfo(build-id)=402638eff6dc32cfe07b36ac4c80f8f37552fc11"
Missing separate debuginfo for /usr/lib/libmount.so.1
Try: zypper install -C "debuginfo(build-id)=5ea72c1f2b13f5cc7f69514942349da27adf029a"
Missing separate debuginfo for /usr/lib/libharfbuzz.so.0
Try: zypper install -C "debuginfo(build-id)=82e2a10091eb4f5f67b56c976a62e2debd741ad1"
Missing separate debuginfo for /usr/lib/libexpat.so.1
Try: zypper install -C "debuginfo(build-id)=9d41e20daf12aebad2eb0b76867ed2c02cc2bd81"
Missing separate debuginfo for /usr/lib/libdatrie.so.1
Try: zypper install -C "debuginfo(build-id)=b4889783fe5d860bb35f05bc9b6f9f1b60bf6383"
Missing separate debuginfo for /usr/lib/libbz2.so.1
Try: zypper install -C "debuginfo(build-id)=59f60c109f049659a7e4f9440fd0b359546be06c"
Missing separate debuginfo for /usr/lib/libGLdispatch.so.0
Try: zypper install -C "debuginfo(build-id)=ff7d1a4c7045febf43dc8a9f5d6b29f249966b2e"
Missing separate debuginfo for /usr/lib/libGLX.so.0
Try: zypper install -C "debuginfo(build-id)=0713c154d4b5553364d3dbd11563fcf497e6f9ff"
Missing separate debuginfo for /usr/lib/libblkid.so.1
Try: zypper install -C "debuginfo(build-id)=7dfb140787e3781a2e2aedc388ae370ae185a902"
Missing separate debuginfo for /usr/lib/libgraphite2.so.3
Try: zypper install -C "debuginfo(build-id)=720de442fa98e876a2b9094d9f10e6a6d0258f2e"
Missing separate debuginfo for /usr/lib/libuuid.so.1
Try: zypper install -C "debuginfo(build-id)=68e5b39c5cf6958e79dc2ac64184d9cf5eca85cd"
Missing separate debuginfo for /usr/lib/gconv/UTF-16.so
Try: zypper install -C "debuginfo(build-id)=01200201a7bd08afd6248d646a16635f391f7bfc"
Missing separate debuginfo for /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so
Try: zypper install -C "debuginfo(build-id)=0346cb01dd9583dce650edd6ee815bd08a535abc"
Missing separate debuginfo for /usr/lib/libcanberra-gtk.so.0
Try: zypper install -C "debuginfo(build-id)=c06c9367b38b21cb77384708236e16857e83c5a9"
Missing separate debuginfo for /usr/lib/libcanberra.so.0
Try: zypper install -C "debuginfo(build-id)=e43e9ccf926a5492b8eed54a1c59e51cfa34e291"
Missing separate debuginfo for /usr/lib/libvorbisfile.so.3
Try: zypper install -C "debuginfo(build-id)=fbf5061d3e94c7ac55be2b4493905c2a207ddaf8"
Missing separate debuginfo for /usr/lib/libltdl.so.7
Try: zypper install -C "debuginfo(build-id)=8e641e6dc8cd978b768539381ff33e61ffac9a43"
Missing separate debuginfo for /usr/lib/libvorbis.so.0
Try: zypper install -C "debuginfo(build-id)=fd7ce934c0dcf740dda0596399b1bc481da592dd"
Missing separate debuginfo for /usr/lib/libogg.so.0
Try: zypper install -C "debuginfo(build-id)=a29329e2ee5c3aa975f07eebcd8fc0f460c95890"

Program received signal SIGSEGV, Segmentation fault.
0xf4fd3cd1 in xcb_writev () from /usr/lib/libxcb.so.1
(gdb) 

thio
Hacker
Hacker
Beiträge: 455
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von thio » 10. Jun 2019, 20:13

Code: Alles auswählen

linux:~ # ls -l /opt/Adobe/Reader9/Reader/intellinux/lib/libxcb.*
ls: cannot access '/opt/Adobe/Reader9/Reader/intellinux/lib/libxcb.*': No such file or directory

Sauerland
Guru
Guru
Beiträge: 3518
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von Sauerland » 10. Jun 2019, 20:36

Ich habs gerade auch noch mit dem von Adobe und dem aus dem Repo versucht, beide tot.

Steck nicht so viel Arbeit hier hinein.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

thio
Hacker
Hacker
Beiträge: 455
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von thio » 10. Jun 2019, 20:48

wobei das Thema ist doch unter 42.3 läuft der reader..
Unter 15.0 & 15.1 nicht mehr!

Sauerland
Guru
Guru
Beiträge: 3518
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von Sauerland » 10. Jun 2019, 21:10

wobei das Thema ist doch unter 42.3 läuft der reader..
Unter 15.0 & 15.1 nicht mehr!
Neuere libs usw.......

Damit kommt der Adobe nicht klar.
Und das wird immer schlimmer.....
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

rolandb
Hacker
Hacker
Beiträge: 469
Registriert: 31. Jan 2014, 17:11

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von rolandb » 11. Jun 2019, 10:45

thio hat geschrieben:
10. Jun 2019, 20:10
Ich habe das ganze nun nochmal versucht erneut druchzuführen...

Weiß jetzt aber nicht mehr weiter...

Code: Alles auswählen

@linux:~> acroread
GNU gdb (GDB; openSUSE Leap 15.0) 8.2
…
Program received signal SIGSEGV, Segmentation fault.
0xf4fd3cd1 in xcb_writev () from /usr/lib/libxcb.so.1
(gdb) 
Na, in der letzten gdb-Zeile ist doch anscheinend der Fehler.
Siehe:
Joerg Kuehne hat geschrieben:To get it working, you can copy all necessary libraries (it depends e.g.
of the gtk2-theme) from a Leap 42.3 installation or from SUSE repos to
/opt/Adobe/Reader9/Reader/intellinux/lib/

at least libxcb (.so file and symlink).
Hast du libxcb1-32bit - X11 core protocol C library auch kopiert?

Code: Alles auswählen

$ ll /usr/lib/libxcb.so*
lrwxrwxrwx 1 root root     15 Jan 12 12:09 /usr/lib/libxcb.so.1 -> libxcb.so.1.1.0
-rwxr-xr-x 1 root root 141088 Jan  9  2018 /usr/lib/libxcb.so.1.1.0
 
Sauerland hat geschrieben:
10. Jun 2019, 20:36
Ich habs gerade auch noch mit dem von Adobe und dem aus dem Repo versucht, beide tot.
Bei mir ist ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/ nicht tot.

Sauerland
Guru
Guru
Beiträge: 3518
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von Sauerland » 11. Jun 2019, 16:54

Bei mir ist ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/ nicht tot.
Das hab ich auch nicht gemeint, einfache Installation und Programm = tot.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

rolandb
Hacker
Hacker
Beiträge: 469
Registriert: 31. Jan 2014, 17:11

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von rolandb » 11. Jun 2019, 18:23

Und was ist mit download.opensuse.org/repositories/home:Ximi1970_Leap_15.1_acroread-9.5.5-lp151.20.2.x86_64.rpm?
 
download.opensuse.org/repositories/home:Ximi1970_Leap_15.0:
Sauerland hat geschrieben:
22. Jul 2018, 13:35
Naja, da fehlt mehr bzw. schlecht gebaut:

Code: Alles auswählen

zypper in acroread
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Paketabhängigkeiten werden aufgelöst...

Problem: ISO8859-1.so benötigt von acroread-9.5.5-lp150.20.3.x86_64 wird nirgends zur Verfügung gestellt
 Lösung 1: acroread-9.5.5-lp150.20.3.x86_64 nicht installieren
 Lösung 2: acroread-9.5.5-lp150.20.3.x86_64 durch Ignorieren einiger Abhängigkeiten brechen

Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie (a)b [1/2/a] (a): a
Joerg Kuehne hat geschrieben:if there is no ISO8859-1.so, The dependencies are wrong, so it could not
selected automatically.

Sauerland
Guru
Guru
Beiträge: 3518
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von Sauerland » 11. Jun 2019, 19:03

Auch tot.....
iso8859 ist übrigens in glibc-locale-base
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

rolandb
Hacker
Hacker
Beiträge: 469
Registriert: 31. Jan 2014, 17:11

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von rolandb » 11. Jun 2019, 19:35

Sauerland hat geschrieben:
11. Jun 2019, 19:03
Auch tot.....
Ja?
iso8859 ist übrigens in glibc-locale-base
Warum hast du dann das Paket nicht installiert? Du hast doch Leap 15.

thio
Hacker
Hacker
Beiträge: 455
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von thio » 11. Jun 2019, 21:41

Funktioniert nun :-)

muss aber gestehen, ich weis gar nicht welcher der beiden Reader (der ausm Repo oder der von der Adobe-Seite) nun läuft.
(Ich vermute der ausm Repo, da ich in /usr/lib/Adobe/Reader9/bin/acroread das "gbd" wieder auf "exec" zurück geändert habe.)

Was habe ich gemacht.
- (zusätzlich) den Reader von der Adobe-Seite installiert.
- zur Fehlerfindung wie oben beschrieben in Zeils 22 "exec" durch "gbd" ersetzt; wenn man somit acroread in der Console startet und anschließend "run" eingibt wird man in der Fehlerfindung ein bisserl unterstützt.
- von einer funktionierenden LEAP 42.3 Installation (die sind somit also Gold wert :-) den Inhalt vom Ordner

Code: Alles auswählen

/usr/lib/Adobe/Reader9/Reader/intellinux/lib/
(da ich dort einen Reader aus dem REPO verwende (sonst; "/opt/Adobe/Reader9/Reader/intellinux/lib/") kopiert und in den entsprechenden Ordner unter Leap 15 eingefügt.
-Zusätzlich musste ich von der Leap 42.3 Installation noch

Code: Alles auswählen

libpcre.so.1

Code: Alles auswählen

libxcb.so.1
von

Code: Alles auswählen

/usr/lib/
in

Code: Alles auswählen

/opt/Adobe/Reader9/Reader/intellinux/lib
(evtl. auch /zusätzlich??) usr/lib/Adobe/Reader9/Reader/intellinux/lib" falls Reader aus dem Repo) kopieren.
- bei den letzten beiden Dateien würde ich unbedingt "ersetzten" verwenden. Bei den anderen habe ioch (wenn ich mich recht erinnere "überspringen falls vorhanden" bei reinkopieren verwendet (bin mir da aber nicht mehr 100% sicher)
- Wichtig: Anschließend "gbd" in Zeile 22 wieder durch "exec" ersetzten, damit der Reader auch automatisch sauber startet (sprich nicht nur über die Konsole)

Vielen Dank für die Unterstützung.

(p.s. Funktioniert wie oben beschrieben auch auf meinen Leap 15.1 Rechner, hier verwende ich "nur" den Reader von der Adobe- Seite.

Benutzeravatar
Uwe.Lü
Hacker
Hacker
Beiträge: 508
Registriert: 7. Nov 2004, 22:21

Re: Leap 15.0 // 15.1: Acroread startet nicht mehr

Beitrag von Uwe.Lü » 20. Jun 2019, 11:26

Ich habe den Master PDF Editor im Einsatz, volle Funktionalität wie der Adobe Acrobat, aber nicht ganz kostenlos, aber bezahlbar.
Seit dem nutze ich Windows nur, wen ich mein Iphone sichern will/muss.
Acer Aspire V17 Nitro - Black Edition, Distribution: openSUSE Leap 15.1 (x86_64), NVIDIA Corporation GM107M (GeForce GTX 860M)
Acer Extensa, Distribution: openSuse Leap 15.1, Kernel-Version: 4.12.14-lp150.11-default

Antworten