Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Schwarze Videos nach Upgrade auch Leap 42.3

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
mairo
Hacker
Hacker
Beiträge: 302
Registriert: 29. Mai 2005, 09:21
Wohnort: Dortmund

Schwarze Videos nach Upgrade auch Leap 42.3

Beitrag von mairo » 10. Feb 2018, 16:21

Hallöchen Forum,

ich habe meinen zweit-pc ein upgrade von leap 42.2 nach 42.3 verpasst. Seitdem werden alle Videos (egal op mp4, mpg, avi) im VLC oder Kaffeine nur noch "schwarz" abgespielt. Der Ton ist da, aber kein Bild.
Die Anleitungen von hier: https://www.opensuse-forum.de/thread/38 ... ei-videos/ oder hier: https://opensuse-community.org/ habe ich natürlich durchgeführt. Unter 42.2 lief auch alles problemlos.
Vielleicht ein Codec oder Videoausgabefehler? Bei der Grafikkarte handelt es sich um eine Nvidia GT210. Als Treiber benutze ich den freien nouveau Treiber.

Code: Alles auswählen

maik-pc:~ # zypper lr -d
Repository-Prioritäten treten in Kraft:                                                                                                               (Siehe 'zypper lr -P' für Details)
      20 (erhöhte Priorität)  :  1 Repository                                                                                                                                      
      80 (erhöhte Priorität)  :  3 Repositorys
      99 (Standard-Priorität) :  5 Repositorys

# | Alias                               | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                               | Dienst
--+-------------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+-----------------------------------------------------------------------------------+-------
1 | KDE_Extra                           | KDE Extra                                               | Ja        | (r ) Ja         | Ja             |   80      | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.3/          |       
2 | download.opensuse.org-non-oss       | Haupt-Repository (NON-OSS)                              | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/                 |       
3 | download.opensuse.org-non-oss_1     | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja             |   80      | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/                            |       
4 | download.opensuse.org-oss           | Haupt-Repository (OSS)                                  | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/                     |       
5 | download.opensuse.org-oss_1         | Hauptaktualisierungs-Repository                         | Ja        | (r ) Ja         | Ja             |   80      | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                                |       
6 | http-download.opensuse.org-310ad057 | home:ecsos:Backup                                       | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/home:/ecsos:/Backup/openSUSE_Leap_42.3/ |       
7 | http-download.opensuse.org-e988a4c4 | multimedia:apps                                         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_42.3/    |       
8 | http-opensuse-guide.org-626c0045    | libdvdcss repository                                    | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                                |       
9 | http-packman.inode.at-419cc5e0      | Packman Repository                                      | Ja        | (r ) Ja         | Ja             |   20      | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.3/                   
Wer weiß Rat?

Gruß
mairo

Werbung:
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5128
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Schwarze Videos nach Upgrade auch Leap 42.3

Beitrag von tomm.fa » 10. Feb 2018, 18:13

mairo hat geschrieben:
10. Feb 2018, 16:21
Vielleicht ein Codec oder Videoausgabefehler?
Und was ist bei VLC und Xine als Videoausgabe eingestellt, welche Ausgabemöglichkeiten wurden ausprobiert? Was ergibt die Ausgabe von

Code: Alles auswählen

zypper se -si vlc xine kaffeine gst ffmpeg
?
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

goeba
Hacker
Hacker
Beiträge: 250
Registriert: 23. Nov 2015, 13:48

Re: Schwarze Videos nach Upgrade auch Leap 42.3

Beitrag von goeba » 11. Feb 2018, 14:16

Hallo,

das ist ein Bug in nouveau. Hatte ich bei meinem zweit-PC auch.

Du kannst, wie schon empfohlen wurde, das Ausgabemodul bei VLC umstellen (wenn Dir das dann von der Performance her reicht, XRender zum Beispiel), oder den proprietären NVidia Treiber installieren (damit gehts).

Es mag noch andere Lösungen geben (etwa bei Nouveau irgend welche Einstellungen ändern), die kenne ich aber leider nicht.

mairo
Hacker
Hacker
Beiträge: 302
Registriert: 29. Mai 2005, 09:21
Wohnort: Dortmund

Re: Schwarze Videos nach Upgrade auch Leap 42.3

Beitrag von mairo » 11. Feb 2018, 16:05

Hallo,

ich habe nun mal im VLC-Player die Beschleunigte Wiedergabe (Overlay) deaktiviert und bei Ausgabe auf X11 umgestellt. Nun laufen alle Videos zumindest in VLC, das Problem mit Kaffeine und anderen Playern bleibt.

Code: Alles auswählen

maik@maik-pc:~> zypper se -si vlc xine kaffeine gst ffmpeg
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                                  | Typ       | Version             | Arch   | Repository                     
---+---------------------------------------+-----------+---------------------+--------+--------------------------------
i+ | GStreamer Multimedia Codecs           | Anwendung |                     | noarch | (Systempakete)                 
i+ | Kaffeine                              | Anwendung |                     | noarch | (Systempakete)                 
i+ | PackageKit-gstreamer-plugin           | Paket     | 1.1.3-4.4           | x86_64 | Haupt-Repository (OSS)         
i+ | VLC Media player                      | Anwendung |                     | noarch | Hauptaktualisierungs-Repository
i+ | VLC Media player                      | Anwendung |                     | noarch | Haupt-Repository (OSS)         
i+ | ffmpeg                                | Paket     | 3.3.4-9.6           | x86_64 | Packman Repository             
i+ | ffmpegthumbs                          | Paket     | 17.04.2-1.1         | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer                             | Paket     | 1.8.3-4.13          | x86_64 | Haupt-Repository (OSS)         
i  | gstreamer-0_10                        | Paket     | 0.10.36-18.4        | x86_64 | Haupt-Repository (OSS)         
i  | gstreamer-0_10-fluendo-mp3            | Paket     | 21-2.9              | x86_64 | Haupt-Repository (NON-OSS)     
i  | gstreamer-0_10-lang                   | Paket     | 0.10.36-18.4        | noarch | Haupt-Repository (OSS)         
i  | gstreamer-0_10-plugin-esd             | Paket     | 0.10.31-20.9        | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer-0_10-plugins-bad            | Paket     | 0.10.23-30.23       | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer-0_10-plugins-bad-lang       | Paket     | 0.10.23-29.15.45    | noarch | (Systempakete)                 
i+ | gstreamer-0_10-plugins-bad-orig-addon | Paket     | 0.10.23-29.15.45    | x86_64 | (Systempakete)                 
i  | gstreamer-0_10-plugins-base           | Paket     | 0.10.36-17.1        | x86_64 | Haupt-Repository (OSS)         
i  | gstreamer-0_10-plugins-base-lang      | Paket     | 0.10.36-17.1        | noarch | Haupt-Repository (OSS)         
i+ | gstreamer-0_10-plugins-ffmpeg         | Paket     | 0.10.13_p201211-3.4 | x86_64 | Packman Repository             
i+ | gstreamer-0_10-plugins-good           | Paket     | 0.10.31-20.9        | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer-0_10-plugins-good-extra     | Paket     | 0.10.31-20.9        | x86_64 | Haupt-Repository (OSS)         
i  | gstreamer-0_10-plugins-good-lang      | Paket     | 0.10.31-20.9        | noarch | Haupt-Repository (OSS)         
i+ | gstreamer-0_10-plugins-ugly           | Paket     | 0.10.19-19.3        | x86_64 | Haupt-Repository (OSS)         
i  | gstreamer-0_10-plugins-ugly-lang      | Paket     | 0.10.19-19.3        | noarch | Haupt-Repository (OSS)         
i+ | gstreamer-lang                        | Paket     | 1.8.3-4.13          | noarch | Haupt-Repository (OSS)         
i+ | gstreamer-libnice                     | Paket     | 0.1.13-6.3          | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer-plugins-bad                 | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | gstreamer-plugins-bad-lang            | Paket     | 1.8.3-8.10          | noarch | Packman Repository             
i+ | gstreamer-plugins-bad-orig-addon      | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | gstreamer-plugins-base                | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer-plugins-base-lang           | Paket     | 1.8.3-7.16          | noarch | Haupt-Repository (OSS)         
i+ | gstreamer-plugins-farstream           | Paket     | 0.2.8-3.4           | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer-plugins-good                | Paket     | 1.8.3-8.1           | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer-plugins-good-extra          | Paket     | 1.8.3-8.1           | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer-plugins-good-lang           | Paket     | 1.8.3-8.1           | noarch | Haupt-Repository (OSS)         
i+ | gstreamer-plugins-libav               | Paket     | 1.8.3-3.6           | x86_64 | Packman Repository             
i+ | gstreamer-plugins-qt                  | Paket     | 1.2.0-20.5          | x86_64 | KDE Extra                      
i+ | gstreamer-plugins-qt5                 | Paket     | 1.2.0-8.2           | x86_64 | Haupt-Repository (OSS)         
i+ | gstreamer-plugins-ugly                | Paket     | 1.8.3-10.3          | x86_64 | Packman Repository             
i+ | gstreamer-plugins-ugly-lang           | Paket     | 1.8.3-10.3          | noarch | Packman Repository             
i+ | gstreamer-plugins-ugly-orig-addon     | Paket     | 1.8.3-10.3          | x86_64 | Packman Repository             
i+ | gstreamer-plugins-vaapi               | Paket     | 1.8.3-3.2           | x86_64 | Haupt-Repository (OSS)         
i+ | kaffeine                              | Paket     | 2.0.14-67.1         | x86_64 | KDE Extra                      
i  | kaffeine-lang                         | Paket     | 2.0.14-67.1         | noarch | KDE Extra                      
i+ | libXinerama1                          | Paket     | 1.1.3-8.3           | x86_64 | Haupt-Repository (OSS)         
i+ | libgstadaptivedemux-1_0-0             | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libgstallocators-1_0-0                | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i  | libgstapp-0_10-0                      | Paket     | 0.10.36-17.1        | x86_64 | Haupt-Repository (OSS)         
i+ | libgstapp-1_0-0                       | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstaudio-1_0-0                     | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstbadaudio-1_0-0                  | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libgstbadbase-1_0-0                   | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libgstbadvideo-1_0-0                  | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libgstbasecamerabinsrc-0_10-23        | Paket     | 0.10.23-29.15.45    | x86_64 | (Systempakete)                 
i+ | libgstbasecamerabinsrc-1_0-0          | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libgstbasevideo-0_10-23               | Paket     | 0.10.23-29.15.45    | x86_64 | (Systempakete)                 
i+ | libgstcodecparsers-0_10-23            | Paket     | 0.10.23-29.15.45    | x86_64 | (Systempakete)                 
i+ | libgstcodecparsers-1_0-0              | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libgstfft-1_0-0                       | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstgl-1_0-0                        | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i  | libgstinterfaces-0_10-0               | Paket     | 0.10.36-17.1        | x86_64 | Haupt-Repository (OSS)         
i+ | libgstmpegts-1_0-0                    | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libgstpbutils-1_0-0                   | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstphotography-0_10-23             | Paket     | 0.10.23-29.15.45    | x86_64 | (Systempakete)                 
i+ | libgstphotography-1_0-0               | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i  | libgstreamer-0_10-0                   | Paket     | 0.10.36-18.4        | x86_64 | Haupt-Repository (OSS)         
i+ | libgstreamer-1_0-0                    | Paket     | 1.8.3-4.13          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstriff-1_0-0                      | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstrtp-1_0-0                       | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstrtsp-1_0-0                      | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstsdp-1_0-0                       | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstsignalprocessor-0_10-23         | Paket     | 0.10.23-29.15.45    | x86_64 | (Systempakete)                 
i+ | libgsttag-1_0-0                       | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgsturidownloader-1_0-0             | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libgstvdp-0_10-23                     | Paket     | 0.10.23-29.15.45    | x86_64 | (Systempakete)                 
i+ | libgstvdpau                           | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libgstvideo-1_0-0                     | Paket     | 1.8.3-7.16          | x86_64 | Haupt-Repository (OSS)         
i+ | libgstwayland-1_0-0                   | Paket     | 1.8.3-8.10          | x86_64 | Packman Repository             
i+ | libvlc5                               | Paket     | 2.2.6-8.4           | x86_64 | Packman Repository             
i+ | libvlccore8                           | Paket     | 2.2.6-8.4           | x86_64 | Packman Repository             
i+ | libxcb-xinerama0                      | Paket     | 1.11.1-9.1          | x86_64 | Hauptaktualisierungs-Repository
i+ | libxine2                              | Paket     | 1.2.9-131.1         | x86_64 | Packman Repository             
i+ | libxine2-codecs                       | Paket     | 1.2.9-131.1         | x86_64 | Packman Repository             
i+ | libxine2-pulse                        | Paket     | 1.2.9-131.1         | x86_64 | Packman Repository             
i+ | npapi-vlc                             | Paket     | 2.2.0-1.6           | x86_64 | Packman Repository             
i+ | phonon-backend-gstreamer              | Paket     | 4.8.2-6.2           | x86_64 | Haupt-Repository (OSS)         
i+ | phonon4qt5-backend-gstreamer          | Paket     | 4.9.0-3.2           | x86_64 | Haupt-Repository (OSS)         
i+ | vlc                                   | Paket     | 2.2.6-8.4           | x86_64 | Packman Repository             
i+ | vlc-codec-gstreamer                   | Paket     | 2.2.6-8.4           | x86_64 | Packman Repository             
i+ | vlc-codecs                            | Paket     | 2.2.6-8.4           | x86_64 | Packman Repository             
i+ | vlc-lang                              | Paket     | 2.2.6-8.4           | noarch | Packman Repository             
i+ | vlc-noX                               | Paket     | 2.2.6-8.4           | x86_64 | Packman Repository             
i+ | vlc-qt                                | Paket     | 2.2.6-8.4           | x86_64 | Packman Repository             
i+ | xinetd                                | Paket     | 2.3.15-17.2         | x86_64 | Hauptaktualisierungs-Repository
Hilft das noch weiter?
In Kaffeine kann ich übrigens auch keine TV-Sender mehr sehen (auch nur schwarzes Bild mit Ton). Sat-TV übrigens....

Gruß

mairo
Hacker
Hacker
Beiträge: 302
Registriert: 29. Mai 2005, 09:21
Wohnort: Dortmund

Re: Schwarze Videos nach Upgrade auch Leap 42.3

Beitrag von mairo » 11. Feb 2018, 16:35

Habe gerade mal den Nvidia Treiber installiert. Jetzt läuft alles. Warum hat das vorher mit dem freien Treiber geklappt und nun nicht mehr? Komisch alles....

Sauerland
Guru
Guru
Beiträge: 3125
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Schwarze Videos nach Upgrade auch Leap 42.3

Beitrag von Sauerland » 11. Feb 2018, 22:28

Da ist aber noch nicht alles auf 42.3 upgegraded oder auf Packman umgestellt
i+ | gstreamer-0_10-plugins-bad | Paket | 0.10.23-30.23 | x86_64 | Haupt-Repository (OSS)
i+ | gstreamer-0_10-plugins-bad-lang | Paket | 0.10.23-29.15.45 | noarch | (Systempakete)

Das sollte z. B. dieselbe Version sein.......

Aber in 42.3 gibt es nur diese:

Code: Alles auswählen

zypper se -s gstreamer-0_10-plugins-bad
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                                            | Typ        | Version          | Arch   | Repository            
---+-------------------------------------------------+------------+------------------+--------+-----------------------
v  | gstreamer-0_10-plugins-bad                      | Paket      | 0.10.23-29.15.46 | x86_64 | Packman Repository    
i+ | gstreamer-0_10-plugins-bad                      | Paket      | 0.10.23-30.23    | x86_64 | openSUSE-Leap-42.3-Oss
   | gstreamer-0_10-plugins-bad                      | Quellpaket | 0.10.23-29.15.46 | noarch | Packman Repository    
   | gstreamer-0_10-plugins-bad                      | Quellpaket | 0.10.23-29.15.21 | noarch | Packman Repository    
   | gstreamer-0_10-plugins-bad-32bit                | Paket      | 0.10.23-30.23    | x86_64 | openSUSE-Leap-42.3-Oss
   | gstreamer-0_10-plugins-bad-debuginfo            | Paket      | 0.10.23-29.15.46 | x86_64 | Packman Repository    
   | gstreamer-0_10-plugins-bad-debugsource          | Paket      | 0.10.23-29.15.46 | x86_64 | Packman Repository    
   | gstreamer-0_10-plugins-bad-devel                | Paket      | 0.10.23-29.15.46 | x86_64 | Packman Repository    
   | gstreamer-0_10-plugins-bad-devel                | Paket      | 0.10.23-30.23    | x86_64 | openSUSE-Leap-42.3-Oss
   | gstreamer-0_10-plugins-bad-doc                  | Paket      | 0.10.23-29.15.46 | x86_64 | Packman Repository    
   | gstreamer-0_10-plugins-bad-doc                  | Paket      | 0.10.23-30.23    | x86_64 | openSUSE-Leap-42.3-Oss
v  | gstreamer-0_10-plugins-bad-lang                 | Paket      | 0.10.23-29.15.46 | noarch | Packman Repository    
v  | gstreamer-0_10-plugins-bad-lang                 | Paket      | 0.10.23-29.15.21 | noarch | Packman Repository    
i+ | gstreamer-0_10-plugins-bad-lang                 | Paket      | 0.10.23-30.23    | noarch | openSUSE-Leap-42.3-Oss
i+ | gstreamer-0_10-plugins-bad-orig-addon           | Paket      | 0.10.23-29.15.46 | x86_64 | Packman Repository    
   | gstreamer-0_10-plugins-bad-orig-addon-debuginfo | Paket      | 0.10.23-29.15.46 | x86_64 | Packman Repository 

Wie man sieht, gibt es die Version gstreamer-0_10-plugins-bad-lang | Paket | 0.10.23-29.15.45 in 42.3 nicht.

Also ist nicht alles auf 42.3 umgestellt.

Ich würde

Code: Alles auswählen

zypper dup --from http://packman.inode.at/suse/openSUSE_Leap_42.3/
noch ausführen.
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

mairo
Hacker
Hacker
Beiträge: 302
Registriert: 29. Mai 2005, 09:21
Wohnort: Dortmund

Re: Schwarze Videos nach Upgrade auch Leap 42.3

Beitrag von mairo » 12. Feb 2018, 10:57

Danke, Sauerland, habe das Paket noch auf die Version von packman aktualisiert.

Mit dem nvidia Treiber lief es ja auch. Den lasse ich jetzt aber erstmal installiert, denn es funktioniert ja jetzt anscheinend alles.

Danke @all

Gruß

goeba
Hacker
Hacker
Beiträge: 250
Registriert: 23. Nov 2015, 13:48

Re: Schwarze Videos nach Upgrade auch Leap 42.3

Beitrag von goeba » 12. Feb 2018, 16:15

Dass es nach dem Upgrade nicht mehr ging, liegt vermutlich daran, dass der in 42.3 enthaltene neuere Nouveau Treiber Unterstützung zum Dekodieren von Videos auf der Grafikkarte enthält.

Scheinbar meldet der Treiber falsche Fähigkeiten an die Software zurück (tut also so, als könnte ein bestimmter Codec auf der Graka dekodiert werden, kann sie aber nicht / oder der Treiber nicht), sodass dann kein Bild kommt.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste