Seite 1 von 1

[gelöst] Adobe "Acroread" druckt nicht

Verfasst: 23. Dez 2017, 17:38
von thio
Hallo,

ich kann mit den Adobe "Acrobat" auf meinen PC keine PDFs drucken.
Andere Dokumente kann ich auf dem Gerät drucken.

Vom Laptop und dem anderen PC kann ich auch PDFs über "Acroread" drucken.
(die gleiche acroread Version "lewar" vom opensuse server)

Wenn ich auf Drucken gehe, kommt nach wenigen Sekunden "The document could not be printed"..

Hat jemand nen Tipp woran es liegen könnte?

Re: Adobe "Acroread" druckt nicht

Verfasst: 23. Dez 2017, 18:06
von Sauerland
Poste bitte.

Code: Alles auswählen

zypper lr -d

Code: Alles auswählen

zypper se -si acro

Re: Adobe "Acroread" druckt nicht

Verfasst: 24. Dez 2017, 11:42
von thio

Code: Alles auswählen

> zypper lr -d
Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.

#  | Alias                               | Name                              | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ      | URI                                                                                                       | Dienst
---+-------------------------------------+-----------------------------------+-----------+-----------------+----------------+-----------+----------+-----------------------------------------------------------------------------------------------------------+-------
 1 | Lokale_RPM                          | Lokale RPM                        | Ja        | ( p) Ja         | Ja             |   99      | plaindir | dir:///home/dave/opensuse/rpm                                                                             |       
 2 | Opensuse_42.3_ISO                   | Opensuse 42.3 ISO                 | Ja        | (r ) Ja         | Nein           |   99      | yast2    | iso:///?iso=openSUSE-Leap-42.3-DVD-x86_64.iso&url=dir%3A%2Fhome%2Fdave%2Fopensuse                         |       
 3 | Wolfi_KDE_4_-_Opensuse_42.3         | Wolfi KDE 4 - Opensuse 42.3       | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | https://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.3/ |       
 4 | http-download.opensuse.org-41736150 | Printing                          | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://download.opensuse.org/repositories/Printing/openSUSE_Leap_42.3/                                    |       
 5 | http-download.opensuse.org-5b0df0e3 | home:lewar                        | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://download.opensuse.org/repositories/home:/lewar/openSUSE_Leap_42.3/                                 |       
 6 | http-download.opensuse.org-5b16b2bd | home:bigironman:hrv               | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://download.opensuse.org/repositories/home:/bigironman:/hrv/openSUSE_Leap_42.3_Ports/                 |       
 7 | http-download.opensuse.org-74bd0d34 | isv:ownCloud:desktop              | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/openSUSE_Leap_42.3/                      |       
 8 | http-download.opensuse.org-8834f7fd | KDE:KDE3                          | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_Leap_42.3/                                   |       
 9 | http-download.opensuse.org-b1489d38 | mozilla                           | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.3/                                     |       
10 | http-opensuse-guide.org-66a0fe5d    | libdvdcss repository              | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                                                        |                                                                                                        
11 | http-packman.inode.at-f1478bb0      | Packman Repository                | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://packman.inode.at/suse/openSUSE_Leap_42.3/                                                          |                                                                                                        
12 | repo-non-oss                        | openSUSE-Leap-42.3-Non-Oss        | Ja        | (r ) Ja         | Ja             |   99      | yast2    | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/                                         |                                                                                                        
13 | repo-oss                            | openSUSE-Leap-42.3-Oss            | Ja        | (r ) Ja         | Ja             |   99      | yast2    | http://download.opensuse.org/distribution/leap/42.3/repo/oss/                                             |                                                                                                        
14 | repo-update                         | openSUSE-Leap-42.3-Update         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://download.opensuse.org/update/leap/42.3/oss/                                                        |                                                                                                        
15 | repo-update-non-oss                 | openSUSE-Leap-42.3-Update-Non-Oss | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   | http://download.opensuse.org/update/leap/42.3/non-oss/                                                    |                                                                                                        
16 | rpm_cloud                           | rpm_cloud                         | Ja        | ( p) Ja         | Ja             |   99      | plaindir | dir:///home/dave/ownCloud/rpm_cloud                                                                       |                                          

Re: Adobe "Acroread" druckt nicht

Verfasst: 24. Dez 2017, 11:43
von thio
zypper se -si acro

Code: Alles auswählen

> zypper se -si acro                                                                                                                                           
Repository 'Wolfi KDE 4 - Opensuse 42.3' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.                                                      
Repository 'mozilla' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.                                                                          
Repository 'Packman Repository' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.                                                               
Repository 'openSUSE-Leap-42.3-Update' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.                                                        
Repository 'rpm_cloud' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.                                                                        
Repository-Daten werden geladen...                                                                                                                                                  
Installierte Pakete werden gelesen...                                                                                                                                               
                                                                                                                                                                                    
S  | Name     | Typ   | Version    | Arch   | Repository                                                                                                                            
---+----------+-------+------------+--------+-----------                                                                                                                            
i+ | acroread | Paket | 9.5.5-19.1 | x86_64 | Lokale 

Re: Adobe "Acroread" druckt nicht

Verfasst: 24. Dez 2017, 12:40
von thio
So jetzt habe ich acroread mal über die Konsole gestartet..

Wenn ich drucken will bekomme ich die folgende "Fehlermeldung" bzw. Ausgabe in der Konsole..

Code: Alles auswählen

ERROR: ld.so: object '/usr/lib/Adobe/Reader9/Reader/intellinux/lib/suse-do-not-grab-server.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

Re: Adobe "Acroread" druckt nicht

Verfasst: 24. Dez 2017, 13:52
von Sauerland

Re: Adobe "Acroread" druckt nicht

Verfasst: 24. Dez 2017, 16:11
von thio
Sorry, aber irgendwie finde ich die Lösung in den Links nicht...

Die (mir relevant erscheinenden) Pakete die in den Links behandelt werden habe ich eigentlich alle installiert...

Re: Adobe "Acroread" druckt nicht

Verfasst: 24. Dez 2017, 16:51
von Sauerland
Sorry, aber irgendwie finde ich die Lösung in den Links nicht
Ich auch nicht.

Re: Adobe "Acroread" druckt nicht

Verfasst: 28. Dez 2017, 13:26
von thio
Besteht die Möglichkeit, dass ich womöglich "lpr" noch installieren muss?
Der Adobe Reader nutzt standardmäßig lpr aus dem Paket cups-bsd. Erhält man die Fehlermeldung:

Fehler beim Druckvorgang. Prüfen Sie, ob der Drucker mit dem Computer verbunden ist.

Muss das Paket nachinstalliert werden:cups-bsd
https://wiki.ubuntuusers.de/Archiv/Adobe_Reader/
https://wiki.ubuntuusers.de/Archiv/Adobe_Reader/

Re: Adobe "Acroread" druckt nicht

Verfasst: 28. Dez 2017, 13:47
von Sauerland
Ich würde sagen, das das Paket nicht mehr funktioniert.

Nimm etwas anderes.

Re: Adobe "Acroread" druckt nicht

Verfasst: 28. Dez 2017, 16:02
von thio
So, jetzt habe ich den Acroread als "Root" aufgerufen.. Und kann Drucken!!!

Als normaler User geht es nicht...

Es scheint also als würde ein "Berechtigungsproblem" vorliegen!

(Leider kenne ich mich hier genaus so wenig aus..)

Ich drucke auf einem Brother MFC-7360n über das Netzwerk (mit den Brother-Treibern von deren Website)

Hat jemand einen Tipp, wo ich noch weiter auf "Ursachenforschung" gehen kann...

Re: Adobe "Acroread" druckt nicht

Verfasst: 29. Dez 2017, 16:36
von thio
So, hab das Problem lösen können :-)

Hab den User in die Gruppe "lp" aufgenommen.
Anschließend alle installierten Pakete aus dem "Printing" Repository und die installierten "Brother-Treiber" neu installiert ("unbedingt aktualisieren" in YAST); nach einem Neustart hat alles wie gewünscht funktioniert :-)