Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Videos werden nicht gezeigt bei Leap 42.3

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

[gelöst] Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 11. Dez 2017, 21:38

Hallo. Ich habe gerade erfolgreich OS Leap 42.3 auf meinem Rechner installiert. Allerdings laufen jetzt unter Kaffeine keine Videos mehr (der Ton kommt noch, aber kein Bild). Auch bei YouTube laufen keine Videos, obwohl ich den Flash Player für YouTube installiert habe. Bei YouTube erscheint die Fehlermeldung:
Dein Browser erkennt zur Zeit keines der verfügbaren Videoformate
. Ich habe Firefox als Browser.
Wer kann mir helfen?

Update. 22.20 Uhr: Inzwischen habe ich die Videos unter Kaffeine zum Laufen gebracht. Auch das Herunterladen von Videos von YouTube etc. mit dem Video Downloadhelper funktioniert inzwischen. Jedoch kann ich weiterhin keine Videos bei YouTube ansehen, mit der o.a. Fehlermeldung,
Zuletzt geändert von Eckart Spindler am 9. Jan 2018, 20:52, insgesamt 1-mal geändert.

Werbung:
Sauerland
Guru
Guru
Beiträge: 3087
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Sauerland » 12. Dez 2017, 07:18

Packman Repo eingebunden, alle Pakete auf dies Repo umgestellt?

Sowie danach:

Code: Alles auswählen

zypper install -f libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-base gstreamer-0_10-plugins-ffmpeg gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon dvdauthor gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-base  gstreamer-plugins-good gstreamer-plugins-good-extra gstreamer-plugins-libav gstreamer-plugins-qt5 gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs ogmtools
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 12. Dez 2017, 20:37

Habe ich alles gemacht. Videos unter YouTube laufen immer noch nicht. Es kommt noch immer die gleiche Fehlermeldung.
Alle anderen Videos laufen (auch DVD, Life Stream vom Fernsehen etc.)

Sauerland
Guru
Guru
Beiträge: 3087
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Sauerland » 13. Dez 2017, 07:05

Poste:

Code: Alles auswählen

zypper lr -d
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 13. Dez 2017, 18:46

Code: Alles auswählen

Repository priorities in effect:                                                                                                                   (See 'zypper lr -P' for details)
      20 (raised priority)  :  1 repository  
      99 (default priority) :  9 repositories

#  | Alias                           | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
---+---------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
 1 | download.nvidia.com-leap        | nVidia Graphics Drivers                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/42.3                           |        
 2 | download.opensuse.org-42.3-test | Ungetestete Aktualisierungen            | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3-test/                      |        
 3 | download.opensuse.org-oss       | Haupt-Repository (DEBUG)                | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/      |        
 4 | download.opensuse.org-oss_1     | Aktualisierungs-Repository (DEBUG)      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/42.3/oss                  |        
 5 | download.opensuse.org-oss_2     | Haupt-Repository (Quellen)              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/     |        
 6 | openSUSE-Leap-42.3-0            | openSUSE-Leap-42.3-0                    | No      | ----      | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-Intenso_Speed_Line-0:0-part2           |        
 7 | opensuse-guide.org-repo         | Libdvdcss Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                       |        
 8 | packman.inode.at-suse           | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   20     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.3/                         |        
 9 | repo-debug                      | openSUSE-Leap-42.3-Debug                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/      |        
10 | repo-debug-non-oss              | openSUSE-Leap-42.3-Debug-Non-Oss        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/  |        
11 | repo-debug-update               | openSUSE-Leap-42.3-Update-Debug         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                 |        
12 | repo-debug-update-non-oss       | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/             |        
13 | repo-non-oss                    | openSUSE-Leap-42.3-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/        |        
14 | repo-oss                        | openSUSE-Leap-42.3-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/            |        
15 | repo-source                     | openSUSE-Leap-42.3-Source               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/     |        
16 | repo-source-non-oss             | openSUSE-Leap-42.3-Source-Non-Oss       | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/ |                                                                                                                                                       
17 | repo-update                     | openSUSE-Leap-42.3-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                       |                                                                                                                                                       
18 | repo-update-non-oss             | openSUSE-Leap-42.3-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/

Spielwurm
Advanced Hacker
Advanced Hacker
Beiträge: 1310
Registriert: 30. Dez 2007, 11:55
Kontaktdaten:

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Spielwurm » 17. Dez 2017, 20:28

Für Youtube braucht man schon lange keinen Flashplayer mehr. Der ist eher schädlich. Google und Mozilla habe sich zusammengetan und Flash abgeschafft, deshalb gibt es seit geraumer Zeit den OpenH264-Videocodec in den Feuerfüchsen. Vielleicht fehlt auch ein Gstreamer-Plugin - good, bad und ugly sollten installiert sein.

Spielwurm
Tuxedo Book 15-Zoll mit GM-940 und Opensuse 42.2, AMD Phenom und Nvidia GT210 für Video mit Opensuse 13.1, Zbox HD-ND01 als Server, Pentium III/600 für Audio mit Opensuse 13.1

Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 18. Dez 2017, 21:34

OpenH264-Videocodec in den Feuerfüchsen. Vielleicht fehlt auch ein Gstreamer-Plugin - good, bad und ugly sollten installiert sein.
Sind alle installiert, trotzdem funktionieren die Videos auf YouTube nicht.

Sauerland
Guru
Guru
Beiträge: 3087
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Sauerland » 19. Dez 2017, 06:53

Firefox mal so starten:

Code: Alles auswählen

firefox --safe-mode
Geht es dann?

Dort alles aktiv:
https://www.youtube.com/html5

Neuen User anlegen und dort einloggen, funktioniert es dann?
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 19. Dez 2017, 21:08

Hallo Sauerland,

ich habe Firefox jetzt im Safe-Modus gestartet und mich als neuen User angemeldet. So funktioniert es.
Wie mache ich aus dem Safe-Modus jetzt mein neues Standard-Firefox?

Sauerland
Guru
Guru
Beiträge: 3087
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Sauerland » 20. Dez 2017, 18:03

Firefox beenden.
Benenne als alter User einfach das ~/.mozilla/firefox/xxxxx.default in xxxxx.default.bak um.

Starte Firefox als User.
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 20. Dez 2017, 20:45

Ja, wenn ich Firefox als neuer User starte, funktioniert YouTube. Aber wenn ich dann Firefox schließe und erneut starte, kommt bei YouTube wieder der alte Fehler. Wie bringe ich Firefox dazu, sich meine neuen Einstellungen zu merken und automatisch als neuer User zu starten?

Sauerland
Guru
Guru
Beiträge: 3087
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Sauerland » 20. Dez 2017, 20:50

Ja, wenn ich Firefox als neuer User starte,
Bedeutet?

Du meldest dich grafisch statt als User a als User b an?
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 21. Dez 2017, 19:00

Ja, ich klicke auf das Firefox-Symbol auf dem Desktop. Wie melde ich mich denn als User a oder b an (außer über Terminal:

Code: Alles auswählen

firefox -P
)?

abgdf
Guru
Guru
Beiträge: 3073
Registriert: 13. Apr 2004, 21:15

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von abgdf » 21. Dez 2017, 22:03

Eckart Spindler hat geschrieben:
21. Dez 2017, 19:00
Ja, ich klicke auf das Firefox-Symbol auf dem Desktop. Wie melde ich mich denn als User a oder b an (außer über Terminal:

Code: Alles auswählen

firefox -P
)?
Indem Du die .desktop-Datei Deines Firefox-Symbols änderst.

Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 6. Jan 2018, 17:35

Und wie genau mache ich das?
Wenn ich auf das Desktop-Symbol von Firefox mit der rechten Maustaste klicke, erscheint kein Menü, womit ich die Bezeichnung ändern könnte.

Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von SUSEDJAlex » 7. Jan 2018, 00:32

Klicke auf dem Desktop mit der rechten Maustaste und wählst "Miniprogramme entsperren"

Nun kannst über den Kontextmenü die Eigenschaften aufrufen und ggf. ändern.

LG SUSEDJAlex
openSUSE LEAP 42.3 mit Plasma 5.11 / arch linux mit Kernel 4.9.70-1-lts und XFCE4

Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 9. Jan 2018, 19:49

Die Miniprogramme habe ich entsperrt. Aber wenn ich mit der rechten Maustaste auf "Firefox" klicke, kann ich zwar Einstellungen für Fensterleiste etc. ändern, aber keine Eigenschaften.

Eckart Spindler
Member
Member
Beiträge: 144
Registriert: 18. Feb 2012, 22:07

Re: Videos werden nicht gezeigt bei Leap 42.3

Beitrag von Eckart Spindler » 9. Jan 2018, 20:51

Ich habe den Flash Player für YouTube entfernt. Jetzt werden die Videos angezeigt.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast