aktuelles photofilmstrip installieren

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Supertux64
Newbie
Newbie
Beiträge: 8
Registriert: 2. Okt 2017, 21:25

aktuelles photofilmstrip installieren

Beitrag von Supertux64 » 2. Okt 2017, 21:52

Hallo zusammen.

Habe mir gerade das letzte Opensuse Thumbleweed aufgesetzt und würde gerne photofilmstrip installieren.
(Das ist ein äußerst praktisches Programm, mit dem man einfach sehr schöne Filme aus Bildern erstellen kann)
In SuSE bin ich Neuling.

Alle Links in diesem Forum sind veraltet und bringen keine Lösung.

Eingangsvoraussetzungen meines Systems (lt Anleitung durchgeführt):
  • pacman repo ist installiert und die Priorität gesetzt.
    --> Alle gstreamer plugins sind aktualisiert
  • vlc und dragonplayer laufen tadellos
Ich habe in Yast-Softwareverwaltung nichts gefunden.

Auf dieser Seite wird photofilmstrip angeboten:
http://www.photofilmstrip.org/de/

Dazu habe ich, wie dort gewünscht
  • wxpython und python-pillow installiert.
Leider funktioniert photofilmstrip trotzdem NICHT.

Wer hat bereits damit Erfahrung?

Danke im voraus, Paul.

Werbung:

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 4986
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: aktuelles photofilmstrip installieren

Beitrag von tomm.fa » 2. Okt 2017, 22:12

Supertux64 hat geschrieben:
2. Okt 2017, 21:52
Leider funktioniert photofilmstrip trotzdem NICHT.
Bedeutet genau? Startet überhaupt nicht; es gibt Probleme bei der Bedienung?

Code: Alles auswählen

zypper se -si python

Code: Alles auswählen

zypper se -si gstream
ergeben was? Photofilmstrip mal aus der Konsole heraus gestartet? Fehlermeldung(en)?

Nebenbei:
Weshalb gerade openSUSE Tumbleweed und nicht Leap?

Edit:
Nach verschiedenen Versuche mit der Version von der Herstellerseite und der älteren vom OBS - ich bleibe bei Imagination (das läuft wenigstens).
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

bmk
Member
Member
Beiträge: 77
Registriert: 22. Mär 2007, 09:12
Wohnort: Rülzheim

Re: aktuelles photofilmstrip installieren

Beitrag von bmk » 3. Okt 2017, 18:41

Hallo,

auch ich habe Probleme mit photofilmstrip aus dem Repo home:frispete:python unter Leap 42.3:

Code: Alles auswählen

photofilmstrip
Traceback (most recent call last):
  File "/usr/bin/photofilmstrip", line 8, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/photofilmstrip/GUI.py", line 52, in main
    guiApp.Start()
  File "/usr/lib/python2.7/site-packages/photofilmstrip/AppMixin.py", line 57, in Start
    self.InitGStreamer()
  File "/usr/lib/python2.7/site-packages/photofilmstrip/AppMixin.py", line 49, in InitGStreamer
    gi.require_version('Gst', '1.0')
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 102, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Gst not available
Laut Website photofilmstrip.org gibt es folgende Abhängigkeiten:
  • Python 2.7
  • GUI framework wxPython 3.0.2 oder später
  • Python Imaging Library (pillow)
  • gstreamer (>1.6) und plugins
Bei mir sind installiert:
python | Paket | 2.7.13-26.1
python-wxWidgets-3_0 | Paket | 3.0.2.0-5.2
gstreamer + plugins | Paket | 1.8.3-4.13

Gibt es da Unterschiede zwischen wxPython und wxWidgets ?

Gruß bmk

Supertux64
Newbie
Newbie
Beiträge: 8
Registriert: 2. Okt 2017, 21:25

Re: aktuelles photofilmstrip installieren

Beitrag von Supertux64 » 4. Okt 2017, 14:31

Danke für die rasche Antwort.
Ich habe jetzt 42.3 installiert (war nur eine Testinstallation)
Mit der one click install Methode hat das an sich bestens geklappt.

Dies ist die Fehlermeldung, die beim Aufruf aus der Konsole angezeigt wird.
Die Version des wxPython scheint nicht zu passen.
Laut Homepage wird eine Version 3.0.2 verlangt.
Bei mir ist 3.0.2.0-5.2 (Lt Yast) installiert. Sollte eigentlich passen.

Ich bekomme eine ähnliche Meldung, wie mein Vorposter, den ich zu spät bemerkt habe:

Code: Alles auswählen

paul@linux-wzda:~> photofilmstrip
Traceback (most recent call last):
  File "/usr/bin/photofilmstrip", line 8, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/photofilmstrip/GUI.py", line 41, in main
    guiApp.Start()
  File "/usr/lib/python2.7/site-packages/photofilmstrip/AppMixin.py", line 71, in Start
    return self._OnStart()
  File "/usr/lib/python2.7/site-packages/photofilmstrip/GUI.py", line 32, in _OnStart
    wxversion.select("2.8")
  File "/usr/lib/python2.7/site-packages/wxversion.py", line 152, in select
    raise VersionError("Requested version of wxPython not found")
wxversion.VersionError: Requested version of wxPython not found
Ideen?
LG
Paul

bmk
Member
Member
Beiträge: 77
Registriert: 22. Mär 2007, 09:12
Wohnort: Rülzheim

Re: aktuelles photofilmstrip installieren

Beitrag von bmk » 5. Okt 2017, 21:12

Hallo,

nachdem ich die Pakete
python-gstreamer-0_10-0.10.22-16.2.x86_64 und
python-gst-1.8.3-6.2.x86_64

installiert habe, läuft photofilmstrip bei mir.

An Supertux64:

Woher war das photofilmstrip-Paket ?

Bei mir ist installiert:
PhotoFilmStrip-2.0.0-1.1

ansonsten:
python-Pillow-2.9.0-8.2.x86_64
python 2.7.13-26.1

Die Zeile

Code: Alles auswählen

 wxversion.select("2.8")
ist suspekt; hat deine Photofilmstrip-Version andere Abhängigkeiten ?

Gruß bmk

Supertux64
Newbie
Newbie
Beiträge: 8
Registriert: 2. Okt 2017, 21:25

Re: aktuelles photofilmstrip installieren

Beitrag von Supertux64 » 6. Okt 2017, 14:50

Danke für die rasche Antwort.
Ich habe einiges herumgewerkelt und die seltsamen Meldungen wahrscheinlich selbst provoziert.

Einerseits habe ich von dort
https://software.opensuse.org/package/P ... ofilmstrip
zu installieren versucht. Das hat aber etliche Abhängigkeiten mitinstalliert.
Funktioniert hat diese Installation nicht.

Ich habe auch versucht von dort
http://www.photofilmstrip.org/de/download/
direkt das neueste Python Paket herunterzuladen und zu entpacken.
Das hat auch nicht gefruchtet.

Ich experimentiere gerade mit Leap 42.3 herum. Das macht einen SEHR guten Eindruck ;)
Momentan habe ich ein komplett frisch aufgesetztes System vor mir.

Folgendes ist drauf:
codecs mittels packman über Konsole wie dort beschrieben:
http://opensuse-guide.org/codecs.php
Dragon Player und VLC laufen jetzt PERFEKT

Gerade habe ich
python-gstreamer-0_10-0.10.22-16.2.x86_64
python-gst-1.8.3-6.2.x86_64
uber Software (Yast) installiert.

Ausserdem gecheckt:
python-Pillow-2.9.0-8.2.x86_64
python 2.7.13-26.1
Passt auch.

Mir pressiert es ja nicht.
Ich habe inzwischen Imaginagion installiert. Das läuft auch nicht schlecht.
Mit Photofilmstrip habe ich jedoch einige Erfahrung. Da kann man ganz tolle Urlaubsvideos machen.
Mal sehen

Wie bist Du weiter vorgegangen?
Über
https://software.opensuse.org/package/P ... ofilmstrip ?

LG
Paul

bmk
Member
Member
Beiträge: 77
Registriert: 22. Mär 2007, 09:12
Wohnort: Rülzheim

Re: aktuelles photofilmstrip installieren

Beitrag von bmk » 7. Okt 2017, 18:36

Hallo Paul,

inzwischen habe ich jetzt auch noch die letzte Hürde genommen:

Nach Installation diverser gstreamer-Plugins aus dem Packman-Repo fehlte noch:

gstreamer-plugins-ugly-orig-addon-1.8.3-7.1.x86_64

und jetzt kann ich auch mp4-Videos in Full-HD (1440 x 1080) erstellen (vorher ging das nur für Theore/Vorbis).

Wie gesagt, ich nutze die Version 2.0.0 aus dem Repo home:frispete:python .

Imagination habe ich auch ausprobiert, Full-HD (1920 x 1080) geht da nur als VOB.

Man kann auch aus digikam heraus Videos erstellen (Extras -> Create video slideshow), 2 Dinge gefallen mir dabei nicht:
- Bilder können nicht individuell bearbeitet werden
- Bilder im Hochformat (EXIF-gedreht) liegen quer
- Standbild steht nicht richtig (leichtes "Pumpen")

Gruß bmk

Supertux64
Newbie
Newbie
Beiträge: 8
Registriert: 2. Okt 2017, 21:25

HEUREIKA

Beitrag von Supertux64 » 10. Okt 2017, 20:51

Hallo.
Gemischte Nachrichten.

Diese plugins sind installiert: gstreamer-plugins-ugly-orig-addon-1.8.3-7.1.x86_64. Wahrscheinlich mit vorherigen Installationen mitgekommen.

Der 1-click install hat dann funktioniert.

Aber beim Aufruf dieses photofilmstrip habe ich leider wieder nur folgende niederschmetternde die Meldung bekommen.

Code: Alles auswählen

paul@linux:~> photofilmstrip
Traceback (most recent call last):
  File "/usr/bin/photofilmstrip", line 8, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/photofilmstrip/GUI.py", line 41, in main
    guiApp.Start()
  File "/usr/lib/python2.7/site-packages/photofilmstrip/AppMixin.py", line 71, in Start
    return self._OnStart()
  File "/usr/lib/python2.7/site-packages/photofilmstrip/GUI.py", line 32, in _OnStart
    wxversion.select("2.8")
  File "/usr/lib/python2.7/site-packages/wxversion.py", line 152, in select
    raise VersionError("Requested version of wxPython not found")
wxversion.VersionError: Requested version of wxPython not found
Danach habe ich (fast schon entmutigt) mittels software photofilmstrip deinstalliert und das repository entfernt.

Spasshalber habe ich die sourcen von Jens Göpfert heruntergeladen und entpackt. Danach direkt per Konsole installiert.

... und siehe da: Photofilmstrip 3.02 läuft. Die beiden Icons im Hauptbild sind nicht sehr schön, aber es läuft. Full HD-Video habe ich auch machen können.

LG
Paul

Supertux64
Newbie
Newbie
Beiträge: 8
Registriert: 2. Okt 2017, 21:25

Re: aktuelles photofilmstrip installieren

Beitrag von Supertux64 » 30. Okt 2017, 09:13

Nachtrag.

Leider konnte ich die Installation auf meinem zweiten PC (Notebook) nicht reproduzieren.
Das Notebook hat zwar eine andere Grafikkarte (nvidia), aber ich denke, das wird nicht die Ursache sein.

Ich schätze, das hat irgendwie mit den Versionen und Zusammenstellungen der Bibliotheken zu tun.
Die ändern sich ja im Laufe der vielen Aktualisierungen, mal sehen - vielleicht klappts ja zu einem späteren Zeitpunkt.

Kommt Zeit, kommt Rat.

josef-wien
Guru
Guru
Beiträge: 4869
Registriert: 23. Sep 2008, 17:09

Re: aktuelles photofilmstrip installieren

Beitrag von josef-wien » 30. Okt 2017, 10:59

Supertux64 hat geschrieben:
30. Okt 2017, 09:13
Das Notebook hat zwar eine andere Grafikkarte (nvidia)
Die Wahrscheinlichkeit spricht dafür, daß das (auch) der Grund ist. Mit "geht nicht" kann Dir niemand helfen.

Supertux64
Newbie
Newbie
Beiträge: 8
Registriert: 2. Okt 2017, 21:25

Re: aktuelles photofilmstrip installieren

Beitrag von Supertux64 » 30. Okt 2017, 17:46

Die Wahrscheinlichkeit spricht dafür, daß das (auch) der Grund ist. Mit "geht nicht" kann Dir niemand helfen.
Nun, mit "geht nicht" meine ich immer denselben Fehler, den ich schon vorher gepostet habe.

Beim Start meckert python immer an, dass wxpython in der falschen Version wäre.

Code: Alles auswählen

"Requested version of wxPython not found"
Das ist das Problem.

Die Version vom repo hat bei mir noch nie funktioniert, lediglich die heruntergeladene Version, aber leider genau einmal auf einem PC und nicht auf dem Notebook.

Naja, glücklicherweise ist das nicht mein dringendstes Anliegen.

LG
Paul

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast