Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

(gelöst) 11.4 lautstärke nichht regelbar

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
herbk
Member
Member
Beiträge: 215
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

(gelöst) 11.4 lautstärke nichht regelbar

Beitrag von herbk » 15. Mär 2011, 19:25

Hi Leute,
bei meiner 11.4 kann ich die Lautstärke nicht Regeln.
Ton ist da, nur eben nicht veränderbar.
Einzige Einschränkung: wenn ich mit Kaffeine etwas abspiele kann ich die Lautstärke mit dem Regler im Kaffeine Panel regeln.

Wenn ich den Mixer aufrufe, habe ich auch keinerlei Einstellmöglichkeiten - ist einfach nur ein Fenster ohne Inhalt...
Zuletzt geändert von herbk am 16. Mär 2011, 16:14, insgesamt 1-mal geändert.
have a lot of input
HerbK

Werbung:
gropiuskalle
Guru
Guru
Beiträge: 4603
Registriert: 20. Nov 2007, 15:17
Wohnort: Berlin
Kontaktdaten:

Re: 11.4 lautstärke nichht regelbar

Beitrag von gropiuskalle » 15. Mär 2011, 19:28

KMix → Einstellungen → Kanäle einrichten → dort die gewünschten Regler aktivieren. Geht's so besser?

herbk
Member
Member
Beiträge: 215
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 11.4 lautstärke nichht regelbar

Beitrag von herbk » 15. Mär 2011, 19:47

Nein, leider nicht - es sind keine Kanäle da - einfach nur ein lehres Fenster.
have a lot of input
HerbK

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7177
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: 11.4 lautstärke nichht regelbar

Beitrag von lOtz1009 » 15. Mär 2011, 19:49

vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

herbk
Member
Member
Beiträge: 215
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

(gelöst) Re: 11.4 lautstärke nichht regelbar

Beitrag von herbk » 16. Mär 2011, 11:29

Hi zusammen,

das von mir Eingangs beschriebene Problem besteht (bei mir zumindest) nur, wenn man die 11.4 parallel installiert und bereits vorhandene User nutzt.

Legt man einen neuen User an, werden unter KMix → Einstellungen → Kanäle einrichten die vorhandenen Kanäle angezeigt. und können auch ganz normal ausgewählt werden.

In der Variante "vorhandenen User nutzen" kann man, auch wenn unter "KMix → Einstellungen → Kanäle einrichten" keine Kanäle angezeigt werden, unter "KMix → Einstellungen → Hauptkanal auswählen" eben diesen auswählen.
Hier den richtigen Kanal ausgewählt - stand bei mir auf "...HDMI", was aber nicht angeschlossen ist - und die Lautstärke lässt sich auch über den Lautstärkeregler in der Taskleiste einstellen.
have a lot of input
HerbK

Benutzeravatar
revo
Member
Member
Beiträge: 126
Registriert: 23. Mär 2006, 18:20
Wohnort: Berlin

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von revo » 16. Mär 2011, 18:50

Hey herbk,
das Problem was du oben beschrieben hattes, war auch bei mir. Es scheint aber doch ein ein generelles Problem bei Suse 11.4 zu sein. Welches Soundmondul hast Du denn?
Hier mal meine:

Code: Alles auswählen

hwinfo --sound
13: PCI 1b.0: 0403 Audio device                                 
  [Created at pci.318]
  Unique ID: u1Nb.BKOM8kUqDq1
  SysFS ID: /devices/pci0000:00/0000:00:1b.0
  SysFS BusID: 0000:00:1b.0
  Hardware Class: sound
  Model: "Intel 82801I (ICH9 Family) HD Audio Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x293e "82801I (ICH9 Family) HD Audio Controller"
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
  SubDevice: pci 0x0201 
  Revision: 0x03
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xf5500000-0xf5503fff (rw,non-prefetchable)
  IRQ: 29 (8078 events)
  Module Alias: "pci:v00008086d0000293Esv00001025sd00000201bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=yes, avail=yes, need=no, active=unknown

27: PCI 100.1: 0403 Audio device
  [Created at pci.318]
  Unique ID: NXNs.dGZr9rwUva1
  Parent ID: vSkL._PokxAwzWC9
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.1
  SysFS BusID: 0000:01:00.1
  Hardware Class: sound
  Model: "nVidia Audio device"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0be2 
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
  SubDevice: pci 0x0201 
  Revision: 0xa1
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xf5000000-0xf5003fff (rw,non-prefetchable)
  IRQ: 16 (155 events)
  Module Alias: "pci:v000010DEd00000BE2sv00001025sd00000201bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=yes, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge
Habe aber die Sache nicht weiter verfolgt. Das war mir zu doo... :/ Bin wieder bei Suse 11.3
Gruß revo
Acer Aspire 7738G-744G32MN *TV Gigant II*
NVIDIA GeForce GT240M 1024 MB VRAM
Windows® 7 Home Premium (64-Bit)
openSUSE 13.2 (Harlequin) (x86_64)
Linux 3.16.7-21-desktop
KDE 4.14.6

herbk
Member
Member
Beiträge: 215
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von herbk » 17. Mär 2011, 07:14

Moin revo:
mein soundmodul:

Code: Alles auswählen

 herbert@nicolle:~> /usr/sbin/hwinfo --sound
19: PCI 14.2: 0403 Audio device                                 
  [Created at pci.318]
  Unique ID: 5Dex.oA41xEVyYuE
  SysFS ID: /devices/pci0000:00/0000:00:14.2
  SysFS BusID: 0000:00:14.2
  Hardware Class: sound
  Model: "ATI SBx00 Azalia (Intel HDA)"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x4383 "SBx00 Azalia (Intel HDA)"
  SubVendor: pci 0x1458 "Giga-byte Technology"
  SubDevice: pci 0xa102 
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xfe024000-0xfe027fff (rw,non-prefetchable)
  IRQ: 16 (5851 events)
  Module Alias: "pci:v00001002d00004383sv00001458sd0000A102bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=yes, avail=yes, need=no, active=unknown

29: PCI 105.1: 0403 Audio device
  [Created at pci.318]
  Unique ID: l4dC.S8sXOYE7ZQB
  Parent ID: vSkL.2yY_xudKZ6E
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.1
  SysFS BusID: 0000:01:05.1
  Hardware Class: sound
  Model: "ATI Audio device"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x970f 
  SubVendor: pci 0x1458 "Giga-byte Technology"
  SubDevice: pci 0x960f 
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xfdffc000-0xfdffffff (rw,non-prefetchable)
  IRQ: 19 (14607 events)
  Module Alias: "pci:v00001002d0000970Fsv00001458sd0000960Fbc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=yes, avail=yes, need=no, active=unknown
  Attached to: #8 (PCI bridge)
  
Was mich mehr generft hat war allerdings, das dhcp bei mir nicht funktioniert....
have a lot of input
HerbK

Benutzeravatar
revo
Member
Member
Beiträge: 126
Registriert: 23. Mär 2006, 18:20
Wohnort: Berlin

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von revo » 17. Mär 2011, 07:42

Moin moin,
da wir beide schon mal den gleichen Treiber nehmen, war mein Verdacht gleich, dass es mit KDE 4.6 zu tun haben muss. Wollte auf KDE 4.55 zurück aber die Repositories von 4.5 hatte ich nicht gefunden.

Noch einen schönen Tag
revo
Acer Aspire 7738G-744G32MN *TV Gigant II*
NVIDIA GeForce GT240M 1024 MB VRAM
Windows® 7 Home Premium (64-Bit)
openSUSE 13.2 (Harlequin) (x86_64)
Linux 3.16.7-21-desktop
KDE 4.14.6

Benutzeravatar
willithepimp
Member
Member
Beiträge: 156
Registriert: 10. Jan 2009, 12:59

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von willithepimp » 18. Mär 2011, 16:16

Hab ähnliche Probleme. Mal sind die Regler da, dann wieder nicht. Mal zeigt Phonon meinen Soundchip des Mainboards an, beim nächsten mal steht davor lokales analoges Soundsystem (oder so ähnlich). Beim nächsten Mal sind ne ganze Reihe (virtueller) Soundkarten aufgeführt, die alle tatsächlich nicht vorhanden sind.
Ähnlich durcheinander geht es im Yast-Modul zu. Mal sind Regler da, dann wieder nicht. Mal funktioniert der Testsound, mal nicht.
Seltsamerweise kann ich aber immer (!) Musik, Systemsounds usw. hören. Die Funktionalität scheint nicht eingeschränkt zu sein.
Nun bin ich im Phonon Backend von G-Streamer auf Xine (Packman) gewechselt. Mal sehn ob das was bringt. Ansonsten zurück zu 11.3.

dietger
Hacker
Hacker
Beiträge: 626
Registriert: 17. Okt 2005, 10:27

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von dietger » 18. Mär 2011, 17:15

Seltsamerweise kann ich aber immer (!) Musik, Systemsounds usw. hören. Die Funktionalität scheint nicht eingeschränkt zu sein.
Dann ist es doch ok, verstehe nicht warum man dann auf 11.3 zurück will. Ist doch letzlich nur eine nachgeordnete, optisch vielleicht unschöne Sache.
Mehr doch nicht.
Bei mir streikte Kmix auch, habe dann einen anderen Mixer installiert(gibt ja genug davon) und die Sache war erledigt.


Dietger

Benutzeravatar
revo
Member
Member
Beiträge: 126
Registriert: 23. Mär 2006, 18:20
Wohnort: Berlin

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von revo » 18. Mär 2011, 17:35

Hey dietger,
verstehe nicht warum man dann auf 11.3 zurück will. Ist doch letztlich nur eine nachgeordnete, optisch vielleicht unschöne Sache.
im Prinzip hast Du ja Recht. Aber ich mache solchen Spaß seit Suse 9.0 mit. Mal geht dies nicht, dann wieder was anderes. Irgendwas ist immer. Was mich nervt ist, dass diese Anwendungen alle schon mal super ihre Arbeit getan haben. Aber immer alles erst einmal bei der neuen Distribution neu erfunden werden muss. Ich weiß ja das man lieber ein bis zwei Monate nach Erscheinen warten sollte. Aber ich habe immer noch die Hoffnung, dass dieses mal alles anders werden würde. :D
LG revo
Acer Aspire 7738G-744G32MN *TV Gigant II*
NVIDIA GeForce GT240M 1024 MB VRAM
Windows® 7 Home Premium (64-Bit)
openSUSE 13.2 (Harlequin) (x86_64)
Linux 3.16.7-21-desktop
KDE 4.14.6

K4m1K4tz3
Advanced Hacker
Advanced Hacker
Beiträge: 987
Registriert: 19. Jan 2005, 13:54
Kontaktdaten:

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von K4m1K4tz3 » 18. Mär 2011, 18:19

Versuche es mal damit Pulseaudio zu deinstallieren.
Mein System: SUSE 11.4, x86_64, KDE 4.6

Mein Jabber: masterunderlined@jabber.ccc.de

Benutzeravatar
revo
Member
Member
Beiträge: 126
Registriert: 23. Mär 2006, 18:20
Wohnort: Berlin

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von revo » 18. Mär 2011, 19:20

Hey K4m1K4tz3,
danke für den Tipp. Wie schon mal schrieb, bin ich schon wieder bei 11.3 gelandet. Kann mich aber erinnern,
Versuche es mal damit Pulseaudio zu deinstallieren.
das war doch schon mal ein Problem bei einer Distri.
Wollte auch nur mal meinen Senf zu diesen Threads geben. Und den Entwicklern vielleicht einen Hinweis geben, dass der Verfasser des Threads(herbk) nicht der einzige ist der das Problem hat.
Danke für diesen Tipp. Für mich leider zu spät.
LG revo
Acer Aspire 7738G-744G32MN *TV Gigant II*
NVIDIA GeForce GT240M 1024 MB VRAM
Windows® 7 Home Premium (64-Bit)
openSUSE 13.2 (Harlequin) (x86_64)
Linux 3.16.7-21-desktop
KDE 4.14.6

Benutzeravatar
bookmark
Newbie
Newbie
Beiträge: 30
Registriert: 16. Nov 2009, 17:59
Wohnort: WLan

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von bookmark » 18. Mär 2011, 22:07

Ist zwar ziemlich "dirty" aber ich würde es mal so versuchen.

Code: Alles auswählen

mv /usr/bin/pulseaudio /usr/bin/pulseaudio.bak
Reboot nicht vergessen.

Bei nicht gefallen einfach zurück verschieben.

Code: Alles auswählen

mv /usr/bin/pulseaudio.bak /usr/bin/pulseaudio
Gentoo amd64 KDE

Spielwurm
Advanced Hacker
Advanced Hacker
Beiträge: 1321
Registriert: 30. Dez 2007, 11:55
Kontaktdaten:

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von Spielwurm » 19. Mär 2011, 10:20

Habe jetzt den zweiten Laptop mit Opensuse 11.4 versorgt. Ton geht, Regler bei kmix können nicht angezeigt werden. Deinstallation von allem, was "pulse" heißt und sich entfernen lässt -> Regler wieder da.

Hartmut
Tuxedo Book 15-Zoll mit GM-940 und Opensuse 15.1, AMD Phenom und Nvidia GT210 für Video mit Opensuse 15.1, Hardkernel Odroid XU4 mit Debian als Server, Thinkpad 570 für Audio mit Puppy-Linux

herbk
Member
Member
Beiträge: 215
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: (gelöst) 11.4 lautstärke nichht regelbar

Beitrag von herbk » 19. Mär 2011, 15:12

....Deinstallation von allem, was "pulse" heißt und sich entfernen lässt ...
jep - jetzt hab ich auch Regler
have a lot of input
HerbK

Antworten