Seite 1 von 1

[gelöst] Apache 2.0x mit PHP 4.x.x oder PHP 5.x.x no file

Verfasst: 25. Feb 2004, 13:50
von Somba
Hallo ,

Nach verschiedenen versuchen PHP Erfolgreich zu Installieren
bin ich immer an dem Punkt gescheidert wenn die libphp4.so
oder libphp5.so benötigt wird.

Konfiguration :

System : Suse 8.0 ohne KDE mit WindowMaker

Installiert --> glib,zlib,gettext,gd,freetype und jpeg.


Appache 2.0.x

./configure --prefix=/usr/local/apache \
--enable-so

oder

./configure --prefix=/usr/local/apache \
--enable-module=most \
--enable-shared=max


configure ohne Probleme.
make ohne Probleme.
make install ohne Probleme.

PHP 4 oder 5

./configure --with-apxs2=/usr/local/apache/bin/apxs \
--with-mysql=/usr/local/mysql/ \
--prefix=/usr/local/apache/php \
--with-config-file-path=/usr/local/apache/conf/ \
--with-zlib \
--with-gettext \
--with-gd \
--with-jpeg \

configure ohne Probleme.
make ohne Probleme.
make install Abbruch wegen Fehlender libphp4.so oder libphp5.so.

wie kann ich ich dieses Problem beheben ?

mfG
Somba

Verfasst: 25. Feb 2004, 17:48
von Somba
hab das Problem gelöst.

Somba

Verfasst: 2. Apr 2004, 16:29
von johnpatcher
kannst du vielleicht sagen, wie? ich hänge genau vor dem selben ... :(

Verfasst: 18. Mai 2004, 14:11
von Paladin
Um auch nachfolgende Leute die Lösung bereitszustellen:
Nach dem "./configure" muss man vor dem "make" noch "make clean" ausführen, dann funktionierts.

Ich hoffe damit euch viele Stunden Sucharbeit erspaart zu haben.

Gruss Bram