Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

leap 15.2 nach Update kein Wlan mehr

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
mike321
Member
Member
Beiträge: 121
Registriert: 15. Sep 2007, 14:12

leap 15.2 nach Update kein Wlan mehr

Beitrag von mike321 »

Moin!
Nach längerer Zeit benötige ich mal Hilfe weil ich einfach nicht mehr weiter komme mit meinem Wissen.Also ich habe einen alten HP DC 5800 Desktop Rechner auf dem leap 15.2 ins Netz gehe ich über einen W-Lan USB Stick,der bis vor ein paar Tagen seinen Dienst sehr gut verrichtet hat,nun geht nix mehr.

Eigentlich hatte ich es über wicked laufen,jetzt habe ich auch mal den Netzwerkmanager aktiviert,das Wlan wird auch gefunden und wenn ich auf verbinden gehe,läuft er ins leere und nach ein paar sekunden heisst es "Wlan wurde deaktiviert".

Wenn ich den Router anpingen will kommt "dieses Netzwerk ist nicht erreichbar".Den Adapter habe ich schon getauscht,Router resetet,ich bin im Kernel von
5.3.18-lp152.66-default auf Kernel 5.3.18-lp152.57-default zurück gegangen,weil das hier erwähnt wurde,das es Problme mit dem neuen Kernel gibt,geht trotzdem nicht mehr.

Über die eingebaute Netzwerkkarte also über Kabel funktioniert das Netz wunderbar.ich habe immer feste IP´s vergeben genau wie Gateway und DNS.
Signalstärke liegt über 50% und ich habe schon die WPA2 Verschlüsselung und MAC Filter abgeschaltet aber ich denke es hat eh nichts mit dem Router sondern mit Leap zu tun das es nicht läuft.

Den Wlan Adapter den ich benutze nennt sich "mt7601u".

Braucht Ihr irgendwelche Logfiles bitte Bescheid sagen,erstmal besten Dank.

Gruß mike
PC 1:OpenSuse Leap 15.2 Plasma 5 Nvidia - GTX560 - MSI Gaming AMD 970 - FX 8350 - 16GB Teamgroup DDR 3 1333Mhz
PC 2:OpenSuse Leap 15.2 Plasma 5 ATI - 5860 - HP DC5800
Sauerland
Guru
Guru
Beiträge: 4031
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: leap 15.2 nach Update kein Wlan mehr

Beitrag von Sauerland »

Konsole öffnen, als root:

Code: Alles auswählen

journalctl -f
Stick anstecken und alle neu hinzugekommenen Meldungen hier in Code-Tags posten.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
mike321
Member
Member
Beiträge: 121
Registriert: 15. Sep 2007, 14:12

Re: leap 15.2 nach Update kein Wlan mehr

Beitrag von mike321 »

Moin!

Code: Alles auswählen

Mär 11 12:53:10 Jupiter kernel: usb 7-4: new high-speed USB device number 4 using ehci-pci
Mär 11 12:53:11 Jupiter kernel: usb 7-4: New USB device found, idVendor=148f, idProduct=7601, bcdDevice= 0.00
Mär 11 12:53:11 Jupiter kernel: usb 7-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mär 11 12:53:11 Jupiter kernel: usb 7-4: Product: 802.11 n WLAN
Mär 11 12:53:11 Jupiter kernel: usb 7-4: Manufacturer: MediaTek
Mär 11 12:53:11 Jupiter kernel: usb 7-4: SerialNumber: 1.0
Mär 11 12:53:11 Jupiter kernel: usb 7-4: reset high-speed USB device number 4 using ehci-pci
Mär 11 12:53:11 Jupiter kernel: mt7601u 7-4:1.0: ASIC revision: 76010001 MAC revision: 76010500
Mär 11 12:53:11 Jupiter kernel: mt7601u 7-4:1.0: Firmware Version: 0.1.00 Build: 7640 Build time: 201302052146____
Mär 11 12:53:11 Jupiter kernel: mt7601u 7-4:1.0: EEPROM ver:0d fae:00
Mär 11 12:53:12 Jupiter kernel: ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Mär 11 12:53:12 Jupiter NetworkManager[3414]: <info>  [1615463592.0178] manager: (wlan0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/4)
Mär 11 12:53:12 Jupiter systemd[1]: Starting Load/Save RF Kill Switch Status...
Mär 11 12:53:12 Jupiter mtp-probe[5011]: checking bus 7, device 4: "/sys/devices/pci0000:00/0000:00:1d.7/usb7/7-4"
Mär 11 12:53:12 Jupiter mtp-probe[5011]: bus: 7, device: 4 was not an MTP device
Mär 11 12:53:12 Jupiter systemd-udevd[5013]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
Mär 11 12:53:12 Jupiter NetworkManager[3414]: <info>  [1615463592.0389] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1d.7/usb7/7-4/7-4:1.0/ieee80211/phy1/rfkill1) (driver mt7601u)
Mär 11 12:53:12 Jupiter systemd[1]: Started Load/Save RF Kill Switch Status.
Mär 11 12:53:12 Jupiter NetworkManager[3414]: <info>  [1615463592.0431] device (wlan0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Mär 11 12:53:12 Jupiter NetworkManager[3414]: <info>  [1615463592.0861] device (wlan0): set-hw-addr: set MAC address to 5E:D8:65:9D:2C:AB (scanning)
Mär 11 12:53:12 Jupiter NetworkManager[3414]: <warn>  [1615463592.1152] device (wlan0): connectivity: "/proc/sys/net/ipv4/conf/wlan0/rp_filter" is set to "1". This might break connectivity checking for IPv4 on this device
Mär 11 12:53:12 Jupiter NetworkManager[3414]: <info>  [1615463592.1628] sup-iface[0x55edb8398a00,wlan0]: supports 4 scan SSIDs
Mär 11 12:53:12 Jupiter NetworkManager[3414]: <info>  [1615463592.1641] device (wlan0): supplicant interface state: starting -> ready
Mär 11 12:53:12 Jupiter NetworkManager[3414]: <info>  [1615463592.1641] device (wlan0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Mär 11 12:53:12 Jupiter plasmashell[2230]: qml: Network interface added: wlan0
Mär 11 12:53:12 Jupiter plasmashell[2230]: qml: Network interface added: wlan0
Mär 11 12:53:12 Jupiter plasmashell[2230]: qml: Network interface added: wlan0
Mär 11 12:53:12 Jupiter plasmashell[2230]: qml: Network interface added: wlan0
Mär 11 12:53:14 Jupiter ModemManager[1028]: <info>  Couldn't check support for device '/sys/devices/pci0000:00/0000:00:1d.7/usb7/7-4': not supported by any plugin
Mär 11 12:53:41 Jupiter kernel: perf: interrupt took too long (3920 > 3918), lowering kernel.perf_event_max_sample_rate to 51000
PC 1:OpenSuse Leap 15.2 Plasma 5 Nvidia - GTX560 - MSI Gaming AMD 970 - FX 8350 - 16GB Teamgroup DDR 3 1333Mhz
PC 2:OpenSuse Leap 15.2 Plasma 5 ATI - 5860 - HP DC5800
Sauerland
Guru
Guru
Beiträge: 4031
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: leap 15.2 nach Update kein Wlan mehr

Beitrag von Sauerland »

Poste:

Code: Alles auswählen

systemctl status network.service
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
mike321
Member
Member
Beiträge: 121
Registriert: 15. Sep 2007, 14:12

Re: leap 15.2 nach Update kein Wlan mehr

Beitrag von mike321 »

Moin!

Danke für Deine Mühe hier die Status Meldung

Code: Alles auswählen

systemctl status network.service
● systemd-networkd.service - Network Service
   Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2021-03-11 17:30:03 CET; 18s ago
     Docs: man:systemd-networkd.service(8)
 Main PID: 5052 (systemd-network)
   Status: "Processing requests..."
    Tasks: 1
   CGroup: /system.slice/systemd-networkd.service
           └─5052 /usr/lib/systemd/systemd-networkd
Gruss mike
PC 1:OpenSuse Leap 15.2 Plasma 5 Nvidia - GTX560 - MSI Gaming AMD 970 - FX 8350 - 16GB Teamgroup DDR 3 1333Mhz
PC 2:OpenSuse Leap 15.2 Plasma 5 ATI - 5860 - HP DC5800
Sauerland
Guru
Guru
Beiträge: 4031
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: leap 15.2 nach Update kein Wlan mehr

Beitrag von Sauerland »

So wie ich das sehe, wird dein System über systemd-networkd und nicht über wicked oder Networkmanager gesteuert.

Nicht unbedingt meine Baustelle.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Sauerland
Guru
Guru
Beiträge: 4031
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: leap 15.2 nach Update kein Wlan mehr

Beitrag von Sauerland »

Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
mike321
Member
Member
Beiträge: 121
Registriert: 15. Sep 2007, 14:12

Re: leap 15.2 nach Update kein Wlan mehr

Beitrag von mike321 »

Moin!
Also früher lief das ja über wicked,Du hattest mir ja gesagt,ich solle mal den Status des network.service abfragen da kommt dann aber

Code: Alles auswählen

systemctl status network.service
Unit network.service could not be found.
deswegen hatte ich mal kurzfristig den systemd-networkd eingeschaltet ,aber eigentlich das habe ich gerade bei meinem anderen PC gesehen läuft dieser Diest nicht deswegen habe ich Ihn jetzt wieder abgeschaltet.

Der NetzwerkManager läuft und gibt folgendes bei Status aus vielleicht kannst Du da ja was mit anfangen,Danke für die Links ich werde mir das mal ansehen.

Code: Alles auswählen

systemctl status NetworkManager.service
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Thu 2021-03-11 18:52:35 CET; 1min 53s ago
     Docs: man:NetworkManager(8)
 Main PID: 1041 (NetworkManager)
    Tasks: 3
   CGroup: /system.slice/NetworkManager.service
           └─1041 /usr/sbin/NetworkManager --no-daemon

Mär 11 18:52:37 Jupiter NetworkManager[1041]: <info>  [1615485157.9809] device (wlan0): set-hw-addr: set MAC address to 1A:03:44:BB:9E:2C (scanning)
Mär 11 18:52:38 Jupiter NetworkManager[1041]: <info>  [1615485158.0781] ovsdb: Could not connect: No such file or directory
Mär 11 18:52:38 Jupiter NetworkManager[1041]: <info>  [1615485158.0813] supplicant: wpa_supplicant running
Mär 11 18:52:38 Jupiter NetworkManager[1041]: <info>  [1615485158.0813] device (wlan0): supplicant interface state: init -> starting
Mär 11 18:52:38 Jupiter NetworkManager[1041]: <info>  [1615485158.0815] modem-manager: ModemManager available
Mär 11 18:52:38 Jupiter NetworkManager[1041]: <info>  [1615485158.3425] sup-iface[0x561d93dd5920,wlan0]: supports 4 scan SSIDs
Mär 11 18:52:38 Jupiter NetworkManager[1041]: <info>  [1615485158.3433] device (wlan0): supplicant interface state: starting -> ready
Mär 11 18:52:38 Jupiter NetworkManager[1041]: <info>  [1615485158.3434] device (wlan0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state>
Mär 11 18:52:43 Jupiter NetworkManager[1041]: <info>  [1615485163.9470] manager: startup complete
Mär 11 18:53:12 Jupiter NetworkManager[1041]: <info>  [1615485192.8796] agent-manager: agent[8c8edcf698f48881,:1.26/org.kde.plasma.networkmanagement/1000]: agent registered
Gruss mike
PC 1:OpenSuse Leap 15.2 Plasma 5 Nvidia - GTX560 - MSI Gaming AMD 970 - FX 8350 - 16GB Teamgroup DDR 3 1333Mhz
PC 2:OpenSuse Leap 15.2 Plasma 5 ATI - 5860 - HP DC5800
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2380
Registriert: 24. Okt 2005, 14:04

Re: leap 15.2 nach Update kein Wlan mehr

Beitrag von Heinz-Peter »

mike321 hat geschrieben: 11. Mär 2021, 19:01Also früher lief das ja über wicked,Du hattest mir ja gesagt,ich solle mal den Status des network.service abfragen da kommt dann aber

Code: Alles auswählen

systemctl status network.service
Unit network.service could not be found.
Komisch, bei mir läuft der NM und das kommt raus:

Code: Alles auswählen

 systemctl status network.service
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Thu 2021-03-11 17:49:16 CET; 17min ago
     Docs: man:NetworkManager(8)
 Main PID: 1364 (NetworkManager)
    Tasks: 3
   CGroup: /system.slice/NetworkManager.service
           └─1364 /usr/sbin/NetworkManager --no-daemon
Vielleicht

Code: Alles auswählen

systemctl restart network.service
versuchen?
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
admine
Administrator
Administrator
Beiträge: 8930
Registriert: 15. Feb 2004, 21:13

Re: leap 15.2 nach Update kein Wlan mehr

Beitrag von admine »

mike321 hat geschrieben: 11. Mär 2021, 19:01

Code: Alles auswählen

systemctl status network.service
Unit network.service could not be found.
Eigentlich ist es egal, welcher Dienst hinter network.service steht. Das kann der NetworkManager sein, das kann wicked sein oder auch networkd
Evt. wird dein Netzwerk-Dienst nicht gestartet beim Booten.
Versuche mal:

Code: Alles auswählen

systemctl enable network.service
systemctl start network.service
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Antworten