Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Ohne Internetverbindung kein Start von Firfox möglich

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,
bayernherz hat geschrieben: 2. Aug 2020, 14:38...
von susejunky » 29. Jul 2020, 09:22
hast Du schon einmal die Konfiguration von NetworkManager unter Kubuntu mit der unter openSUSE Tumbleweed abgeglichen?
NetworkManager.conf (Kubuntu 18,04.x LTS

Code: Alles auswählen

main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no
/etc/NetworkManager.conf (Tumbleweed)

Code: Alles auswählen

main]
plugins=keyfile

[connectivity]
uri=http://conncheck.opensuse.org

/etc/...resolv.conf

Code: Alles auswählen

### /etc/resolv.conf is a symlink to /var/run/netconfig/resolv.conf
### autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
### Call "netconfig update -f" to force adjusting of /etc/resolv.conf.
search 217.0.43.161 217.0.43.177
nameserver 217.0.43.161
nameserver 217.0.43.177
und was ist mit den restlichen Konfigurationsdateien?

Code: Alles auswählen

> whois 217.0.43.161
% This is the RIPE Database query service.
% The objects are in RPSL format.
%
% The RIPE Database is subject to Terms and Conditions.
% See http://www.ripe.net/db/support/db-terms-conditions.pdf

% Note: this output has been filtered.
%       To receive output for a database update, use the "-B" flag.

% Information related to '217.0.0.0 - 217.5.127.255'

% Abuse contact for '217.0.0.0 - 217.5.127.255' is 'abuse@telekom.de'

inetnum:        217.0.0.0 - 217.5.127.255
netname:        DTAG-DIAL13
descr:          Deutsche Telekom AG
org:            ORG-DTAG1-RIPE
country:        DE
admin-c:        DTIP
tech-c:         DTST
status:         ASSIGNED PA
mnt-by:         DTAG-NIC
created:        2002-01-08T09:31:20Z
last-modified:  2014-06-18T06:11:59Z
source:         RIPE

organisation:   ORG-DTAG1-RIPE
org-name:       Deutsche Telekom AG
org-type:       OTHER
address:        Group Information Security, SDA/Abuse
address:        T-Online-Allee 1
address:        DE 64295 Darmstadt
remarks:        abuse contact in case of Spam,
                hack attacks, illegal activity,
                violation, scans, probes, etc.
mnt-ref:        DTAG-NIC
mnt-by:         DTAG-NIC
abuse-c:        DTAG4-RIPE
created:        2014-06-17T11:47:04Z
last-modified:  2014-06-17T11:47:04Z
source:         RIPE # Filtered

person:         DTAG Global IP-Addressing
address:        Deutsche Telekom AG
address:        Darmstadt, Germany
phone:          +49 180 2 33 1000
nic-hdl:        DTIP
mnt-by:         DTAG-NIC
created:        2003-01-29T10:22:59Z
last-modified:  2019-05-14T12:55:19Z
source:         RIPE # Filtered

person:         Security Team
address:        Deutsche Telekom AG
address:        Darmstadt, Germany
phone:          +49 180 2 33 1000
nic-hdl:        DTST
mnt-by:         DTAG-NIC
created:        2003-01-29T10:31:11Z
last-modified:  2019-05-14T12:56:39Z
source:         RIPE # Filtered

% Information related to '217.0.0.0/13AS3320'

route:          217.0.0.0/13
descr:          Deutsche Telekom AG, Internet service provider
origin:         AS3320
member-of:      AS3320:RS-PA-TELEKOM
mnt-by:         DTAG-RR
created:        1970-01-01T00:00:00Z
last-modified:  2004-06-15T17:32:51Z
source:         RIPE

% This query was served by the RIPE Database Query Service version 1.97.2 (BLAARKOP)
Na, wenn das mal nicht der Telekom-DNS-Server ist ...
bayernherz hat geschrieben: 2. Aug 2020, 14:38... Weitere Frage:
In welcher config kann ich nachschauen, ob der ntp-server korrekt auf disable steht.
Bisher habe ich den ntp-serve in der KDE Oberfläche: Datum & Zeit Einstellung mit
set date and time automatically -> abgeklickt eingestellt.
YaST -> Datum und Zeit -> Andere Einstellungen -> Mit NTP-Server synchronisieren -> Konfigurieren
bayernherz hat geschrieben: 2. Aug 2020, 14:38... Mittlerweile hat Tumbleweed für mich einen unbrauchbaren Zustand erreicht! :(
Also ich verwende seit Anfang diesen Jahres openSUSE Tumbleweed auf allen meinen Produktivsystemen und habe bis heute keine Probleme damit gehabt ...

Das was Du machst, das Gateway (Router) aus dem Netzwerk nehme, ist kein "Standardbetrieb". Es ist sicherlich möglich, erfordert aber ggf. Änderungen an der Standard-Konfiguration. Ein Großteil Deines Problems dürfte an der unterbrochenen Namensauflösung (ohne Router) liegen.

Wenn Du, obwohl Dir bereits einige hier davon abgeraten haben, Deine aktuelle Vorgehensweise unbedingt beibehalten willst, dann wirst Du nicht umhin kommen
  • herauszufinden, welche Anwendungen (auch solche die ständig im Hintergrund aktiv sind) Internetzugriff benötigen
  • wie die Namensauflösung unter openSUSE funktioniert und wie Du sie anpassen musst, damit Du wie gewünscht arbeiten kannst.
Viele Grüße

susejunky
bayernherz
Hacker
Hacker
Beiträge: 490
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von bayernherz »

hallo zusammen,
hallo susejunky,
von susejunky » 2. Aug 2020, 16:19
und was ist mit den restlichen Konfigurationsdateien?
Welche brauchst Du noch ?
von susejunky » 2. Aug 2020, 16:19
YaST -> Datum und Zeit -> Andere Einstellungen -> Mit NTP-Server synchronisieren -> Konfigurieren
Ist auf manuell eingestellt !
von susejunky » 2. Aug 2020, 16:19
Wenn Du, obwohl Dir bereits einige hier davon abgeraten haben, Deine aktuelle Vorgehensweise unbedingt beibehalten willst, dann wirst Du nicht umhin kommen

herauszufinden, welche Anwendungen (auch solche die ständig im Hintergrund aktiv sind) Internetzugriff benötigen
wie die Namensauflösung unter openSUSE funktioniert und wie Du sie anpassen musst, damit Du wie gewünscht arbeiten kannst
.
Im Moment benötige ich diese Konfiguration u. sie hat bereits auf Tumbleweed funktioniert u.
funktioniert ja auch bei Kubuntu.
Sage mir bitte was u. wie ich noch diagnostizieren kann.
Mir sind ausser ntp keine Anwendungen bekannt, die bei mir ständig Internet benötigen.

Nachtrag:
.

Code: Alles auswählen

/collectNWData.sh

collectNWData.sh V0.7.5.8 2016/05/22/15:43:21 - e8982e6

This program comes with ABSOLUTELY NO WARRANTY; This is free software, and you are welcome to redistribute it under certain conditions

--- Der Aufruf des Scripts als root erlaubt eine detailiertere Analyse und liefert bessere Ergebnisse. 
--- Falls Bedenken existieren das Script als root auszuführen bitte http://www.linux-tips-and-tricks.de/CND_ROOT lesen.
--- Willst Du das Script als root ausführen lassen ([j]/n)?j
--- Soll das Ergebnisfile in einem internationalen Forum gepostet werden (j/[n])?n
Enter password of user root
!!! Das Programm ifconfig,arp,route ist nicht verfügbar. Das Programm nachinstallieren und das Script danach noch einmal ausführen

bayernherz :thumbs:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,
bayernherz hat geschrieben: 2. Aug 2020, 17:28...
von susejunky » 2. Aug 2020, 16:19
und was ist mit den restlichen Konfigurationsdateien?
Welche brauchst Du noch ?
eigentlich nur die (NetworkManager Konfigurationsdateien), deren Inhalte bei Kubuntu anders sind, als wie bei openSUSE und ggf. solche, die nur auf einem der Systeme vorhanden sind (falls es solche gibt).

bayernherz hat geschrieben: 2. Aug 2020, 17:28...
von susejunky » 2. Aug 2020, 16:19
YaST -> Datum und Zeit -> Andere Einstellungen -> Mit NTP-Server synchronisieren -> Konfigurieren
Ist auf manuell eingestellt !
Was ist das Ergebnis von

Code: Alles auswählen

> systemctl status chronyd.service
(aber der NTP-Service ist meines Erachtens eher nicht für Dein Problem verantwortlich).

bayernherz hat geschrieben: 2. Aug 2020, 17:28... Nachtrag:

Code: Alles auswählen

/collectNWData.sh
collectNWData.sh V0.7.5.8 2016/05/22/15:43:21 - e8982e6

This program comes with ABSOLUTELY NO WARRANTY; This is free software, and you are welcome to redistribute it under certain conditions

--- Der Aufruf des Scripts als root erlaubt eine detailiertere Analyse und liefert bessere Ergebnisse. 
--- Falls Bedenken existieren das Script als root auszuführen bitte http://www.linux-tips-and-tricks.de/CND_ROOT lesen.
--- Willst Du das Script als root ausführen lassen ([j]/n)?j
--- Soll das Ergebnisfile in einem internationalen Forum gepostet werden (j/[n])?n
Enter password of user root
!!! Das Programm ifconfig,arp,route ist nicht verfügbar. Das Programm nachinstallieren und das Script danach noch einmal ausführen
Ich kann Dir leider nicht sagen, ob es mittlerweile eine Version von collectNWData.sh gibt, welche die aktuell verfügbaren Werkzeuge (z.B. ip) verwendet.

bayernherz hat geschrieben: 2. Aug 2020, 17:28... Sage mir bitte was u. wie ich noch diagnostizieren kann.
Mir sind ausser ntp keine Anwendungen bekannt, die bei mir ständig Internet benötigen.
Damit ich Dich unterstützen kann, brauche ich ein besseres Verständnis, von dem was Du da genau machst. Hier was ich glaube bisher verstanden zu haben:
  • Dein Netzwerk besteht aus einem Router (der sich mit dem Internet verbindet) und einem separaten Switch.
  • Alle Deine Rechner und der Router sind per Kabel mit dem Switch verbunden.
  • Alle Rechner im Netzwerk verwenden statische IP-Adressen.
  • Auf allen Rechnern kommt NetworkManager zum Einsatz.
  • NetworkManager ist (auf allen Rechnern) so konfiguriert, dass eine Verbindungen, auch eine kabelgebundene, immer manuell aktiviert werden muss.
  • Um ohne Internet-Zugriff zu arbeiten, steckst Du den Router am Switch aus und zwar dann, wenn bereits alle Rechner des Netzwerks eingeschaltet und aktiv sind.
Falls einer der obigen Punkte nicht zutrifft, beschreibe bitte präzise, was anders ist.

03.08.2020 NACHTRAG

Ich habe mir noch einmal alle Beiträge durchgelesen, daher waren oben ein paar Korrekturen notwendig.
  • Woher beziehen Deine Rechner (beim Betrieb mit statischer IP Adresse) die DNS-Server-Adresse(n)?
  • Ist auf dem Router oder auf einem anderen Rechner des Netzwerks ein DHCP-Server aktiv?
  • Ist in Deinem Netzwerk ein lokaler DNS-Server aktiv?
bayernherz hat geschrieben: 25. Jul 2020, 16:05 Noch einen Nachtrag zur Netzwerkconfig.
Ein Netwerkzugangskabel wird mittel network manager mit 2 kabelgebundenen Zugangsconfigs verwaltet.
Config. 1 : kabelgebundene Verbindung manuell (statische IPs)
Config. 2: kabelgebundene Verbindung DHCP (für Reisetätigkeiten)
Zeige bitte den Inhalt dieser beiden NetworkManager-Verbindungsprofile (sowohl für Kubuntu als auch für openSUSE).
bayernherz hat geschrieben: 22. Jul 2020, 19:10 ... Auf dem System sind zwei Benutzer installiert.
Benutzer A und Benutzer B
Benutzer B hat geänderte Benutzergruppen eingestellt.
Über der Benutzergruppe user wurde eine weiter Gruppe übergeordnet
und zur Standard Benutzergruppe gesetzt wurde.
Auf meinem openSUSE Tumbleweed System gibt es nur die Gruppe "users" aber keine Gruppe "user"?!
Was verstehst Du unter "übergeordnet"? Was hast Du da im Detail verändert?
Bitte zeige das Ergebnis von

Code: Alles auswählen

> id BENUTZER_B
sowohl unter Kubuntu als auch unter openSUSE.

ENDE NACHTRAG

Viele Grüße

susejunky
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,

ich habe heute Dein Szenario nachgebaut:
  • ein Router, der mit dem Internet verbunden ist
  • ein Switch
  • ein PC
  • ein NAS
  • alle Geräte sind per Kabel mit dem Switch verbunden
  • es läuft kein DHCP-Server im Netzwerk
  • alle Geräte verwenden statische IP
  • alle Geräte haben eine statische DNS-Konfiguration
Der PC:

Betriebssystem: openSUSE Tumbleweed 20200801
KDE-Plasma-Version: 5.19.4
KDE-Frameworks-Version: 5.72.0
Qt-Version: 5.15.0
Kernel-Version: 5.7.11-1-default
Art des Betriebssystems: 64-bit
Prozessoren: 8 × Intel® Core™ i7-4790K CPU @ 4.00GHz
Speicher: 30,8 GiB Arbeitsspeicher
Grafikprozessor: Mesa DRI Intel® HD Graphics 4600
NetworkManager 1.26.0-1.1

Der NAS

Linux-Kernel + Busybox


Wenn ich den Router vom Switch abstecke kommt es zu keinem der von Dir beschriebenen Probleme. Unabhängig davon, ob der PC bereits im Netzwerk eingebunden war, wenn der Router vom Switch getrennt wird oder ob der PC erst dann gestartet wird, wenn der Router bereits vom Switch getrennt ist.

Ich kann mit Firefox auf meinen NAS zugreifen und wenn ich eine externe Seite aufrufe erhalte ich nach ca. 30 sec. die Meldung, dass die Seite nicht erreicht werden kann. Aber das System ist während dessen in keinster Weise "blockiert".

Wenn ich die captive portal detection von NetworkManager aktiviere (bei mir standardmäßig deaktiviert), dann führt das lediglich dazu, dass mir das plasma-nm5-Applet (eingeschränkte Verbindung) anzeigt, wenn der Router abgesteckt ist.

Damit dürfte bewiesen sein, dass das von Dir gewünschte Vorgehen mit openSUSE Tumbleweed problemlos möglich ist und Deine Probleme sehr wahrscheinlich auf von Dir vorgenommene Anpassungen zurück zu führen ist.

Jetzt gilt es "nur noch" herauszufinden auf welche ...

Viele Grüße

susejunky
bayernherz
Hacker
Hacker
Beiträge: 490
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von bayernherz »

hallo zusammen,
hallo susejunky,

vielen Dank für Deinen Versuch.
Du hasst Dir da ja wirklich viel Mühe u. Arbeit gemacht. :wink:
Auch ich war nicht untätig.
Ich melde mich zu dem Thema morgen ausführlich.

viele Grüsse
bayernherz :thumbs:
bayernherz
Hacker
Hacker
Beiträge: 490
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von bayernherz »

hallo zusammen,
hallo susehunky,

ich habe mich entschlossen Tumbleweed platt zu machen und völlig neu zu installieren.
Fazit:
Ohne irgendwelche neuen Einstellungen (mit Einschränkung networkManager, Kabelgebunde Verbindung mit statischen IPs) oder Updates oder Installationen von Programmen durchzuführen.

Code: Alles auswählen

Betriebssystem: openSUSE Tumbleweed 20200801
KDE-Plasma-Version: 5.19.4
KDE-Frameworks-Version: 5.72.0
Qt-Version: 5.15.0
Kernel-Version: 5.7.11-1-default
Art des Betriebssystems: 64-bit
Prozessoren: 4 × Intel® Core™ i5-6267U CPU @ 2.90GHz
Speicher: 15,5 GiB Arbeitsspeicher
Grafikprozessor: Mesa DRI Intel® Iris® Graphics 550
Das Problem zeigte sich nicht sofort, sondern nach einigen Neustarts.

von susejunky » 3. Aug 2020, 17:41
ich habe heute Dein Szenario nachgebaut:

ein Router, der mit dem Internet verbunden ist
ein Switch
ein PC
ein NAS
alle Geräte sind per Kabel mit dem Switch verbunden
es läuft kein DHCP-Server im Netzwerk
alle Geräte verwenden statische IP
alle Geräte haben eine statische DNS-Konfiguration
Dieses ist auch bei mir so, bis auf: es läuft kein DHCP-Server im Netzwerk
Mein Router läuft mit einer DHCP Config u. einer Config mit statischen IPs.
Alle anderen Netzwerkteilnehmer haben statisch IPs.
D.h. ich kann mit der Router Config mit den Teilnehmern mittels DHCP oder statischen IPs arbeiten.
Der DHCP war wegen dem Gästenetzwerkanschluss notwendig, da dieser ausschliesslich nur mittels DHCP arbeiten kann.

Der Patient ((ACER Notebook Aspire F15 F5-573-51AW) hat mit dem networkManager nachfolgende Verbindungen konfiguriert:
1. Kabelgebundene Verbindung DHCP (Einstellung autom. mit Priorität verbinden: abgeklickt)
2. Kabelgebundene Verbindung manuell (Einstellung autom. mit Priorität verbinden -100: angeklickt.

Ich habe auf dem Patienten auf einer weiter SSD eine
Kubuntu 20.x LTS mit KDE installiert.
Ebenfalls mit den Einstellung wie oben für Tumbleweed beschrieben.
Fazit: Das Problem tritt nicht auf.

Ich denke jetzt können wir an einem ggf. nicht verkonfiguriertem System diagnostizieren.

viele grüsse
bayernherz :thumbs:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,
bayernherz hat geschrieben: 6. Aug 2020, 17:06... Mein Router läuft mit einer DHCP Config u. einer Config mit statischen IPs.
Alle anderen Netzwerkteilnehmer haben statisch IPs.
D.h. ich kann mit der Router Config mit den Teilnehmern mittels DHCP oder statischen IPs arbeiten.
Der DHCP war wegen dem Gästenetzwerkanschluss notwendig, da dieser ausschliesslich nur mittels DHCP arbeiten kann.
verstehe ich das richtig:

Auf Deinem Router läuft ein DHCP-Server und parallel (d.h. zur selben Zeit) verwenden Deine PCs statische IP-Adressen?

Wie ermitteln Deine PCs, wenn sie mit statischer IP-Adresse arbeiten, welchen DNS-Server sie verwenden können ?

Bist Du Dir sicher, dass Du für den Betrieb Deines Gäste-Netzwerks DHCP-Server für alle von Deinem Router bereit gestellten Netze aktivieren musst?

Bei meinem Router ist das Gäste-Netzwerk ein eigenes Subnetz (IP-Adresse: 192.YYY.ZZZ.nnn) für das (zwangsweise) ein DHCP-Server aktiv ist, der den Gästen IP-Adressen aus dem Bereich 192.YYY.ZZZ.nnn zuweist und auch den vom ISP benannten DNS-Server weiterreicht.

Mein "privates" Netz (auf dem selben Router) nutzt den IP-Bereich 192.VVV.WWW.nnn und für diesen Bereich ist kein DHCP-Server aktiv. Alle Teilnehmer im "privaten" Netz verwenden ausschließlich statische IP-Adressen und bestimmen selbst, welche DNS-Server sie nutzen.

Viele Grüße

susejunky
Sauerland
Guru
Guru
Beiträge: 3730
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von Sauerland »

Du kannst dem dhcp-Server sagen, aus welchem Adressbereich er Adressen vergeben darf, z.B. 192.168.1.100 - 192.168.1.200
Diese sollten dann natürlich auch nicht mehr als Feste IPs vergeben werden.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 4.12
bayernherz
Hacker
Hacker
Beiträge: 490
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von bayernherz »

hallo zusammen,
von Sauerland » 6. Aug 2020, 19:53
Du kannst dem dhcp-Server sagen, aus welchem Adressbereich er Adressen vergeben darf, z.B. 192.168.1.100 - 192.168.1.200
Diese sollten dann natürlich auch nicht mehr als Feste IPs vergeben werden.
Genau so habe ich es gemacht !
von susejunky » 6. Aug 2020, 19:20
Mein "privates" Netz (auf dem selben Router) nutzt den IP-Bereich 192.VVV.WWW.nnn und für diesen Bereich ist kein DHCP-Server aktiv. Alle Teilnehmer im "privaten" Netz verwenden ausschließlich statische IP-Adressen und bestimmen selbst, welche DNS-Server sie nutzen.
Das habe ich auch im config vom networkManager eingestellt !
Aber im Router sind ebenfalls die DNS-Server eingestellt.


viele grüsse
bayernherz :thumbs:
Sauerland
Guru
Guru
Beiträge: 3730
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von Sauerland »

Ich hab an den ersten beiden Stellen immer auswärtige DNS-Server eingestellt und als Fallback immer an 3. Stelle die IP des Routers.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 4.12
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,
bayernherz hat geschrieben: 6. Aug 2020, 17:06 ... Der Patient ((ACER Notebook Aspire F15 F5-573-51AW) hat mit dem networkManager nachfolgende Verbindungen konfiguriert:
1. Kabelgebundene Verbindung DHCP (Einstellung autom. mit Priorität verbinden: abgeklickt)
2. Kabelgebundene Verbindung manuell (Einstellung autom. mit Priorität verbinden -100: angeklickt.
bitte zeige
  • den Inhalt der zu diesen beiden Verbindungen gehörenden NetworkManager-Verbindungsprofile (bitte vollständig, gerne anonymisiert)
  • den Inhalt von /etc/resolv.conf
beides sowohl von openSUSE Tumbleweed, als auch von Kubuntu.

Verwendet Dein Gäste-Netzwerk das selbe Subnetz wie Dein internes LAN?


Viele Grüße

susejunky
bayernherz
Hacker
Hacker
Beiträge: 490
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von bayernherz »

hallo zusammen,
hallo susejunky,
von susejunky » 6. Aug 2020, 21:06
bitte zeige
den Inhalt der zu diesen beiden Verbindungen gehörenden NetworkManager-Verbindungsprofile (bitte vollständig, gerne anonymisiert)
/etc/NetworkManager/system-connections/Kabelgebundene Verbindung DHCP.nmconnection
/etc/NetworkManager/system-connections/Kabelgebundene Verbindung manuell.nmconnection
ist eine Binardatei. :-?
Oder habe ich das falsch verstanden ?

NetworkManager.conf

Code: Alles auswählen

[main]
plugins=keyfile

[connectivity]
uri=http://conncheck.opensuse.org
/etc/resolv.conf
#

Code: Alles auswählen

## /etc/resolv.conf is a symlink to /var/run/netconfig/resolv.conf
### autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
### Call "netconfig update -f" to force adjusting of /etc/resolv.conf.
search 217.0.43.177 217.0.43.161
nameserver 217.0.43.177
nameserver 217.0.43.161
viele grüsse
bayernherz :thumbs:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,
bayernherz hat geschrieben: 6. Aug 2020, 21:27... /etc/NetworkManager/system-connections/Kabelgebundene Verbindung DHCP.nmconnection
/etc/NetworkManager/system-connections/Kabelgebundene Verbindung manuell.nmconnection
ist eine Binardatei. :-?
Oder habe ich das falsch verstanden ?
also bei mir sind alle Dateien unter /etc/NetworkManager/system-connections/ reine Textdateien (allerdings nur für "root" lesbar).

Viele Grüße

susejunky
bayernherz
Hacker
Hacker
Beiträge: 490
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von bayernherz »

hallo zusammen,
hallo susejunky,
von susejunky » 6. Aug 2020, 21:41
also bei mir sind alle Dateien unter /etc/NetworkManager/system-connections/ reine Textdateien (allerdings nur für "root" lesbar).

Code: Alles auswählen

[connection]
id=Kabelgebundene Verbindung manuell
uuid=73cc33dc-757e-4680-931a-fe19c90e0257
type=ethernet
autoconnect=false
permissions=user:bayernherz:;

[ethernet]
duplex=full
mac-address=A8:1E:84:18:5B:BD
mac-address-blacklist=
mtu=1500
speed=100

[ipv4]
address1=192.168.178.120/24,192.168.178.2
dhcp-send-hostname=false
dns=217.0.43.177;217.0.43.161;
dns-search=217.0.43.177;217.0.43.161;
may-fail=false
method=manual

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=ignore

[proxy]



[connection]
id=Kabelgebundene Verbindung DHCP
uuid=eeb83f68-be4b-3ce3-bf00-dd2616fbeeee
type=ethernet
autoconnect=false
permissions=

[ethernet]
mac-address-blacklist=

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

[proxy]
bayernherz :thumbs:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,
bayernherz hat geschrieben: 6. Aug 2020, 22:08 hallo zusammen,
hallo susejunky,
von susejunky » 6. Aug 2020, 21:41
also bei mir sind alle Dateien unter /etc/NetworkManager/system-connections/ reine Textdateien (allerdings nur für "root" lesbar).

Code: Alles auswählen

[connection]
id=Kabelgebundene Verbindung manuell
uuid=73cc33dc-757e-4680-931a-fe19c90e0257
type=ethernet
autoconnect=false
permissions=user:bayernherz:;

[ethernet]
duplex=full
mac-address=A8:1E:84:18:5B:BD
mac-address-blacklist=
mtu=1500
speed=100

[ipv4]
address1=192.168.178.120/24,192.168.178.2
dhcp-send-hostname=false
dns=217.0.43.177;217.0.43.161;
dns-search=217.0.43.177;217.0.43.161;
may-fail=false
method=manual

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=ignore

[proxy]



[connection]
id=Kabelgebundene Verbindung DHCP
uuid=eeb83f68-be4b-3ce3-bf00-dd2616fbeeee
type=ethernet
autoconnect=false
permissions=

[ethernet]
mac-address-blacklist=

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

[proxy]
bayernherz :thumbs:
openSUSE? Kubuntu?

Viele Grüße

susejunky
bayernherz
Hacker
Hacker
Beiträge: 490
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von bayernherz »

hallo zusammen,
hallo susejunky,
von susejunky » 6. Aug 2020, 22:46
Hallo bayernherz,

bayernherz hat geschrieben: ↑
6. Aug 2020, 22:08
hallo zusammen,
hallo susejunky,

von susejunky » 6. Aug 2020, 21:41
also bei mir sind alle Dateien unter /etc/NetworkManager/system-connections/ reine Textdateien (allerdings nur für "root" lesbar).

Code: Alles auswählen

Code: Alles auswählen

    [connection]
    id=Kabelgebundene Verbindung manuell
    uuid=73cc33dc-757e-4680-931a-fe19c90e0257
    type=ethernet
    autoconnect=false
    permissions=user:bayernherz:;

    [ethernet]
    duplex=full
    mac-address=A8:1E:84:18:5B:BD
    mac-address-blacklist=
    mtu=1500
    speed=100

    [ipv4]
    address1=192.168.178.120/24,192.168.178.2
    dhcp-send-hostname=false
    dns=217.0.43.177;217.0.43.161;
    dns-search=217.0.43.177;217.0.43.161;
    may-fail=false
    method=manual

    [ipv6]
    addr-gen-mode=stable-privacy
    dns-search=
    method=ignore

    [proxy]



    [connection]
    id=Kabelgebundene Verbindung DHCP
    uuid=eeb83f68-be4b-3ce3-bf00-dd2616fbeeee
    type=ethernet
    autoconnect=false
    permissions=

    [ethernet]
    mac-address-blacklist=

    [ipv4]
    dns-search=
    method=auto

    [ipv6]
    addr-gen-mode=stable-privacy
    dns-search=
    method=auto

    [proxy]
bayernherz :thumbs:

openSUSE? Kubuntu?

Code: Alles auswählen

Betriebssystem: Kubuntu 20.04
KDE-Plasma-Version: 5.18.5
KDE-Frameworks-Version: 5.68.0
Qt-Version: 5.12.8
Kernel-Version: 5.4.0-42-generic
Art des Betriebssystems: 64-bit
Prozessoren: 4 × Intel® Core™ i5-6267U CPU @ 2.90GHz
Speicher: 15,5 GiB Arbeitsspeicher

--- Kabelbebundene Verbindung DHCP.nmconnection ---

[connection]
id=Kabelgebundene Verbindung DHCP
uuid=dc3aa71f-6987-3403-9a77-ddf28528de1b
type=ethernet
autoconnect=false
permissions=

[ethernet]
mac-address-blacklist=

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

[proxy]


--- Kabelbebundene Verbindung manuell.nmconnection ---

[connection]
id=Kabelbebundene Verbindung manuell
uuid=e5122365-66ba-41c1-84f9-5c416d738bf4
type=ethernet
autoconnect-priority=-100
permissions=

[ethernet]
auto-negotiate=true
mac-address=A8:1E:84:18:5B:BD
mac-address-blacklist=

[ipv4]
address1=192.168.178.120/24,192.168.178.2
dhcp-send-hostname=false
dns=217.0.43.177;217.0.43.161;
dns-search=217.0.43.177;217.0.43.161;
may-fail=false
method=manual

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=ignore

[proxy]



--- NetworkManager.config ---
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no
Ich denke hiermit muss man das network von Tumbleweed konfigurieren
/etc/sysconfig/network/config

Code: Alles auswählen

## Type:        integer
## Default:     ""
#
# How log to wait for IPv6 autoconfig in ifup when requested with
# the auto6 or +auto6 tag in BOOTPROTO variable.
# When unset, a wicked built-in default defer time (10sec) is used.
#
AUTO6_WAIT_AT_BOOT=""

## Type:        list(all,dns,none,"")
## Default:     ""
#
# Whether to update system (DNS) settings from IPv6 RA when requested
# with the auto6 or +auto6 tag in BOOTPROTO variable.
# Defaults to update if autoconf sysctl (address autoconf) is enabled.
#
AUTO6_UPDATE=""

## Type:        list(auto,yes,no)
## Default:     "auto"
#
# Permits to specify/modify a global ifcfg default. Use with care!
#
# This settings breaks rules for many things, which require carrier
# before they can start, e.g. L2 link protocols, link authentication,
# ipv4 duplicate address detection, ipv6 duplicate detection will
# happen "post-mortem" and maybe even cause to disable ipv6 at all.
# See also "man ifcfg" for further informations.
#
LINK_REQUIRED="auto"

## Type:        string
## Default:     ""
#
# Allows to specify a comma separated list of debug facilities used
# by wicked. Negated facility names can be prepended by a "-", e.g.:
#   "all,-events,-socket,-objectmodel,xpath,xml,dbus"
#
# When set, wicked debug level is automatically enabled.
# For a complete list of facility names, see: "wicked --debug help".
#
WICKED_DEBUG=""

## Type:        list("",error,warning,notice,info,debug,debug1,debug2,debug3)
## Default:     ""
#
# Allows to specify wicked debug level. Default level is "notice".
#
WICKED_LOG_LEVEL=""
## Path:	Network/General
## Description:	Global network configuration
#
# Note: 
# Most of the options can and should be overridden by per-interface
# settings in the ifcfg-* files.
#
# Note: The ISC dhclient started by the NetworkManager is not using any
# of these options -- NetworkManager is not using any sysconfig settings.
#

## Type:        yesno
## Default:     yes
# If ifup should check if an IPv4 address is already in use, set this to yes.
#
# Make sure that packet sockets (CONFIG_PACKET) are supported in the kernel,
# since this feature uses arp, which depends on that.
# Also be aware that this takes one second per interface; consider that when
# setting up a lot of interfaces. 
CHECK_DUPLICATE_IP="yes"

## Type:        list(auto,yes,no)
## Default:     auto
# If ifup should send a gratuitous ARP to inform the receivers about its
# IPv4 addresses. Default is to send gratuitous ARP, when duplicate IPv4
# address check is enabled and the check were sucessful.
#
# Make sure that packet sockets (CONFIG_PACKET) are supported in the kernel,
# since this feature uses arp, which depends on that.
SEND_GRATUITOUS_ARP="auto"

## Type:        yesno
## Default:     no
# Switch on/off debug messages for all network configuration stuff. If set to no
# most scripts can enable it locally with "-o debug".
DEBUG="no"

## Type:	integer
## Default:	30
#
# Some interfaces need some time to come up or come asynchronously via hotplug.
# WAIT_FOR_INTERFACES is a global wait for all mandatory interfaces in
# seconds. If empty no wait occurs.
#
WAIT_FOR_INTERFACES="30"

## Type:	yesno
## Default:	yes
#
# With this variable you can determine if the SuSEfirewall when enabled
# should get started when network interfaces are started.
FIREWALL="yes"

## Type:	int
## Default:	30
#
# When using NetworkManager you may define a timeout to wait for NetworkManager
# to connect in NetworkManager-wait-online.service.  Other network services
# may require the system to have a valid network setup in order to succeed.
#
# This variable has no effect if NetworkManager is disabled.
#
NM_ONLINE_TIMEOUT="30"

## Type:        string
## Default:     "dns-resolver dns-bind ntp-runtime nis"
#
# This variable defines the start order of netconfig modules installed
# in the /etc/netconfig.d/ directory.
#
# To disable the execution of a module, don't remove it from the list
# but prepend it with a minus sign, "-ntp-runtime".
#
NETCONFIG_MODULES_ORDER="dns-resolver dns-bind dns-dnsmasq nis ntp-runtime"

## Type:        yesno
## Default:     no
#
# Enable netconfig verbose reporting.
#
NETCONFIG_VERBOSE="no"

## Type:	yesno
## Default:	no
#
# This variable enables netconfig to always force a replace of modified
# files and automatically enables the -f | --force-replace parameter.
#
# The purpose is to use it as workaround, when some other tool trashes
# the files, e.g. /etc/resolv.conf and you observe messages like this
# in your logs on in "netconfig update" output:
# ATTENTION: You have modified /etc/resolv.conf. Leaving it untouched.
#
# Please do not forget to also report a bug as we have a system policy
# to use netconfig.
#
NETCONFIG_FORCE_REPLACE="no"

## Type:        string
## Default:     "auto"
#
# Defines the DNS merge policy as documented in netconfig(8) manual page.
# Set to "" to disable DNS configuration.
#
NETCONFIG_DNS_POLICY="auto"

## Type:        string(resolver,bind,dnsmasq,)
## Default:     "resolver"
#
# Defines the name of the DNS forwarder that has to be configured.
# Currently implemented are "bind", "dnsmasq" and "resolver", that
# causes to write the name server IP addresses to /etc/resolv.conf
# only (no forwarder). Empty string defaults to "resolver".
#
NETCONFIG_DNS_FORWARDER="resolver"

## Type:        yesno
## Default:     yes
#
# When enabled (default) in forwarder mode ("bind", "dnsmasq"),
# netconfig writes an explicit localhost nameserver address to the
# /etc/resolv.conf, followed by the policy resolved name server list
# as fallback for the moments, when the local forwarder is stopped.
#
NETCONFIG_DNS_FORWARDER_FALLBACK="yes"

## Type:        string
## Default:     ""
#
# List of DNS domain names used for host-name lookup.
# It is written as search list into the /etc/resolv.conf file.
#
NETCONFIG_DNS_STATIC_SEARCHLIST=""

## Type:        string
## Default:     ""
#
# List of DNS nameserver IP addresses to use for host-name lookup.
# When the NETCONFIG_DNS_FORWARDER variable is set to "resolver",
# the name servers are written directly to /etc/resolv.conf.
# Otherwise, the nameserver are written into a forwarder specific
# configuration file and the /etc/resolv.conf does not contain any
# nameservers causing the glibc to use the name server on the local
# machine (the forwarder). See also netconfig(8) manual page.
#
NETCONFIG_DNS_STATIC_SERVERS=""

## Type:        string
## Default:     "auto"
#
# Allows to specify a custom DNS service ranking list, that is which
# services provide preferred (e.g. vpn services), and which services
# fallback settings (e.g. avahi).
# Preferred service names have to be prepended with a "+", fallback
# service names with a "-" character. The special default value
# "auto" enables the current build-in service ranking list -- see the
# netconfig(8) manual page -- "none" or "" disables the ranking.
#
NETCONFIG_DNS_RANKING="auto"

## Type:        string
## Default:     ""
#
# Allows to specify options to use when writting the /etc/resolv.conf,
# for example:
# 	"debug attempts:1 timeout:10"
# See resolv.conf(5) manual page for details.
#
NETCONFIG_DNS_RESOLVER_OPTIONS=""

## Type:        string
## Default:     ""
#
# Allows to specify a sortlist to use when writting the /etc/resolv.conf,
# for example:
# 	130.155.160.0/255.255.240.0 130.155.0.0"
# See resolv.conf(5) manual page for details.
#
NETCONFIG_DNS_RESOLVER_SORTLIST=""

## Type:        string
## Default:     "auto"
#
# Defines the NTP merge policy as documented in netconfig(8) manual page.
# Set to "" to disable NTP configuration.
#
NETCONFIG_NTP_POLICY="auto"

## Type:        string
## Default:     ""
#
# List of NTP servers.
#
NETCONFIG_NTP_STATIC_SERVERS=""

## Type:        string
## Default:     "auto"
#
# Defines the NIS merge policy as documented in netconfig(8) manual page.
# Set to "" to disable NIS configuration.
#
NETCONFIG_NIS_POLICY="auto"

## Type:        string(yes,no,)
## Default:     "yes"
#
# Defines whether to set the default NIS domain. When enabled and no domain
# is provided dynamically or in static settings, /etc/defaultdomain is used.
# Valid values are:
#  - "no" or ""         netconfig does not set the domainname
#  - "yes"              netconfig sets the domainname according to the
#                       NIS policy using settings provided by the first
#                       iterface and service that provided it.
#  - "<interface name>" as yes, but only using settings from interface.
#
NETCONFIG_NIS_SETDOMAINNAME="yes"

## Type:        string
## Default:     ""
#
# Defines a default NIS domain.
#
# Further domain can be specified by adding a "_<number>" suffix to
# the NETCONFIG_NIS_STATIC_DOMAIN and NETCONFIG_NIS_STATIC_SERVERS
# variables, e.g.: NETCONFIG_NIS_STATIC_DOMAIN_1="second".
#
NETCONFIG_NIS_STATIC_DOMAIN=""

## Type:        string
## Default:     ""
#
# Defines a list of NIS servers for the default NIS domain or the
# domain specified with same "_<number>" suffix.
#
NETCONFIG_NIS_STATIC_SERVERS=""

## Type:	string
## Default:	''
#
# Set this variable global variable to the ISO / IEC 3166 alpha2
# country code specifying the wireless regulatory domain to set.
# When not empty, ifup-wireless will be set in the wpa_supplicant
# config or via 'iw reg set' command.
#
# Note: This option requires a wpa driver supporting it, like
# the 'nl80211' driver used by default since openSUSE 11.3.
# When you notice problems with your hardware, please file a
# bug report and set e.g. WIRELESS_WPA_DRIVER='wext' (the old
# default driver) in the ifcfg file.
# See also "/usr/sbin/wpa_supplicant --help" for the list of
# available wpa drivers.
#
WIRELESS_REGULATORY_DOMAIN=''
Was mir weiternin aufgefallen ist, es wurde bei der Installation kein hostname abgefragt
und es wurde auch kein default hostname vergeben, da die Datei /etc/hostname leer ist !!

viele grüsse
bayernherz :thumbs:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,
bayernherz hat geschrieben: 7. Aug 2020, 16:23... openSUSE ?

Code: Alles auswählen

    [connection]
    id=Kabelgebundene Verbindung manuell
    uuid=73cc33dc-757e-4680-931a-fe19c90e0257
    type=ethernet
    autoconnect=false
    permissions=user:bayernherz:;

    [ethernet]
    duplex=full
    mac-address=A8:1E:84:18:5B:BD
    mac-address-blacklist=
    mtu=1500
    speed=100

    [ipv4]
    address1=192.168.178.120/24,192.168.178.2
    dhcp-send-hostname=false
    dns=217.0.43.177;217.0.43.161;
    dns-search=217.0.43.177;217.0.43.161;
    may-fail=false
    method=manual

    [ipv6]
    addr-gen-mode=stable-privacy
    dns-search=
    method=ignore

    [proxy]

    [connection]
    id=Kabelgebundene Verbindung DHCP
    uuid=eeb83f68-be4b-3ce3-bf00-dd2616fbeeee
    type=ethernet
    autoconnect=false
    permissions=

    [ethernet]
    mac-address-blacklist=

    [ipv4]
    dns-search=
    method=auto

    [ipv6]
    addr-gen-mode=stable-privacy
    dns-search=
    method=auto

    [proxy]
Kubuntu

Code: Alles auswählen

--- Kabelbebundene Verbindung DHCP.nmconnection ---

[connection]
id=Kabelgebundene Verbindung DHCP
uuid=dc3aa71f-6987-3403-9a77-ddf28528de1b
type=ethernet
autoconnect=false
permissions=

[ethernet]
mac-address-blacklist=

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

[proxy]


--- Kabelbebundene Verbindung manuell.nmconnection ---

[connection]
id=Kabelbebundene Verbindung manuell
uuid=e5122365-66ba-41c1-84f9-5c416d738bf4
type=ethernet
autoconnect-priority=-100
permissions=

[ethernet]
auto-negotiate=true
mac-address=A8:1E:84:18:5B:BD
mac-address-blacklist=

[ipv4]
address1=192.168.178.120/24,192.168.178.2
dhcp-send-hostname=false
dns=217.0.43.177;217.0.43.161;
dns-search=217.0.43.177;217.0.43.161;
may-fail=false
method=manual

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=ignore

[proxy]
die "Kabelgebundene Verbindung manuell" unter Kubuntu ist eine andere als die unter openSUSE:
  • Das openSUSE-Verbindungsprofil kann nur von dem Benutzer "user:bayernherz:" genutzt werden, während das Kubuntu-Verbindungsprofil von jedem Benutzer genutzt werden darf.
  • Das openSUSE-Verbindungsprofil wird nicht automatisch aktiviert (autoconnect=false) während das Kubuntu-Verbindungsprofil sich automatisch verbindet (default wenn autoconnect nicht definiert wird).
(siehe auch https://developer.gnome.org/NetworkMana ... tings.html)

Was ich allerdings nicht beurteilen kann (weil ich so etwas noch nie gemacht habe) ist, welche Konsequenzen sich daraus ergeben, dass einerseits Dein Router IP-Adressen per DHCP vergibt, Du aber andererseits gleichzeitig statische IP-Adressen aus dem selben Subnetz einsetzt.

Treten die von Dir geschilderten Probleme auch dann auf, wenn Du den DHCP-Server auf Deinem Router deaktivierst und ausschließlich statische IP-Adressen verwendest?

Viele Grüße

susejunky
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,

gestern abend habe ich im openSUSE-Forum diesen Beitrag

https://forums.opensuse.org/showthread. ... g-the-user

gesehen. PackageKit ist also ein weiterer Kandidat, der Probleme bereiten könnte, wenn die Internet-Verbindung plötzlich gekappt wird.

Da ich PackageKit nicht nutze und es auf meinen Systemen auch nicht installiert habe, kann ich Dir dazu jedoch nicht mehr sagen.

Viele Grüße

susejunky
bayernherz
Hacker
Hacker
Beiträge: 490
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von bayernherz »

hallo zusammen,
hallo susejunky,
von susejunky » 8. Aug 2020, 10:18
gestern abend habe ich im openSUSE-Forum diesen Beitrag
https://forums.opensuse.org/showthread ... -the-user
gesehen. PackageKit ist also ein weiterer Kandidat, der Probleme bereiten könnte, wenn die Internet-Verbindung plötzlich gekappt wird.
Da ich PackageKit nicht nutze und es auf meinen Systemen auch nicht installiert habe, kann ich Dir dazu jedoch nicht mehr sagen.
Ist mir leider nicht gelungen, da zu komplexe Abhängigkeiten.
von susejunky » 8. Aug 2020, 10:18
gestern abend habe ich im openSUSE-Forum diesen Beitrag
https://forums.opensuse.org/showthread. ... g-the-user
Ich denke, da kann irgendwo der Schlüssel zum Erfolg liegen.

Ich habe wieder einen radikal Test durchgeführt und habe

Code: Alles auswählen

Betriebssystem: openSUSE Tumbleweed 20200220
KDE-Plasma-Version: 5.18.0
KDE-Frameworks-Version: 5.67.0
Qt-Version: 5.14.1
Kernel-Version: 5.5.4-1-default
Art des Betriebssystems: 64-bit
Prozessoren: 4 × Intel® Core™ i5-6267U CPU @ 2.90GHz
Speicher: 15,5 GiB Arbeitsspeicher 
installiert. Mit dieser Version habe ich zum Dato mit Tumbleweed begonnen zu arbeiten.
Das Netzwerkproblem besteht bei dieser Version nicht.
Nach einem Upgrade mit

Code: Alles auswählen

zypper dup
war Tumbleweed dann so gut wie zerstört. (wenns interessiert Teile des Upgradeprotokolls habe ich noch)
Damit dürfte nachgewiesen sein das das Problem mit dem Upgrade um den 25.07.2020

Code: Alles auswählen

zypper dup
Metadaten von Repository 'Haupt-Repository (NON-OSS)' abrufen ......................................................................[fertig]
Cache für Repository 'Haupt-Repository (NON-OSS)' erzeugen .........................................................................[fertig]
Metadaten von Repository 'Haupt-Repository (OSS)' abrufen ..........................................................................[fertig]
Cache für Repository 'Haupt-Repository (OSS)' erzeugen .............................................................................[fertig]
Metadaten von Repository 'Packman' abrufen .........................................................................................[fertig]
Cache für Repository 'Packman' erzeugen ............................................................................................[fertig]
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Warnung: Sie sind im Begriff, eine Distributionsaktualisierung mit allen aktivierten Repositorys durchzuführen. Vergewissern Sie sich, dass diese Repositorys kompatibel sind, bevor Sie fortfahren. Weitere Informationen zu diesem Kommando finden Sie unter 'man zypper'.
Distributions-Aktualisierungen werden verarbeitet...

Das folgende NEUE Paket wird installiert:
  kernel-default-5.7.9-1.2

Das folgende Paket wird GELÖSCHT:
  kernel-default-5.7.9-1.1

Die folgenden 1186 Pakete werden aktualisiert:

aufgetreten ist, dazu sieh auch https://linux-club.de/forum/viewtopic.p ... 13#p792113
Genau dieses Problem hatte ich am Anfang ebenfalls.

Habe danach openSUSE Tumbleweed 20200807 installiert, mit gleichem Fehlerbild wie vorher.



Weiterhin habe ich festgestellt, wenn in der networkManager (KDE-Einstellung),
die DNS-server und die Suchdomane in de Kabelgebundenen Verbindung manuell entfernt werden,
tritt das Startproble mit KDE-Anwendungsmenue mit Firefox o. anderen Programmen nicht auf.
Allerdings kann dann auch keine Verbindung ins Internet aufgebaut werden.
Interne LAN-Verbindungen mit statischen IPs funktionieren.
Warum nochmals die DNS-Server in Tumbleweed definieren, die sind ja bereits im Router hinterlegt.

Ich würde mich über weitere Tipps, die zur Lösung des Problems beitragen sehr freuen.
Vielen Dank.

viele grüsse
bayernherz :thumbs:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 750
Registriert: 19. Sep 2014, 18:22

Re: Ohne Internetverbindung kein Start von Firfox möglich

Beitrag von susejunky »

Hallo bayernherz,

da Du mittlerweile Dein System mehrfach (neu) installiert hast, habe ich aktuell überhaupt keine Vorstellung mehr davon wann welches Problem bei Dir auftritt. Daher beschränke ich mich erst einmal auf allgemeinere Hinweise, was Probleme machen könnte, wenn man den Zugang zum Internet kappt:

PIM
Wenn Du EMail-Clients (kmail, thunderbird, ...) aktiv hast und diese in festen Abständen Mailserver auf neu eingegangene EMails überprüfen.
Wenn Du Kalenderprogramme (korganizer, thunderbird, ...) aktiv hast und diese binden Kalender aus dem Internet ein.

CLOUD
Wenn Du Cloudspeicher eingebunden hast (über webdav oder andere Protokolle).

bayernherz hat geschrieben: 10. Aug 2020, 15:03...
Weiterhin habe ich festgestellt, wenn in der networkManager (KDE-Einstellung),
die DNS-server und die Suchdomane in de Kabelgebundenen Verbindung manuell entfernt werden,
tritt das Startproble mit KDE-Anwendungsmenue mit Firefox o. anderen Programmen nicht auf.
Allerdings kann dann auch keine Verbindung ins Internet aufgebaut werden.
Interne LAN-Verbindungen mit statischen IPs funktionieren.
Nun das ist nicht verwunderlich, denn ohne DNS-Server gibt es keine Namensauflösung für externe/öffentliche Adressen (außer in Firefox, wenn man das eingebaute DoH aktiviert hat).

Viele Grüße

susejunky
Antworten