Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] WLAN geht mit 15.1 nicht mehr

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
klaus-dieter
Hacker
Hacker
Beiträge: 412
Registriert: 10. Jun 2004, 04:50

[gelöst] WLAN geht mit 15.1 nicht mehr

Beitrag von klaus-dieter » 8. Jun 2019, 08:35

Hallo,

Laptop neu mit 15.1 installiert, WLAN geht nicht mehr ging aber unter 42.3.

Der Link in https://linux-club.de/forum/viewtopic.php?f=86&t=109291 liefert leider ein 404 sonst hätte ich das Skript ausgeführt.

Kill switches:

Code: Alles auswählen

rfkill list all
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
Kernel Modul sollte geladen sein

Code: Alles auswählen

lspci -nnk | grep -i -A3 net
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
        Subsystem: Hewlett-Packard Company Device [103c:81c1]
        Kernel driver in use: rtl8723be
        Kernel modules: rtl8723be
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast Ethernet controller [10ec:8136] (rev 07)
        Subsystem: Hewlett-Packard Company Device [103c:81e1]
        Kernel driver in use: r8169
        Kernel modules: r8169
hwinfo

Code: Alles auswählen

hwinfo --wlan
12: PCI 200.0: 0282 WLAN controller                             
  [Created at pci.386]
  Unique ID: PL6s.ir4uVzTW3gD
  Parent ID: hoOk.TilF6Lq2nFD
  SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Realtek RTL8723BE PCIe Wireless Network Adapter"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0xb723 "RTL8723BE PCIe Wireless Network Adapter"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x81c1 
  Driver: "rtl8723be"
  Driver Modules: "rtl8723be"
  Device File: wlan1
  Features: WLAN
  I/O Ports: 0x2000-0x20ff (rw)
  Memory Range: 0x91200000-0x91203fff (rw,non-prefetchable)
  IRQ: 18 (no events)
  HW Address: 36:94:56:34:7d:3d
  Permanent HW Address: 3c:95:09:89:91:f5
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000010ECd0000B723sv0000103Csd000081C1bc02sc80i00"
  Driver Info #0:
    Driver Status: rtl8723be is active
    Driver Activation Cmd: "modprobe rtl8723be"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #8 (PCI bridge)
Das seltsame, bei einem reboot, kam ein Pop-up hoch wo ich das Root Passwort eingeben sollte, dann hat er irgendwie das WLAN Passwort abgespeichert und ich war im WLAN. Jetzt sehe ich nichts mehr. Auch das Netzwerk Icon in KDE zeigt mir keine verfügbaren WLANs an.
Zuletzt geändert von klaus-dieter am 8. Jun 2019, 20:27, insgesamt 1-mal geändert.

Werbung:
Sauerland
Guru
Guru
Beiträge: 3504
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von Sauerland » 8. Jun 2019, 09:01

Poste:

Code: Alles auswählen

zypper lr -d

Code: Alles auswählen

zypper se -si rtl
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

klaus-dieter
Hacker
Hacker
Beiträge: 412
Registriert: 10. Jun 2004, 04:50

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von klaus-dieter » 8. Jun 2019, 09:10

Code: Alles auswählen

zypper lr -d
#  | Alias                     | Name                                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                | Service
---+---------------------------+---------------------------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------+--------
 1 | openSUSE-Leap-15.1-1      | openSUSE-Leap-15.1-1                                    | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-VendorCo_ProductCode_920703152D196403946-0:0-part2 |        
 2 | repo-debug                | Debug Repository                                        | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/                |        
 3 | repo-debug-non-oss        | Debug Repository (Non-OSS)                              | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/            |        
 4 | repo-debug-update         | Update Repository (Debug)                               | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.1/oss/                           |        
 5 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS)                      | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.1/non-oss/                       |        
 6 | repo-non-oss              | Non-OSS Repository                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/                  |        
 7 | repo-oss                  | Haupt-Repository                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                      |        
 8 | repo-source               | Source Repository                                       | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/               |        
 9 | repo-source-non-oss       | Source Repository (Non-OSS)                             | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/           |        
10 | repo-update               | Hauptaktualisierungs-Repository                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss                                  |        
11 | repo-update-non-oss       | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/    

Code: Alles auswählen

zypper se -si rtl
Loading repository data...
Reading installed packages...
No matching items found.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5348
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von tomm.fa » 8. Jun 2019, 11:04

Magst du noch die Ausgaben von

Code: Alles auswählen

uname -r

Code: Alles auswählen

systemctl show -p Id network.service

Code: Alles auswählen

cat /etc/sysconfig/network/ifcfg-[earw]*

Code: Alles auswählen

zypper se -si firmware
hier vorführen?
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!


klaus-dieter
Hacker
Hacker
Beiträge: 412
Registriert: 10. Jun 2004, 04:50

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von klaus-dieter » 8. Jun 2019, 13:19

zu den Ausgaben

Code: Alles auswählen

# uname -r
4.13.8-2.g7aed50c-default

Code: Alles auswählen

# systemctl show -p Id network.service
Id=NetworkManager.service

Code: Alles auswählen

# cat /etc/sysconfig/network/ifcfg-[earw]*
BOOTPROTO='dhcp'
STARTMODE='auto'
DHCLIENT_SET_HOSTNAME='yes'

Code: Alles auswählen

# zypper se -si firmware
Loading repository data...
Reading installed packages...

S  | Name            | Type    | Version             | Arch   | Repository      
---+-----------------+---------+---------------------+--------+-----------------
i+ | kernel-firmware | package | 20190118-lp151.1.10 | noarch | Haupt-Repository

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5348
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von tomm.fa » 8. Jun 2019, 13:43

Vergessen, bitte noch die Ausgabe von

Code: Alles auswählen

systemctl status NetworkManager
Zu den bisherigen Ausgaben. Da du den NetworkManager verwendest, solltest du vorhanden Konfigurationen deines Internetzugangs, welche mit YaST erstellt wurden, löschen. Diese können (aber müssen nicht) zu Komplikationen führen.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

klaus-dieter
Hacker
Hacker
Beiträge: 412
Registriert: 10. Jun 2004, 04:50

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von klaus-dieter » 8. Jun 2019, 14:08

Code: Alles auswählen

systemctl status NetworkManager
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Sat 2019-06-08 13:14:15 CEST; 48min ago
     Docs: man:NetworkManager(8)
 Main PID: 1159 (NetworkManager)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/NetworkManager.service
           ├─1159 /usr/sbin/NetworkManager --no-daemon
           └─1420 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf /var/run/dhclient-eth1.pid -lf /var/lib/NetworkManager/dhclient-a0facb6d-d16f-310f-afbe-6e8d219a538b-eth1.lease -cf /var>

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
Im Yast unter den Netzwerk Einstellungen bekomme ich die Meldung dass Netzwerk Manager genutzt wird und ein paar Optionen nicht genutzt werden können. Ich sehe nicht wo ich da was löschen könnte, in den globalen Optionen steht im Drop Down dass ich Netzwerk Manager nutze und im Tag Übersicht ist alles deaktiviert. Da sind aber 3 Einträge drin

Ethernet DHCP eth0
RTL810xE PCI Nicht konfiguriert
RTL8723BE PCie WLAN Adapter nicht konfiguriert

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5348
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von tomm.fa » 8. Jun 2019, 14:17

klaus-dieter hat geschrieben:
8. Jun 2019, 14:08
Im Yast unter den Netzwerk Einstellungen bekomme ich die Meldung dass Netzwerk Manager genutzt wird und ein paar Optionen nicht genutzt werden können. Ich sehe nicht wo ich da was löschen könnte, in den globalen Optionen steht im Drop Down dass ich Netzwerk Manager nutze und im Tag Übersicht ist alles deaktiviert. Da sind aber 3 Einträge drin

Ethernet DHCP eth0
RTL810xE PCI Nicht konfiguriert
RTL8723BE PCie WLAN Adapter nicht konfiguriert
https://linux-club.de/wiki/opensuse/Net ... orkManager

Aber soeben kam ja noch was anderes zum Vorschein.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Sauerland
Guru
Guru
Beiträge: 3504
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von Sauerland » 8. Jun 2019, 14:52

# uname -r
4.13.8-2.g7aed50c-default
Kommt woher?
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

klaus-dieter
Hacker
Hacker
Beiträge: 412
Registriert: 10. Jun 2004, 04:50

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von klaus-dieter » 8. Jun 2019, 18:21

was meinst du mir woher kommt? Ich habe 08/15 einfach die Installation durchgeführt und alle Updates eingespielt. Was soll am Kernel falsch sein?

Sauerland
Guru
Guru
Beiträge: 3504
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von Sauerland » 8. Jun 2019, 18:29

Code: Alles auswählen

uname -r
4.12.14-lp151.28.4-default
Der Kernel von Leap 15.X ist 4.12.........

Poste:

Code: Alles auswählen

zypper se -si kernel
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

klaus-dieter
Hacker
Hacker
Beiträge: 412
Registriert: 10. Jun 2004, 04:50

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von klaus-dieter » 8. Jun 2019, 19:12

Code: Alles auswählen

# zypper se -si kernel
Loading repository data...
Reading installed packages...

S  | Name                 | Type    | Version                     | Arch   | Repository       
---+----------------------+---------+-----------------------------+--------+------------------
i+ | kernel-default       | package | 4.13.8-2.1.g7aed50c         | x86_64 | (System Packages)
i+ | kernel-default       | package | 4.12.14-lp151.27.3          | x86_64 | Haupt-Repository 
i+ | kernel-firmware      | package | 20190118-lp151.1.10         | noarch | Haupt-Repository 
i  | texlive-l3kernel     | package | 2017.133.svn44483-lp151.6.1 | noarch | Haupt-Repository 
i  | texlive-l3kernel-doc | package | 2017.133.svn44483-lp151.6.1 | noarch | Haupt-Repository 
linux-xnsi:~ # 
Ich habe keine Quellen manuell zugefügt.

Ich hatte mich jetzt auch in den Netzwerkeinstellungen nochmals umgeschaut, also das Applet in KDE. Da kommt immer hoch dass ich das root Passwort eingeben muss. Ich hatte mal gegoogelt bei anderen hat geholfen dass die Einstellung dass die Verbindung nicht für alle User genutzt werden kann ausgeschaltet werden soll. Hat bei mir nicht geholfen. Ich befürchte fast dass ich hier einfach ein root/non-root Problem habe.

Sauerland
Guru
Guru
Beiträge: 3504
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von Sauerland » 8. Jun 2019, 19:20

Ich habe keine Quellen manuell zugefügt.
Den aber zumindest dann installiert:
i+ | kernel-default | package | 4.13.8-2.1.g7aed50c | x86_64 | (System Packages)
Das ist ein älterer Kernel aus kernel:stable, den würde ich erst mal wieder deinstallieren.

Ich hatte mich jetzt auch in den Netzwerkeinstellungen nochmals umgeschaut, also das Applet in KDE. Da kommt immer hoch dass ich das root Passwort eingeben muss. Ich hatte mal gegoogelt bei anderen hat geholfen dass die Einstellung dass die Verbindung nicht für alle User genutzt werden kann ausgeschaltet werden soll. Hat bei mir nicht geholfen.
Das Passwort sollte das Master-Passwort für KWallet sein......
Einfach in Kwallet leer lassen.......
Denn der Networkmanager speicher das Wlan Passwort in Kwallet.

Oder das root Passwort wenn du angegeben hast:
Diese Verbindung darf jeder User nutzen, Passwort wird unverschlüsselt in einer Datei gespeichert.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

klaus-dieter
Hacker
Hacker
Beiträge: 412
Registriert: 10. Jun 2004, 04:50

Re: WLAN geht mit 15.1 nicht mehr

Beitrag von klaus-dieter » 8. Jun 2019, 20:27

Jetzt funktioniert es wieder. Was habe ich gemacht:

- Kernel wie vorgeschlagen geändert. Mein alter kam Suse Build Service, wie der installiert werden konnte habe ich keine Idee.
- Ich habe in KDE Wallet das Passwort gelöscht, das steht jetzt aber wie drin, das sollte also nichts geändert haben

Dann hatte ich ganz schwachen Empfang. Im alten Suse 42.2 musste ich für ordentlichen Empfang den folgenden Wert

Code: Alles auswählen

 # cd /etc/modprobe.d/
linux-xnsi:/etc/modprobe.d # more 99-local.conf
#
# please add local extensions to this file
#
#options rtl8723be ant_sel=2

eintragen, den habe ich jetzt auskommentiert. Damit hatte ich guten Empfang. Ich hatte das damals so verstanden dass mein WLAN Modul 2 Antennen hat und bei mir die Antenne 2 verlötet ist. Warum jetzt der Eintrag hinderlich ist, ist mir sehr rätselhaft. Ich habe sicherlich keine Kabel umgelötet.

Ich danke euch allen für die tolle Hilfe.

Antworten