Seite 1 von 2

[gelöst] Kein Livestream des Deutschlandfunkes

Verfasst: 1. Sep 2018, 19:55
von Benutzer 56323 gelöscht
Hallo alle,

warum auch immer, schafft es der Fuchs, aus Standardrepos, oben genannten Livestream nicht abzuspielen. Der aktuelle Opera, der bei DMR abk… macht es:

https://srv.deutschlandradio.de/themes/ ... D=4&state=

Unter Noscript habe ich entsprechende Skripte freigegeben. uBlock und Disconnect sind aktiv, sollten aber kein Problem sein, oder?

sd0

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 1. Sep 2018, 20:09
von tomm.fa
Funktioniert hier (auch mit aktiviertem µBlock, aber Disconnect & NoScript sind nicht vorhanden). Andere Antwort/Informationen erwartet? Dann sollte man seine Beiträge entsprechend erstellen.

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 1. Sep 2018, 21:07
von Benutzer 56323 gelöscht
Ich lerne gerne dazu. Welche Informartionen fehlen?

Leap 15.0?

sd0

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 2. Sep 2018, 00:27
von abgdf
Also, mein Firefox macht das (SuSE 13.1). Alternativ geht auch:

Code: Alles auswählen

mplayer http://st01.dlf.de/dlf/01/128/mp3/stream.mp3
https://www.deutschlandfunk.de/unsere-l ... 96.de.html

Wenn das läuft, kannst Du es auch in mein Webradio-Skript eintragen. Dann ist der Start recht bequem.

Bzgl. nervender Skripte verwende ich in Firefox nur das "JavaScript on-off applet" von "dasOoops".

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 2. Sep 2018, 05:03
von Sauerland
Ich werfe hier mal Packman-Repo ein..........

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 2. Sep 2018, 19:23
von dietterle65
Hatte mal ein ähnliches Problem.....

Keine Video`s im Firefox.

Ursache: Datei libavutil56 war aus einem anderen Repo als der Rest von Firefox.
Lösung: Datei fix auf Packmann Repo umgestellt, und alles lief wie es sollte.

Vielleicht ist das auch bei dir der Haken...
Dateien für ein Programm aus unterschiedlichen Repo`s

cio

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 3. Sep 2018, 16:30
von Benutzer 56323 gelöscht
LOL, eben mal nachinstalliert. An der liegt es nicht oder ist nicht alleinige Ursache.

Dennoch danke dir

sd0

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 6. Sep 2018, 17:19
von Heinz-Peter
Hallo @sd0,

hier unter Leap 42.3 funktioniert, auch mit aktivem uBlock. Versuche, als normaler user an der Konsole mit

Code: Alles auswählen

rpm --verify MozillaFirefox
Die Ausgabe zeigt eventuelle Änderungen an Dateien zu der Originalinstallation. Falls nach dem Befehl keine Ausgabe folgt, dann hat sich nichts geändert.
Was für eine Firefox Version läuft bei dir?
Ich habe getestet mit

Code: Alles auswählen

rpm -qa | grep -i firefox
Meine Konsoleausgabe

Code: Alles auswählen

MozillaFirefox-translations-common-60.1.0-106.1.x86_64
MozillaFirefox-60.1.0-106.1.x86_64
MozillaFirefox-branding-openSUSE-45-14.1.x86_64
Grüße Heinz-Peter

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 6. Sep 2018, 17:32
von Heinz-Peter
Hallo @dietterle65,

du schreibst:
Hatte mal ein ähnliches Problem.....

Keine Video`s im Firefox.

Ursache: Datei libavutil56 war aus einem anderen Repo als der Rest von Firefox.
Lösung: Datei fix auf Packmann Repo umgestellt, und alles lief wie es sollte.
Finde deinen Beitrag interessant. Hätte gerne gewusst, mit welchen Befehlen werden die Repos und die Bibliotheken ausgegeben.

Grüße Heinz-Peter

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 6. Sep 2018, 17:44
von Sauerland
Finde deinen Beitrag interessant. Hätte gerne gewusst, mit welchen Befehlen werden die Repos und die Bibliotheken ausgegeben.

Code: Alles auswählen

zypper lr -d

Code: Alles auswählen

zypper se -si NAME
Und das hab ich auch schon mal erwähnt:
Sauerland hat geschrieben:
2. Sep 2018, 05:03
Ich werfe hier mal Packman-Repo ein..........
Jetzt frage ich:
Alles umgestellt auf das Packman Repo:

Code: Alles auswählen

zypper dup --from PACKMANREPO

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 6. Sep 2018, 19:08
von dietterle65

Code: Alles auswählen

 zypper se -si flash ffmpeg libav
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                    | Typ   | Version        | Arch   | Repository            
---+-------------------------+-------+----------------+--------+-----------------------
i+ | ffmpeg-3                | Paket | 3.4.4-9.2      | x86_64 | Packman Repository    
i+ | ffmpeg2theora           | Paket | 0.30-2.5       | x86_64 | Packman Repository    
i+ | ffmpegthumbs            | Paket | 17.04.2-1.1    | x86_64 | openSUSE-Leap-42.3-Oss
i+ | flash-player            | Paket | 30.0.0.154-1.1 | x86_64 | Packman Repository    
i+ | gstreamer-plugins-libav | Paket | 1.8.3-3.14     | x86_64 | Packman Repository    
i+ | libavahi-client3        | Paket | 0.6.32-3.5     | x86_64 | openSUSE-Leap-42.3-Oss
i+ | libavahi-client3-32bit  | Paket | 0.6.32-3.5     | x86_64 | openSUSE-Leap-42.3-Oss
i+ | libavahi-common3        | Paket | 0.6.32-3.5     | x86_64 | openSUSE-Leap-42.3-Oss
i+ | libavahi-common3-32bit  | Paket | 0.6.32-3.5     | x86_64 | openSUSE-Leap-42.3-Oss
i+ | libavahi-core7          | Paket | 0.6.32-3.5     | x86_64 | openSUSE-Leap-42.3-Oss
i+ | libavahi-glib1          | Paket | 0.6.32-3.3     | x86_64 | openSUSE-Leap-42.3-Oss
i+ | libavahi-gobject0       | Paket | 0.6.32-3.3     | x86_64 | openSUSE-Leap-42.3-Oss
i+ | libavc1394-0            | Paket | 0.5.4-18.3     | x86_64 | openSUSE-Leap-42.3-Oss
i+ | libavcodec56            | Paket | 2.8.15-9.2     | x86_64 | Packman Repository    
i+ | libavcodec57            | Paket | 3.4.4-9.2      | x86_64 | Packman Repository    
i+ | libavcodec58            | Paket | 4.0.1-18.1     | x86_64 | Packman Repository    
i+ | libavdevice56           | Paket | 2.8.15-9.2     | x86_64 | Packman Repository    
i+ | libavdevice57           | Paket | 3.4.4-9.2      | x86_64 | Packman Repository    
i+ | libavfilter5            | Paket | 2.8.15-9.2     | x86_64 | Packman Repository    
i+ | libavfilter6            | Paket | 3.4.4-9.2      | x86_64 | Packman Repository    
i+ | libavformat56           | Paket | 2.8.15-9.2     | x86_64 | Packman Repository    
i+ | libavformat57           | Paket | 3.4.4-9.2      | x86_64 | Packman Repository    
i+ | libavformat58           | Paket | 4.0.1-18.1     | x86_64 | Packman Repository    
i+ | libavresample2          | Paket | 2.8.15-9.2     | x86_64 | Packman Repository    
i+ | libavresample3          | Paket | 3.4.4-9.2      | x86_64 | Packman Repository    
i+ | libavutil54             | Paket | 2.8.15-9.2     | x86_64 | Packman Repository    
i+ | libavutil55             | Paket | 3.4.4-9.2      | x86_64 | Packman Repository    
i+ | libavutil56             | Paket | 4.0.1-18.1     | x86_64 | Packman Repository    
i+ | libffmpegthumbnailer4   | Paket | 2.2.0-4.9      | x86_64 | Packman Repository    

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 7. Sep 2018, 17:21
von Benutzer 56323 gelöscht
So Leute,

meine Ausgaben:

Code: Alles auswählen

:~> rpm -qa | grep -i firefox
MozillaFirefox-60.1.0-lp150.3.11.1.x86_64
MozillaFirefox-branding-openSUSE-45-lp150.2.1.x86_64
MozillaFirefox-translations-common-60.1.0-lp150.3.11.1.x86_64
… und:

Code: Alles auswählen

:~> rpm --verify MozillaFirefox
…@linux-k9k1:~> 
Also keine Änderung.

Dann:

Code: Alles auswählen

:~> zypper se -si flash ffmpeg libav
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name               | Typ   | Version              | Arch   | Repository            
---+--------------------+-------+----------------------+--------+-----------------------
i+ | ffmpeg-3           | Paket | 3.4.4-lp150.9.1      | x86_64 | Packman Repository    
i  | ffmpegthumbs       | Paket | 17.12.3-lp150.1.1    | x86_64 | Haupt-Repository (OSS)
i  | ffmpegthumbs       | Paket | 17.12.3-lp150.1.1    | x86_64 | openSUSE-Leap-15.0-0  
i  | flash-player-ppapi | Paket | 30.0.0.154-lp150.1.1 | x86_64 | Packman Repository    
i  | libavahi-client3   | Paket | 0.6.32-lp150.3.2     | x86_64 | Haupt-Repository (OSS)
i  | libavahi-client3   | Paket | 0.6.32-lp150.3.2     | x86_64 | openSUSE-Leap-15.0-0  
i  | libavahi-common3   | Paket | 0.6.32-lp150.3.2     | x86_64 | Haupt-Repository (OSS)
i  | libavahi-common3   | Paket | 0.6.32-lp150.3.2     | x86_64 | openSUSE-Leap-15.0-0  
i  | libavahi-core7     | Paket | 0.6.32-lp150.3.2     | x86_64 | Haupt-Repository (OSS)
i  | libavahi-core7     | Paket | 0.6.32-lp150.3.2     | x86_64 | openSUSE-Leap-15.0-0  
i  | libavahi-glib1     | Paket | 0.6.32-lp150.3.2     | x86_64 | Haupt-Repository (OSS)
i  | libavahi-glib1     | Paket | 0.6.32-lp150.3.2     | x86_64 | openSUSE-Leap-15.0-0  
i  | libavc1394-0       | Paket | 0.5.4-lp150.1.12     | x86_64 | Haupt-Repository (OSS)
i  | libavc1394-0       | Paket | 0.5.4-lp150.1.12     | x86_64 | openSUSE-Leap-15.0-0  
i+ | libavcodec57       | Paket | 3.4.4-lp150.9.1      | x86_64 | Packman Repository    
i+ | libavdevice57      | Paket | 3.4.4-lp150.9.1      | x86_64 | Packman Repository    
i+ | libavfilter6       | Paket | 3.4.4-lp150.9.1      | x86_64 | Packman Repository    
i+ | libavformat57      | Paket | 3.4.4-lp150.9.1      | x86_64 | Packman Repository    
i+ | libavresample3     | Paket | 3.4.4-lp150.9.1      | x86_64 | Packman Repository    
i+ | libavutil55        | Paket | 3.4.4-lp150.9.1      | x86_64 | Packman Repository    
i+ | libavutil56        | Paket | 4.0.1-lp150.15.1     | x86_64 | Packman Repository   
Zu guter Letzt:

Code: Alles auswählen

:~> zypper lr -d
Repository-Prioritäten treten in Kraft:                                                         (Siehe 'zypper lr -P' für Details)
      10 (erhöhte Priorität)  :  2 Repositorys
      99 (Standard-Priorität) :  5 Repositorys

# | Alias                           | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                               | Dienst
--+---------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+-------------------------------------------------------------------+-------
1 | download.opensuse.org-non-oss   | Haupt-Repository (NON-OSS)                              | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/ |       
2 | download.opensuse.org-non-oss_1 | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/            |       
3 | download.opensuse.org-oss       | Haupt-Repository (OSS)                                  | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/     |       
4 | download.opensuse.org-oss_1     | Hauptaktualisierungs-Repository                         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/15.0/oss                 |       
5 | openSUSE-Leap-15.0-0            | openSUSE-Leap-15.0-0                                    | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/     |       
6 | opensuse-guide.org-repo         | Libdvdcss Repository                                    | Ja        | (r ) Ja         | Ja             |   10      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/                |       
7 | packman.inode.at-suse           | Packman Repository                                      | Ja        | (r ) Ja         | Ja             |   10      | rpm-md | http://packman.jacobs-university.de/suse/openSUSE_Leap_15.0/
So, wenn abgeschickt, sehe ich, ob ich was vergessen.

sd0

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 7. Sep 2018, 18:11
von Sauerland
Repo 3 = Repo 5, eines kannst du davon löschen.

zypper dup auf Packman gemacht?

Code: Alles auswählen

zypper dup --from http://packman.jacobs-university.de/suse/openSUSE_Leap_15.0/
Edit:
Wenn man die Ausgabe nicht scrollt, sieht man nur die Hälfte.......
Anscheinend der dup schon erfolgt, aber ich würde noch die Codecs von ffmpeg-4 installieren:

Code: Alles auswählen

zypper in libavcodec58

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 7. Sep 2018, 19:31
von Benutzer 56323 gelöscht
Hallo Sauerland,

ich habe Repo 5 gelöscht, weil es nicht auf 15.0 spezifiziert wurde. Gute Idee?

Code: Alles auswählen

:~> sudo zypper dup --from http://packman.jacobs-university.de/suse/openSUSE_Leap_15.0/
[sudo] Passwort für root: 
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Distributions-Aktualisierungen werden verarbeitet...

Das folgende Objekt ist gesperrt und wird durch keine Aktivität geändert:
 Verfügbar:
  pattern:games

Keine auszuführenden Aktionen.
Es mag nur ein Tick von mir sein aber mich nerven Spiele auf einem Rechner. Wenn es aber sein muss, gebe ich dieses Pattern frei.

sd0

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 7. Sep 2018, 19:35
von Benutzer 56323 gelöscht
Kleiner Nachtrag:

Code: Alles auswählen

:~> sudo zypper in libavcodec58
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Paketabhängigkeiten werden aufgelöst...

Die folgenden 2 NEUEN Pakete werden installiert:
  libavcodec58 libswresample3

2 neue Pakete zu installieren.
Gesamtgröße des Downloads: 4,1 MiB. Bereits im Cache gespeichert: 0 B. Nach der Operation werden zusätzlich 11,3 MiB belegt.
Fortfahren? [j/n/...? zeigt alle Optionen] (j): j
Paket libswresample3-4.0.1-lp150.15.1.x86_64 abrufen                                         (1/2),  92,5 KiB (132,3 KiB entpackt)
Abrufen: libswresample3-4.0.1-lp150.15.1.x86_64.rpm ......................................................................[fertig]
Paket libavcodec58-4.0.1-lp150.15.1.x86_64 abrufen                                           (2/2),   4,1 MiB ( 11,2 MiB entpackt)
Abrufen: libavcodec58-4.0.1-lp150.15.1.x86_64.rpm ..........................................................[fertig (688,5 KiB/s)]
Überprüfung auf Dateikonflikte läuft: ....................................................................................[fertig]
(1/2) Installieren: libswresample3-4.0.1-lp150.15.1.x86_64 ...............................................................[fertig]
(2/2) Installieren: libavcodec58-4.0.1-lp150.15.1.x86_64 .................................................................[fertig
bleibt ohne Erfolg. Auch meine Idee, mal den Fuchs über Konsole zu starten, brachte keine Fehlermeldung raus.

sd0

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 7. Sep 2018, 19:42
von Sauerland
Bei mir läuft es.....

Als root:

Code: Alles auswählen

zypper install -f libxine2-codecs ffmpeg-3 lame  dvdauthor gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-base  gstreamer-plugins-good gstreamer-plugins-good-extra gstreamer-plugins-libav gstreamer-plugins-qt5 gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs vlc-codec-gstreamer ogmtools libavcodec58
Das ist ein Befehl.........

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 7. Sep 2018, 20:33
von Benutzer 56323 gelöscht
@Sauerland,

woow, ungefähr die Hälfte deiner Pakete fehlte mir. Damit wird mir aber der Wert der "codecs-kde.ymp" in Frage.

Test folgt.

Danke

sd0

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 7. Sep 2018, 22:05
von abgdf
sd0 hat geschrieben:
7. Sep 2018, 19:31
Es mag nur ein Tick von mir sein aber mich nerven Spiele auf einem Rechner.
Ah! Bitte beachten: PackMan (Repository mit von kompetenten Benutzern erstellten rpm-Softwarepaketen, insbesondere aus dem Bereich Multimedia, für SuSE-Linux-Distributionen) ist nicht Pacman (Punktefreßspiel mit einer gelben Pampelmuse von 1980).

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 7. Sep 2018, 23:05
von Sauerland
Damit wird mir aber der Wert der "codecs-kde.ymp" in Frage.
Die stelle ich schon immer in Frage...
Der entsprechende Link wurde im offiziellen openSUSE Forum (forums.opensuse.org) übrigens vor kurzem entfernt.........

Re: Kein Livestream des Deutschlandfunkes

Verfasst: 9. Sep 2018, 15:21
von Benutzer 56323 gelöscht
Hallo alle,

so, DLF streamt auch bei mir endlich. Woran es genau lag, kann ich nicht schreiben, weil nicht weiß. Nach dem Umstellen der Mozillaprogis von Suse Standard auf Mozillarepo, tauchten unter NoScript weitere Scripte auf, deren Grund irgendwie nachvollziehbar war. Also freigegeben und jetzt fluppt es.

Danke euch

sd0