Seite 1 von 1

Pulseaudio-DLNA Firewall Port

Verfasst: 15. Apr 2018, 14:01
von Lance_Blastoff
Hallo mal wieder.
Ich nutze pulseaudio-dlna um Musik vom Laptop auf meine Audio-Anlage zu Senden. Das Arbeitet aber nur wenn ich die Firewall ausschalte.
Ich habe schon versucht tcp Port 8080 und udp Port 1900 in der Firewall frei zu schalten bzw. pulseaudio-dlna via

Code: Alles auswählen

 pulseaudio-dlna --port 10291

zu starten und diesen Port 10291 frei zu schalten.
Leider führt dies nicht zum gewünschten Erfolg. Ich vermute das sich meine Audio-Anlage über einen anderen Port verbindet. Pulseaudio-dlna scheint selber nach verfügbaren Geräten zu suchen.
Wie kann ich rausfinden an welchem Port sich pulseaudio-dlna verbindet?

Re: Pulseaudio-DLNA Firewall Port

Verfasst: 15. Apr 2018, 14:06
von spoensche
Was sagen den die Logs der Firewall?

Re: Pulseaudio-DLNA Firewall Port

Verfasst: 15. Apr 2018, 14:56
von Lance_Blastoff
Ich habe in Yast das Protokolierungslevel auf "Alles" gesetzt.
Dann PA-DLNA gestarted.
Das sagt

Code: Alles auswählen

journalctl -u SuSEfirewall2

Code: Alles auswählen

Apr 15 14:53:54 linux-tqvx systemd[1]: Stopping SuSEfirewall2 phase 2...
Apr 15 14:53:54 linux-tqvx SuSEfirewall2[14794]: Firewall rules unloaded.
Apr 15 14:53:54 linux-tqvx systemd[1]: Stopped SuSEfirewall2 phase 2.
Apr 15 14:53:54 linux-tqvx systemd[1]: Starting SuSEfirewall2 phase 2...
Apr 15 14:53:54 linux-tqvx SuSEfirewall2[14854]: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Apr 15 14:53:54 linux-tqvx SuSEfirewall2[14854]: using default zone 'ext' for interface eth0
Apr 15 14:53:54 linux-tqvx SuSEfirewall2[14854]: using default zone 'ext' for interface wlan0
Apr 15 14:53:55 linux-tqvx SuSEfirewall2[14854]: Firewall rules successfully set
Apr 15 14:53:55 linux-tqvx systemd[1]: Started SuSEfirewall2 phase 2
Ich kann da nichts sehen ausser das die Firewall läuft :???:

Re: Pulseaudio-DLNA Firewall Port

Verfasst: 17. Apr 2018, 18:57
von Heinz-Peter
Lance_Blastoff hat geschrieben:
15. Apr 2018, 14:56
Wie kann ich rausfinden an welchem Port sich pulseaudio-dlna verbindet?
Vielleicht mit wireshark versuchen?

Grüße Heinz-Peter

Re: Pulseaudio-DLNA Firewall Port

Verfasst: 17. Apr 2018, 22:47
von josef-wien
Lance_Blastoff hat geschrieben:
15. Apr 2018, 14:56
journalctl -u SuSEfirewall2
Als ich noch openSUSE verwendet habe, gab es diesen Begriff nicht bei den iptables-Meldungen, und das wird wohl immer noch so sein. Schau im Ergebnis von

Code: Alles auswählen

iptables-save
nach, was da so bei
--log-prefix
verwendet wird, und suche danach. Oder versuche mit
DPT=1900
Dein Glück.

Re: Pulseaudio-DLNA Firewall Port

Verfasst: 17. Apr 2018, 23:57
von Sauerland
pulseaudio-dlna --port 10291
lt. Man page:
-p --port=<port>
Set the server port [default: 8080].

Re: Pulseaudio-DLNA Firewall Port

Verfasst: 19. Apr 2018, 09:35
von Lance_Blastoff
Vielen Dank erstmal für die Antworten.
Ich komme erst in 14 Tagen dazu das Ganze zu testen.
Ich habe in der Zwischenzeit einiges über die Log-Files gelernt und bin dem Port auf der Spur.
Ich werde berichten.