Seite 1 von 1

[GELÖST]CIFS Freigabe einbinden funktioniert nicht

Verfasst: 18. Mär 2018, 19:21
von Coolzero
Hallo,
ich hab versucht eine CIFS Freigabe von meinem WinServer 2016 mittels

Code: Alles auswählen

sudo mount -t cifs -o user=Thomas,vers=3.0  //192.168.188.22/Bilder /home/thomas/Test
einzubinden, die funktioniert auch, allerdings kann ich anschließend nichts in der Freigabe bearbeiten, da diese dann root gehört.
Der User Thomas hat auf dem Server Vollzugriff auf die Freigabe

Code: Alles auswählen

drwxr-xr-x 2 root   root      0 16. Mär 19:29 Test
Der Eigentümer lässt sich auch nicht über Chown ändern..

Re: CIFS Freigabe einbinden funktioniert nicht

Verfasst: 18. Mär 2018, 19:56
von Sauerland

Re: CIFS Freigabe einbinden funktioniert nicht

Verfasst: 19. Mär 2018, 07:11
von Coolzero
Sauerland hat geschrieben:
18. Mär 2018, 19:56
Stichworte zum suchen:
samba opensuse wiki

https://linux-club.de/wiki/opensuse/Samba
https://doc.opensuse.org/documentation/ ... samba.html
Das hab ich mir jetzt mal alles durchgelesen, allerdings kann ich an meinem mount Befehl von oben da auch keinen Fehler entdecken!?

Re: CIFS Freigabe einbinden funktioniert nicht

Verfasst: 19. Mär 2018, 17:50
von spoensche

Code: Alles auswählen

mount -t cifs -o user=Thomas,uid=Thomas //192.168.188.22/Bilder /mnt
Ist der Win Server ein Domänen Controller? Ist der Username auf dem Server Thomas oder thomas? U.U kann es auch sein das du die Option "cifsacl" statt user und uid verwenden musst.

Re: CIFS Freigabe einbinden funktioniert nicht

Verfasst: 19. Mär 2018, 19:56
von Coolzero
spoensche hat geschrieben:
19. Mär 2018, 17:50

Code: Alles auswählen

mount -t cifs -o user=Thomas,uid=Thomas //192.168.188.22/Bilder /mnt
Ist der Win Server ein Domänen Controller? Ist der Username auf dem Server Thomas oder thomas? U.U kann es auch sein das du die Option "cifsacl" statt user und uid verwenden musst.
Also Thomas ist großgeschrieben richtig. Mit deinem Befehl bekomme ich diese ausgabe

Code: Alles auswählen

sudo mount -t cifs -o user=Thomas,uid=Thomas //192.168.188.22/Bilder /mnt
[sudo] Passwort für root: 
bad option uid="Thomas"
Hab noch ein wenig versucht, damit der mount überhaupt erfolgreich ist, muss

Code: Alles auswählen

-o vers=3.0
gesetzt werden, also z.b. so.

Code: Alles auswählen

sudo mount -t cifs -o user=Thomas,vers=3.0 //192.168.188.22/Bilder /mnt
Wenn ich deinen Befehl mit Vers=3 verwende bekomme ich

Code: Alles auswählen

sudo mount -t cifs -o user=Thomas,uid=Thomas,vers=3.0 //192.168.188.22/Bilder /mnt
bad option uid="Thomas"
Dann wird gemountet, allerdings als user und group = root

Mit cifsacel bekomme ich das

Code: Alles auswählen

sudo mount -t cifs -o cifsacl,vers=3.0 //192.168.188.22/Bilder /mnt
Password for root@//192.168.188.22/Bilder:  ********************
mount error(13): Permission denied
Der Server ist kein Domänen Controller

Re: CIFS Freigabe einbinden funktioniert nicht

Verfasst: 19. Mär 2018, 20:16
von tomm.fa
Sollte die UID nicht eine Nummer (in diesem Fall die Identifikationsnummer von Thomas) und kein Name sein? Herauszufinden ist diese Nummer zum Beispiel durch Eingabe des Befehls „id“ in der Konsole.

Re: CIFS Freigabe einbinden funktioniert nicht

Verfasst: 19. Mär 2018, 21:00
von Coolzero
tomm.fa hat geschrieben:
19. Mär 2018, 20:16
Sollte die UID nicht eine Nummer (in diesem Fall die Identifikationsnummer von Thomas) und kein Name sein? Herauszufinden ist diese Nummer zum Beispiel durch Eingabe des Befehls „id“ in der Konsole.
Super, genau das war der entscheidende Hinweis, mit

Code: Alles auswählen

sudo mount -t cifs -o user=Thomas,uid=1000,gid=100,vers=3.0 //192.168.188.22/Bilder /home/thomas/Test
funktioniert es jetzt genau wie es soll.

Danke für die Hilfe