Seite 1 von 1

[GELÖST]Zugriff auf NFS Freigabe klappt nicht

Verfasst: 28. Feb 2018, 21:29
von Coolzero
Hallo,
ich habe einen WinServer 2016, auf dem ich NFS Freigaben erstellt habe, diese wollte ich nun unter Leap42.3 einbinden, dazu hab ich in Yast den NFS Client gestartet und dort nach dem Server und der Freigabe gesucht, wird auch dann gefunden und lässt sich ohne Fehlermeldung mit OK einbinden.

Wenn ich dann aber in Dolphine auf die Freigabe klicke, bekomme ich nur die Meldung "Ordner lässt sich nicht öffnen"

Was mach ich da falsch?

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 28. Feb 2018, 23:16
von marce
erste Vermutung: Wie sehen denn die Dateisystemrechte aus? Was sagt die Serverkonfig bzgl. Rechten? Was passiert an der Konsole?

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 17. Mär 2018, 13:54
von Coolzero
Hi,
auf dem Bild anbei sind die NFS einstellungen auf dem WinServer2016 zu sehen.
https://picload.org/view/dacgadgl/winservernfs.png.html

Bei einem

Code: Alles auswählen

sudo mount 192.168.188.22:/Downloads /home/thomas/DownloadsServer
auf der Konsle, gibt es keine Rückmeldung, also auch keinen Fehler.

Aber das verhalten in Dolphin bleibt gleich, auch auf der Konsole kann ich nicht auf den Mount zugreifen

Code: Alles auswählen

cd DownloadsServer
bash: cd: DownloadsServer: Keine Berechtigung
Die Berechtigungen sehen auch schräg aus

Code: Alles auswählen

drwx------ 2 4294967294 4294967294   64 14. Mär 22:11 DownloadsServer
Ich kann die Eigentümer über Chown aber auch nicht ändern...

Code: Alles auswählen

chown thomas:users DownloadsServer                                                                                                                                                                     
chown: der Eigentümer von 'DownloadsServer' wird geändert: Keine Berechtigung 
Die Eigentümer werden beim mount Befehl gesetzt, wenn ich umount durchführe, hat das Verzeichniss wieder die gewollten Berechtigungen.....

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 17. Mär 2018, 14:08
von Sauerland
Ich kann die Eigentümer über Chown aber auch nicht ändern...
Welches du auch als root ausführst?
Deswegen ist es wichtig, immer die Ausgabe eines Befehls incl. der kompletten Eingabezeile zu posten.....

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 17. Mär 2018, 14:09
von Coolzero
Hi, ja sorry hast recht, ja hab es mit sudo und auch als user root versucht, immer das gleiche Ergebnis

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 17. Mär 2018, 14:16
von Sauerland
Freigabe unmounten, gibt es das Verzeichnis dann?

Code: Alles auswählen

ls -al /home/thomas/DownloadsServer
PS:
Serverfreigaben besser nach /mnt mouten.

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 17. Mär 2018, 14:28
von Coolzero
Sauerland hat geschrieben:
17. Mär 2018, 14:16
Freigabe unmounten, gibt es das Verzeichnis dann?

Code: Alles auswählen

ls -al /home/thomas/DownloadsServer
PS:
Serverfreigaben besser nach /mnt mouten.
Gibt dann

Code: Alles auswählen

ls -al /home/thomas/DownloadsServer
insgesamt 4
drwxr-xr-x  2 thomas users    6 28. Feb 19:24 .
drwx------ 51 thomas users 4096 17. Mär 14:04 ..
Nur für mich zum Verständniss, worin liegt der unterschied/vorteil nach /mnt zu mounten?

Danke

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 17. Mär 2018, 18:02
von josef-wien
Die Berechtigungen von Linux- und Windows-Dateisystemen sind inkompatibel. Daher müssen die Berechtigungen von Windows-Dateisystemen beim Einhängen definiert werden, eine Änderung mit chown bzw. chmod ist nicht möglich. Wenn es keine fstab-Eintragung mit den passenden Berechigungsdefinitionen gibt, muß der mount-Befehl diese Angaben enthalten.

Die Berechtigungen eines (leeren) Verzeichnisses, das als Einhängepunkt vorgesehen ist, aber bei dem nichts eingehängt ist, spielen keine Rolle. Sobald ein Linux-Dateisystem eingehängt ist, können damit die Rechte des Dateisystems (also dessen Hauptverzeichnisses) mit chown bzw. chmod geändert werden.

Bei nur einem Benutzer ist der Einhängepunkt eher Geschmackssache, bei mehreren Benutzer ist die Verwendung des Heimatverzeichnisses eines bestimmten Benutzers nicht so ideal.

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 17. Mär 2018, 18:19
von Coolzero
Hi,
ok es gibt nur einen Benutzer, daher sollte das kein Problem sein.

Da ich das Verzeichniss zum testen erstmal temporär mounten will bevor es in die FSTAB kommt, wie müsste der Befehl aussehen?
So klappt es nicht

Code: Alles auswählen

sudo mount -t nfs -rw 192.168.188.22:/Downloads /home/thomas/DownloadsServer 

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 17. Mär 2018, 18:26
von josef-wien
Coolzero hat geschrieben:
17. Mär 2018, 13:54
drwx------ 2 4294967294 4294967294 64 14. Mär 22:11 DownloadsServer
Suche einmal in der großen digitalen Welt nach "linux 4294967294". Welche Lösung für Dich sinnvoll ist, kann ich nicht beurteilen.

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 18. Mär 2018, 13:57
von Coolzero
Ich hab jetzt alles mögliche bei google gelesen und davon ausprobiert, allerdings ohne erfolg, ich bekomme das NFS Share nicht gemountet

Hab jetzt nochmal über NFS-Client in Yast gemuntet mit der option pNFS(NFS-V4.1) dann werden die Berechtigungen richtig gesetzt

Code: Alles auswählen

drwxr-xr-x 2 thomas users    6 28. Feb 19:24 DownloadsServer
Aber es werden trotzdem noch keine Daten in der Freigabe angezeigt
In der /etc/fstab werden dabei die folgenden Einträge erzeugt:

Code: Alles auswählen

Home-Server.fritz.box:/Downloads           /home/thomas/DownloadsServer  nfs    minorversion=1                  0  0
Home-Server.fritz.box:/Bilder              /home/thomas/BilderServer  nfs    minorversion=1                  0  0
Home-Server.fritz.box:/Musik               /home/thomas/MusikServer   nfs    minorversion=1                  0  0
Home-Server.fritz.box:/Videos              /home/thomas/VideosServer  nfs    minorversion=1                  0  0
thomas@linux-a2pl:~> 
Wenn ich es über die Konsole mit

Code: Alles auswählen

sudo mount -t nfs -onfsvers=4.1  192.168.188.22:/Downloads /home/thomas/DownloadsServer
versuche bekomme ich das

Code: Alles auswählen

mount.nfs: access denied by server while mounting 192.168.188.22:/Downloads

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 18. Mär 2018, 14:38
von Sauerland

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 18. Mär 2018, 18:42
von spoensche
M$ Schrott als NFS- Server macht man nicht. Schrott kann halt nix funktionierendes freigeben. Windows kann auch kein User ID Mapping.

1. Dateiaustausch Linux <-> Windows mit CIFS.
2. Dateiaustausch Linux <-> *nix Systeme: NFS

Tue dir selber den Gefallen und verwende Cifs oder noch besser, schmeiss weg den Windows Mist.

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 18. Mär 2018, 19:12
von Coolzero
Ok, jetzt hab ich es hinbekommen, das Problem war das ich auf dem Server die NFS Freigaben "Anonymen Zugriff zulassen" aktiviert hatte (damit sind die Freigaben auf meinem Enigma2 Reciever verfügbar), nachdem ich dort auf (Zugriff per UID/GID umgestellt habe, klappt auch der Zugriff.

Danke für die Hilfe

Re: Zugriff auf NFS Freigabe klappt nicht

Verfasst: 18. Mär 2018, 19:22
von Coolzero
spoensche hat geschrieben:
18. Mär 2018, 18:42
M$ Schrott als NFS- Server macht man nicht. Schrott kann halt nix funktionierendes freigeben. Windows kann auch kein User ID Mapping.

1. Dateiaustausch Linux <-> Windows mit CIFS.
2. Dateiaustausch Linux <-> *nix Systeme: NFS

Tue dir selber den Gefallen und verwende Cifs oder noch besser, schmeiss weg den Windows Mist.
Das klappt aus irgendeinem Grund auch nicht richtig mit CIFS, siehe hier
https://linux-club.de/forum/viewtopic.php?f=86&t=122318