Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

gelöst 42.2 WLAN Karte RTL8723BE funktioniert nicht

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 27. Dez 2016, 21:18

Ich habe die Module jetzt noch einmal entladen und nach jedem schritt rfkill list ausgeführt.

Code: Alles auswählen

linux-qiqv:~ # lsmod | grep -Ei 'acer|wmi'
acer_wmi               24576  0 
video                  40960  1 acer_wmi
hp_wmi                 16384  0 
sparse_keymap          16384  2 acer_wmi,hp_wmi
wmi                    16384  2 acer_wmi,hp_wmi
rfkill                 28672  9 cfg80211,acer_wmi,hp_wmi,bluetooth
linux-qiqv:~ # lsmod | grep -Ei 'hp|wmi'  
acer_wmi               24576  0 
video                  40960  1 acer_wmi
hp_wmi                 16384  0 
sparse_keymap          16384  2 acer_wmi,hp_wmi
wmi                    16384  2 acer_wmi,hp_wmi
rfkill                 28672  9 cfg80211,acer_wmi,hp_wmi,bluetooth
shpchp                 36864  0 
hp_wireless            16384  0 
linux-qiqv:~ # modprobe -r acer_wmi
linux-qiqv:~ # rfkill list
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
linux-qiqv:~ # systemctl restart NetworkManager.service
linux-qiqv:~ # lsmod | grep -Ei 'hp|wmi'
hp_wmi                 16384  0 
sparse_keymap          16384  1 hp_wmi
wmi                    16384  1 hp_wmi
rfkill                 28672  9 cfg80211,hp_wmi,bluetooth
shpchp                 36864  0 
hp_wireless            16384  0 
linux-qiqv:~ # modprobe -r hp_wmi
linux-qiqv:~ # lsmod | grep -Ei 'hp|wmi'
shpchp                 36864  0 
hp_wireless            16384  0 
linux-qiqv:~ # rfkill list
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
linux-qiqv:~ # modprobe hp_wmi
linux-qiqv:~ # rfkill list
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
4: acer-wireless: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
linux-qiqv:~ # 
Findet rfkill hp_wmi?
have a lot of input
HerbK

Werbung:
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5169
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von tomm.fa » 27. Dez 2016, 21:38

Die Option „-v“ steht für „verbose“ und ist aussagekräftiger.

Du solltest endlich mal
tomm.fa hat geschrieben:Edit 17:45:
Für dich aber eventuell interessant: https://wiki.ubuntuusers.de/rfkill/
durchlesen, besonders folgenden Abschnitt: https://wiki.ubuntuusers.de/rfkill/#Mod ... e-Probleme

Bedeutet also acer_wmi wieder entladen, auf die schwarze Liste setzen, Rechner neu starten, schauen was Sache ist.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 27. Dez 2016, 22:05

Hatte ich schon gelesen,
Bringt das Entladen von acer_wmi den gewünschten Erfolg,
weil nach dem Entladen das Wlan nicht funktioniert hat (auch nicht mit setzen auf wireless=1) habe ich das Blacklisten nicht probiert.
Ich probier' s, - mal sehen was passiert... :)
have a lot of input
HerbK

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 27. Dez 2016, 22:35

Hi Tomm,
nach blacklisten und neustart arbeitet die Wlankarte jetzt, aber nur wenn der Laptop direkt neben dem Router steht.

In den links von Dir weiter oben, war dazu etwas von "Antenne umstellen" die rede, ich habe aber nicht wirklich verstanden wie das zu realisieren ist.
have a lot of input
HerbK

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5169
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von tomm.fa » 27. Dez 2016, 22:46

Da meine Englischkenntnisse auch ziemlich bescheiden sind und ich verschiedene Übersetzungswerkzeuge verwenden muss, hatte ich es auch nur kurz überflogen. Es geht wohl darum das vom Treiber nur eine Antenne, obwohl zwei verbaut sind, erkannt wird und es dadurch zu Störungen/Instabilität kommen soll. Es soll aber eine Anpassung/einen Ersatz geben der diesen Fehler behebt und so schwer sieht die Anleitung auch nicht aus. Hat dein Laptop denn zwei Antennen?

Ansonsten könnte man auch mal schauen was es hier so gibt: https://software.opensuse.org/package/r ... =rtl8723be und was noch alles dazu muss. Aber jetzt ist erstmal Pause für mich.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5107
Registriert: 23. Sep 2008, 17:09

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von josef-wien » 27. Dez 2016, 23:29

herbk hat geschrieben:In den links von Dir weiter oben, war dazu etwas von "Antenne umstellen" die rede, ich habe aber nicht wirklich verstanden wie das zu realisieren ist.
Falls bei

Code: Alles auswählen

modinfo rtl8723be | grep ant_sel
nichts herauskommt, unterstützt Dein Kernel das nicht, und Du darfst aufhören zu lesen (oder den aktuellen 4.9 aus http://download.opensuse.org/repositori ... /standard/ versuchen).

Wenn das Entladen mit

Code: Alles auswählen

modprobe -r rtl8723be
möglich ist, lade das Modul erneut mit:

Code: Alles auswählen

modprobe rtl8723be ant_sel=1
Danach wird das Modul wieder entladen und mit ant_sel=2 neu geladen. Hilft keine der beiden Möglichkeiten, liegt das Problem woanders.

Wenn das Entladen nicht möglich ist, mußt Du Linux mit der Boot-Option

Code: Alles auswählen

rtl8723be.ant_sel=1
(bzw. 2) starten.

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 28. Dez 2016, 12:46

nach

Code: Alles auswählen

modprobe rtl8723be ant_sel=1
habe ich jetzt auch eine ordentliche Signalstärke.

Deshalb erst mal ein Danke an die Helfer.

Ich unterstelle jetzt aber, dass ich dieses rtl8723be ant_sel=1 noch irgendwo eintragen muss, damit es beim booten des Systems automatisch erfolgt.
Wenn mir noch jemand sagen könnte wo...
have a lot of input
HerbK

Alero

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von Alero » 28. Dez 2016, 12:55

Ich hab es zwar alles nur quer gelesen aber glaube irgendwo stand etwas von Grub Command Line.
Ansonsten würde wohl auch ein Script im Autostart die Sache automatisieren können.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5107
Registriert: 23. Sep 2008, 17:09

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von josef-wien » 28. Dez 2016, 16:43

Erstelle eine Datei /etc/modprobe.d/99-local.conf mit folgendem Inhalt:

Code: Alles auswählen

# Damit mein WLAN ordentlich funktioniert:
options rtl8723be ant_sel=1
P. S. Da openSUSE immer schon die initrd mit viel unnötigem Zeug vollmüllt, mußt Du sie eventuell neu erzeugen.

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 28. Dez 2016, 18:23

nach
Code: Alles auswählen
modprobe rtl8723be ant_sel=1
habe ich jetzt auch eine ordentliche Signalstärke.
Leider muss ich doch wieder negatives berichten:
Der Networkmanager zeigt mir jetzt zwar eine gute SIgnalstärke für mein Netzwerk (und auch die anderen Netzwerke ringsum), verbindet sich aber nicht damit.
Ohne das entladen und neu Laden des habe ich zwar nur einen ganz kleinen Pegel, aber wenn ich nahe genug am Router bin verbindet sich der Rechner mit den Netzwerk.
Da openSUSE immer schon die initrd mit viel unnötigem Zeug vollmüllt, mußt Du sie eventuell neu erzeugen.
Auch da habe ich keine Ahnung wie das geht, sorry
have a lot of input
HerbK

Alero

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von Alero » 28. Dez 2016, 18:33

Nur mal der Neugierde halber.
Was hängt auf der anderen Seite des WLan? Meine, was ist da als Router im Einsatz und gab es damit schon einmal Verbindungsprobleme?

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 28. Dez 2016, 18:42

der Router ist vom "Magenta T" ein W 724, Probleme hatte ich mit dem noch nicht, auch der Lapi mit dem ich das hier schreibe und ein paar andere funktionieren problemlos.

Noch etwas ist mir aufgefallen: Ich sehe keine der beiden Netzwerkkarten in der Firewall, - ist das normal? "Hier" auf der OS 13.2 werden die Netzwerkkarten angezeigt.
have a lot of input
HerbK

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 28. Dez 2016, 19:39

josef-wien hat geschrieben:Erstelle eine Datei /etc/modprobe.d/99-local.conf mit folgendem Inhalt:

Code: Alles auswählen

# Damit mein WLAN ordentlich funktioniert:
options rtl8723be ant_sel=1
P. S. Da openSUSE immer schon die initrd mit viel unnötigem Zeug vollmüllt, mußt Du sie eventuell neu erzeugen.
Die Datei 99-local.conf gab es schon, ich konnte sie einfach um die Zeilen erweitern.
Nach einem Neustart sagt Networkmanager jetzt zwar dass er mit dem Netzwerk verbunden ist, ich bekomme aber keine Antwort vom Router, auch ein Ping bleibt unbeantwortet.
have a lot of input
HerbK

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 28. Dez 2016, 21:54

Noch einmal ein update:
Die Wlanverbindung funktioniert, aber nur wenn ich als normaler User eingeloggt bin..
Wenn ich mich als root einlogge, dann ist die Wlanverbindung blockiert :???: :???:

Noch mal Danke!
have a lot of input
HerbK

Benutzeravatar
Jägerschlürfer
Moderator
Moderator
Beiträge: 4477
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von Jägerschlürfer » 31. Dez 2016, 15:21

wieso willst du auch als root arbeiten? Das ist doch nicht nötig und da die Karte als normaler User funktioniert, passt doch eigentlich alles,..
>Linux-Club Foren FAQ< >LC-Wiki<

Know your enemy and know yourself Sun Tzu

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 1. Jan 2017, 16:22

Hi Jägerschlürfer,
ich mache Administrationsarbeiten halt lieber als root eingeloggt, gerade wenn mal was nicht so ganz rund läuft. Und da ist es dann nicht besonders hilfreich wenn man keinen Zugriff auf das i-Net hat...
have a lot of input
HerbK

herbk
Member
Member
Beiträge: 211
Registriert: 21. Mär 2004, 17:30
Wohnort: Windsbach

Re: gelöst 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von herbk » 15. Jan 2017, 13:58

Hallo,
noch mal eine Frage zu der Geschichte, weil die Verbindung noch einmal "zicken" machte.

Das Erste war, dass die Verbindung immer instabiler wurde (sprich: die Verbindung brach ab und eine neue Verbindung wurde erst nach mehrmaligen klicken auf "neu verbinden" etabliert. Gestern ging dann auf einmal gar nichts mehr...

Ich habe dann die ganzen Schritte noch einmal wiederholt und bin auf etwas merkwürdiges gestossen:
Das erst mal bekam ich eine Verbindung wenn die Karte mit der Option "ant_sel=1" gestartet wurde. Jetzt muss ich die Karte mit "ant_sel=2" starten um eine Verbindung zu bekommen.

Womit kann das zusammenhängen?

Und noch eine Frage an josef-wien:
P. S. Da openSUSE immer schon die initrd mit viel unnötigem Zeug vollmüllt, mußt Du sie eventuell neu erzeugen.
Was meins Du damit? und wie kann ich sie neu erzeugen?
have a lot of input
HerbK

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5107
Registriert: 23. Sep 2008, 17:09

Re: gelöst 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von josef-wien » 15. Jan 2017, 16:58

herbk hat geschrieben:Womit kann das zusammenhängen?
Ich kenne Deine Karte nicht, aber nach Deinen Erlebnissen könnte man glauben, sie habe ein Eigenleben.

herbk hat geschrieben:Was meins Du damit? wie kann ich sie neu erzeugen?
Auch 99-local.conf könnte bei openSUSE schon in der initrd benötigt werden. Du findest vermutlich immer noch in /var/log/zypp/history einen Musterbefehl für dracut.

Benutzeravatar
spezi
Hacker
Hacker
Beiträge: 772
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Re: gelöst 42.2 WLAN Karte RTL8723BE funktioniert nicht

Beitrag von spezi » 15. Jan 2017, 19:09

Hallo,
eventuelll hilft Dir das HIER weiter. Bei mir tat es das. Hat halt den Haken das mit jedem Kernelupdate der ganze Sermon wiederholt werden muss.

mfg
spezi.
Dell Optiplex 790 i5-2400, LG-32MP58, Lenovo V320 i5-7200U, BR MFC-J4420DW, FRITZ!Box 7490, Syynology DS215j, oS Leap 15, Raucher

Antworten