Seite 1 von 1

[gelöst]Kein brauchbarer Webbrowser mehr, Segmentation fault

Verfasst: 26. Jan 2014, 14:53
von panamajo
Seit gestern funktioniert kein Webbrowser mehr bei meinem openSUSE 13.1.

Code: Alles auswählen

jo@l33t ~> firefox
(process:29849): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Segmentation fault
jo@l33t ~> chromium
Segmentation fault
jo@l33t ~> /usr/bin/konqueror
KCrash: Application 'konqueror' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/home/jo/.kde4/socket-l33t/kdeinit4__0
Unable to start Dr. Konqi
Konqueror zeigt kurz ein Fenster, alle anderen gar nichts.

Wie kann das denn sein?
Firefox ist aus dem openSUSE 13.1 Update repo installiert:

Code: Alles auswählen

l33t: # rpm -qa | grep Firefox | sort
MozillaFirefox-26.0-4.2.x86_64
MozillaFirefox-branding-upstream-26.0-4.2.x86_64
MozillaFirefox-devel-26.0-4.2.x86_64
MozillaFirefox-translations-common-26.0-4.2.x86_64
chromium ebenfalls, 31.0.1650.63-13.7

Arch ist x86_64

Re: Kein brauchbarer Webbrowser mehr - Segmentation fault

Verfasst: 26. Jan 2014, 15:58
von P6CNAT
Hi,

:???: zunächst würde ich versuchen die Fehlerquellen eingrenzen, in der Hoffnung fündig zu werden.

Die angeforderten Binaries sind noch da und haben Zugriffsrechte gesetzt?
Geht es unter einem anderen Benutzer?
Andere Netzwerkdienste (ntp, mail, telnet ....) funktionieren?
Gehen andere Programme, vielleicht hat das RAM einen Schlag?

Grüße
Georg

Re: Kein brauchbarer Webbrowser mehr - Segmentation fault

Verfasst: 26. Jan 2014, 16:02
von Jägerschlürfer
gabs irgend welche Updates bevor die Browser nicht mehr funktionierten?

Irgend eine Besserung, wenn du zum Test die Browser mal als root ausführst?

[gelöst]Kein brauchbarer Webbrowser mehr, Segmentation fault

Verfasst: 27. Jan 2014, 18:17
von panamajo
Irgendwie hat das mozilla-nss Paket nicht zu den installierten Webbrowsern gepasst. Auf einem funktionierenden Vergleissystem war Mozilla aus dem "Mozilla based projects" Repo installiert.
Bei einem

Code: Alles auswählen

# zypper in --oldpackage MozillaFirefox-common-26.0-1.2 MozillaFirefox-branding-upstream-26.0-1.2 MozillaFirefox-26.0-1.2
wurde mozilla-nss-3.15.4-1.1 installiert, seitdem funktioniert FF, chrome und Konqueror wieder.

Re: [gelöst]Kein brauchbarer Webbrowser mehr, Segmentation f

Verfasst: 27. Jan 2014, 22:47
von P6CNAT
panamajo hat geschrieben:wurde mozilla-nss-3.15.4-1.1 installiert, seitdem funktioniert FF, chrome und Konqueror wieder.
Ich bin überrascht, dass Konqueror auf mozilla Bibliotheken zurückgreift, bei chrome leuchtet mir das eher ein.

Grüße
Georg

Re: [gelöst]Kein brauchbarer Webbrowser mehr, Segmentation f

Verfasst: 27. Jan 2014, 23:33
von panamajo
P6CNAT hat geschrieben:Ich bin überrascht, dass Konqueror auf mozilla Bibliotheken zurückgreift, bei chrome leuchtet mir das eher ein.
ging mir ebenso. Aber KHTML ist ja irgendwie der Urvater von Webkit, fllt. hängt es damit zusammen.