Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Opensuse 13.1 - langsamer Systemstart mit ifup

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

mojo
Member
Member
Beiträge: 182
Registriert: 7. Jul 2007, 11:04

Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von mojo »

Bislang habe ich 2 PC von Opensuse 12.3 64-bit auf Opensuse 13.1 "upgegraded".
Ein PC wurde neu installiert (lediglich die /home-Verzeichnisse wurden übernommen), der andere wurde von 12.3 upgegraded.

In beiden Fällen wurde dafür das entsprechende .iso von DVD benutzt.

Nun ist mir aufgefallen, dass bei beiden PC beim Systemstart eine recht lange Pause eingelegt wird.
Wenn ich mir beim booten mit F1 die Meldungen anzeigen lasse, kann ich bei beiden PC feststellen, dass diese Pause auftritt, wenn die Netzwerkkarte initialisiert wird.

Testweise habe ich nun bei beiden PC von "ifup" auf "Networkmanager" umgestellt.

Damit "rennt" der PC ohne Pause bis zum Anmeldebildschirm durch.

Das Problem ist also ifup!

Ich meine mich erinnern zu können, dass diese lange Pause erst auftrat, nachdem ich das erste Update nach der Installation gemacht habe ( möchte dafür jedoch auch nicht meine Hand ins Feuer legen ;) ).

Hat jemand dieses Problem auch festgestellt?


mojo
Benutzeravatar
Feuervogel
Hacker
Hacker
Beiträge: 744
Registriert: 4. Feb 2009, 16:28
Wohnort: Heusenstamm

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von Feuervogel »

Hallo mojo,

ich den langsameren Systemstart von openSUSE 13.1 im Vergleich zur 12.3 bestätigen.

Netzwerkanbindung bei mir auch per ifup.

Gruß
Feuervogel
Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.
Clifford Stoll
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von admine »

Hier auch ifup, aber Laptop startet wie zuvor auch ... nicht schneller, aber auch nicht langsamer.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Sauerland
Guru
Guru
Beiträge: 3738
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von Sauerland »

Mein PC startet auch langsamer.

Code: Alles auswählen

systemd-analyze blame
         10.754s network.service
          9.937s network@enp2s0.service
          2.155s systemd-udev-settle.service
          1.718s cycle.service
          1.700s systemd-udev-root-symlink.service
          1.472s kmod-static-nodes.service
          1.471s dev-hugepages.mount
          1.470s dev-mqueue.mount
          1.469s sys-kernel-debug.mount
          1.263s systemd-vconsole-setup.service
          1.123s plymouth-start.service
          1.111s systemd-remount-fs.service
           879ms lvm2-activation-early.service
           758ms systemd-fsck@dev-disk-by\x2did-ata\x2dSAMSUNG_HD501LJ_S0MUJ1FP829161\x2dpart5.service
           603ms systemd-fsck@dev-disk-by\x2did-ata\x2dST1000DM003\x2d9YN162_W1D1R00C\x2dpart3.service
           563ms home-musik.mount
           548ms home-1000TB.mount
           534ms SuSEfirewall2_init.service
           505ms systemd-logind.service
           497ms systemd-fsck@dev-disk-by\x2did-ata\x2dSAMSUNG_HD103UJ_S13PJ1KS633688\x2dpart3.service
           491ms systemd-fsck@dev-disk-by\x2did-ata\x2dSAMSUNG_HD501LJ_S0MUJ1FP829161\x2dpart2.service
           478ms systemd-readahead-collect.service
           467ms systemd-readahead-replay.service
           432ms mnt-123.mount
           393ms vboxdrv.service
           383ms ModemManager.service
           355ms avahi-daemon.service
           354ms wpa_supplicant.service
           321ms systemd-sysctl.service
           276ms postfix.service
           271ms systemd-fsck@dev-disk-by\x2did-ata\x2dST1000DM003\x2d9YN162_W1D1R00C\x2dpart5.service
           232ms SuSEfirewall2.service
           218ms home.mount
           213ms lvm2-activation.service
           212ms systemd-tmpfiles-clean.service
           204ms systemd-tmpfiles-setup-dev.service
           174ms lm_sensors.service
           149ms rsyslog.service
           129ms vboxweb-service.service
            93ms ntp.service
            86ms systemd-tmpfiles-setup.service
            68ms user@1000.service
            63ms xdm.service
            63ms udisks2.service
            49ms systemd-modules-load.service
            43ms home-video.mount
            35ms pdns-recursor.service
            33ms alsa-restore.service
            32ms user@0.service
            31ms rtkit-daemon.service
            30ms systemd-udev-trigger.service
            26ms plymouth-read-write.service
            26ms noip2.service
            22ms teamviewerd.service
            17ms polkit.service
            17ms vboxballoonctrl-service.service
            12ms systemd-user-sessions.service
            12ms dev-disk-by\x2did-ata\x2dST1000DM003\x2d9YN162_W1D1R00C\x2dpart1.swap
            12ms vboxautostart-service.service
            11ms systemd-journal-flush.service
             8ms sshd.service
             7ms upower.service
             5ms rc-local.service
             4ms sys-fs-fuse-connections.mount
             3ms bluetooth.service
             3ms systemd-update-utmp.service
             3ms var-run.mount
             2ms var-lock.mount
             2ms systemd-readahead-done.service
             2ms systemd-update-utmp-runlevel.service
             1ms systemd-udevd.service
             1ms systemd-random-seed.service
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
mojo
Member
Member
Beiträge: 182
Registriert: 7. Jul 2007, 11:04

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von mojo »

@Sauerland,
@Feuervogel,

und wenn ihr testweise mal auf Networkmanager umstellt? Geht das dann schneller?


mojo
Benutzeravatar
Feuervogel
Hacker
Hacker
Beiträge: 744
Registriert: 4. Feb 2009, 16:28
Wohnort: Heusenstamm

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von Feuervogel »

Hallo mojo,

kann ich leider jetzt nicht machen. Bin an einer WinDOSe. Zugriff auf meinen Linux-Rechenknecht habe ich frühestens gegen 20:00 Uhr.

Gruß
Feuervogel
Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.
Clifford Stoll
Sauerland
Guru
Guru
Beiträge: 3738
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von Sauerland »

mojo hat geschrieben:@Sauerland,
@Feuervogel,

und wenn ihr testweise mal auf Networkmanager umstellt? Geht das dann schneller?


mojo
Warum sollte ich, benutze hier immer Yast/ifup mit fester IP.

Aus der /var/log/messages:

Code: Alles auswählen

2013-11-25T11:05:18.698089+01:00 linux64 systemd[1]: Starting ifup managed network interface enp2s0...
2013-11-25T11:05:28.635173+01:00 linux64 systemd[1]: Started ifup managed network interface enp2s0.
Sind dort 10 Sekunden.

Netzwerkmanager ist deinstalliert.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von admine »

Interessant zur Analyse:

Code: Alles auswählen

systemd-analyze blame
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
mojo
Member
Member
Beiträge: 182
Registriert: 7. Jul 2007, 11:04

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von mojo »

Sauerland hat geschrieben:
mojo hat geschrieben:@Sauerland,
@Feuervogel,

und wenn ihr testweise mal auf Networkmanager umstellt? Geht das dann schneller?
Warum sollte ich, benutze hier immer Yast/ifup mit fester IP.
Ähem, weil dein System jetzt auch langsam startet? ;)

Ich hatte seit meinen Anfängen mit Linux seit jeher ifup genutzt (damals gab es ja auch noch keinen Networkmanager), was auch immer reibungslos funktionierte. Seit der 13.1 habe ich auch die Pause beim booten, die aber nicht auftritt, wenn man auf Networkmanager umstellt.

Natürlich hätte ich auch gerne wieder "mein" ifup. Aber ich habe mir doch keine SSD eingebaut, um dann die eingesparte Zeit beim Warten auf die Netzwerkkarte zu vertrödeln.

Der Vorschlag, testweise mal auf den Networkmanager umzustellen, diente doch nur um festzustellen, ob das Problem damit auch bei dir behoben ist. Dann könnte man nämlich davon ausgehen, dass ifup in der 13.1 einen Bug hat.
Sauerland hat geschrieben: Aus der /var/log/messages:

Code: Alles auswählen

2013-11-25T11:05:18.698089+01:00 linux64 systemd[1]: Starting ifup managed network interface enp2s0...
2013-11-25T11:05:28.635173+01:00 linux64 systemd[1]: Started ifup managed network interface enp2s0.
Sind dort 10 Sekunden.

Netzwerkmanager ist deinstalliert.
Hier mal meine "Werte":

Code: Alles auswählen

linux-j3nm:/home/test # systemd-analyze blame
          1.253s systemd-udev-settle.service
          1.178s ntp.service
           265ms plymouth-start.service
           153ms hddtemp.service
           144ms windows-C.mount
           132ms windows-D.mount
           110ms systemd-modules-load.service
           101ms cycle.service
            98ms systemd-udev-root-symlink.service
            93ms apparmor.service
            84ms NetworkManager.service
            84ms systemd-tmpfiles-clean.service
            usw.
mojo
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von admine »

Bei mir aus /var/log/messages mit ifup und einem neu installierten System:

Code: Alles auswählen

2013-11-25T16:30:01.499609+01:00 linux systemd[1]: Starting ifup managed network interface wls1...
2013-11-25T16:30:06.884290+01:00 linux systemd[1]: Started ifup managed network interface wls1.
Das ist nicht langsam ;)

Aber ich muss gestehen auf meinem Firmen-Laptop und einem Update auf die 13.1 und damit noch den "alten" Interface-Bezeichnungen
hab ich zwischen "Starting" und "Started" auch fast 10s.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5453
Registriert: 23. Sep 2008, 17:09

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von josef-wien »

admine hat geschrieben:auf meinem Firmen-Laptop und einem Update
Gibt es dort noch /etc/udev/rules.d/70-persistent-net.rules?
Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2595
Registriert: 12. Feb 2005, 22:45

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von panamajo »

Lt. Google liegt die Verzögerung daran dass IPv6 IPv4 vorgezogen wird. Versucht man mit openSUSE 13.1 z.B. eine IP von einem DHCP Server zu erhalten (also z.B. zum WLAN Router zu connecten) und dieser liefert nur IPv4 aus dann wird per default WAIT_FOR_INTERFACES / 2 Sekunden auf gültige IPv6 Adressen gewartet.

Wie lange auf IPv6 gewartet wird kann man in /etc/sysconfig/network/config festlegen:

Code: Alles auswählen

## Type:        integer
## Default:     ""
#
# The number of seconds to wait for the end of IPv6 duplicate address
# detection in ifup.
# Default is to use WAIT_FOR_INTERFACES/2 seconds in normal ifup runs.
# When ifup is called by /etc/init.d/network at boot time, the check
# is done, but /etc/init.d/network waits WAIT_FOR_INTERFACES seconds
# for all interfaces togerther. Set to 0 to disable it.
#
IPV6_DAD_WAIT="0"
Edit: Mist, hilft nicht. Liegt entweder an was anderem oder man muss woanders schrauben.
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von admine »

josef-wien hat geschrieben:
admine hat geschrieben:auf meinem Firmen-Laptop und einem Update
Gibt es dort noch /etc/udev/rules.d/70-persistent-net.rules?
Ja, gibt es mit diesem Inhalt:

Code: Alles auswählen

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:24:d7:4b:8b:80", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="f0:de:f1:10:d3:7a", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
mojo
Member
Member
Beiträge: 182
Registriert: 7. Jul 2007, 11:04

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von mojo »

panamajo hat geschrieben:Lt. Google liegt die Verzögerung daran dass IPv6 IPv4 vorgezogen wird. Versucht man mit openSUSE 13.1 z.B. eine IP von einem DHCP Server zu erhalten (also z.B. zum WLAN Router zu connecten) und dieser liefert nur IPv4 aus dann wird per default WAIT_FOR_INTERFACES / 2 Sekunden auf gültige IPv6 Adressen gewartet.
IPv6 ist bei mir gar nicht aktiviert.
panamajo hat geschrieben:Edit: Mist, hilft nicht. Liegt entweder an was anderem oder man muss woanders schrauben.
Sag ich doch ;) .

Auch mit den neuen Interfacebezeichnungen hat es offenbar nichts zu tun. Bei einem Rechner habe ich ein Upgrade von 12.3 gemacht (hat somit noch die "alten" Interfacebezeichnungen), bei dem anderen Rechner neu installiert (= neue Interfacebezeichnungen).

Beide Rechner legen bei "ifup" eine Pause von geschätzt 10 Sekunden ein. Wird der Networkmanager verwendet, booten beide sofort bis zum Loginbildschirm (einmal mit SSD und einmal mit SSHD - wobei die SSHD nicht langsamer als die SSD ist: geschätzt vom Bootmanager bis Loginbildschirm ca. 5 Sekunden).


mojo
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5453
Registriert: 23. Sep 2008, 17:09

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von josef-wien »

admine hat geschrieben:Ja, gibt es mit diesem Inhalt
Auf Grund der Aussage
mojo hat geschrieben:Auch mit den neuen Interfacebezeichnungen hat es offenbar nichts zu tun.
wird es nicht helfen, die Datei zu entfernen, aber ein Versuch schadet nicht. Was mir mangels 13.1 noch einfällt, ist ein Vergleich der Dateiinhalte von /etc/sysconfig/network/.
mojo
Member
Member
Beiträge: 182
Registriert: 7. Jul 2007, 11:04

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von mojo »

Bezüglich der neuen Namenskonvention für "Netzwerkgeräte" habe ich nachfolgend interessanten Link gefunden.
Möglicherweise hilft es dem einen oder anderen, der an dieser Stelle Probleme hat:
http://forums.opensuse.org/english/get- ... fig-2.html


mojo
mojo
Member
Member
Beiträge: 182
Registriert: 7. Jul 2007, 11:04

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von mojo »

Ich habe testweise mal wieder mittels "ifup" gebootet.
Die ca. 10 Sekunden lange Pause besteht aber immer noch.

In der /var/log/boot.log findet sich folgender Eintrag:

Code: Alles auswählen

[[32m  OK  [0m] Created slice system-network.slice.
         Starting ifup managed network interface eth0...
[[0m[31m*     [0m] (1 of 2) A start job is running for LSB: Configure network interfaces and set up routing
[K[[1;31m*[0m[31m*    [0m] (1 of 2) A start job is running for LSB: Configure network interfaces and set up routing
[K[[31m*[1;31m*[0m[31m*   [0m] (1 of 2) A start job is running for LSB: Configure network interfaces and set up routing
[K[ [31m*[1;31m*[0m[31m*  [0m] (2 of 2) A start job is running for ifup managed network interface eth0
[K[  [31m*[1;31m*[0m[31m* [0m] (2 of 2) A start job is running for ifup managed network interface eth0
[K[   [31m*[1;31m*[0m[31m*[0m] (2 of 2) A start job is running for ifup managed network interface eth0
[K[    [31m*[1;31m*[0m] (1 of 2) A start job is running for LSB: Configure network interfaces and set up routing
[K[     [31m*[0m] (1 of 2) A start job is running for LSB: Configure network interfaces and set up routing
[K[    [31m*[1;31m*[0m] (1 of 2) A start job is running for LSB: Configure network interfaces and set up routing
[K[   [31m*[1;31m*[0m[31m*[0m] (2 of 2) A start job is running for ifup managed network interface eth0
[K[  [31m*[1;31m*[0m[31m* [0m] (2 of 2) A start job is running for ifup managed network interface eth0
[K[ [31m*[1;31m*[0m[31m*  [0m] (2 of 2) A start job is running for ifup managed network interface eth0
[K[[31m*[1;31m*[0m[31m*   [0m] (1 of 2) A start job is running for LSB: Configure network interfaces and set up routing
[K[[1;31m*[0m[31m*    [0m] (1 of 2) A start job is running for LSB: Configure network interfaces and set up routing
[K[[32m  OK  [0m] Started ifup managed network interface eth0.
[[32m  OK  [0m] Started LSB: Configure network interfaces and set up routing.
[[32m  OK  [0m] Reached target Network.
         Starting Command Scheduler...
[[32m  OK  [0m] Started Command Scheduler.
[[32m  OK  [0m] Reached target Host and Network Name Lookups.
Leider kann ich damit nicht viel anfangen, aber vielleicht hilft es ja, den Fehler irgendwie einzugrenzen und die Ursache zu beheben.

Nachdem ich wieder zurück zum Networkmanager gewechselt habe, startet das System wieder ohne Pause.


mojo
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von admine »

Nach dem Löschen von /etc/udev/rules.d/70-persistent-net.rules und einem Reboot war erst einmal kein Netzwerk da ;)
Hab die "neuen" Interface konfiguriert, Netz war wieder da und Laptop neu gestatet ... wobei das ein Shutdown und Start war!
Tja, hat aber nichst gebracht. Zwischen Starting ifup und Started ifup liegen 8s.

Allerdings bin ich mir sicher, dass das bei mir nicht das Problem ist.
Mir ist aufgefallen, dass das System an einer anderen Stelle wirklich sehr lange steht.
und das ist hier (aus bootlog):
[ OK ] Started Write information about system start to sysstat log.
danach kommt das:
[ OK ] Started LSB: Network time protocol daemon (ntpd)
und es blieb da auch stehen, als das Netzwerk wieder funktionierte!
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
Jägerschlürfer
Moderator
Moderator
Beiträge: 4505
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von Jägerschlürfer »

deaktiviere den ntp Dienst doch bitte einmal,...
>Linux-Club Foren FAQ< >LC-Wiki<

Know your enemy and know yourself Sun Tzu
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Opensuse 13.1 - langsamer Systemstart mit ifup

Beitrag von admine »

Jägerschlürfer hat geschrieben:deaktiviere den ntp Dienst doch bitte einmal,...
Teste ich bei Gelegenheit, da es mein Firmenlaptop ist und ich das Teil wirklich brauche ;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Antworten